KR C1 Online-Hilfe

KR C2
Online-Help

Version 4.3.2

KUKA Roboter GmbH
Zugspitzstr. 140
D-86165 Augsburg
Copyright © 1995 - 2005


$MOVE_ENABLE Eingang (1025) nicht erlaubt

Ursache:

In Betriebsart Automatik Extern darf $MOVE_ENABLE nicht auf $OUT[1025] projektiert sein.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

$MOVE_ENABLE umrangieren.


$TOOL ungültig: Keine Arbeitsraumüberwachung möglich

Ursache: | "$TOOL" ist bei aktiver Arbeitsraumüberwachung ungültig.
Auswirkung: | keine
Abhilfe: | "$TOOL" zuweisen bzw. Arbeitsraumüberwachung abschalten.


<$Variable> unzulässiger Wert

Ursache:

Vom Maschinendatenlader wurde erkannt, dass die angegebene Variable falsch initialisiert wurde:- Grenzwert wurde überschritten.

  • logischer Zusammenhang von Maschinendaten ist nicht gegeben.

Auswirkung:

Kein RC-Ready.

Abhilfe:

Die Wertzuweisung berichtigen.


Absolutgenaues Modell: Parameter nicht mit Maschinendaten konsistent

Ursache: | Maschinendaten wurden geändert, so dass eine neue Absolutvermessung nötig ist.
Auswirkung: | Absolutmodell kann nicht initialisiert werden.


Absolutgenaues Modell Parameterfile falsche Seriennummer

Ursache:

Parameterfile "prec_robxxxxxxxxxx.xml" enthält
Seriennummer, die nicht mit dem Roboter übereinstimmt.

Auswirkung:

Absolutmodell kann nicht initialisiert werden.

Abhilfe:

  • Korrekte Parameter-Datei verwenden.

  • Die korrekte Seriennummer verwenden.


Absolut Roboter Objekt Modul konnte nicht nachgeladen werden

Ursache: | Datei "mada/prec_rob.o" nicht gefunden oder fehlerhaft.
Auswirkung: | Keine Absolutgenauigkeit
Abhilfe: | "prec_rob.o" installieren und neu starten.


Abweichung Absolutposition DSE - RDW Achse <Achsnummer>

Ursache:

Der Wert für die Absolutposition, der auf der DSE berechnet wurde, weicht vom Wert auf der RDW um mehr als 1/4 Resolverumdrehung ab.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aktiver Kommandos


Abweichungswarnung Master-Slave <Achsnummer>

Ursache:

Die Positionsabweichung zwischen Master und Slave Antrieb überschreitet die Warnschwelle


Achsarbeitsraum Nummer <Arbeitsraumnummer> freifahren

Ursache: | Der Roboter befindet sich innerhalb eines Arbeitsraumes (Mode = #INSIDE_STOP) oder außerhalb eines Arbeitsraumes (Mode = #OUTSIDE_STOP) und die Arbeitsraumüberwachung ist überbrückt.
Auswirkung: | Der Roboter stoppt.
Abhilfe: | Achsarbeitsraum freifahren.


Achsarbeitsraum Nummer <Arbeitsraumnummer> verletzt

Ursache:

Der Roboter steht innerhalb eines Arbeitsraumes (Mode = #INSIDE_STOP) bzw. außerhalb (Mode = #OUTSIDE_STOP).

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Achsarbeitsraum abschalten oder die Arbeitsraumüberwachung im T1-Betrieb überbrücken und Roboter freifahren.


Antriebsfreigabe fehlt <Powermodul Nummer>

Ursache: | KPSi der Cobra-Steuerung meldet keine Antriebsfreigabe
Auswirkung: | Roboter stoppt
Abhilfe: | Fehler an KPSi beseitigen


<Achsnummer> ohne Leistungsspannung

Ursache:

An der angegebenen Achse fehlt die Leistungsspannung.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Akku defekt DSE <DSE Nummer> KPS <KPS Nummer>. Bitte sichern Sie vor dem Ausschalten die Justage.

Ursache:

Akku ist nicht ausreichend für zuverlässigen Pufferbetrieb.

Auswirkung:

Im Falle des Ausschaltens oder eines Stromausfalls kann ein Justage- und Datenverlust auftreten.

Abhilfe:

  • Neue Akkus installieren.

Hinweis:
KUKA empfiehlt, bei mehreren Akkus, aber nur einer HW-Option DC-USV15, alle Akkus (also auch die nicht überwachten) zu tauschen.

  • Vor dem Abschalten muss die Justage gesichert werden, um einen Justageverlust zu vermeiden.

  • Wird der Roboter vor dem Ausschalten bewegt, muss die Justage erneut gesichert werden.


Akku fehlt DSE <DSE Nummer> KPS <KPS Nummer>. Bitte sichern Sie vor dem Ausschalten die Justage.

Ursache:

  • Pufferbereitschaft fehlt, z.B. Akku nicht oder verpolt angeschlossen.

  • Option DC-USV-Modul_15 ist nicht für jedes KPS vorhanden, aber die Akkuüberwachung ist in $OPTION.DAT durch $EXT_ACCU_MON=TRUE aktiviert.

  • Es ist keine DSE-IBS-C33 installiert.

Auswirkung:

Falls der Akku nicht oder verpolt angeschlossen ist, kann im Falle des Ausschaltens oder eines Stromausfalls ein Justage- und Datenverlust auftreten.

Abhilfe:

  • Vor dem Abschalten die Justage sichern, um einen Justageverlust zu vermeiden. Wird der Roboter vor dem Ausschalten bewegt, muss die Justage erneut gesichert werden.

  • Falls die Option DC-USV-Modul_15 vorhanden ist, den Anschluss des Akkus überprüfen.

  • Falls mehrere KPS an die Steuerung angeschlossen sind und $EXT_ACCU_MON=TRUE ist, aber nicht für jedes KPS je ein DC-USV-Modul_15 angeschlossen ist, so muss an den KPS ohne angeschlossene Akkuüberwachung der Eingang X114/Pin6 an 24V gelegt sein, da anderenfalls der nicht beschaltete Eingang diese Meldung zur Folge hat.

  • Falls kein DC-USV-Modul_15 vorhanden ist, den Wert $EXT_ACCU_MON auf FALSE setzen.

  • Falls keine DSE-IBS-C33 vorhanden ist, DSE gegen eine DSE-IBS-C33 tauschen oder den Wert $EXT_ACCU_MON auf FALSE setzen.


Akku prüfen <KPS Nummer>

Ursache:

  • Der Akku wird nicht mehr richtig geladen.

  • Der Akku ist zu alt oder defekt.

Auswirkung:

  • Gegebenenfalls Justageverlust.

  • Kaltstart.

  • Aktive Kommandos verriegelt.

Abhilfe:

Akku austauschen.


Akku-Spannung an <KPS Nummer> bei letzter Pufferung unter <Spannungspegel> Volt

Ursache:

  • Die Spannung des Akkus war zu niedrig, um die Energieversorgung beim letzten Ausschalten zu puffern.

  • Der Akku wird nicht mehr richtig geladen.

  • Der Akku ist zu alt oder defekt.

Auswirkung:

  • Gegebenenfalls Justageverlust.

  • Kaltstart

  • Aktive Kommandos verriegelt.

Abhilfe:

Akku austauschen.


Akkuspannung für Pufferung zu niedrig <Powermodul Nummer>

Ursache: | Die Spannung des Pufferakkus ist zu niedrig.
Auswirkung: | Beim nächsten Ausschalten der Steuerung können die zu speichernden Roboterdaten nicht mehr komplett auf Festplatte geschrieben werden.
Abhilfe: | Akku tauschen.


Allgemeiner Fehler: <Fehlernr.> <Funktion> <Zusatzinfo.>

Ursache:

Unbekannte Rückmeldung einer Funktion im Objekt bei Kommandobearbeitung.

Auswirkung:

  • Keine

Abhilfe:

Bitte verständigen Sie Ihren KUKA-Kundendienst.


Allgemeiner KSD-Fehler <Achsnummer>

Ursache:

  • Das KSD der betroffenen Achse meldet einen allgemeinen Fehlerzustand. Genaue Informationen hierüber liefern die ausgegebenen Folgemeldungen.

  • Erscheint diese Meldung ohne Folgemeldungen, so stand der Fehler im KSD so kurz an, dass die DSE die Fehlernummer im KSD nicht auslesen konnte. In diesem Fall muss der Fehlerspeicher im betroffenen KSD ausgelesen werden. Hierfür ist das DSE/RDW-Tool zu öffnen und die Codestellen des betroffenen KSDs in ein Logfile zu exportieren.

Detaillierte Informationen zu der Fehlerhistorie liefern die Codestellen 162, 163 und 164. Codestelle 161 enthält den aktuellen Fehler.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Setzen Sie sich bitte mit dem KUKA-Kundendienst in Verbindung.


Antriebe nicht bereit

Ursache:

  • Powermodul, Zwischenkreisspannung entladen.

  • Not-Aus steht an.

  • Antriebskreis unterbrochen.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Antriebe einschalten.

  • Powermodul, DSE prüfen.

  • Antriebskreis prüfen.


Antriebe aus, Zwischenkreisspannung noch geladen

Ursache:

Das Antriebsschütz fällt. Die Energie im Zwischenkreis reicht noch aus, um einen bahntreuen Stop zu gewährleisten.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Antriebskreis auf Fehler untersuchen.

  • Antriebe wieder einschalten.


Antriebsbus DSE <DSE Nummer> Teilnehmer Nr. <Interbus Teilnehmernr.> nicht konfiguriert

Ursache:

Interbuskonfiguration und physikalischer Aufbau stimmen nicht überein.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Interbuskonfiguration und Hardware aufeinander abstimmen.


Antriebsbus DSE <DSE Nummer> Teilnehmer Nr. <Interbus Teilnehmernr.> nicht vorhanden

Ursache:

Interbuskonfiguration und physikalischer Aufbau stimmen nicht überein.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Interbuskonfiguration und Hardware aufeinander abstimmen.


Antriebsfehler <Achsnummer>

Ursache:

Antriebsfehler an der angegebenen Achsnummer.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Antriebsfehler <Achsnummer>

Ursache:

Bei der angegebenen Achsnummer liegt ein Antriebsfehler vor.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Mechanik, Elektrik, Verkabelung, etc. überprüfen.


Antriebsfehler <Achsnummer> Nr. <Fehlernummer>

Ursache:

Es liegt ein Antriebsfehler vor.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Nach dem Quittieren kann der Roboter bis zur nächsten Meldung weitergefahren werden.
Setzen Sie sich bitte mit dem KUKA-Service in Verbindung.


Antriebsfehler <Achsnummer>

Ursache:

Antriebsfehler an der angegebenen Achsnummer.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Antriebsbus DSE-Nr. <DSE Nummer> Teilnehmer Nr. <IBS-Teilnehmernr.> unbekannt

Ursache:

Ein unbekannter Teilnehmer wurde in den Interbus eingefügt und kann nicht unterstützt werden.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Unbekannten Teilnehmer aus dem Antriebsbus entfernen.


Antriebsbusstörung nach <Achsnummer>

Ursache:

  • Defektes Buskabel.

  • Defektes Busmodul.

  • Defekter Bustreiber.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Defektes Element ersetzen.


Antriebsbusstörung nach <KPS Nummer>

Ursache:

Es liegt eine Antriebsbusstörung vor.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Störungsursache beseitigen.


Antriebsbusstörung DSE <DSE Nummer>

Ursache:

  • Defektes Buskabel.

  • Defektes Busmodul.

  • Defekter Bustreiber.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Defektes Element ersetzen.


Antriebsbusstörung nach DSE <DSE Nummer>, keine Pufferung und autom. Datensicherung möglich

Ursache:

Die Kommunikation zum KPS ist gestört, deshalb kann die Pufferung nicht aktiviert werden.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Kommunikation zum KPS wiederherstellen.


Antriebsfehler <Achsnummer>

Ursache:

Für die angegebene Achsnummer wurde ein Antriebsfehler gemeldet.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Antriebsfehler <Achsnummer>

Ursache:

Antriebsfehler an der angegebenen Achsnummer.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Antriebsfehler <Achsnummer>

Ursache:

Bei einer Achse liegt ein Antriebsfehler vor.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Mechanik / Elektrik / etc. prüfen.


Antriebsfehler <DSE Nummer>

Ursache:

Antriebsfehler

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Anwahl aktiv

Ursache: | Eine Neuanwahl erfordert vorherige Abwahl bzw. Beendigung des Bindevorgangs.
Auswirkung: | Keine
Abhilfe: | Warten, bis Bindevorgang beendet ist.


Anwenderdaten fehlerhaft

Ursache:

Der Lader für die Anwenderdaten hat erkannt, dass eine Variable mit einem falschen Wert initialisiert wurde:- Grenzwert wurde überschritten.

  • logischer Zusammenhang der Daten ist nicht gegeben.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die Wertzuweisung der angezeigten Variable korrigieren.


<$Variable> APT-E/A-Rangierung fehlerhaft <richtiger Index>

Ursache: | Anpassteil-Ausgang ist doppelt belegt.
Auswirkung: | Kein RC-Ready.
Abhilfe: | Gemeldetes Maschinendatum korrigieren.


Arbeitsraum Nr. <Arbeitsraumnummer> freifahren.

Ursache: | TCP befindet sich in einem Arbeitsraum mit – MODE "INSIDE-STOP" bzw. außerhalb eines Arbeitsraumes mit – MODE "OUTSIDE-STOP" und die Arbeitsraumüberwachung ist überbrückt.
Abhilfe: | Betroffenen Arbeitsraum freifahren.


Arbeitsraum Nr. <Achsbereichsnummer> überschritten

Ursache: | Eine oder mehrere Achsen haben den angegebenen Achsbereich verlassen.
Auswirkung: | Der Roboter wird gestoppt und darf nur mit reduzierter Geschwindigkeit weiterfahren.
Abhilfe: | Der Roboter muss wieder in den Achsbereich gefahren werden.


Arbeitsraum Nr. <Arbeitsraumnummer> verletzt.

Ursache:

TCP befindet sich in einem Arbeitsraum mit
– MODE "INSIDE-STOP"
bzw. außerhalb eines Arbeitsraumes mit
– MODE "OUTSIDE-STOP".

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Arbeitsraum abschalten.

  • Durch Menüpunktanwahl "Arbeitsraumüberwachung überbrücken" und im T1-Betrieb freifahren.


<Achsnummer> asynchrone Zusatzachse

Ursache:

Zusatzachse ist als asynchrone Achse geschaltet.


Ausfall einer Netzphase <Powermodul Nummer>

Ursache:

Eine Phase des Drehstromnetzes ist ausgefallen

Auswirkung:

Das KPS kann die geforderte Leistung nicht mehr liefern

Abhilfe:

  • Überprüfung auf Wackelkontakt

  • Überprüfung auf Kabelbruch


Ausfall einer Netzphase DSE <DSE Nummer> KPS <KPS Nummer>

Ursache:

  • Eine Phase der Spannungsversorgung des KPS fehlt.

  • Es kann auch die entsprechende Schrankverdrahtung fehlen.

Auswirkung:

  • Der Roboter hält nach ca. einer Minute an, falls das Problem nicht behoben wird. Es zählt dabei nur die Zeit, in der sich der Roboter tatsächlich bewegt.

Abhilfe:

  • Stellen Sie die Spannungsversorgung aller drei Phasen sicher.

  • Prüfen Sie die erforderliche Schrankverdrahtung: X110/Pin2 muss auf 24V und X110/Pin3 muss auf GND liegen.


Ausfall einer Motorphase <Achsnummer>

Ursache:

Powermodul oder Zwischenkreisspannung sind entladen.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Antriebe einschalten.

  • Powermodul, DSE überprüfen.


Automatische Repositionierung

Ursache: | $MOT_STOP_OPT = TRUE. Roboter befindet sich nicht auf der programmierten Bahn. In EXTERN wurde $MOT_STOP (Flag, dass Roboter nicht auf Bahn) vom Benutzer (via BOF) auf FALSE gesetzt, so dass der Roboter automatisch in Prozessgeschwindigkeit auf Bahn fährt.
Auswirkung: | nur Hinweis, dass der Roboter sich in EXTERN auf der Bahn bewegt.
Abhilfe: | Die Meldung wird automatisch gelöscht, sobald SAK erreicht ist.


Ballastschalter zu lange ein <KPS-Nummer> beim Laden

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Ballastschalter zu lange eingeschaltet <Powermodul Nummer>

Ursache:

Die Energie der abgebremsten Achse lag über dem Limit.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Powermodul-Ballastwiderstand überprüfen und ggf. austauschen.

  • Bremsrampe weniger steil einstellen.


Bedienerschutz/Schutzgitter offen

Ursache:

Der Eingang $USER_SAF hat den Signalzustand 0. Betriebsart ist AUTOMATIK oder EXTERN.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Umschalten in die Betriebsart T1 oder T2, in diesen Betriebsarten ist ein Verfahren bei 0-Signal zulässig.

  • Schutzgitter schließen.

  • Eingang überprüfen.


Begrenzung <Signalname>

Ursache: | Der Wert für den entsprechenden Analogausgang liegt außerhalb des normierten Bereichs.
Auswirkung: | Der Wert des betroffenen Analogausgangs wird auf Maximal- bzw. Minimalwert begrenzt.
Abhilfe: | Die Meldung steht an, bis der Wert des entsprechenden Analogausgangs innerhalb des normierten Bereichs liegt und daher keine Begrenzung mehr notwendig ist.


Betriebszustand unzulässig E<VW Sicherheitsschlüsselstellung>.

Ursache:

E2-Schließung in Betriebsart "AUTO".

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Betriebsart ändern.


Bewegungspause wegen Interrupt von <Name/IP der Verursacher>

Ursache: | Wenn in einem Interrupt einer (durch LK()- Zuweisung) abhängigen Steuerung BRAKE oder eine Bewegung ausgeführt wurde, wird die unabhängige Steuerung so lange gestoppt, wie das BRAKE wirkt.
Auswirkung: | Die Bewegung bleibt stehen.
Abhilfe: | Die Bewegung fährt fort, wenn die abhängige Steuerung das Interrupt-Programm verlässt.


Bremsenabkühlzeit <Achsnummer>;<Abkühlzeit> Sekunden

Ursache: | Die Bremse der angegebenen Achse ist zu heiß geworden.
Auswirkung: | Die Antriebe werden für die Abkühlzeit verriegelt.
Abhilfe: | Bremsenabkühlzeit abwarten.


Bremsenkanal nicht geöffnet <Achsnummer>

Ursache:

Bremse wurde nicht geöffnet, da nicht alle Achsen an diesem Bremsenkanal in Regelung sind.

Auswirkung:

Fehlermeldungen zum Beispiel:

  • Stellgröße oder

  • Motor blockiert.

Abhilfe:

  • Alle Achsen an einem Bremsenkanal zusammen ansteuern oder

  • Einzelbremsensteuerung verwenden.


Bremsenstörung <KPS Nummer> Kanal <Bremsenkanal>

Ursache:

Es ist eine Bremsenstörung aufgetreten.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Entsprechende Hardware überprüfen.


Betriebsartenwechsel

Ursache:

Der Betriebsartenwahlschalter befindet sich in einer ungültigen Stellung.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Betriebsartenwahlschalter in gültige Stellung bringen.


Bremse defekt <Achsnummer>.

Ursache:

  • Bremsenverschleiß.

  • Bremse defekt.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Achse kann unter Umständen nicht abgebremst werden.

Abhilfe:

Entsprechenden Motor austauschen.


Checksummenfehler Datei <Dateiname>

Ursache: | Die Datei wurde inkorrekt verändert.
Auswirkung: | Parameter werden nicht übernommen.
Abhilfe: | Korrektes Parameterfile installieren.


CYC-TASK: Zeitüberwachung in <Taskname>

Ursache: | Die Zeitüberwachung wird nicht im korrekten Zeitabstand durchgeführt.
Abhilfe: | Steuerung neu starten.


Datei <Dateiname> nicht gefunden.

Ursache:

Parameterdatei für absolutgenauen Roboter nicht gefunden.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

  • Datei einspielen.

  • Steuerung neu booten.


Drehzahl-Stopp aktiv

Ursache: | Falls "LAGNP" die Anforderung eines generatorischen Stopps erkennt (Bit "GEN_STOP" von Meldungsbearbeitung gesetzt), erzeugt "LAGNP" diese Zustandsmeldung.
Auswirkung: | Die Verlängerung des generatorischen Stopps bis zum Stillstand des Roboters vermeidet unterschiedliche Zustände in "LAGNP" und "LAGHP".
Abhilfe: | Wenn der Roboter zum Stillstand kommt, wird diese Meldung ohne weitere Folgemeldung zurückgenommen.


DSE Achsrangierung <Achsnummer> falsch

Ursache: | Mit dem Maschinen-Datum $IFACE_DRV[6] wurde eine Antriebsschnittstelle doppelt belegt oder es wurde eine nicht vorhandene Schnittstelle angesprochen. Weitere Ursachen: Es wurden KTL-Geber eingetragen in $IFACE_DRV[6] ohne APC-Schnittstellen zu stecken oder es wurden ADAR-Achsen in $ADAR_AXIS eingetragen, ohne ADAR Schnittstellen zu stecken.
Auswirkung: | Kein RC-Ready.
Abhilfe: | Die entsprechenden Maschinendaten berichtigen.


DSE-Datei nicht vorhanden <Dateiname>

Ursache:

  • Das DSE-Programm, welches in "HW_INF.INI" eingetragen ist, existiert nicht.

  • Ein Servofile, das in "R1\MADA\$MACHINE.DAT" eingetragen ist, existiert nicht.

  • Das File ist leer oder konnte nicht geöffnet werden.

Auswirkung:

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Eintrag in der "HW_INF.INI" bzw. "R1\MADA\$MACHINE.DAT" überprüfen und ggf. ändern.

  • Überprüfen, ob das betroffene File auf der Festplatte ist (Verzeichnisse C:\KRC\Roboter\DSE und ..\R1\MADA).


DSE <DSE Nummer> Programm läuft nicht hoch

Ursache:

  • Das Grundsystem hat die Rückmeldung "DSEREADY" nach dem Start des DSE Programms nicht erhalten.

Auswirkung:

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Prüfen, ob die DSE richtig steckt.

  • DSE austauschen.


DSE <DSE Nummer> nicht vorhanden

Ursache:

Das Bit auf der MFC, welches anzeigt, ob eine DSE vorhanden ist, ist nicht gesetzt, obwohl Achsen auf der DSE gesteckt sind.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • DSE überprüfen.

  • MFC überprüfen.


<DSE Nummer>. DSE Kommando Timeout

Ursache:

Die DSE hat einen Befehl nicht ausgeführt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware im Bereich DSE und MFC überprüfen.


E/A Rekonfiguration gestartet, bitte warten

Ursache:

Von der BOF aus wurde E/A rekonfigurieren ausgelöst.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ende der Rekonfiguration abwarten.


E/A Verknüpfung: Ausgang <Ausgangsnummer> ist ein Systemausgang

Ursache: | Der angegebene Ausgang ist ein Systemausgang.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Programm entsprechend ändern.


E/A-Verknüpfung: Doppelbelegung Ausgang <Ausgangsnummer>

Ursache: | Der angegebene Ausgang ist mehrfach belegt.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Programm entsprechend ändern.


E/A Verknüpfung: Mehr als <Anzahl Links> Verknüpfungen nicht konfigurierbar

Ursache: | Es wurden mehr als die angegebenen Verknüpfungen konfiguriert.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Anzahl der E/A-Verknüpfungen entsprechend reduzieren.


Effektivstrom <KPS Nummer> zu groß

Ursache: | KPS muss einen zu großen Effektivstrom liefern
Auswirkung: | KPS schaltet zum Eigenschutz ab
Abhilfe: | Umteachen der Roboterbahn, langsameres Verfahren


Empfangspufferüberlauf

Ursache:

Der Empfangspuffer ist voll.

Auswirkung:

Die Steuerung nimmt keine Telegramme mehr an.

Abhilfe:

  • Mit CREAD Telegramm lesen.

  • In Datei "SERIAL.INI" die Anzahl der Eingangspuffer erhöhen.


Erlaubte Maximalkraft ueberschritten <Achsnummer>

Ursache:

Das Kraftsensorsignal ist nach dem Einschalten der Kraftregelung "($Force[Achse] > FORCE_LIM)" grösser als "FORCE_MAX + UPPER_LIMIT_TOL".

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Kraftsensorwert "$Force_act[Achse]" mit Hilfe der Menüfunktion "Anzeige-Variable-Einzeln" prüfen und ggf. korrigieren;

  • Kraftsensor und Kabel überprüfen;

  • Trace-Aufzeichnung der Testgruppe "Kraftregelung" darauf überprüfen, ob der Regler zu stark überschwingt.


Sicherheitskreis hat Peripheriefehler detektiert. ESC-Diagnose öffnen

Ursache:

Fehler in der Peripherieverkabelung (Sicherheitskreise)

Auswirkung:

  • Bahntreuer Stop

  • Verriegelung aller aktiven Kommandos

Abhilfe:

  • Die diagnostizierte Störung beheben

  • Meldung quittieren


Fahrfreigabe gesamt

Ursache:

0 Signal am Eingang $MOVE_ENABLE.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Eingang überprüfen.


Falsche Meldungskonfiguration: <Konfigurationsdatei> Zeile: <fehlerhafte Zeile>

Ursache:

  • in der Datei "ext_conf.ini" wurde eine nicht vorhandene Meldung konfiguriert;

  • in der Datei "ext_conf.ini" wurde eine Hinweis-Meldung konfiguriert;

  • in der Datei "ext_conf.ini" wurde eine Zustands-Meldung konfiguriert.

Auswirkung:

  • Aktive Kommandos verriegelt.

Abhilfe:

  • Die Datei "ext_conf.ini" entsprechend ändern und einen Kaltstart der Steuerung durchführen.


Unbekannte Hardware gefunden

Ursache:

Beim Setup wurde der falsche Steuerungstyp (KRC1, KRC1A, KRC2) ausgewählt oder die Hardwarekonfiguration ist ungültig.

Auswirkung:

  • Bahntreuer Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Setup erneut durchführen oder Hardwarekonfiguration ändern.


Falscher Achsverstärker <Achsnummer>

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aktiver Kommandos.

Abhilfe:

Berichtigen


Falscher Antriebsparametersatz <Achsnummer>

Ursache:

Für die angegebene Achsnummer ist der falsche Antriebsparametersatz angegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Entsprechend ändern.


Fehler Antriebsschütz K1

Ursache:

Der Kontakt im Antriebsschütz K1 ist verklebt.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Powermodul wechseln.


Fehler beim Laden von <Modulname>

Ursache: | Beim Laden eines vordefinierten Objektes (eincompilierte Daten werden überschrieben) trat ein schwerer Fehler auf.
Auswirkung: | Maschinendaten sind inkonsistent.


Fehler beim Lesen, Treiber: <Treiber Nummer> <0>

Auswirkung:

Bahntreuer Stopp


Fehler <interner Fehlercode> beim Lesen der Konfigurationsdatei <Dateiname>

Ursache:

Für eine kraftgeregelte Achse trat ein Fehler beim Lesen der Konfigurationsdatei im Mada Verzeichnis auf.
Fehlercode:
1: Datei konnte nicht geöffnet werden
2: Fehlender Eintrag
3: inkonsistente Daten
4: Konfigurierte Maximalkraft + Toleranz > 6500 Inkremente max. Sensorauflösung

Auswirkung:

Kraftregelung wird nicht aktiviert

Abhilfe:

  • Fehler in der Konfigurationsdatei beseitigen

  • Kraftregelung explizit ausschalten ($LOOP_TYPE <> 6)


Fehler beim Schreiben auf Bosch

Auswirkung: | Bahntreuer Stop.
Abhilfe: | Programm entsprechend ändern.


Fehler beim Schreiben auf Perceptron

Auswirkung:

Bahntreuer Stop.


Fehler beim Schreiben, Treiber: <Treiber Nummer> <0>

Auswirkung:

Bahntreuer Stop


Fehler beim Starten der Safe RDW

Ursache:

  • Ungültige RDW-Dateien

  • Hardwareprobleme

Auswirkung:

Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Gültige RDW-Dateien verwenden.

  • Hardware überprüfen und erforderlichenfalls Fehler beheben.


Fehler Konfiguration E/A-Treiber <Treibername>

Ursache: | Fehler in der Datei "IOSYS.INI" (Verzeichnis "...\KRC\ROBOTER\INIT")
Auswirkung: | Die zu diesem Treiber gehörende Anwendung ist nicht funktionsfähig.
Abhilfe: | Datei "IOSYS.INI" überprüfen und entsprechend ändern.


Fehler Sync. eingang Antriebsmodul <Achsnummer>

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Fehler beseitigen.


Fehler Synchronisation mit DSE <Achsnummer>

Ursache:

  • Meldung vom Grundsystem: Das Grundsystem hat den Watchdog-Timer zur Überwachung der Kommunikation mit der DSE nicht gesetzt oder die DSE hat den Watchdog-Timer nicht zurückgesetzt.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

Abhilfe:

  • Steckverbindung zwischen DSE und MFC, sowie zwischen MFC und Motherboard prüfen (Wackelkontakt).

  • Sollte dies keine Verbesserung bringen, DSE oder MFC tauschen.

  • Untersuchen, ob der Antriebsbus oder der ISA-Bus auf dem Motherboard gestört werden (EMV).


Fehler Zustimmkreis

Ursache:

Ein Kanal ist ausgefallen oder mehr als ein Zustimmungsschalter gedrückt.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Fehler beheben bzw. nicht mehr als einen Zustimmungsschalter betätigen.


Fehlerhafte Master-Slave Zuordnung <Achsnummer>

Ursache:

Die Zuordnung Master - Slave ist nicht korrekt

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Zuordnung richtigstellen.


Fehlerhafte Übertragung <KCP oder RST>

Ursache:

Verbindung zum KCP ist gestört.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

KCP-Kabel überprüfen.


Fehlfunktion <KCP oder RST>

Ursache:

KCP defekt.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

KCP auswechseln.


<Achsnummer> Firmwarestand <Firmwarestand auf den Umrichtern>

Ursache:

Information über den Firmwarestand der jeweiligen Achse.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Firmware des Antriebsreglers oder die Servofiles hochrüsten.


Geberleitung defekt <Achsnummer>

Ursache:

  • Geberleitung defekt.

  • Lose Steckverbindung.

  • Versorgungsspannung fehlt.

  • Geber defekt.

Auswirkung:

  • Generatorischer Stopp

  • Ausgang "$ALARM_STOP" hat den Signalpegel 0.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Geberleitung überprüfen.

  • Steckverbindungen überprüfen.

  • Versorgungsspannung kontrollieren.

  • Geber überprüfen und ggf. austauschen.


Geberleitung defekt extern posinput <Achsnummer> <Zusatzinfo bei speziellen Gebern>

Ursache:

  • Geberleitung externer Positionseingang defekt.

  • Lose Steckverbindung.

  • Versorgungsspannung fehlt.

  • Geber defekt.

Auswirkung:

  • Generatorischer Stop

  • Ausgang "$ALARM_STOP" hat den Signalpegel 0.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Geberleitung überprüfen.

  • Steckverbindungen überprüfen.

  • Versorgungsspannung kontrollieren.

  • Geber überprüfen und ggf. austauschen.


Geberleitung defekt Position Tracker auf DSE <Dse Nummer>

Ursache:

  • Geberleitung für Position Tracker Eingang defekt.

  • Lose Steckverbindung.

  • Versorgungsspannung fehlt.

  • Position Tracker Positionsgeber defekt.

Auswirkung:

Ausgangssignal $POS_TRACKER_ERROR wird gesetzt

Abhilfe:

  • Position Tracker Geberleitung überprüfen.

  • Steckverbindungen überprüfen.

  • Versorgungsspannung kontrollieren.

  • Position Tracker Geber überprüfen und ggf. austauschen.


Gegenseitige geometrische Abhängigkeit festgestellt

Ursache: | Die lokale Maschine verhält sich wie ein Master und Slave gleichzeitig zu einer entfernten Maschine.
Auswirkung: | Unberechenbare Bewegung möglich.
Abhilfe: | Ändern Sie das Programm, um die Kreisabhängigkeit zu vermeiden.


Gesamtanalyse aktiv

Ursache: | Der Compiler führt eine Gesamtanalyse durch.
Auswirkung: | Keine
Abhilfe: | Warten, bis der Vorgang beendet ist.


Hardware-Defekt DSE Nr. <DSE Nummer> (<Fehlertyp>)

Ursache: | Ein Hardware-Defekt in der DSE-Karte ist erkannt worden.
Auswirkung: | System wird aus Sicherheitsgründen angehalten.
Abhilfe: | DSE austauschen.


Hardware-Endschalter / +24V fehlen

Ursache:

Der Hardware-Endschalter der angezeigten Achse wurde in der angezeigten Richtung angefahren.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Achse in Gegenrichtung freifahren.


Höheres Fahrprofil mit gekoppelten Zusatzachsen nicht möglich

Ursache: | Kopplung von Zusatzachsen im höheren Fahrprofil
Abhilfe: | Konfigurierung entsprechend ändern.


i*i-t Überwachung, Strombelastung der Motorleitung <Achsnummer> nach <Zeit> s 95 % erreicht

Ursache:

Achse überlastet.

Der Wert für den max. zulässigen Grenzstrom wird in den Maschinendaten durch "$CURR_MON[]" vorgegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung der aktiven Kommandos.

Abhilfe:

Belastung verringern.


i*i-t Überwachung, Strombelastung der Motorleitung <Achsnummer> nach <Zeit> s 100 %

Ursache:

Achse überlastet.
Der Wert für den max. zulässigen Grenzstrom wird in den Maschinendaten durch "$CURR_MON[]" vorgegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung der aktiven Kommandos.

Abhilfe:

Belastung verringern.


Ixt-Antriebsregler <Achsnummer> Überschreitet Wert <I*I*t Wert> %

Ursache:

Wenn auf einem Antriebsregler der eingestellte Warnungswert für die Ixt-Überwachung überschritten wird, dann muss der Roboter zum Stillstand gebracht werden. Ansonsten schaltet der Antriebsregler bei Überschreiten des Maximalwertes von 100 % ab.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.


Inbetriebnahme

Ursache: | Das Inbetriebnahme-Menü wurde angewählt.
Auswirkung: | Es ist keine Programmbearbeitung möglich.
Abhilfe: | Mit RECALL-Taste Inbetriebnahme-Menü verlassen.


Interpolationstakt Zeitüberwachung <Achsnummer>

Ursache:

DSE hat keinen Vorschub vom Grundsystem für diese Achse erhalten.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Steckverbindung zwischen DSE und MFC, sowie zwischen MFC und Motherboard auf einwandfreie Kontaktgabe prüfen.

  • Sollte dies keine Verbesserung bringen, dann DSE bzw. MFC austauschen.


Istgeschwindigkeit <Achsnummer> Überwachung

Ursache:

Fehler im Regelkreis:
– Motorleitungen zweier Achsen vertauscht.
– Fehler in der Achsrangierung.
– Powermodul defekt.
– Resolver dejustiert.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Motorleitungen überprüfen.

  • Fehler in Regelkreis / Achsrangierung beheben.

  • Powermodul überprüfen und ggf. austauschen.

  • Bei dejustiertem Resolver Roboter neu justieren.


Justage durchführen <Achsnummer>

Ursache:

  • Lage-Istwert-Differenz nach Wiederanlauf zu groß; Störjustage nicht möglich, weil keine Übernahmefahrt durchgeführt wurde.

  • Es wurden fehlerhafte Korrekturdaten geladen.

Auswirkung:

Verriegelung aller aktiven Kommandos.

Abhilfe:

Justage durchführen.


Justage-Referenzierung fehlgeschlagen

Ursache:

Um eine korrekte Roboterjustage zu garantieren, muss diese durch Anfahren eines definierten Punktes referenziert werden. Die Referenzierung ist fehlgeschlagen.
Mögliche Ursachen sind:

  • Fehlerhafte Justage

  • Defekter Referenzschalter

  • Falsch positionierter Referenzschalter.

Auswirkung:

Der Roboter darf nur mit reduzierter Geschwindigkeit verfahren werden.

Abhilfe:

  • Justage prüfen und ggf. berichtigen.

  • Referenzschalter prüfen und ggf. austauschen.

  • Position des Referenzschalters prüfen und ggf. korrigieren.

Nach Durchführung einer erfolgreichen Referenzfahrt kann der Roboter wieder mit normaler Geschwindigkeit verfahren werden.


K1 Kontakt verschweißt <Powermodul Nummer>

Ursache:

K1 Kontakt ist verschweißt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung der aktiven Kommandos.

  • Energie wird nicht abgeschaltet.

Abhilfe:

Schütz, KPS tauschen.


Kanal <Name des Kanals> nicht belegbar

Ursache: | Der angewählte Kanal kann nicht belegt werden.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Kanal an anderer Stelle freigeben.


KCP Vorseriengerät

Ursache: | Es ist noch ein KCP aus der Vorserie angeschlossen.
Auswirkung: | Es ist keine KCP-Watchdog Funktion vorhanden.
Abhilfe: | Vorhandenes KCP gegen ein Seriengerät austauschen.


Kein Multiplexbetrieb für DSE-Kanal <Kanal-Nummer>

Ursache:

Kraftbetrieb ist aktiviert, aber die RDW hat keine Aufsteckkarte für Multiplexbetrieb

Auswirkung:

Kraftbetrieb wird nicht aktiviert

Abhilfe:

  • RDW-Aufsteckkarte stecken

  • Kraftbetrieb explizit deaktivieren


Roboternummer prüfen

Ursache: | Es ist keine Kalibrierungsdatei vorhanden.
Abhilfe: | Kalibrierungsdatei zuweisen.


<Kommandoname> aktiv

Ursache: | OBJH Kommando wird ausgeführt.
Auswirkung: | Keine.
Abhilfe: | Warten, bis OBJH wieder frei ist.


Konfiguration des Antriebsbus DSE 1 zu lang

Ursache:

Die Konfiguration erzeugt eine zu große IBS-Wortlänge aufgrund zu vieler Interbusteilnehmer.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

IBS-Konfiguration ändern.


Korrekturdaten fehlerhaft

Ursache:

Der Lader für die Korrekturdaten hat eine Variable mit einem unzulässigen Wert erkannt.- Grenzwert wurde überschritten.

  • logischer Zusammenhang der Daten ist nicht gegeben.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die Wertzuweisung der angezeigten Variablen berichtigen.


<Pfad> Korrekturdatenlader abgebrochen

Ursache:

Die Anzahl der vom Korrekturdatenlader erkannten Fehler überschreitet die Kapazität des Meldungspuffers.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die Wertzuweisung der angezeigten Variablen berichtigen.


Kraftanstieg in Kraftregelung bleibt aus <Achsnummer>

Ursache:

Bei einem angefahrenen kraftgeregelten Punkt steigt der Wert des Kraftsensors nicht an.
Mögliche Ursachen können sein:

  • Kraftsensor, KSK, Kabel, RDW,... defekt oder nicht richtig angeschlossen.

  • Zangenkappen berühren das Bauteil nicht.

Auswirkung:

Zur Vermeidung von Beschädigungen der Zange und des Bauteiles erfolgt ein Stopp.

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

  • Der Kraftregler wird nicht aktiviert.

Abhilfe:

  • Kraftsensor prüfen.

  • Leitung zum Kraftsensor prüfen.

  • RDW Aufsteckkarte (KSK) prüfen.


Kraft- und Wegänderung nicht proportional in Kraftregelung <Achsnummer>

Ursache:

Kraftsensor Signal passt nicht zur Bewegung:

  • Istkraft ändert sich und Position bleibt konstant.

  • Position ändert sich und Istkraft bleibt konstant.

Hinweis:
Diese Überwachungen sind nur während der Kraftregelung aktiv.

Abhilfe:

  • Kraftsensor prüfen.

  • Kraftsensor Kabel prüfen.

  • RDW Aufsteckkarte (KSK) prüfen.

  • Zangenlager und -führungen prüfen.

  • Prüfen ob Zangensack zu eng.


KRC Systemfehler <Fehlernummer> <Verursacher>

Ursache:

Es ist ein KRC-Systemfehler aufgetreten.

  • Der Fehler ist im Grundsystem aufgetreten und nicht quittierbar.

  • Absturz einer Systemtask

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Archivierung starten

  • Sämtliche Logfiles an die Entwicklung schicken

  • Bedienhandlung beschreiben

  • KRC-Steuerung neu starten.

  • Nach dem Neustart, falls vorhanden, C:\KRC\Bin\vxworks.debug an Entwicklung schicken.


Kurzschluss Zwischenkreis <Powermodul Nummer>

Ursache: | KPS muss einen zu großen Strom liefern
Auswirkung: | KPS schaltet aus Eigenschutz ab.


Leistungsüberwachung Zwischenkreisnetzteil <KPS Nummer>

Ursache:

Überlastung der Zwischenkreisspannung eines KPS.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Belastung verringern.


LK() Kopplung von <Abhängige Steuerung> aktiv

Ursache:

Es wurde versucht, eine Bewegung abhängig von einer anderen Steuerung auszuführen. Die bewegungsführende Steuerung ist zur Zeit aber noch von der lokalen Steuerung geometrisch abhängig.

Diese Meldung wird ausgegeben, wenn sich die Richtung der Bewegungskopplung von einer Bewegung zur nächsten umkehrt.

Auswirkung:

Lokale Bewegungsausführung startet erst, wenn die LK()-Kopplung der anderen Steuerung aufgehoben ist.

Abhilfe:

  • Flüchtiger Zustand.

  • Falls die Meldung bestehen bleibt und nicht von einer Stop-Meldung begleitet wird, benachrichtigen Sie den KUKA-Kundendienst.


Lokaler Zeitgeber nicht synchronisiert während der Bewegungskooperation

Ursache: | Der lokale Zeitgeber ist mit dem entfernten Zeitgeber während einer gemeinsamen Bewegungskooperation nicht synchronisiert.
Auswirkung: | Programmausführung wird gestoppt.
Abhilfe: | Vergewissern Sie Sich, dass die Zeitgeber-Synchronisation installiert wurde und richtig arbeitet.


Lüfter defekt. Modul <Achsnummer, KPS Nummer> tauschen, um Ausfall zu vermeiden.

Ursache:

Lüfter auf dem Umrichter einer Cobra Steuerung ist defekt.

Auswirkung:

Umrichter wird nicht mehr ausreichend gekühlt.

Abhilfe:

  • Überprüfung auf freie Drehbarkeit des Lüfters.

  • Tausch des Lüfters


Mainboardtemperatur erreichte Warngrenze

Ursache:

  • Steuerschranklüfter zu hoch.

  • Umgebungstemperatur zu hoch.

Abhilfe:

  • Lüfter überprüfen.

  • Lüfterfilter wechseln.


Mainboardtemperatur zu hoch

Ursache:

  • Steuerschranklüfter ausgefallen.

  • Umgebungstemperatur zu hoch.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Lüfter überprüfen.

  • Lüfterfilter auswechseln.

  • Umgebungstemperatur senken.


Mainboardtemperaturüberwachung nicht verfügbar

Ursache:

  • Steuerschranklüfter zu hoch.

Das Mainboard unterstützt keine Temperaturüberwachung.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Temperaturüberwachung ausschalten.

  • Mainboard austauschen.


<Pfad> Maschinendaten fehlerhaft

Ursache:

Der Maschinendatenlader hat eine Variable mit einem unzulässigen Wert erkannt.- Grenzwert wurde überschritten.

  • logischer Zusammenhang der Daten ist nicht gegeben.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die Wertzuweisung der angezeigten Variablen berichtigen.


Maschinendatenlader ($CUSTOM.DAT) abgebrochen

Ursache:

Die vom Anwenderdatenlader erkannten Fehler überschreiten die Kapazität des Meldungspuffers.- Ansprechen der Grenzwertüberwachung

  • Logischer Zusammenhang der Daten nicht gegeben

  • bei "POWER ON"

  • nach dem Editieren der Anwenderdaten

  • nach dem Einlesen der Anwenderdaten

Auswirkung:

  • Bahntreuer Stop

  • Verriegelung aller aktiven Kommandos

  • kein RC-Ready

Abhilfe:

  • Die Wertzuweisungen der angezeigten Variablen berichtigen.


Maschinendaten ungleich Robotertyp

Ursache: | Die auf der Steuerung geladenen Maschinendaten entsprechen nicht dem Robotertyp.
Auswirkung: | Der Roboter darf nicht verfahren werden! Achtung! Aufgrund der nicht zum Roboter passenden Maschinendaten kann der Roboter beim Verfahren infolge Überlastung Schaden nehmen. Wird der Roboter dennoch mit falschen Maschinendaten betrieben, erlischt jeglicher Gewährleistungsanspruch gegen den Hersteller!
Abhilfe: | Die richtigen Maschinendaten laden.


<"/" oder "/R1"> Maschinendatenlader abgebrochen

Ursache:

Die Anzahl der vom Maschinendatenlader erkannten Fehler überschreitet die Kapazität des Meldungspuffers.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die angezeigten Fehlermeldungen abarbeiten.


Master nicht bereit <xxx>

Ursache: | Die lokale Steuerung ist Slave in einer zeitsynchronen Bewegung und wartet darauf, dass der Master diesen Bewegungssatz ausführt. Hinweis: Dieser Zustand sollte nicht über längere Zeit bestehen. Falls doch, so ist das Programm gestoppt worden oder der Master mit Interrupt-Bewegungen beschäftigt.
Auswirkung: | Bewegung kann erst starten, wenn der Master den Satz im Hauptlauf erreicht hat.
Abhilfe: | Master-Steuerung starten.


Master-Slave Maximalposition überschritten <Achsnummer>

Ursache: | Die maximal zulässige Position des Slaves in Inkrementen (8.000.000) ist überschritten.
Auswirkung: | Es kommt durch die Skalierungsfaktoren (Float) zu Rechenfehlern in Istgeschwindigkeit, Schleppfehler und Positionsabweichung.
Abhilfe: | Arbeitsbereich entsprechend anpassen, so dass er im Bereich +/- 8.000.000 Inkrementen liegt.


MDR Rekonfiguration gestartet, bitte warten

Ursache:

Über die BOF wurde ein MDR Reload-Befehl abgesetzt.

Auswirkung:

  • Bahntreuer Stopp

  • Aktive Kommandos verriegelt.

Abhilfe:

Zustand bereinigt sich nach erfolgreicher Rekonfiguration selbst.


Mehrdeutiger Name! lokal: '<Lokal->Coop_Krc.Name>' auf Steuerung '<Lokal->Coop_Krc.Name>' Name: '<Remote->Coop_Krc.Name>'

Ursache: | Der konfigurierte Name einer Steuerung (in $Coop_Krc[x]) unterscheidet sich für eine bestimmte IP-Adresse auf den Steuerungen. z.B. Roboter_1 hat den $Coop_KRC[1].Name="ROB_1" [IP=192.0.10.1] Roboter_2 hat den $Coop_KRC[2].Name="ROBI_1" [IP=192.0.10.1]
Auswirkung: | Die Namensungleichheit könnte beim Anwender zu Verwirrungen führen.
Abhilfe: | Die Namen sollten innerhalb des kooperierenden Verbundes einheitlich vergeben werden. Also bitte umkonfigurieren.


Mehrere Kalibrierungs-Dateien vorhanden

Ursache: | Es sind mehrere Kalibrierungs-Dateien vorhanden.
Abhilfe: | Richtige Kalibrierungs-Datei zuweisen.


MFC - Übertemperatur

Ursache:

Der Temperaturfühler auf der MFC hat ausgelöst.

Auswirkung:

Bahntreuer Stop.

Abhilfe:

  • Lüfter im Schaltschrank überprüfen.

  • Ggf. MFC austauschen.


Modul <Achsnummer> KSD-<Maximalstrom des KSDs> erforderlich

Ursache:

Der Maximalstrom des Gerätes stimmt nicht mit dem konfigurierten Maximalstrom überein.


Motorleitung <Achsnummer>

Ursache:

Die Motorleitung der angegebenen Achsnummer ist defekt.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


NOT-AUS

Ursache:

  • Not-Aus-Taster gedrückt

  • Not-Aus-Kreis unterbrochen

  • Not-Stop vom Programm ausgelöst

Auswirkung:

  • Bahntreuer Stop

  • Verriegelung aller aktiven Kommandos

Abhilfe:

  • Not-Aus-Taster entriegeln (drehen Sie hierzu das Oberteil in Pfeilrichtung)

  • Not-Aus-Kreis kontrollieren und ggf. wiederherstellen

  • Die gemeldete Störung beheben und quittieren


NOT-AUS extern

Ursache:

  • Not-Aus-Taster gedrückt.

  • Not-Stop von der Software ausgelöst.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Die gemeldete Störung beheben und quittieren.

  • Not-Aus-Taster kontrollieren.


NOT-AUS durch KRC (Notstopp)

Ursache:

Von der KRC Systemsoftware wurde wegen eines schwerwiegenden Fehlers Not-Stopp ausgelöst.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Die gemeldete Störung beheben.


NOT-AUS wegen Drehjustage

Ursache:

  • Betätigung des Softkeys für Drehjustage

  • Wertzuweisung $TURN = 1

  • Einstellen eines Gebers, absolut oder inkrementell

  • bei der Anweisung $TURN

Auswirkung:

  • generatorischer Stop

  • Ausgang "$ALARM_STOP" 0-Signal

  • Verriegelung aller aktiven Kommandos

Abhilfe:

  • Durch zweimaliges Betätigen der Recall-Taste das Justage-Menü verlassen.


Optionsdaten fehlerhaft

Ursache:

Der Lader für die Optionsdaten hat erkannt, dass eine Variable mit einem falschen Wert initialisiert wurde:- Grenzwert wurde überschritten.

  • logischer Zusammenhang der Daten ist nicht gegeben.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die Wertzuweisung der angezeigten Variable korrigieren.


Optionsdatenlader abgebrochen

Ursache:

Die Anzahl der vom Optionsdatenlader erkannten Fehler überschreitet die Kapazität des Meldungspuffers.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kein RC-Ready.

Abhilfe:

Die angezeigten Fehlermeldungen abarbeiten.


Palettiermodus: Achse <Achsnummer> <Verfahrrichtung> in Position fahren

Ursache: | Im Palettiermodus ($PAL_MODE = TRUE) hat die Achse 4 oder 5 nicht die erwartete Stellung, d. h. Achse 4 = 0 Grad und Achse 5 = 90 Grad.
Auswirkung: | keine
Abhilfe: | Die Achse in angegebene Richtung verfahren.


Parameterfehler <Achsnummer> <Parametersatz-Nr.>

Ursache:

Es besteht ein Parameterfehler bei der angegebenen Achsnummer und Parametersatznummer.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.


<Ausgang/Eingang> Parameter außerhalb seines Bereichs <max. E/A>

Ursache: | Der angegebene Parameter liegt außerhalb des Bereichs.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Parameter entsprechend ändern.


Parityfehler Powermodul <KPS Nummer>

Ursache:

Beim Lesen der Powermodulregister ist mehr als fünfmal hintereinander ein Parityfehler aufgetreten. Powermodulschnittstelle wird zu stark gestört oder Powermodul defekt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Kabel prüfen.

  • Abschirmung prüfen.

  • Powermodul tauschen.


Passiver STOPP <RST oder PHG>

Ursache:

Stopp von einem passiven Bediengerät.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


PC Lüfter defekt

Ursache:

Der PC-Lüfter ist defekt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

PC-Lüfter austauschen.


Warnung: PC Lüfter unter Nenndrehzahl

Ursache: | Der PC-Lüfter ist unter Nenndrehzahl gefallen.
Auswirkung: | Bauteile können überhitzen.
Abhilfe: | PC-Lüfter überprüfen und ggf. austauschen.


Powermodul Achse <Achsnummer> nicht oder falsch gesteckt

Ursache: | Das Stromkabel für die Achse ist am Powermodul nicht oder falsch angeschlossen.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Stromkabel richtig anschließen.


Powermodul Rangierung <Achsnummer> falsch

Ursache:

$PMCHANNEL doppelt belegt oder falscher Kanal.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Maschinendatenlader wird abgebrochen.

Abhilfe:

$PMCHANNEL korrigieren.


Taskstack für Kommandoabarbeitung zu klein

Ursache:

  • KRL-Programm bzw. Kommando hat zur Abarbeitung zu wenig Taskstack zur Verfügung.

  • Bei Programmbearbeitung bzw. Kommandobearbeitung

Auswirkung:

  • Rampen Stop

  • Verriegelung aller aktiven Kommandos

Abhilfe:

Struktur des Programms ändern und Programmreset.


Programmlaufart Umschaltung noch nicht wirksam!

Ursache: | Bei der Umschaltung der Programmlaufart von "#GO/#PSTEP" nach "#xSTEP" muss eine implizite Satzanwahl auf den aktuellen Hauptlaufsatz erfolgen, um einen evtl. geplanten Vorlauf zu verwerfen und im Step-Betrieb weiterfahren zu können. Diese Satzanwahl ist nicht möglich, wenn sich der Hauptlauf noch in einem Unterprogramm befindet, der Interpreter (Vorlauf) dieses aber bereits verlassen hat. In diesem Fall wird bis zum Ende des Unterprogramms in "#GO/#PSTEP" weitergefahren und die Umschaltung nach "#xSTEP" wird erst nach Abarbeitung des Unterprogramms wirksam.
Auswirkung: | Trotz Umschaltung der Programmlaufart nach "#xSTEP" fährt der Roboter weiter in "#GO" bis zum Verlassen des Unterprogramms.
Abhilfe: | Die Meldung wird nicht mehr angezeigt, sobald die Umschaltung wirksam ist.


Roboternummer konfigurieren - Robotername programmieren

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Roboternummer <Roboterseriennummer (RDW)> ungleich Kalibrierungsdatei <Nummer der Kalibrierungsdatei>

Ursache: | Die Kalibrierungsdatei passt nicht zur Roboterseriennummer.
Abhilfe: | Die richtige Kalibrierungsdatei aufspielen.


RDW <RDW Nummer> läuft nicht hoch

Ursache:

  • Beim Einschalten der Steuerung konnte die RDW nicht initialisiert werden.

  • Defekt in RDW, DSE oder Verbindungsleitung.

Auswirkung:

  • Kein Hochlauf.

Abhilfe:

  • Verbindungsleitung, Steckverbindungen zwischen RDW und DSE prüfen.

  • Defekte RDW, DSE bzw. Leitung zwischen RDW und DSE austauschen.


RDW-Datei nicht vorhanden <Programmname>

Ursache: | Das in der RD_HWINF.INI eingetragene RDW-Programm existiert nicht.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | RDW-Programm in die RD_HWINF.INI-Datei korrekt eintragen.


Robotersimulation aktiv

Ursache: | Die Variable $SERVO_SIM ist auf TRUE gesetzt.
Auswirkung: | Programme werden ohne Roboterbewegung ausgeführt.
Abhilfe: | Um die Robotersimulation zu beenden, setzen Sie die Variable $SERVO_SIM auf FALSE.


Robotersimulation nur im Testbetrieb möglich

Ursache: | Robotersimulation in den Betriebsarten "#AUT" oder "#EXT" nicht möglich.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Wechseln der Betriebsart.


Bitte Schrank ausschalten

Ursache:

Die Parameter der Antriebsregler sind geladen und werden erst beim nächsten Hochlauf gültig.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Schaltschrank ausschalten.


Schranklüfter defekt

Ursache: | Der Schranklüfter ist defekt.
Auswirkung: | Bauteile können überhitzen.
Abhilfe: | Schranklüfter überprüfen und gegebenenfalls austauschen.


Warnung: Schranklüfter unter Nenndrehzahl

Ursache: | Der Schranklüfter dreht sich unter Nenndrehzahl.
Auswirkung: | Bauteile können überhitzen.
Abhilfe: | Schranklüfter überprüfen und gegebenenfalls austauschen.


Schranktemperatur zu hoch <Powermodul Nummer>

Ursache:

Die Schaltschrank-Temperatur ist unzulässig hoch.

Auswirkung:

  • Rampen Stop.

  • Verriegelung alle aktiven Kommandos.

Abhilfe:

  • Funktion der Lüfter im Schaltschrank prüfen.

  • Prüfen, ob Lüftungsöffnungen am Schrank frei sind und genügend Luft zirkuliert.

  • Umgebungstemperatur verringern.

  • Gegebenenfalls Aufstellungsort verändern.


Sensorfehler Kühlkörpertemparatur <Achsnummer>

Ursache:

Sensorfehler

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Sensorfehler beheben.


Sensorfehler Motortemperatur <Achsnummer>

Ursache:

Für den Sensor Motortemperatur der angegebenen Achse wird ein Fehler gemeldet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Slaves nicht bereit (bevor INTERPOLATION) <Name/IP der Verursacher>

Ursache:

Die lokale Steuerung ist ein LK()-Master und wartet am Bewegungsanfang darauf, dass alle abhängigen Steuerungen die Bewegungsausführung aktivieren.

Hinweis:
Dieser Zustand sollte nicht dauerhaft anstehen. Typischerweise tritt dieser Zustand auf, wenn kein synchroner Start aktiviert ist und nach einem Stop zunächst nur der Master angestartet wurde. Verharrt der Slave nach Wiederanstarten des Programmes im Interrupt, kann dies ebenfalls zu so einer solchen Situation führen.

Auswirkung:

Bewegungsausführung kann nicht starten, weil nicht auf allen abhängigen Steuerungen die Bewegungsausführung aktiv ist.

Abhilfe:

  • Slave-Programm anstarten.

  • Ggf. Wartemeldungen aus einem Interruptbaustein einem Slave beachten und entsprechende Fehlersituation beseitigen.


Softwareendschalter der asynchronen Achse <Verfahrrichtung> <Achsnummer>

Ursache: | Asynchrone Achse ist in den positiven oder negativen SOE gefahren.
 | Der Softwareendschalter wird zyklisch geprüft, wenn die Achse als asynchrone Achse geschaltet ist.
Abhilfe: | Betroffene Achse freifahren.


Spannungsausfall

Ursache:

Die Spannungsversorgung der Steuerung ist unterbrochen.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Spannungsversorgung wiederherstellen.


Satzanwahl: SAK-Fahrt in T1/T2 erforderlich

Ursache: | Es wurde eine Satzanwahl in einem fehlerhaften Programm durchgeführt.
Auswirkung: | Das Programm wird nicht ausgeführt.
Abhilfe: | Damit der Roboter wieder auf die programmierte Bahn kommt, ist eine SAK-Fahrt durchzuführen. Vorsicht Crashgefahr! Der Roboter bewegt sich bei der SAK-Fahrt auf einer nicht programmierten Bahn. Prüfen Sie vorher den Handoverride und achten Sie darauf, dass nicht mit zu hoher Geschwindigkeit losgefahren wird. Stellen Sie die Betriebsart T1 oder T2 ein und betätigen Sie die Starttaste.


Sensorfehler Innenraumtemperatur <Achsnummer>

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


SAK-Fahrt in Single-Step erforderlich

Abhilfe:

Es ist eine SAK-Fahrt in Single-Step erforderlich.


Sicherheitslogik überprüfen. Schützabfallzeit bei NOT-AUS wurde überschritten

Ursache: | Die definierte max. Abfallzeit für einen Schütz wurde bei gegebenem Not-Aus überschritten.
Abhilfe: | Hardware überprüfen.


Schlupf zu groß <Achsnummer>

Ursache:

Die Regelabweichung hat einen Grenzwert überschritten, da der Schlupf zu groß ist.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware, etc. überprüfen.


Servofilekonfiguration <Konfiguration aus den Madas> paßt nicht zum <"DSE-Software-" bzw. "Firmware-"> -Stand <install. "DSE-SW" bzw. "Firmw.-">

Ursache:

Die Servofilekonfiguration beinhaltet Parameter für den Antriebsregler, die von der Firmware nicht unterstützt werden.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Firmware des Antriebsreglers oder die Servofiles hochrüsten.


Sicherheitsparameter nicht korrekt <Parameterindex>

Ursache: | Die Daten im Sicherheits-Parametersatz sind fehlerhaft oder unvollständig.
Auswirkung: | Die Antriebsfreigabe kann nicht gegeben werden.
Abhilfe: | Die korrekten Sicherheits-Parameter müssen nachgeladen werden.


Sicherer Betriebshalt verletzt

Ursache: | Der Roboter hat sich bewegt, obwohl der sichere Betriebshalt aktiviert ist.
Auswirkung: | Der Roboter wird gestoppt und kann nur mit verminderter Geschwindigkeit verfahren werden.
Abhilfe: | Der sichere Betriebshalt muss deaktiviert werden oder der Roboter muss an die Position zurückkehren, an der der sichere Betriebshalt aktiviert wurde.


Sicheren kartesischen Arbeitsraum <Nummer des Arbeitsraums> überschritten

Ursache: | Der Roboter ist aus dem kartesischen Arbeitsraum gefahren, der in den Sicherheitsparametern definiert wurde.
Auswirkung: | Der Roboter darf nicht weiterfahren.
Abhilfe: | Der Roboter muss wieder in den Arbeitsraum zurückfahren, bzw. der nächste Arbeitsraum in den er fälschlicherweise gefahren ist, muss freigeschaltet werden.


Softwareendschalter <Verfahrrichtung> <Achsnummer>

Ursache: | Der Istwert der angegebenen Achse hat den Wert des Softwareendschalters erreicht.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Achse in Gegenrichtung freifahren.


Software der <DSE Nummer> passt nicht zur DSE Hardware oder DSE defekt

Ursache:

Es wurde die falsche Software für die DSE konfiguriert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Prüfen, ob der Eintrag in der "hw_inf.ini" zur vorhandenen DSE Hardware passt.

  • Ggf. DSE tauschen.


Softwareversion von DSE <DSE Nummer> passt nicht zum Grundsystem

Ursache:

DSE-Software und Grundsystemsoftware sind zusammen nicht lauffähig.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Speicherabzug erstellen.

  • KRC-Software neu installieren.


<"normale" bzw."Konfigurations-"> Servoparameter <Achsnummer> werden geladen

Ursache:

Das Laden der Parameter der Antriebsregler.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Warten, bis Parameter geladen sind.


Slaves nicht bereit (nach ferngesteuertem Bremsen) <Name/IP der Verursacher>

Ursache: | Die lokale Steuerung wurde durch einen Interrupt einer abhängigen Steuerung in der Bewegungsausführung unterbrochen und wartet darauf, dass die abhängige Steuerung ihre eigene Bewegungsausführung aktiviert. Nach einem Interrupt mit BRAKE, der mit RESUME verlassen wurde, wird der aktuelle Bewegungssatz des Slaves verworfen, die LK-Beziehung aber nicht aufgehoben. Folgt nach dem Rücksprung am Slave keine oder eine verzögerte Bewegung, die entweder wieder LK-bezogen ist oder die Beziehung aufhebt, so wird der Master blockiert.
Auswirkung: | Bewegung kann nicht fortgesetzt werden, weil nicht auf allen abhängigen Steuerungen die Bewegungsausführung aktiv ist.
Abhilfe: | Das Programm ist ggf. anzupassen, bzw. bei korrektem Programm ist abzuwarten, bis das Programm des Slaves auf einen neuen Bewegungssatz trifft.


Speichertest-Fehler DSE <DSE Nummer>

Ursache:

Der Speichertest auf dem DP-RAM der DSE war fehlerhaft.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

DSE oder MFC tauschen.


Spitzenstrom <Powermodul Nummer> zu groß

Ursache: | KPS muss einen zu großen Spitzenstrom liefern
Auswirkung: | KPS schaltet zum Eigenschutz ab
Abhilfe: | Umteachen der Roboterbahn, langsameres Verfahren


Stopptaste <PHG oder RST>

Ursache:

Die Starttaste oder die Richtungstaste wurde bei gedrückter Stopptaste betätigt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Stopptaste überprüfen.


Stellgröße <Achsnummer>

Ursache:

Zu großer Schleppfehler. Die Achse folgt nicht dem Sollwert.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung der aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Überprüfen der Maschinendaten $IN_POS_MA (Positionierfenster Achse) und $FOL_ERR_MA (Faktor für Schleppfehlerüberwachung).

  • Stromrichter überprüfen.

  • Mechanik und Motor kontrollieren.

  • Überprüfen der Regelparameter und der Getriebeübersetzungen der Achse.

  • Überprüfen der Maschinendaten $COM_VAL_MI (Solldrehzahlbegrenzung Achse) und $TL_COM_VAL (Toleranzzeit für Solldrehzahlbegrenzung).


Steuerschranktür offen

Ursache: | Die Tür des Steuerschranks ist offen.
Abhilfe: | Türe schließen.


Steuerschranktür schließen, sonst Garantieverlust

Ursache: | Die Steuerschranktür stand länger als 30 Minuten offen.
Auswirkung: | Verschmutzungsgefahr.
Abhilfe: | Steuerschranktür schließen.


Steuerung nicht lokal konfiguriert: '<Remote->Coop_Krc.Name> [<Remote->Coop_Krc.IP_Addr>]'

Ursache: | Ein Ping von einer Remote-Steuerung wurde empfangen, die aber lokal nicht konfiguriert ist (in $Coop_KRC[x]).
Auswirkung: | Der Anwender wird darauf hingewiesen, dass er diese Steuerung auch in seine lokale Konfiguration aufnehmen soll.
Abhilfe: | Diese Steuerung mit dem genannten Namen nun auch lokal konfigurieren.


SYNCCMD-Kommandos werden simuliert (<Simulierte Steuerungen>)

Ursache: | Globale Simulation der SYNCCMD-Kommandos wurde für die angegebenen Steuerungen aktiviert. Simulierte Steuerungen werden für Programmsynchronisationspunkte und zeitsynchrone Bewegungen grundsätzlich nicht berücksichtigt.
Auswirkung: | Lokale SYNCCMD-Kommandos wirken stets so, als hätte die betroffene Steuerung den Synchronisationspunkt als erste erreicht.
Abhilfe: | Deaktivierung im Dialog "Cell Map Simulation".


Synchronisationsfehler Antriebsmodul <Achsnummer>

Ursache:

Synchronisationsfehler Antriebsmodul der angegebenen Achsnummer.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.


Synchronisierung mit <machine list> nicht möglich

Ursache: | Es wurde versucht, eine Programmsynchronisation bzw. eine Bewegungssynchronisation aufzubauen, wobei aber kein Kommunikationskanal mit der betroffenen Steuerung erstellt werden konnte.
Auswirkung: | Solange keine Verbindung aufgebaut werden kann, ist eine Synchronisierung nicht möglich.
Abhilfe: | Überprüfen, ob das Netzwerkkabel korrekt angeschlossen ist, und die entsprechenden IP-Adressen korrekt konfiguriert sind.


Syntaxfehler beim Lesen der Datei <Dateiname> in Zeile <Inhalt der Zeile>

Ursache: | Syntaxfehler beim Interpretieren der Parameterdatei (absolutgenauer Roboter).
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Datei einspielen, Steuerung booten.


Systemzeit ungültig

Ursache: | Die Systemzeit ist nach "TIME_HW_FAILURE" ungültig und wurde mit dem Initialwert beschrieben.
Auswirkung: | Systemzeit wurde mit 01.01.93 00:00:00,00 initialisiert.
Abhilfe: | Mittels Formular "syszeit" die Systemzeit aktualisieren.


Temperatur Warnung <Antriebsnummer>

Ursache:

An der angegebenen Stelle wird die Temperatur überschritten.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ursache feststellen und Fehler beheben.


TEPRO inaktiv

Ursache: | Der SBC sendet kein Lebenszeichen mehr zur KRC. (TEPRO = Technologieprozess)
Auswirkung: | Die SBC-Schnittstelle kann nicht betrieben werden.
Abhilfe: | Das SBC-Programm neu initialisieren.


<Variable> Überlappung AP-AP

Ursache: | Es wurden Anpassteil-Ausgänge doppelt belegt.
Auswirkung: | Kein RC-Ready.
Abhilfe: | Die Wertzuweisung korrigieren.


Überlauf Meldungspuffer

Ursache:

Meldungspuffer, der die aktuell anstehenden Meldungen (Quittungs- und Zustandsmeldungen) enthält, ist bis zu einer bestimmten Grenze gefüllt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Die gemeldeten Störungen beheben und quittieren.


Überspannung <KPS Nummer> beim Laden

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware überprüfen.


Übertemperatur Ballastwiderstand <KPS Nummer>

Ursache:

Der Ballastwiderstand ist zu heiß geworden, da im Bewegungsprogramm zu häufig beschleunigt und gebremst wurde.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Beschleunigung reduzieren.

  • Wartezeiten einführen.


Übertemperatur Ballastwiderstand <Powermodul Nummer> oder Lüfter

Ursache:

Temperatur des betreffenden Ballastwiderstands ist zu heiß.
Zum Beispiel: Im Fahrprogramm wird in zu kurzen Zeitabständen beschleunigt und gebremst.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Wartezeiten in das Bewegungsprogramm einfügen.

  • Beschleunigungen/Bremsungen reduzieren.


Übertemperatur Lüfter <Powermodul Nummer>

Ursache:

Einer der Lüfter im Schrank ist defekt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Defekten Lüfter ersetzen.


Übertragungsfehler <DSE Nummer>. DSE - RDW

Ursache:

  • Schadhafte Leitung oder Steckverbindung zwischen DSE und RDW.

  • Leitung nicht oder nicht richtig angeschlossen.

  • Störung der Datenübertragung zwischen DSE und RDW.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • DSE und RDW Spannungsversorgung prüfen (LEDs).

  • Leitung (auch die Abschirmung!) und Steckverbindungen überprüfen.

  • Serielle Schnittstelle DSE - RDW überprüfen.

  • Masseverbindung von Roboter und Schrank prüfen.


Unerreichbarer ASYPTP- Punkt Softwareendschalter <Achsnummer> in Modul <Modulname> Satz <Satznummer>

Ursache: | In einem Submit-Modul verletzt eine Komponente eines ASYPTP-Zielpunkt die Softwareendschalter
Auswirkung: | Keine, es steht lediglich die Zustandsmeldung an
Abhilfe: | Editieren des Submit-Moduls, alle Folds öffnen, Detailansicht einschalten (sonst stimmt die Satznummer nicht). Korrigieren des Zielpunkts.


Ungültige Betriebsart (?)

Ursache: | Ungültige Betriebsart erkannt.
Auswirkung: | Antriebe verriegelt
Abhilfe: | KCP austauschen


Ungültiger Parameter A <Achsnummer>

Ursache:

Der angegebene Parameter ist nicht gültig.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Parameter entsprechend korrigieren.


Ungültiges Kommando <Antriebsnummer>

Ursache: | Es wurde ein ungültiges Kommando aufgerufen.
Auswirkung: | Drehzahl Stop.
Abhilfe: | Kommando berichtigen.


Unterspannung <Achsnummer>

Ursache:

  • Die interne Betriebsspannung (+15V) der Servo-Endstufe wird überwacht. Ist die Servo-Endstufe nicht bereit, so ist evtl. die Zwischenkreisspannung zu niedrig.

  • Tritt zyklisch auf.

Auswirkung:

  • Rampen Stopp.

  • Stopp der Programmbearbeitung.

Abhilfe:

  • Fehler beseitigen.

  • Rücksetzen durch Betätigung des Hardware-Quittungstasters "ACK" an DSE I-Baugruppe.


Unterspannung <KPS Nummer> beim Laden

Ursache:

  • Meldung kommt direkt vom KPS.

  • Zwischenkreis konnte nicht richtig geladen werden.

Auswirkung:

  • Generatorischer Stopp.

  • Aktive Kommandos verriegelt.

Abhilfe:

  • Versorgungsspannungen des KPS auf Störungen und Ausfälle prüfen (insbesondere Drehstromnetz).

  • Falls erforderlich KPS austauschen.


Unzulässige Motorbelastung <Antriebsnummer>

Ursache:

Die Motorbelastung ist zu hoch.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Motorbelastung verringern durch geeignete Maßnahmen (geringere Last, Verringerung der Beschleunigung, etc.).


Unzulässige Programmstruktur für RESUME

Ursache:

Als RESUME abgearbeitet wurde, verwies der Vorlaufzeiger auf die Ebene, in welcher der Interrupt deklariert wurde.

Hinweis:

  • RESUME darf nur mit der Unterprogrammtechnik verwendet werden.

  • Der Interrupt darf nicht in der Ebene ausgelöst werden, in welcher er deklariert wurde.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm Reset.

  • Programm entsprechend ändern.

Hinweis:
Bei Abarbeitung von RESUME muss $ADVANCE=0 sein.


Verbindung zu Roboter <IP Addresse> verloren

Ursache:

Die lokale Steuerung kann einen anderen KIR-Teilnehmer dauerhaft nicht erreichen.

Auswirkung:

Programmausführung kann nicht fortgesetzt werden.

Abhilfe:

  • Alle Netzwerkverbindungen überprüfen.

  • Sicherstellen, dass aktive Netzwerk-Komponenten als "Full-Duplex" konfiguriert sind.

  • Sicherstellen, dass das KIR-Netzwerk gegenüber anderen Kommunikationseinrichtungen entkoppelt ist.


Versionskonflikt Firmware <Antriebsnummer>

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Konfiguration überprüfen.


Versionskonflikt mit externem Modul: Version <Version des Moduls> mit Version <erforderliche Version>

Ursache:

Die Version eines externen Moduls stimmt nicht mit der vom Grundsystem unterstützten Version überein.

Auswirkung:

  • Rampen Stop

  • Verriegelung aktiver Kommandos.

Abhilfe:

Das externe Modul muss in der geforderten Version installiert werden oder das externe Modul darf nicht geladen werden.


Warmfahren aktiv

Ursache:

  • Der Roboter hat nicht seine Betriebstemperatur;

  • "$WARMUP_RED_VEL" ist TRUE;

  • PTP-Satz wird gefahren und mindestens ein Motorstrom ist größer als "$WARMUP_CURR_LIMIT".

Auswirkung:

Roboter fährt mit verringerter Geschwindigkeit.


Watchdog Powermodul <Powermodul Nummer>

Ursache:

Watchdog des Powermoduls abgefallen.
(Triggerung durch DSE erfolgt im Abstand von 0,125 ms)

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • DSE überprüfen.

  • Powermodul überprüfen.


Wertebereichsüberlauf <Verfahrrichtung> <Achsnummer>

Ursache: | Überlauf des Istwertes einer Endlosachse. Istwert > +/– 90*10E15 Inkremente oder –99999000 < $REVO_NUM < 999999000.
Auswirkung: | Die Bewegung wurde bereits gestoppt; – beim achsspezifischen Handverfahren normal, – anderenfalls durch Drehzahl Stop.
Abhilfe: | Zurückdrehen oder Neujustage der entsprechenden Achse.


Zange faehrt kraftgeregelt kleiner FORCE_LIM <Achsnummer>

Ursache:

Die Zange öffnet sich weiter als bis zur gemäß FORCE_LIM korrespondierenden Position.Es folgt ein Stopp, um unkontrolliertes Öffnen der Zange zu vermeiden.
Hinweis:
Diese Überwachungen sind nur während der Kraftregelung aktiv!

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Kraftsensor prüfen.

  • Kraftsensor Kabel prüfen.

  • RDW Aufsteckkarte (KSK) prüfen.

  • Trace Aufzeichnung der Testgruppe 11-Kraftregelung, um zu ermitteln, ob der Regler zu stark schwingt.


Zeitgeber auf <Name or IP of remote machine> nicht synchronisiert

Ursache: | Der lokale Zeitgeber ist mit dem entfernten Zeitgeber während einer gemeinsamen Bewegungskooperation nicht synchronisiert.
Auswirkung: | Programmausführung gestoppt.
Abhilfe: | Vergewissern Sie Sich, dass die Zeitgeber-Synchronisation installiert wurde und richtig arbeitet.


Zeitgeber Status: Initialisierungsfehler

Ursache: | Die von der Bewegungskooperation sowie von der Kollisionsvermeidung geforderte Zeitgebersynchronisierung konnte nicht richtig initialisiert werden.
Auswirkung: | Bewegungskooperation nicht zulässig.
Abhilfe: | Überprüfen Sie die Zeitgeber-Synchronisierungsverbindungen und starten Sie die Steuerung erneut.


Zeitgeber Status: <Master/Slave> - Kein MASTER Impuls

Ursache:

Es wird kein Zeitsignal von der Master-Steuerung empfangen.

Auswirkung:

Bewegungssynchronisation und Kollisionsvermeidung sind gesperrt.

Abhilfe:

  • Überprüfen der KIR-Verkabelung.

  • Prüfen und sicherstellen, dass eine Steuerung im KIR-Verbund als Zeit-Master konfiguriert ist.

  • Erforderlichenfalls Kaltstart durchführen.


Zeitgeber Status: <Master/Slave>

Ursache:

Die Zeitsynchronisation der lokalen Steuerung wurde mit dem KIR-Verbund hergestellt.

Auswirkung:

Bewegungssynchronisation und Kollisionsvermeidung sind gesperrt.

Abhilfe:

  • Keine Benutzeraktionen erforderlich.

  • Meldung dient nur Debug-Zwecken.


Zeitgeber Status: <Master/Slave> - nicht synchronisiert

Ursache:

Nach Kaltstart und Start aus dem Hibernate-Modus sind die Uhren der Steuerungen im KIR-Verbund nicht synchronisiert.

Auswirkung:

Bewegungssynchronisation und Kollisionsvermeidung sind gesperrt.

Abhilfe:

  • Vorübergehender Zustand

  • Meldung wird nicht mehr angezeigt, sobald die Uhren synchronisiert sind.


Zeitgeber Status: Ungültig

Ursache:

Es ist ein interner Fehler in der Uhrensynchronisation aufgetreten.

Auswirkung:

Bewegungssynchronisation und Kollisionsvermeidung sind gesperrt.

Abhilfe:

  • Überprüfen der KIR-Verkabelung

  • Kaltstart durchführen


Zeit-Slaves fehlen <Name/IP der Verursacher>

Ursache: | Die lokale Steuerung ist Master in einer zeitsynchronen Bewegung und wartet darauf, dass alle Slaves diesen Bewegungssatz abfahren können. Hinweis: Der Zustand sollte nicht über längere Zeit bestehen. Falls doch, so ist ein Slave gestoppt worden oder mit Interruptbewegungen beschäftigt.
Auswirkung: | Bewegung kann erst starten, wenn alle Slaves den Satz im Hauptlauf erreicht haben.
Abhilfe: | Slave-Steuerungen überprüfen und ggf. Slave-Programme anpassen.


Zustimmschalter losgelassen

Ursache:

Der Zustimmungsschalter wurde während einer aktiven Funktion (Bewegung einer Achse) in der Betriebsart T1 oder T2 losgelassen.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Zustimmungsschalter drücken.

  • Eingang $SAFETY_SW überprüfen.


Zu viele Meldungen

Ursache:

Es wurden zyklisch zu viele Meldungen abgesetzt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ein Warmstart der ACR.


Zu viele Teilnehmer im Antriebsbus DSE <DSE Nummer>

Ursache:

Zu viele Teilnehmer im Interbusring verursachen eine zu große IBS-Wortlänge.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Anzahl der Teilnehmer oder Wortlänge verringern.


Zweites Motorkabel nicht angeschlossen

Ursache:

Das zweite Motorkabel ist nicht oder nicht korrekt angeschlossen. Im Zusatzkabel werden zwei Adern mitgeführt, die am Roboter verbunden sind. Das Rückführsignal wird auf das KPS X114 Pin 7 geführt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Zweites Motorkabel und Rückführsignal am KPS X114 Pin 7 prüfen.


Zwischenkreis Ladeschaltung defekt <Powermodul Nummer>

Ursache:

Optokoppler auf dem KPS meldet keinen Stromfluss.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Zwischenkreis lässt sich nicht laden.

Abhilfe:

Betroffene KPS austauschen.


"#" erwartet

Ursache: | Das Zeichen "#" fehlt oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"#" oder ENUM-Typname erwartet

Ursache: | Entweder wurde das Zeichen "#" vergessen oder kein deklarierter Enum-Typname verwendet. Beispiel: ENUM Emma e1,e2,e3 STRUC Hugo Emma a DECL Hugo RealHugo = {a e1}
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: ENUM Emma e1,e2,e3 STRUC Hugo Emma a DECL Hugo RealHugo = {a #e1}


$ORI_TYPE implizit auf #VAR gesetzt

Ursache: | $IPO_MODE steht auf #TCP (externer TCP) und $ORI_TYPE auf #JOINT. Diese Kombination ist nicht möglich. Diese Meldung wird nur in den Betriebsarten T1 und T2 ausgegeben.
Auswirkung: | $ORI_TYPE wird implizit auf #VAR gesetzt.
Abhilfe: | Entweder $IPO_MODE auf #BASE setzen oder $ORI_TYPE auf #VAR oder #CONSTANT


$OUT_C[n] hier unzulässig

Ursache: | $OUT_C[n] darf nicht in Trigger- oder Interruptvereinbarungen oder auf der rechten Seite einer Zuweisung verwendet werden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


$Simulated_Axis : Unzulässiger Wert

Ursache: | Unzulässiger Wert für "$Simulated_Axis".
Auswirkung: | Der unzulässige Wert wurde zurückgewiesen und der vorhergehende Wert wird verwendet.
Abhilfe: | "$Simulated_Axis" ist eine bitmask, basierend auf der Achsenanzahl. Der Wert für "$Simulated_Axis" darf nicht negativ und muss gleich oder kleiner als 0x0FFF sein.


"=" erwartet

Ursache: | Das Zeichen "=" fehlt oder steht an falscher Stelle.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


"(" erwartet

Ursache: | Das Zeichen "(" fehlt oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


")" erwartet

Ursache: | Das Zeichen ")" fehlt oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"*" erwartet

Ursache: | Das Zeichen "*" fehlt oder steht an falscher Stelle. Beispiel: ANOUT ON Draht = .5 Wert
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT ON Draht = .5 *Wert


"," erwartet

Ursache: | Das Zeichen "," fehlt oder steht an falscher Stelle.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


"," erwartet

Ursache: | Das Zeichen "," fehlt oder steht an falscher Position.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"," oder "}" erwartet

Ursache: | Eines der Zeichen "," oder "}" fehlt oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"/" fehlt im P_PFAD

Ursache: | Das Zeichen "/" wurde vergessen.
Abhilfe: | "/" einfügen.


":" erwartet

Ursache: | Das Zeichen ":" fehlt oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"[" erwartet

Ursache: | Das Zeichen "[" fehlt oder steht an falscher Stelle.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


"]" erwartet

Ursache: | Das Zeichen "]" fehlt oder steht an falscher Stelle. Beispiel: SIGNAL Hugo $OUT[2
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: SIGNAL Hugo $OUT[2]


"]" oder "," erwartet

Ursache: | Eines der Zeichen "]" oder "," fehlt oder steht an falscher Stelle. Meist bei Feldvereinbarungen.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


"{" erwartet

Ursache: | In der Programmzeile fehlt das Zeichen "{" oder es steht an falscher Stelle.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


"+" oder "-" erwartet

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Abbruch erfolgt

Ursache: | "BREAK" wurde wiederholt.
Auswirkung: | Keine


Absolute Pfadangabe erwartet

Ursache: | Die Pfadangabe ist nicht absolut.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Absoluter Pfad nach Geräte-/Kanalnamen erwartet

Ursache: | Kein absoluter Pfad nach Geräte- / Kanalname.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Achse <Achsnummer> referieren unzulässig

Ursache: | Eine nicht inkrementelle Achse soll referiert werden.
Auswirkung: | Die ausgewählte Achse wird nicht referiert.
Abhilfe: | Achse justieren.


<Achsnummer> Achse synchron

Ursache: | Beim Referieren der Einzelachsen sollte eine bereits referierte Achse erneut referiert werden.
Auswirkung: | Achse wird nicht referiert.
Abhilfe: | Nächste noch nicht referierte Achse anwählen.


Achse <Achsnummer> verriegelt

Ursache: | Es wurde versucht, eine Achse in die gesperrte Richtung (gesperrt durch Software-Endschalter) zu verfahren.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Achse in andere Richtung freifahren.


ACTIVE nur in <Betriebsart> zulässig

Ursache:

Falsche Betriebsart eingestellt.

  • Bei RST und ortsfestem KCP ist die Betriebsart "AUT" erforderlich;

  • Bei nicht ortsfestem KCP ist die Betriebsart "T1" oder "T2" erforderlich;

  • Bei Leitrechnern ist die Betriebsart "EXT" erforderlich.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

Korrekte Betriebsart einstellen.


ACTIVE-Status erforderlich

Ursache: | Das eingegebene Kommando darf nur vom aktiven Bediengerät abgegeben werden (Betriebsart T1, T2, AUT).
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Bediengerät aktivieren.


Aggregat-Typ (POS) unverträglich mit Kontext

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Aktive Kommandos verriegelt

Ursache: | Es steht eine Meldung an, die eine Verriegelung aktiver Kommandos bewirkt.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Anstehende Meldungen im Meldungsfenster quittieren.


Aktuelle Justagedaten erfolgreich gesichert.

Ursache: | Der Benutzer hat die aktuellen Justagedaten gesichert.
Auswirkung: | Selbst bei sofortigem Stromverlust (ohne Pufferung) verliert der Roboter nicht seine Justage, sofern er nicht mehr bewegt wird.


Aktuelle Justagedaten NICHT gesichert.

Ursache:

Sicherung der aktuellen Justagedaten fehlgeschlagen, weil

  • entweder der Roboter nicht im absoluten Stillstand war (alle Bremsen müssen eingefallen sein) oder

  • die Kommunikationsschnittstelle zur DSE belegt war.

Auswirkung:

Die aktuellen Justagedaten wurden nicht gesichert.

Abhilfe:

Roboter anhalten, warten, bis die Bremsen eingefallen sind und nochmals die aktuellen Justagedaten sichern.


Alle Impulsausgänge belegt

Ursache:

Es wurden mehr als 16 Impulsausgänge eingeschaltet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm entsprechend ändern.


Alle Analogfunktionen belegt

Ursache:

Es wurden mehr als 2 zyklische Analogausgaben eingeschaltet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

ANOUT OFF eingeben oder Anweisung zurücknehmen.


Alle Komponenten von GLOBAL Variable / Typ müssen GLOBAL sein.

Ursache: | GLOBAL Type bzw. GLOBAL Variable hat Komponenten, die nicht GLOBAL sind.
Auswirkung: | Fehler im Programm durch fehlerhafte Symbol-Tabellen.


Als Option nur "I", "B", "H", "V" erlaubt

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Alte/neue Signaltypen sind verschieden

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Analogausgabe : Delayreduzierung

Ursache: | Der intern für die Funktionalität Analogausgabe mit "Delay" zur Verfügung gestellte Speicher reicht für den programmierten "Delay"-Wert nicht aus.
Auswirkung: | Das programmierte "Delay" wird automatisch entsprechend reduziert.
Abhilfe: | Kleineren Wert für "Delay" programmieren.


Analogausgang bereits belegt

Ursache:

Im Programm wird ein Analogausgang für die zyklische Analog-Ausgabe ein zweites Mal belegt.
Beispiel:
– SIGNAL SIG1 $ANOUT[1]
– SIGNAL SIG2 $ANOUT[1]
– ANOUT ON SIG1 = ....
– ANOUT ON SIG2 = ....

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Zyklische Analog-Ausgabe abschalten:
ANOUT OFF SIGNALNAME.


Analogeingabesignal erwartet

Ursache: | Es wird ein Analogeingabesignal erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<Dateiformat>: Änderung von <Variable> unzulässig während Aufzeichnung von <Recordname>

Ursache: | Abhängig vom EMS-Treiber ist während einer Aufzeichnung die Änderung von Systemvariablen ($tool, $base, $ipo_mode und andere) nicht zulässig.
Auswirkung: | Die Aufzeichnung wird gestoppt.
Abhilfe: | Ändern Sie Systemvariablen nicht während einer Aufzeichnung.


Anfangssatznummer > Endsatznummer

Ursache: | Die Anfangssatznummer ist größer als die Endsatznummer.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Angaben nicht erlaubt

Ursache:

  • Extension nicht verträglich.

  • Es wurde der Befehl "COPY *.*" verwendet.

Der Befehl "COPY *.*" ist nur bei einem Katalog erlaubt.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

Extension korrekt angeben.


Angegebener Feldindex hier nicht zulässig

Ursache: | Der angegebene Feldindex ist an dieser Stelle nicht zulässig.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Angegebener Feldname hier nicht zulässig

Ursache: | Ein Feldname wurde an unzulässiger Stelle verwendet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Anwahl erforderlich

Ursache:

  • Start-Taste betätigt, obwohl kein Programm angewählt ist.

  • "RUN" ohne Pfadangabe und kein Programm angewählt.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

Programm anwählen.


Anwahl nicht möglich

Ursache: | Editoranwahl nicht möglich.
Abhilfe: | Prüfen, ob das File existiert (z.B. wenn ein Objekt im Anzeigemodus geöffnet werden soll) oder mit dem Attribut "hidden" versehen ist.


Anwahl unzulässig

Ursache: | Satz im Programm nicht vorhanden.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Korrekte Satznummer anwählen.


Anweisung im Spline Block nicht erlaubt

Ursache: | Unzulässige Anweisung innerhalb eines Spline..Endspline Blockes; die Syntax ist nicht korrekt.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Anweisung im Spline Block nicht erlaubt

Ursache: | Eine verbotene Anweisung wurde in einem Spline Block verwendet.
Auswirkung: | Syntaxfehler im Programm.
Abhilfe: | Programm entsprechend ändern.


Anweisung nicht im Anweisungsteil

Ursache: | Eine Anweisung befindet sich außerhalb des Anweisungsteils.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Anweisung in den Anweisungsteil verschieben.


Applikationsbeziehung verloren (Fileserver)

Ursache: | Applikationsbeziehung zum Fileserver wurde unterbrochen oder abgebaut.
Abhilfe: | Übertragungsstrecke zwischen ACR und Fileserver überprüfen.


APS Systemfehler

Ursache: | Interner Fehler vom APS im APS erkannt.
Abhilfe: | Rückfrage bei APS, vermutlich Neustart notwendig.


exitspace '<ws name>' fehlgeschlagen - Arbeitsbereich nicht angefordert

Ursache: | Ein Programm adressierte einen "EXITSPACE"-Befehl an einen Arbeitsbereich, welcher nicht von dieser Steuerung angefordert wurde.
Auswirkung: | Keine
Abhilfe: | Ungültigen "EXITSPACE"-Befehl aus dem Programm entfernen.


Der Arbeitsbereich '<WorkspaceName>' wurde manuell durch eine Remote-Steuerung freigegeben (<KrcName>)

Ursache: | Der Arbeitsbereich wurde manuell durch eine Remote-Steuerung freigegeben.
Auswirkung: | Der Arbeitsbereich wurde freigegeben, und der nächste Anfrager des Arbeitsbereiches bekommt denselben.
Abhilfe: | keine


Der Arbeitsbereich ist in Bearbeitung - die Definition kann nicht geändert werden

Ursache: | Der Arbeitsbereich ist in Bearbeitung - die Definition kann nicht geändert werden.
Auswirkung: | Die Arbeitsbereichsdefinition wird nicht abgespeichert.
Abhilfe: | Es dürfen keine Anfragen für diesen Arbeitsbereich vorliegen, bevor die Definition des Arbeitsbereiches geändert wird.


Arbeitsraumüberwachung kann nur im T1-Betrieb überbrückt werden

Ursache: | In der Betriebsart T2, AUT oder EXT wurde versucht, den Wert der Variablen "$WBOXDISABLE" zu ändern.
Abhilfe: | In die Betriebsart T1 wechseln.


Asynchrone Bewegung aktiv

Ursache: | Handverfahren, während eine asynchrone Bewegung aktiv ist. Wenn eine asynchrone Bewegung ausgeführt wird, ist Handverfahren nicht möglich.
Auswirkung: | Handverfahren wird nicht ausgeführt.
Abhilfe: | Asynchrone Bewegung stoppen oder Bewegungsende abwarten.


Auf SWITCH folgt kein CASE

Ursache: | "SWITCH"-Konstrukt enthält keinen "CASE"-Zweig.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Aufruf nur in Roboterinterpreter-Programm zulässig

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Aufsteigende Indizes erwartet

Ursache: | Bei der ersten Indexangabe in der Programmzeile wurde ein höherer Wert als bei der zweiten eingetragen. Beispiel: SIGNAL $DIGIN1 $IN[20] TO $IN[10]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: SIGNAL $DIGIN1 $IN[10] TO $IN[20]


<Dateiformat>: Aufzeichnung <Recordname> existiert

Ursache: | Eine Aufzeichnung mit diesem Namen existiert bereits.
Auswirkung: | Das Kommando wird nicht ausgeführt.
Abhilfe: | Löschen Sie die existierende Datei.


<Dateiformat>: Aufzeichnung <Recordname> nicht vorhanden

Ursache: | Die Aufzeichnung ist nicht vorhanden oder wurde nicht gefunden.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Erstellen oder Laden einer Aufzeichnung.


<Dateiformat>: Aufzeichnung <Recordname> wird bereits verwendet

Ursache: | Die Aufzeichnung wird gerade in einem anderen Kommando verwendet.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Warten, bis das andere Kommando beendet ist.


Ausdruck nach RETURN-Anweisung fehlt

Ursache: | In einer Funktion wird nach der RETURN-Anweisung ein Rückgabewert erwartet. Beispiel: DEFFCT INT Otto() INT a ... RETURN ENDFCT
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEFFCT INT Otto() INT a ... RETURN(a) ENDFCT


Ausdruck nach RETURN-Anweisung unzulässig

Ursache: | Der Ausdruck nach "RETURN" ist unzulässig. Beispiel: DEF Up() ... RETURN (1) END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Up() ... RETURN END


Ausdruck ungleich BOOL

Ursache: | Es wird ein Ausdruck vom Datentyp "BOOL" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Ausdruck ungleich CHAR, INT, ENUM

Ursache: | Es wird ein Ausdruck vom Datentyp "CHAR", "INT" oder "ENUM" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Ausdruck ungleich INT

Ursache: | Es wird ein Ausdruck vom Datentyp "INT" erwartet. Beispiel: INT i FOR i=1.3TO 7 ... ENDFOR
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT i FOR i=1TO 7 ... ENDFOR


Ausdruck ungleich INT, REAL

Ursache: | Es wird ein Ausdruck vom Datentyp "INT" oder "REAL" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Ausdruck ungleich POS, FRAME

Ursache: | Es wird ein Ausdruck vom Datentyp "POS" oder "FRAME" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Ausdruck ungleich POS, FRAME, AXIS

Ursache: | Es wird ein Ausdruck vom Datentyp "POS", "FRAME" oder "AXIS" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Ausgänge setzen blockiert in AUT/EXT

Ursache:

  • Variable "$BLK_IO_AUT" ist auf TRUE gesetzt.

  • Es wurde versucht, die Ausgänge manuell zu setzen.

Auswirkung:

Keine.

Abhilfe:

Variable "$BLK_IO_AUT" auf FALSE setzen.


Auslastungsabh. Beschl.anpassung für PTP in Satz <Satznummer> nicht möglich

Ursache:

Simulationsrechnung des integrierten Dynamikmodells überschreitet vorgegebene Grenzwerte der Getriebedauermomente.

Abfrage erfolgt bei jeder PTP-Präparation mit zugeschalteter auslastungsabhängiger Beschleunigungsanpassung.
Siehe auch [image] Bedienerinformation.

Auswirkung:

keine

Abhilfe:

  • Falls zulässig: Erhöhung der max. zulässigen Getriebedauermomente.

  • Absenkung der Optimierungsgrenze "$OPTEXCLUDE".


Baustein löschen über spezielle Löschfunktion

Abhilfe:

Programm entsprechend ändern.


Bediengerät blockiert

Ursache:

Kommando kann nicht ausgeführt werden, weil die Einstellungen am KCP die Bedingungen nicht erfüllen.

  • Für RST und ortsfestes KCP ist die Betriebsart "AUT" erforderlich.

  • Für nicht ortsfestes KCP ist die Betriebsart "T1" oder "T2" erforderlich.

  • Für Leitrechner-Betriebsart ist "EXT" erforderlich.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

Aktiv-Bedingungen herstellen.


<Bediengerät> hat ACTIVE-Status

Ursache: | Angezeigtes Bediengerät ist aktiv.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Angezeigtes Bediengerät deaktivieren.


Beide Operanden ungleich BOOL

Ursache: | Beide Operanden haben nicht den Datentyp "BOOL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Beide Operanden ungleich INT, CHAR

Ursache: | Beide Operanden haben nicht den Datentyp "INT" oder "CHAR".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Beide Operanden ungleich INT, REAL

Ursache: | Beide Operanden haben nicht den Datentyp "INT" oder "REAL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Beide Operanden ungleich INT, REAL, CHAR, ENUM

Ursache: | Der Datentyp beider Operanden ist nicht "INT", "REAL", "CHAR" oder "ENUM".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Beide Seiten der Wertzuweisung sind nicht verträglich

Ursache: | Die Datentypen der Objekte beidseitig vom Gleichheitszeichen sind unverträglich. Beispiel: $OUT[3]=1
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: $OUT[3]=TRUE


Der neue Besitzer (<krc name>) des Arbeitsbereiches '<Workspacename>' ist nicht erreichbar.

Ursache: | Die Arbeitsbereichszuteilung konnte nicht ausgeführt werden, da der neue Eigner des Arbeitsbereiches nicht erreichbar war.
Auswirkung: | Der Arbeitsbereichseigner wird am Arbeitsbereich warten, da er die Nachricht, dass der Bereich frei ist, nicht bekommt.
Abhilfe: | Überprüfen Sie die Netzwerkverbindung.


Bewegungsanforderung von <Robotername/IP-Addr.> nicht ausführbar

Ursache:

Es wurde versucht, den Master-Roboter manuell zu verfahren, wobei der mit LK() gekoppelte Slave-Roboter momentan nicht verfahren werden kann.

Gründe hierfür können zum Beispiel sein:

  • Anstehende verriegelnde Meldungen;

  • Antriebe des Slave sind nicht aktiviert.

Auswirkung:

Slave-Roboter und Master-Roboter können die Bewegung nicht ausführen.

Abhilfe:

  • Ursache der Störung beseitigen (verriegelnde Zustände / Meldungen).

  • Alle Quittierungsmeldungen quittieren.

  • Sicherstellen, dass die Antriebe eingeschaltet sind.


Bewegungskooperation Versionskonflikt von <IP Address>

Ursache: | Nicht alle Teilnehmer der Bewegungskooperation verwenden die gleiche Version des Kommunikationsprotokolls.
Auswirkung: | Bewegungskooperation ist unzulässig.
Abhilfe: | Software-Update aller beteiligten Steuerungen durchführen.


Bezugssystem nicht ausreichend zugewiesen

Ursache: | Mindestens ein Frame, das für die Berechnung der Bezugsmatrix nötig ist, wurde noch nicht zugewiesen.
Abhilfe: | Zuweisung entsprechend durchführen.


Bezugssystem nicht programmiert

Ursache:

"$BASE" ist nicht oder unvollständig programmiert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

"$BASE" korrekt programmieren.


Bezugssystem unzulässig

Ursache: | Das Handverfahrbezugssystem ist für diese Kinematik nicht zulässig.
 | Die Abfrage erfolgt bei Betätigung der Start- und der Richtungstasten.
Abhilfe: | Das Bezugssystem umschalten (TRANSSYS).


Bremsenstörung <Achsnummer>

Ursache:

Überwachungseinrichtung der Leitung zur Bremse hat Kurzschluss, Überlastung oder Unterbrechung gemeldet.

Auswirkung:

  • Bahntreuer Stop.

  • Stop der Programmbearbeitung.

Abhilfe:

  • Fehler beseitigen.

  • Rücksetzen des Fehlers an der DSE I - Baugruppe durch Betätigung des Hardware-Quittungstasters "ACK".


CA erwartet

Ursache: | Schlüsselwort wurde vergessen oder falsch geschrieben.
Auswirkung: | Programm kann nicht compiliert werden.
Abhilfe: | Programm korrigieren.


CA Parameterwert zu groß

Ursache: | Im CIRC-Satz wurde der Wert für den Parameter CA (Gesamtwinkel) zu groß programmiert.
Abhilfe: | Wert des CA-Parameters entsprechend korrigieren.


CAN-Controller <Nummer> defekt

Ursache: | Der CAN Controller ist defekt.
Auswirkung: | Das CAN Bussystem ist nicht funktionsfähig.
Abhilfe: | Controller überprüfen.


CASE/DEFAULT nach DEFAULT

Ursache: | Der "DEFAULT"-Zweig enthält ein "CASE"- oder "DEFAULT"-Schlüsselwort.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


CONST mit mehreren Variablen nicht erlaubt

Ursache: | In der Konstantenvereinbarung sind mehrere Variablennamen angegeben.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


COR nur bei Datenlisten

Ursache: | Es wurde das Kommando "COR" verwendet, bei nicht angewählter Datenliste.
 | Das Kommando "COR" ist nur bei Datenlisten zulässig.
Auswirkung: | Kommando wird nicht bearbeitet
Abhilfe: | Entsprechende Datenliste anwählen.


<Dateiformat>: Datei <Dateiname> kann nicht geöffnet werden

Ursache:

  • Lesevorgang: Datei nicht vorhanden.

  • Schreibvorgang: Datei oder Speichermedium schreibgeschützt oder kein Speicherplatz frei.

Auswirkung:

Das Kommando wird nicht ausgeführt.

Abhilfe:

  • Lesevorgang: Erstellen Sie eine Datei.

  • Schreibvorgang: Entfernen Sie den Schreibschutz, bzw. erhöhen Sie den Speicherplatz durch Löschen nicht benötigter Dateien.


Datenliste ist nicht PUBLIC

Ursache: | Globale Variable aus DAT-Files können in anderen benannten SRC-Files nur verwendet werden, wenn das DAT-File als "PUBLIC" deklariert worden ist. Beispiel: DEFDAT P1 DECL GLOBAL INT a = 1 ENDAT DEF P2() a = 2 END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Das Schlüsselwort "PUBLIC" in die Kopfzeile des DAT-Files einfügen. Unter Umständen muss zu diesem Zweck über die Menüs "KONFIGURIEREN -> EXTRAS -> EDITOR -> DEF-Zeile" die Kopfzeile erst sichtbar gemacht werden. Beispiel: DEFDAT P1 PUBLIC DECL GLOBAL INT a = 1 ENDAT DEF P2() a = 2 END


Datenübernahme durchgeführt <Achsnummer>

Ursache: | Die Übernahmefahrt wurde korrekt durchgeführt.
Auswirkung: | keine


DEF oder DEFFCT erwartet

Ursache: | Das "DEF" oder "DEFFCT"-Schlüsselwort wurde vergessen oder falsch geschrieben.
Auswirkung: | Programm kann nicht compiliert werden.
Abhilfe: | Programm korrigieren.


Defaultparameter unzulässig

Ursache:

Einer vordefinierten C-Funktion wurde ein Defaultparameter oder kein Parameter übertragen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

C-Funktion mit Parameter aufrufen.


DEFDAT erwartet

Ursache: | Die erste Zeile eines DAT-Files muss mit dem Schlüsselwort "DEFDAT" beginnen.
Auswirkung: | Zugehöriges SRC-File kann nicht ausgeführt werden.
Abhilfe: | DAT-File ändern.


DEFDAT nicht erlaubt

Ursache: | "DEFDAT" wurde an unerlaubter Stelle eingefügt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Deklaration nicht im Deklarationsteil

Ursache: | Eine Deklaration befindet sich außerhalb des Deklarationsteils.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Deklaration in den Deklarationsteil verschieben.


Deklaration zu formalem Parameter fehlt

Ursache: | Ein formaler Parameter wurde nicht deklariert.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


DELAY erwartet

Ursache: | Das Schlüsselwort "DELAY" wurde vergessen oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


DEL muss folgen

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


DEV muss folgen

Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Digitaleingang erwartet

Ursache: | Es wird ein Digitaleingang erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Digitaleingang hier nicht erlaubt

Ursache: | An dieser Stelle ist ein Digitaleingang nicht erlaubt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Dimension inkorrekt

Ursache: | Die angegebene Felddimension entspricht nicht der deklarierten Dimension. Beispiel: DECL INT f[3] f[4,3]=1
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DECL INT f[3] f[2]=1


Dimension stimmt nicht überein

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Diskette schreibgeschützt

Ursache: | Schreibschutz der Diskette ist aktiviert.
Auswirkung: | Diskette kann nicht beschrieben werden.
Abhilfe: | Schreibschutz entfernen.


DISTANCE: nur 1 oder 0 zulässig

Ursache: | Dem Schaltpunkt "DISTANCE" dürfen ausschließlich die Werte 1 oder 0 zugewiesen werden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


DISTANCE oder PATH erwartet

Ursache: | Es fehlt eines der Schlüsselworte "DISTANCE" oder "PATH" oder es steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


DO erwartet

Ursache: | Bei INTERRUPT- oder TRIGGER-Anweisung wurde das Schlüsselwort "DO" vergessen. Syntax: INTERRUPT DECL PrioritätWHEN BedingungDO Unterprogrammname TRIGGER WHEN DISTANCE = SchaltpunktDELAY = ZeitDO AnweisungPRIO = Priorität
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Doppeldeklaration

Ursache: | Der verwendete Name wurde bereits an ein anderes Objekt vergeben.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Driftabgleich Abbruch

Ursache:

Der Driftabgleich wurde durch einen Stopp unterbrochen (Betätigung der Stopp-Taste, Meldung mit Stopp-Auslösung).

Auswirkung:

  • Driftabgleich fehlgeschlagen.

  • Generatorischer Stop.

Abhilfe:

Driftabgleich wiederholen.


DSE - Bootvorgang abgeschlossen

Ursache:

Der DSE-Bootvorgang wurde abgeschlossen.


E/A Verknüpfung: Ausgang <Ausgangsnummer> schreibgeschützt im Modul <Modulname> Satz <Satznummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


E/A Verknüpfung: Ausgang <Ausgangsnummer> schreibgeschützt

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Verknüpfung berichtigen.


EB-Anweisung unzulässig

Ursache: | Die EB-Anweisung wurde nicht korrekt in einer $BASE Anweisung verwendet.
Auswirkung: | Roboter und Interpreter Stopp
Abhilfe: | Korrektur der Anweisung $BASE=EB(...)


Editorkommandos wieder zulässig

Ursache: | Sie befinden sich im Modus "Editieren ohne implizite Satzanwahl" und haben nach Beendigung des aktuellen Bewegungssatzes eine Editor-Freigabe erhalten.
Auswirkung: | Editieren ist wieder möglich.


Editor gesperrt, Bewegungssatz zu Ende fahren

Ursache: | Sie haben versucht, ein Programm zu editieren, befinden sich dabei aber im Modus "Editieren ohne implizite Satzabwahl". Das Programm befindet sich noch in einem Bewegungssatz.
Auswirkung: | Es kann nicht editiert werden.
Abhilfe: | Erneut Starttaste drücken, bis die Meldung "Editor-Kommandos wieder zulässig" erscheint. Danach kann editiert werden.


Eindimensionales CHAR-Feld erwartet

Abhilfe:

Programm entsprechend ändern.


Eine Variable dieses Namens existiert nicht

Ursache: | Es wurde ein Variablenname angegeben, der nicht existiert.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Eintrag in HW_INF.INI für DSE <DSE Nummer>:<Eintrag in hw_inf.ini> ignoriert. <geladene Datei> geladen

Ursache: | Die autom. Servo-Hardwareerkennung hat einen Eintrag in der HW_INF.INI entdeckt, der für den anwesenden DSE-Typ bzw. die DSE-Datei-Situation auf der HD nicht zutreffen kann. Der DSE-Code wird von einer anderen Quelle geladen.
Auswirkung: | Info für den Benutzer!
Abhilfe: | Einträge in HW_INF.INI ändern bzw. DSE-Dateien in das entspr. Verzeichnis kopieren.


Eintrag in Symboltabelle ist nicht Marke

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Einzelbremsenmodul <Achsnummer> nicht konfiguriert

Ursache: | Das Einzelbremsenmodul mit der angegebenen Achsnummer ist nicht konfiguriert.
Auswirkung: | Die Bremse wird durch einen anderen Kanal oder überhaupt nicht gesteuert.
Abhilfe: | Einzelbremsenmodul konfigurieren, bzw. Maschinendaten entsprechend ändern.


EMT-Justageweg überschritten

Ursache:

  • Kerbe nicht gefunden.

  • Achsposition war vor Start nicht vor Kerbe.

Auswirkung:

Rampen Stop.

Abhilfe:

  • Justagestellung (siehe Bedienungshandbuch) anfahren.

  • EMT überprüfen.

  • Messkerbe an Achse überprüfen.


END/ENDFCT/ENDDAT hier unzulässig

Ursache: | Das "END", ENDFCT" oder "ENDDAT"-Schlüsselwort wurde an unzulässiger Stelle eingefügt oder die Syntax nicht korrekt eingehalten.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


ENDDAT-Satz nicht vorhanden

Ursache: | Am Ende einer DAT-Datei fehlt das Schlüsselwort ENDDAT.
Auswirkung: | Die zugehörige SRC-Datei kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


ENDFOR fehlt

Ursache: | "FOR"-Schleife wurde nicht mit "ENDFOR" abgeschlossen. Beispiel: DEF Prog() INT i i=1 FOR i=1 TO 6 ... END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog() INT i i=1 FOR i=1 TO 6 ... ENDFOR END


ENDIF fehlt

Ursache: | "IF"-Schleife wurde nicht mit "ENDIF" abgeschlossen.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


ENDLOOP fehlt

Ursache: | "LOOP"-Schleife wird nicht durch "ENDLOOP" abgeschlossen. Beispiel: DEF Prog() LOOP ... END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog() LOOP ... ENDLOOP END


ENDSWITCH fehlt

Ursache: | "SWITCH"-Anweisung wurde nicht mit "ENDSWITCH" abgeschlossen.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


ENDWHILE fehlt

Ursache: | "WHILE"-Schleife wurde nicht mit "ENDWHILE" abgeschlossen. Beispiel: DEF Prog() INT i i=1 WHILE i<100 END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog() INT i i=1 WHILE i<100 ... ENDWHILE END


ENUM nicht in $CONFIG vereinbart

Ursache:

  • Es läuft ein SET INFO auf eine ENUM-Variable aus einer Anwenderdatenliste.

  • Die Suchpfaderweiterung wurde geändert.

  • Kein Zugriff auf ENUM-Typinformation.

Abhilfe:

ENUM-Vereinbarung und Variablendeklaration in die Datei "$CONFIG.DAT" eintragen.


ERROR-Token im I-Code

Abhilfe:

Programm entsprechend ändern.


Erste Konstante unverträglich mit dieser Konstante

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Erwarteter Typ der Konstanten unbekannt

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Es wurde kein Deadlock entdeckt

Ursache: | Die Steuerung, auf welcher eine Kreisabhängigkeitssuche gestartet wurde, wartet nicht auf einen Arbeitsbereich in einer Kreisabhängigkeit.
Auswirkung: | Keine
Abhilfe: | Keine


EXIT liegt nicht im Schleifenrumpf

Ursache: | Das Schlüsselwort "EXIT" steht außerhalb einer Schleife.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


IS erwartet

Ursache: | Das Schlüsselwort "IS" fehlt oder steht an falscher Stelle. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 /R1/PROG_1 .. Otto END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 IS/R1/PROG_1..Otto END


EXITSPACE '<workspace name>' fehlgeschlagen - kein Verbindungsaufbau möglich zu <krc name>

Ursache:

  • Der Befehl "EXITSPACE" ist wegen eines Verbindungsfehlers fehlgeschlagen.

  • Die lokale Steuerung konnte keine Kommunikation mit dem Arbeitsbereichsmanager herstellen.

Auswirkung:

Der Befehl wird so lange gesendet, bis der Arbeitsbereichsmanager erreicht werden kann.
Dabei behält die lokale Steuerung die Kontrolle über den betroffenen Arbeitsbereich.

Abhilfe:

Netzwerkverbindung prüfen und ggf. vorhandene Fehler korrigieren.


Extension fehlt

Ursache: | Die Extension wurde nicht angegeben.
Abhilfe: | Programm entsprechend ändern.


Extension nicht erlaubt

Ursache: | Es wurde eine Extension angegeben, die an dieser Stelle nicht zulässig ist.
Abhilfe: | Extension entfernen.


Extension oder ".*" nicht erlaubt

Ursache: | Es wurde eine Extension oder der Joker ".*" angegeben.
Abhilfe: | Programm entsprechend ändern.


Extension-Angabe unzulässig

Ursache: | Bei einem Befehl wurde unzulässiger Weise eine Extension angegeben (z.B. "analyse otto.src").
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Befehl entsprechend korrigieren.


Extern-Vereinbarung ungleich Deklaration von UP/FKT

Ursache: | Extern-Vereinbarung entspricht nicht der UP/FKT Deklaration.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Extern-Vereinbarungen überprüfen.


Externe Funktion erwartet, Unterprogramm gefunden

Ursache: | Es wurde eine Funktion als extern vereinbart, es wurde aber ein Unterprogramm gleichen Namens gefunden. Beispiel: DEF Test(x:IN) INT x ... ENDDEF P() EXTFCT INT Test(INT:IN) END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEFFCT INT Test(x:IN) INT x ... ENDFCTDEF P() EXTFCT INT Test(INT:IN) END


Externer Befehl <Name der externen Funktion> nicht geladen

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Externes Unterprogramm erwartet, Funktion gefunden

Ursache: | Es wurde ein Unterprogramm als extern vereinbart, es wurde aber eine Funktion gleichen Namens gefunden. Beispiel: DEFFCT INT Test(x:IN) INT x ... ENDFCTDEF P() EXT Test(INT:IN) END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Test(x:IN) INT x ... END DEF P() EXT Test(INT:IN) END


Falsches Eingabezeichen

Ursache: | Es wurde ein Zeichen eingegeben, welches an dieser Stelle keinen Sinn ergibt. Beispiel: $OUT[2b]=TRUE
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: $OUT[2]=TRUE


Falsches Kontrollstrukturende

Ursache: | Eine Kontrollstruktur wird mit falschem Schlüsselwort abgeschlossen, z. B. "LOOP" mit "ENDWHILE".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Fehler am Satzende

Ursache: | Satzende enthält Fehler.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern


<Objekt> : <Anzahl der Fehler> Fehler bei Analyse

Ursache: | Bei der Gesamtanalyse wurde im angezeigten Objekt die angezeigte Anzahl von Fehlern erkannt.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Fehler korrigieren.


<Objektname> : <Fehlernummer> Fehler bei Analyse

Ursache: | Analysefehler aufgrund eines unbekannten Datentyps, kann bei globalen selbst definierten Datentypen und ENUM's auftreten. Als Folge muss die BOF einen zweiten Download veranlassen.
Auswirkung: | Bei Verursachung durch globale Typen kann zweimaliger Download des Files den Fehler beheben.
Abhilfe: | Die BOF filtert die Fehlernummer heraus und löst den zweiten Download für das betroffene File aus.


Fehler bei Formatangabe Nr. <Nummer der falschen Formatangabe>

Ursache: | Inkonsistenz von Formatangabe und Parameter, oder falsche Formatangabe bei CWRITE-Anweisung.
 | Abfrage erfolgt bei der Programmbearbeitung in S_INT Funktion CWRITE.
Auswirkung: | Stop der Programmbearbeitung.
Abhilfe: | Richtige Formatangabe programmieren.


Fehler bei Gesamtanalyse - ERR-Dateien existieren

Ursache: | Bei der Gesamtanalyse wurden Fehler entdeckt und Error-Dateien angelegt.
Auswirkung: | Fehlerbehaftete Dateien sind nicht ausführbar.
Abhilfe: | Programme ändern. Bitte Hinweise in den Error-Dateien beachten.


<Dateiformat>: Fehler bei Start der Aufzeichnung <Recordname>

Ursache: | Beim Start der Aufzeichnung trat ein Fehler auf.
Auswirkung: | Die Aufzeichnung wird nicht gestartet.
Abhilfe: | Setzen Sie sich mit dem Service der Fa. KUKA in Verbindung.


<Modul> Fehler beim Binden

Ursache: | Beim Binden wurde im angezeigten Modul ein oder mehrere Fehler erkannt.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Anhand der Fehlerliste den oder die Fehler korrigieren.


Fehler beim Laden der O-Datei

Ursache: | Fehler beim Laden/Lesen von "ident_vx.o": Speicher oder File nicht vorhanden.
 | Abfrage erfolgt in der Schreibfunktion "w_ident_state".
Auswirkung: | Sprung zum Ende im Lastdatenprogramm.
Abhilfe: | Die Datei "ident_vx.o" in das Verzeichnis "/ir_spec/l_ident" kopieren, oder Speicher durch Ändern des Wertes "VxWinRAM" in der Registry erhöhen.


Fehler beim Lesen von TRACE.DEF

Ursache:

Beim Starten einer Trace-Aufzeichnung konnte die Datei "TRACE.DEF" nicht gelesen werden.

Auswirkung:

Trace wird nicht durchgeführt.

Abhilfe:

  • "TRACE.DEF" zur Verfügung stellen.

  • FTP-Server starten bzw. prüfen.


Fehler <Fehlernummer> in der PTP-Bahnplanung, evtl. kein Überschleifen

Ursache:

Interner Fehler bei der Planung des Überschleifsatzes.

Zum Abfahren des Überschleifsatzes muss die Geschwindigkeit bereits im vorangehenden Satz reduziert werden.

Auswirkung:

  • Abhängig von der Fehlernummer wird ggf. nicht überschliffen. Es erfolgt "Genauhalt".

  • Wird dennoch überschliffen, ergeben sich keine weiteren Auswirkungen.

Abhilfe:

  • Profildaten (Geschwindigkeit, Beschleunigung, Überschleifradius) entsprechend ändern.

  • Erforderlichenfalls Rücksprache mit KUKA nehmen, um die numerischen Algorithmen zu verfeinern.


Fehler in Konfigurationsdatei

Ursache: | Die Konfigurationsdatei ist fehlerhaft.
Abhilfe: | Konfigurationsdatei berichtigen.


Fehler in Pfadangabe

Ursache: | Fehler in der Pfadangabe (z.B. /R5).
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Pfadangabe prüfen und korrigieren.


Fehler in Trace-Definition

Ursache: | In der Datei "TRACE.DEF" wurde der Trace falsch konfiguriert.
Abhilfe: | "TRACE.DEF" korrigieren.


Fehler Restart I/O <Bus-/Treibername>

Ursache: | Feldbus-Fehler ist weiterhin vorhanden.
Auswirkung: | Bus–Ein- und Ausgänge nicht verfügbar.
Abhilfe: | Fehler in der Feldbus-Hardware beseitigen.


<Dateiformat>: Fehler während Aufzeichnung von <Recordname>

Ursache: | Während der Aufzeichnung trat ein treiberspezifischer Fehler auf.
Auswirkung: | Die Aufzeichnung wird gestoppt.
Abhilfe: | Setzen Sie sich mit dem Service der Fa. KUKA in Verbindung.


Feld als Operand unzulässig

Ursache: | Ein Feld als Operand ist hier unzulässig.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Feld enthält zu viele Elemente

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Feld unzulässig

Ursache: | An dieser Stelle darf kein Feld angegeben werden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Felddimension größer 1 hier unzulässig

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Feldelement/Variable nicht vom Typ REAL

Ursache: | In der Programmzeile wird ein Feldelement bzw. eine Variable vom Datentyp REAL erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Feldgrenze fehlt

Ursache: | Die Feldgrenze wurde nicht angegeben. Beispiel: REAL vb[]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: REAL vb[4]


Feldgrenze zu groß

Abhilfe:

Programm entsprechend ändern.


Feldindex fehlt

Ursache: | Der Feldindex fehlt.
Abhilfe: | Programm entsprechend ändern.


Feldindex passt nicht zu Dimension des Feldes

Abhilfe:

Programm entsprechend ändern.


Feldindex überschreitet Feldgrenzen

Ursache: | Der angegebene Feldindex ist größer als die vereinbarte Feldgrenze.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Feldkomponenten können nicht indiziert werden

Ursache: | Es wurde versucht, eine Feldkomponente zu indizieren.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Formaler Parameter nicht definiert

Ursache: | Den formalen Parametern im Unterprogramm bzw. der Funktion ist kein Datentyp zugeordnet worden. Beispiel: INT i i=1 Hb(i) ... DEF Hb(a:IN) END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: INT i i=1 Hb(i) ... DEF Hb(a:IN) INT a ... END


Fortsetzstart nicht möglich

Ursache: | BSTEP
Auswirkung: | Keine


Füllstand Hydraulik

Ursache:

Das Ölniveau in der Hydraulik wurde unterschritten.

Die Abfrage erfolgt bei PLC-Programmbearbeitung.

Auswirkung:

  • Keine

Abhilfe:

Hydrauliköl nachfüllen und Hydraulik auf Dichtheit prüfen.


Füllstand Klebstoff

Ursache:

Das Klebstoff-Faß ist leer.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • keine

Abhilfe:

Neues Klebstoff-Faß bereitstellen oder auf gefülltes Faß umschalten.


Ganzzahlige Konstante erwartet

Ursache: | Die Konstante ist nicht ganzzahlig.
Abhilfe: | Programm entsprechend ändern.


Ganzzahlige Konstante erwartet

Ursache: | Es wird eine ganzzahlige Konstante erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Ganzzahlige Konstante ungleich 0 erwartet

Ursache: | Es fehlt die Angabe einer ganzzahligen Konstanten ungleich 0. Beispiel: INT i i=1 FOR i=1 TO 7 STEP ... ENDFOR
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT i i=1 FOR i=1 TO 7 STEP2 ... ENDFOR


Ganzzahlige positive Konstante erwartet

Ursache: | Es wird eine ganzzahlige numerische positive Konstante verlangt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Ganzzahlige, reelle oder Zeichenkonstante erwartet

Ursache: | Es fehlt die Angabe eines ganzzahligen oder reellen Wertes, bzw. einer Zeichenkonstante. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = { a , b}
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2}


Geometrische Kopplung wurde durch Programm-Reset aufgehoben

Ursache: | Die geometrische Kopplung zwischen dieser Steuerung und der Master-Steuerung wurde durch lokalen Programm-Reset aufgehoben.
Auswirkung: | Die lokale Steuerung führt keine an die Master-Steuerung gekoppelten Bewegungen mehr aus.
Abhilfe: | Erforderlichenfalls (zur Vermeidung von Kollisionen) den Slave-Roboter freifahren, bevor der Master-Roboter wieder bewegt wird.


Handverfahren nicht erlaubt: Starttaste gedrückt

Ursache: | Handverfahren mit betätigter Starttaste. Bei gedrückter Starttaste ist Handverfahren nicht möglich.
Auswirkung: | Handverfahren wird nicht ausgeführt.
Abhilfe: | Starttaste loslassen.


Hintergrund belegt von <Bediengerät>

Ursache:

Der Hintergrund ist von einem anderen Bediengerät exklusiv belegt.

Auswirkung:

Hintergrund kann nicht exklusiv belegt werden.

Abhilfe:

  • Exklusiv-Belegung des angezeigten Gerätes aufheben.

  • Angaben in der Datei "$OPTION.DAT" vervollständigen.


Hintergrund nicht frei

Ursache:

Im Hintergrund wird bereits ein Kommando bearbeitet.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

  • Kommando abbrechen.

  • Warten, bis laufendes Kommando bearbeitet ist.


Identifikator nirgends deklariert

Ursache: | Im Unterprogramm bzw. der Funktion wurde dem Identifikator, das ist der Name für den Übergabeparameter, kein Datentyp zugewiesen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog(a:IN) REAL a ...


Identische vordefinierte Signalnamen erwartet

Ursache: | Es wurden nicht einheitlich nur Ein- oder Ausgänge angegeben. Beispiel: SIGNAL $DIGIN1 $OUT[20] TO $IN[29]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: SIGNAL $DIGIN1 $IN[20] TO $IN[29]


IFC Syntaxfehler

Ursache: | Beim Versuch einen Kanal zu öffnen bzw. zu schließen ist auf der Interface-CPU ein Syntaxfehler bezüglich des von der Steuerung generierten Kommandos aufgetreten.
Abhilfe: | Kanal schließen und erneut öffnen.


Import-Variable ist in der Datenliste nicht deklariert

Ursache:

Mit der IMPORT-Anweisung wird auf eine Variable verwiesen, die in der genannten Datenliste nicht existiert.

Auswirkung:

Das Programm ist nicht ausführbar.

Abhilfe:

  • Namen überprüfen.

  • Pfad überprüfen.

  • Variable deklarieren.


IN oder OUT erwartet

Ursache: | Bei Unterprogramm- oder Funktionsdeklaration wurde vergessen, die übergebenen Parameter als "IN" bzw. "OUT"-Parameter zu kennzeichnen oder es liegt ein Schreibfehler vor. IN-Parameter: "Call by Value"; Es wird nur ein Wert übergeben. Der Variablenwert kann vom Unterprogramm bzw. der Funktion nicht verändert werden. OUT-Parameter: "Call by Reference"; Übergeben wird die Adresse des Speicherplatzes der Variablen, die somit von dem Unterprogramm bzw. der Funktion beschrieben werden kann. Beispiel: DEF Prog(X:IN, Y:xx, Z:OUT) INT X,Y,Z ...
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog(X:IN, Y:OUT, Z:OUT) INT X,Y,Z ...


In Parameterspezifikation sind Feldgrenzen unzulässig

Ursache: | Bei einer Parameterspezifikation wurden Feldgrenzen eingetragen. Beispiel: DEF Hb(a[]:IN) INT a[5]
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEF Hb(a[]:IN) INT a[]


Index darf nicht geändert werden

Ursache: | Unzulässige Änderung des Index.
Abhilfe: | Änderung rückgängig machen.


Indizierung oder [] erwartet

Ursache: | Feldvariablenname wurde ohne eckige Klammern bzw. Indexangabe verwendet.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Indizierung oder [] nicht erlaubt

Ursache: | Ein Name, der nicht als Feld vereinbart worden ist, wurde mit einem Index bzw. eckigen Klammern versehen. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2} Hugo.a[3]=7
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2} Hugo.a=7


Initialwert hier nicht zulässig

Ursache: | Der Initialwert ist an dieser Stelle nicht zulässig.
Abhilfe: | Programm entsprechend ändern.


Initialwertsatz nicht im Initialteil

Ursache: | Initialwert befindet sich nicht im Initialteil.
Abhilfe: | Entsprechend korrigieren.


Initialwert zu angegebenem Index existiert bereits

Ursache: | Indexwert wurde bereits initialisiert.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Inkorrektes Ende der Parameterliste

Ursache: | Die Parameterliste wurde nicht korrekt abgeschlossen. Beispiel: DEF Up(x:IN) INT x END DEF Prog() INT Var Var= 1 Up(Var; ) END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEF Up(x:IN) INT x END DEF Prog() INT Var Var= 1 Up(Var) END


<Objektname> interner Fehler bei Zugriff

Ursache: | Beim Zugriff auf ein Objekt trat ein interner Fehler auf.
Auswirkung: | Die Aktion wird nicht korrekt durchgeführt.


Interner Fehler <Fehlernummer> (<Task-Id>,<Return-Status>)

Ursache: | Interner Software-Fehler
Abhilfe: | Bitte setzen Sie sich mit Ihrem zuständigen KUKA Kundendienst in Verbindung.


Hardware unterstützt keine Netzphasenausfallüberwachung.

Ursache:

In der Datei "$OPTION.DAT" ist die Netzphasenausfallüberwachung durch "$PHASE_MONITORING=TRUE" projektiert, obwohl entweder die KPS-SW-Version niedriger als 11 oder keine "DSE-IBS-C33" verfügbar ist.

Auswirkung:

Die Netzphasenausfallüberwachung ist nicht aktiv.

Abhilfe:

  • In der Datei "$OPTION.DAT" die Netzphasenausfallüberwachung auf

"$PHASE_MONITORING=FALSE" setzen oder

  • die erforderlichen Hardwarevoraussetzungen herstellen (KPS ab Software-Version 11 sowie "DSE-IBS-C33").


Justage durchgeführt <Achsnummer>

Ursache:

Es wurde versucht, eine bereits justierte Achse nochmals zu justieren.

Auswirkung:

  • Rampen Stopp

Abhilfe:

Mit RECALL abbrechen.


Justagereihenfolge unzulässig

Ursache: | Die vorgeschriebene Justage-Reihenfolge wurde nicht eingehalten (abhängig vom Maschinendatum "$SEQ_CAL").
Abhilfe: | Justage unter Einhaltung der vorgeschriebenen Reihenfolge vornehmen.


Kanal bereits geöffnet

Ursache:

Es wurde versucht, einen bereits geöffneten Kanal nochmals zu öffnen.


Kanal bereits geschlossen

Ursache: | Es wurde versucht, einen bereits geschlossenen Kanal nochmals zu schließen.
Auswirkung: | keine
Abhilfe: | Kommando abbrechen.


Kanal bereits maximal belegt

Ursache: | Der Kanal ist bereits mit der maximal zulässigen Anzahl von Aufträgen belegt.
Auswirkung: | keine
Abhilfe: | Warten, bis mindestens ein Auftrag beendet ist.


Kanal im Kommando nicht erlaubt

Ursache: | Das Kommando unterstützt keine Kanäle.
Auswirkung: | Das Kommando wird nicht ausgeführt.
Abhilfe: | keine


Kanal mit maximaler Anzahl von Prozessen belegt

Ursache: | Über die serielle Schnittstelle laufen zu viele Prozesse.
Abhilfe: | Warten, bis ein Prozess beendet ist.


Kanal öffnen/schließen notwendig

Ursache: | Die beim Belegen des Kanals benutzten Kanal-Parameter stimmen nicht mit dem aktuellen Kanal-Parametern überein.
Auswirkung: | keine
Abhilfe: | Kanal vor dem Belegen schließen.


Kanal öffnen/schließen unzulässig

Ursache: | Es wurde versucht, einen SINEC H1-Kanal auf Bedienerinitiative mittels OPEN-Kommando zu öffnen bzw. CLOSE-Kommando zu schließen.
Auswirkung: | Keine
Abhilfe: | SINEC-H1-Kanäle werden automatisch geöffnet und geschlossen.


Kanalangabe unzulässig

Ursache:

  • Es wurde versucht, ein Produktivkommando über den SINEC L2 - Buskanal zu senden.

  • Es wurde versucht, das Protokoll oder den Meldungspuffer über den SINEC H1 - Kanal an eine dritte Station auszugeben.

Auswirkung:

keine

Abhilfe:

keine


Kanal-Handle erwartet

Ursache: | Es wird ein Kanal-Handle erwartet.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Kanalname fehlt

Ursache: | Es wurde kein Kanalname angegeben.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kanalnamen erwartet

Ursache: | Der Kanalname fehlt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Kanalparameter fehlerhaft oder unvollständig

Ursache: | In der Parametervariablen des Kanals in "$CUSTOM.DAT" ist mindestens ein Kanalparameter fehlerhaft oder nicht initialisiert.
Auswirkung: | keine
Abhilfe: | Parametervariable korrigieren bzw. initialisieren.


Kein Anwenderspeicher mehr vorhanden

Ursache: | Unzureichende Speicherkapazität zum Kopieren von Objekten.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Nicht benötigte Objekte löschen, um Speicherkapazität freizumachen.


Kein Aufzählungsdatentyp vorgegeben

Abhilfe:

Programm entsprechend ändern.


Kein Jokerzeichen erlaubt

Ursache: | Es wurde ein unzulässiges Jokerzeichen verwendet.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Kein korrekter Pfad

Ursache: | Die Pfadangabe ist nicht korrekt
Auswirkung: | Aktion wird nicht ausgeführt.
Abhilfe: | Pfadangabe korrigieren.


Kein korrekter Typeintrag vorhanden

Ursache: | In einer Deklaration wird ein Datentyp verwendet, dessen Vereinbarung fehlerhaft ist. Beispiel: ENUM Otto #Ottomotor DECL Otto Otto1
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: ENUM Otto Ottomotor DECL Otto Otto1


Kein Name einer Konstanten des Typs

Ursache: | Der Konstantenname passt nicht zum Datentyp.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kein Name einer Konstanten dieses Typs

Ursache: | Es wurde ein Konstantenname angegeben, der nicht existiert oder nicht zum Datentyp passt. Beispiel: ENUM Farben blau, gelb, rot DECL Farben Einzelfarbe Einzelfarbe=#orange
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: ENUM Farben blau, gelb, rot, orange DECL Farben Einzelfarbe Einzelfarbe=#orange


Kein Name eines Aufzählungsdatentyps

Ursache: | Es wird ein Aufzählungsdatentypname erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kein Name eines Datentyps: Neuanlegen verboten

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kein Objekt vorhanden

Ursache: | Zu den im DIR-Kommando angegebenen Suchkriterien ist kein entsprechendes Objekt vorhanden.
Auswirkung: | Keine.
Abhilfe: | Angaben und Schreibweise im DIR-Kommando überprüfen.


Kein Objektname angegeben

Ursache: | Es wurde kein Objektname angegeben.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kein passendes Endspline gefunden.

Ursache: | Endspline zum Spline wurde nicht gefunden.
Auswirkung: | Programm ist syntaktisch nicht korrekt.
Abhilfe: | Programm entsprechend ändern.


<Dateiformat>: Kein Speicher frei für <Recordname>

Ursache: | Es befinden sich zu viele Aufzeichnungen im Arbeitsspeicher.
Auswirkung: | Das Kommando wird nicht ausgeführt.
Abhilfe: | Entfernen Sie einige andere Aufzeichnungen.


Kein Strukturdatentyp

Ursache: | Die Variable hat keinen Strukturdatentyp. Beispiel: INT Hugo Hugo.a=1
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: INT Hugo Hugo=1


Kein Systemspeicher mehr vorhanden

Ursache: | Der Systemspeicher ist zu gering, um die Befehle "SHOW VAR" oder "SET INFO" auszuführen.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Nicht benötigte Programme auf Datenträger sichern, um Speicherkapazität freizumachen.


Kein Zugriff auf importierte Variable möglich

Ursache: | Der Suchpfad wurde nicht auf die externe Datenliste erweitert.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Suchpfad entsprechend erweitern.


Kein Zugriff auf Laufzeitdaten

Ursache:

Zugriff auf einen ungültigen oder nicht vorhandenen OWS- bzw. LZD- Datenbereich über die Hierarchietabelle (Suchpfad).

Auswirkung:

  • keine

Abhilfe:

Den Suchpfad auf die aktuelle Interpreterumgebung einstellen.


Keine Achse angewählt

Ursache: | Es wurde versucht, einen Tachoabgleich durchzuführen, obwohl keine Achse angewählt ist.
 | Abfrage erfolgt bei Wertzuweisung an "$TACH_CHANGE".
Auswirkung: | Wertzuweisung wird nicht durchgeführt.
Abhilfe: | Erst Achse auswählen, dann Tachoabgleich durchführen.


Keine AXIS-Komponente

Ursache: | Es wird eine Komponente vom Datentyp "AXIS" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Keine Daten / Variablen mehr vorhanden

Ursache:

Bei SREAD/CREAD kein Text zum Lesen mehr vorhanden oder keine Variablen zum Ablegen der Werte vorhanden.


Keine DSE-Achse

Ursache: | Versuch, für eine Achse, die nicht auf der DSE-Messkreisbaugruppe liegt, einen Tachoabgleich durchzuführen.
 | Abfrage erfolgt bei Wertzuweisung an "$TACH_CHANGE".
Auswirkung: | Wertzuweisung wird nicht durchgeführt.
Abhilfe: | Tachoabgleich nur für DSE-Achsen durchführen.


Keine Feldgrenzen in Parameterspezifikation zulässig

Ursache: | Bei einer Parameterspezifikation wurden Feldgrenzen eingetragen. Beispiel: DEF Hb(a[]:IN) INT a[5]
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEF Hb(a[]:IN) INT a[]


Keine FRAME-Komponente

Ursache: | Es wird eine Komponente vom Datentyp "FRAME" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Keine in der Datenliste vereinbarte Variable

Ursache: | Es wird eine Variable verlangt, die im DAT-File deklariert sein muss.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Keine Namensänderung bei globalem UP/Funktion erlaubt

Ursache: | Unerlaubte Namensänderung
Abhilfe: | Namensänderung rückgängig machen.


Keine POS-Komponente

Ursache: | Es wird eine Komponente vom Datentyp "POS" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Keine Schnittstellen erlaubt

Abhilfe:

Programm entsprechend ändern.


Keine zulässige Extension

Ursache: | Die angegebene Extension ist nicht zulässig.
Abhilfe: | Verwenden Sie eine gültige und zulässige Extension.


Ki erwartet: 1

Ki erwartet: 1<=i<=12

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Klammerung von Path-Ausdrücken verboten

Ursache: | Path-Ausdrücke dürfen nicht geklammert werden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


"," oder ")" erwartet

Ursache: | Komma oder ")" fehlt oder befindet sich an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kommando abgebrochen

Ursache:

  • Das Kommando wurde abgebrochen.

  • Beim Editieren wurde vor dem Aufruf des entsprechenden Kommandos (ERASE, GET, FIND) durch den Editor-Kern an der Oberfläche Abbruch selektiert.


In diesem Edit-Modus unzulässig

Ursache:

  • Im Protokolliermodus des Editors wurde ein das Objekt veränderndes Kommando eingegeben.

  • Im Datenkorrekturmodus wurde versucht, einen Satzblock zu löschen oder zu kopieren oder einen nur aus einer Zeile bestehenden Satz zu löschen.

Auswirkung:

Versuchte Aktion wird nicht ausgeführt.

Abhilfe:

Im vollen Editormodus editieren.


Kommando nicht in Bearbeitung

Ursache:

Abzubrechendes Kommando wurde bereits bearbeitet.

Auswirkung:

  • keine


Kommando unzulässig

Ursache:

Das Kommando ist nicht zulässig oder nicht bekannt.

Auswirkung:

  • keine

Abhilfe:

Kommando korrekt eingeben.


Kommandoausführung nicht frei

Ursache:

Ein vorangegangenes Kommando ist noch in Bearbeitung.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

  • Kommando abbrechen.

  • Warten, bis zur Beendigung des vorangegangenen Kommandos.


Komponente als Feld vereinbart: Indizierung erwartet

Ursache: | Bei der Komponente handelt es sich um ein Feld. Zur eindeutigen Zuordnung ist eine Indizierung notwendig.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Komponente doppelt angegeben

Ursache: | Ein Komponentenname wurde zweimal angegeben, z. B. im Aggregat einer Struktur. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = {a 1, b 2.2, a 4}
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = {a 1, b 2.2}


Komponente gehört nicht zum Typ

Ursache: | Es wird eine Komponente verwendet, die nicht in der Datentypvereinbarung steht. Beispiel: STRUC Otto INT a, REAL b DECL Otto Emma Emma.ccc=1
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: STRUC Otto INT a, REAL b DECL Otto Emma Emma.a=1


Komponente gehört weder zu FRAME noch zu POS

Abhilfe:

Programm entsprechend ändern.


Komponente im selben Aggregat mehrfach initialisiert

Ursache: | Jede Komponente darf in einem Aggregat nur einmal enthalten sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Komponente ist kein Feld

Abhilfe:

Programm entsprechend ändern.


Komponente nicht als Feld vereinbart

Ursache: | Die Komponente wurde nicht als Feld vereinbart.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Komponentenfeldangabe mehrdimensional

Ursache: | Die Komponentenfeldangabe ist mehrdimensional.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Komponentenname erwartet

Ursache: | Ein Komponentenname wurde nicht angegeben, z. B. im Aggregat einer Struktur. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo ={ 1, b 2.2}
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: STRUC Otto INT a, REAL b DECL Otto Hugo = { a1, b 2.2}


Komponententyp nicht oder nicht korrekt definiert

Ursache: | Es wurde ein Komponententyp eingetragen, der nicht oder nicht korrekt vereinbart worden ist. Beispiel: Enum Otto#Ottomotor STRUC Willi Ottoa
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: Enum Otto Ottomotor STRUC Willi Ottoa


Komponententyp unbekannt

Ursache: | Der Komponententyp ist nicht bekannt.
Abhilfe: | Programm entsprechend ändern.


Konstante erwartet

Ursache: | In der Programmzeile fehlt die Angabe einer Konstanten, z. B. nach dem Schlüsselwort "CASE".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Bereich inkorrekt angegeben

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Konstante oder Variable erwartet

Ursache: | Die Angabe einer Konstanten oder Variablen fehlt. Beispiel: ANOUT ON Draht = .5 * Faktor + 1.0 DELAY =
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT ON Draht = .5 * Faktor + 1.0 DELAY = 5


Konstantenname gehört nicht zum Variablentyp

Abhilfe:

Programm entsprechend ändern.


Konstantentyp unverträglich mit Ausdrucktyp im SWITCH

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Kontrollstrukturende hier falsch

Ursache: | Die Syntax für Kontrollstrukturen wurde verletzt. Beispiel: FOR i=1 TO 6 ... ELSE ... ENDFOR
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: FOR i=1 TO 6 ... ENDFOR


<Objekt> Kopieren Abgelehnt (-S.)

Ursache: | Systemobjekt wurde über Schnittstelle übertragen, aber die Option "-S" ist nicht gesetzt.
 | "-S" ist die Kennung für das Download-Kommando.
Auswirkung: | Objekt wird nicht übertragen.
Abhilfe: | Option "-S" setzen.


KCPDRV: KCP Message Handler Fehler beim Start

Ursache:

CAN-Kontroller kann nicht initialisiert werden

Auswirkung:

Kommunikation auf dem CAN-Bus ist fehlerhaft.

Abhilfe:

  • Meldung quittieren

  • Kabelverbindungen zum KCP prüfen.


KCPDRV: Safety Flag Verletzung

Ursache: | Unterschiedlicher Sicherheitsstatus im Programmierhandgerät (KCP) und im Treiber.
Auswirkung: | Das KCP wird neu initialisiert.
Abhilfe: | Fehlermeldung quittieren.


KCPDRV: Unbekannter Fehlercode <Fehlercode>

Ursache: | Der KCP-Treiber lieferte eine unbekannte Fehlermeldung.
Abhilfe: | Setzen Sie sich mit dem Technischen Support der Firma KUKA in Verbindung.


KCPDRV: Watchdog Fehler

Ursache: | CAN-Busfehler, CAN-Busüberlauf und Timeout der Alive-Botschaft
Auswirkung: | Das KCP wird neu initialisiert.
Abhilfe: | Meldung quittieren.


Dieses KRL Statement darf innerhalb eines Splines nicht verwendet werden.

Ursache: | In einem Spline Block wurde ein nicht erlaubtes KRL Statement gefunden.
Auswirkung: | Syntaxfehler im Modul.
Abhilfe: | Programm entsprechend ändern.


Kühlkörpertemperatur <Achsnummer>

Ursache:

Thermoschalter auf den Kühlkörpern der Servoendstufe signalisiert zu hohe Temperatur der Endstufentransistoren.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ursache der Überhitzung beseitigen (z. B. Verringerung der Belastung).


Leerzeichen nicht zulässig

Ursache: | Es wurden unzulässigerweise ein oder mehrere Leerzeichen eingefügt.
Abhilfe: | Leerzeichen entfernen.


Leseschutz wegen Bediengeräte-Status

Ursache: | Es wurde versucht, eine "$"-Variable bei falsch eingestelltem Bediengerät-Status zu lesen.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Status des Bediengerätes auf "aktiv" setzen.


Leseschutz wegen Prozess-Status

Ursache: | Lesen einer "$"-Variablen bei unzulässigem Prozess-Status (aktiv, nicht aktiv, RC-Ready).
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Zulässigen Prozess-Status einstellen.


Linke Seite: Feld unzulässig

Ursache: | Im Ausdruck darf links kein Feld, unter Umständen aber ein Feldelement angegeben werden. Beispiel: $OUT[ ]=TRUE
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: $OUT[3]=TRUE


Linker Operand ungleich BOOL

Ursache: | Linker Operand hat nicht den Datentyp "BOOL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand ungleich INT, CHAR

Ursache: | Linker Operand hat nicht den Datentyp "INT" oder "CHAR".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand ungleich INT, REAL

Ursache: | Linker Operand hat nicht den Datentyp "INT" oder "REAL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand ungleich INT, REAL, BOOL, CHAR, ENUM

Ursache: | Der Datentyp des linken Operanden ist nicht "INT", "REAL", "BOOL", "CHAR" oder "ENUM".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand ungleich INT, REAL, CHAR, ENUM

Ursache: | Linker Operand hat nicht den Datentyp INT, REAL, CHAR oder ENUM.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand ungleich POS, FRAME

Ursache: | Der Datentyp des linken Operanden ist nicht "POS" oder "FRAME".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Linker Operand: Feld bzw. Pfad unzulässig

Ursache: | Linker Operand darf kein Feld oder Pfad sein. Beispiel: INT x[9] x[2]=13 IF x[]== 7 THEN ...
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT x[9] x[2]=13 IF x[2]== 7 THEN ...


LOAD nicht programmiert

Ursache:

Bei eingeschalteter Beschleunigungsanpassung ist die Roboter-Last nicht vollständig programmiert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

"$LOAD" korrekt programmieren.


Lokale STRUC/ENUM in globaler STRUC nicht vereinbart

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Lokales UP darf nicht in Prozesskommandos stehen

Abhilfe:

Programm entsprechend ändern.


Löschen der Aufzeichnung: Rückwärtsfahren nicht mehr möglich

Ursache: | Es wurde editiert, oder es wurde eine Satzanwahl durchgeführt, die zur Löschung der Aufzeichnung führt.
Auswirkung: | Rückwärtsfahren ist nicht möglich.
Abhilfe: | Vorwärtsfahren


LTC: Initialisierung fehlgeschlagen (Grund: <Grund>)

Ursache:

Die LTC-Task nicht richtig initialisiert.

Auswirkung:

Die LTC-Task sammelt und meldet keine Daten an den Windows Client.

Abhilfe:

  • Die Datei "LTC_Para.ini" in das Verzeichnis "\INIT" kopieren;

  • Roboter mit mindestens 6 Achsen konfigurieren;

  • Dynamikmodell aktivieren.


Marke nicht lokal vereinbart

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Maschinendaten nicht korrekt

Ursache: | Die Maschinendaten sind noch nicht überprüft.
Auswirkung: | Keine.
Abhilfe: | Korrekte Maschinendaten oder Optionsdatendatei auf Steuerung kopieren.


Maximal drei Dimensionen erlaubt

Ursache: | Bei einer Feldvereinbarung wurde die Anzahl der maximal erlaubten 3 Dimensionen überschritten. Beispiel: DECL INT Hugo[3,2,7,6]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DECL INT Hugo[3,2,7]


<Dateiformat>: Maximale Anzahl gleichzeitiger Aufzeichnungen

Ursache: | Abhängig vom Treiber kann die Anzahl simultaner Aufzeichnungen begrenzt sein, wobei nur eine Aufzeichnung zur gleichen Zeit möglich ist.
Auswirkung: | Die Aufzeichnung wird nicht gestartet.
Abhilfe: | Warten, bis eine andere Aufzeichnung beendet ist.


MDR: Status des Device nicht aktiv

Ursache: | Ein MDR / EB - Kommando wurde aufgerufen, wobei der Device-Status nicht ACTIVE war.
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Device-Status auf ACTIVE setzen.


MDR: Device nicht vom Typ <korrekter Device Typ>

Ursache: | Device hat nicht den korrekten Typ
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Verwenden eines Device vom korrekten Typ


MDR: Device-Name unbekannt

Ursache: | Ein nicht in der Device-Liste enthaltener Gerätename wurde verwendet.
Auswirkung: | Roboter und Interpreter Stopp
Abhilfe: | Verwendung des korrekten Namens.


MDR: Motion Driver gibt Fehler <Fehlernummer> zurück

Ursache: | Der Anruf des Motion Driver lieferte eine Fehlermeldung.
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Treiber abhängig.


MDR: Status Wechsel nicht erlaubt

Ursache: | Der Status-Wechsel mit "MD_SETSTATE()" ist nicht zulässig.
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Zulässig ist: INITIALIZED <-> ACTIVE Wenn der Status INITIALIZED nicht möglich ist, ging eine Störung während der Initialisierung voraus.


Mehr aktuelle als formale Parameter angegeben

Ursache: | Im Unterprogramm- oder Funktionsaufruf sind mehr aktuelle Parameter angegeben als formale in der Unterprogramm- bzw. Funktionsvereinbarung. Beispiel: Up(3,5,9) ... DEF Up(a:IN,b:IN) INT a,b ...
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: Up(3,5) ... DEF Up(a:IN,b:IN) INT a,b ...


Mehrere 'Master' im Zeitgebersynchronisationsverbund entdeckt

Ursache: | Zwei oder mehrere Steuerungen im Zeitgebersynchronisationsverbund wurden als 'Master' konfiguriert.
Auswirkung: | Die problemverursachende Steuerung wird in einen 'Slave'-Zustand gezwungen.
Abhilfe: | Konfigurieren Sie nur eine Steuerung im Zeitgebersynchronisationsverbund eindeutig als 'Master'.


Meldung nicht quittierbar

Ursache: | Quittieren einer Zustandsmeldung.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Keine. Bitte beachten Sie die Meldung.


Meldung nicht vorhanden

Ursache:

Versuch der textuellen Quittierung einer nicht vorhandenen Meldung.

Auswirkung:

Kommando kann nicht ausgeführt werden.

Abhilfe:

  • keine


Messfahrt unterbrochen - wird als Testfahrt beendet

Ursache: | Während der Lastdatenermittlung wurde die Starttaste bzw. Zustimmtaste losgelassen.
Auswirkung: | Die Messfahrt wird als Testfahrt gewertet.
Abhilfe: | Die Messfahrt muss neu gestartet werden.


<Modul> angewählt

Ursache: | Programm ist nicht einbindbar; Modul ist mit "RUN" angewählt.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Programmablauf abbrechen (CANCEL).


Modul ist nicht vorhanden

Ursache:

Ein notwendiges Modul kann nicht gefunden werden, z. B. weil es nicht oder nicht als global deklariert wurde.

Beispiel:
DEFDAT P PUBLIC
DECL CONST INT Hugo = 1
ENDDAT

DEF Up()
IMPORT INT Hugo
END

Auswirkung:

Das Programm ist nicht ausführbar.

Abhilfe:

  • Pfadangaben und Modulnamen überprüfen.

  • Modul vereinbaren bzw. als global deklarieren.

Beispiel:
DEFDAT P PUBLIC
DECL GLOBALCONST INT Hugo = 1
ENDDAT

DEF Up()
IMPORT INT Hugo
END


<Modul> nicht gebunden

Ursache:

"UNLINK" auf ein Objekt, welches kein Programm ist.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

  • keine


<Modul> nicht korrekt

Ursache: | Beim Binden wurde ein nicht korrektes Modul angewählt.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Fehler im angezeigten Modul beheben.


<Modulname> ist kein Modul

Ursache: | Der angegebene Name steht für einen Katalog.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Modulnamen verwenden.


Kollisionsüberwachung Achse <Achsnummer>

Ursache:

Das Motormoment befindet sich nicht im angegebenen Überwachungsbereich.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Lastdaten überprüfen

  • ggf. Überwachungsbereich vergrößern.


Motor blockiert <Achsnummer>

Ursache:

Der vom Drehzahlregler gelieferte Momenten-Sollwert überschreitet den max. Momenten-Sollwert um mehr als 30%.

Die Abschaltung erfolgt im Rahmen der "i*t"-Überwachung bei Erreichen eines "i*t"-Wertes von ca. 0,75 [(Momentensollwert / max. Momentensollwert)*sec].

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ursache für die Momenten-Überlastung beseitigen (Geschwindigkeit, Beschleunigung verringern).


Motortemperatur <Achsnummer>

Ursache:

Die Motortemperatur der angezeigten Achse beträgt mehr als 155°C. (Signalisierung erfolgt durch PTC-Element in der Motorwicklung.)

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Mechanische Belastung verringern.

  • Gegebenenfalls Fehler beseitigen.


Nach ENDDAT darf nur Kommentar eingefügt werden

Ursache: | Nach "ENDDAT" wurde unerlaubter Programmcode eingefügt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programmcode nach "ENDDAT" entfernen oder auskommentieren.


Nach Komma nur Wertebereich 0-7 zulässig

Ursache: | Wertebereich wurde überschritten.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Nächste Diskette einlegen

Ursache: | Anforderung der nächsten Diskette.
Abhilfe: | Diskette in das Disketten-Laufwerk einlegen.


Name der Laufschleifenvariable erwartet

Ursache: | Der Name der Laufschleifenvariablen fehlt.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Name einer Datenliste darf nicht geändert werden

Ursache: | Es wurde versucht, den Namen einer Datenliste zu ändern.
Auswirkung: | Änderung wird verworfen.
Abhilfe: | Alten Namen beibehalten.


Name eines Signals erwartet

Ursache: | In der Programmzeile fehlt der Name eines Signals. Beispiel: ANOUT OFF
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT OFF $ANOUT[2]


Name eines Strukturdatentyps erwartet

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Name eines Unterprogramms erwartet

Ursache: | Es wird der Name eines Unterprogramms erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Name erwartet

Ursache: | Im Ausdruck fehlt die Angabe eines Namens oder die Angabe entspricht nicht den Regeln einer reinen Ziffernfolge bei Variablennamen. Beispiel: BOOL
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: BOOL Hugo


<Name> existiert bereits

Ursache: | SVB-Baustein kann nicht im Editor angelegt werden, wenn bereits ein gleichnamiger SKL-Baustein existiert, und umgekehrt.
Abhilfe: | Namen des Bausteins ändern.


Name in erster Zeile muß gleich Modulname sein

Ursache: | Name in erster Programmzeile entspricht nicht dem Modulnamen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Name ist zu lang

Ursache: | Der angegebene Name enthält zu viele Zeichen.
Abhilfe: | Anzahl der Zeichen verringern.


Name länger als 24 Zeichen

Ursache: | Der Name darf nicht aus mehr als 24 Zeichen bestehen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Name nicht als einfache Variable deklariert

Ursache: | Es handelt sich nicht um eine einfache Variable, die allein durch ihren Namen korrekt beschrieben ist oder um eine Variable, die im falschen Kontext verwendet wird. Anstatt des Namens einer einfachen Variablen wurde der Name z. B. eines Unterprogramms verwendet oder es handelt sich um eine Feldvariable, die ohne Index verwendet wurde. Beispiel 1: DEF hhh() hhh=1 END Beispiel 2: INT Hugo[3] Hugo=1
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Name nicht als Feld vereinbart

Ursache: | Variable wurde mit Index angegeben, ist aber nicht als Feld deklariert. Beispiel: INT Hugo Hugo[3]=7
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: INT Hugo Hugo=7


Name nicht als Funktion vereinbart

Ursache: | Einer Variable wird ein vermeintlicher Funktionswert zugewiesen. Meistens ist die vermeintliche Funktion als Unterprogramm definiert. Beispiel: INT i i=Prog() ... DEF Prog() ... END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: INT i i=Prog() ... DEFFCT INT Prog() ... ENDFCT


Name nicht als Kanal deklariert

Ursache: | Der Name wurde nicht als Kanal deklariert.
Abhilfe: | Programm entsprechend ändern.


Name nicht als Kanal deklariert

Ursache: | Der Name wurde nicht als Kanal deklariert.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Name nicht als Marke deklariert

Ursache: | Es wird versucht, mit dem "GOTO"-Befehl auf eine Marke zu springen, die nicht definiert ist.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Name nicht als Unterprogramm vereinbart

Ursache:

  • Es wird ein Unterprogramm aufgerufen, welches nicht existiert, z. B. aus einer Interrupt- oder Triggerdeklaration.

  • Es wird eine Funktion als Unterprogramm aufgerufen.

Auswirkung:

Programm ist nicht ausführbar.

Abhilfe:

Programm entsprechend ändern.


Nicht initialisierte Variable

Ursache: | Eine Variable wurde nicht initialisiert.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Variable initialisieren.


Nicht überschleiffähige Anweisungsfolge (Modul <Modulname>, Satz <Satznummer Bewegung>)

Ursache: | Zwischen zwei Bewegungssätzen, die überschliffen werden sollen, ist "DRIFT", "$TOOL oder "$FILTER" programmiert.
Auswirkung: | Bewegungssätze werden nicht überschliffen.
Abhilfe: | Programm entsprechend ändern.


NODE muss folgen

Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm ändern.


NODE, USER oder PERI erwartet

Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm ändern.


NOT-AUS intern gedrückt

Ursache:

NOT-AUS intern wurde ausgelöst.

Auswirkung:

  • Bahntreuer Stop

  • Verriegelung aller aktiven Kommandos

Abhilfe:


OBJ, NODE, USER oder PERI erwartet

Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm ändern.


Objekt hat keinen gültigen Typ

Abhilfe:

Programm entsprechend ändern.


<Objektname> hat maximale Größe erreicht

Ursache: | Wenn ein Baustein die maximale Größe (65536 Bytes) erreicht hat, so erscheint der Hinweis z.B. "SRC HAT DIE MAXIMALE GRÖSSE ERREICHT UND KANN NICHT VERG".
Abhilfe: | Größe entsprechend reduzieren.


<Objektname> zu viele lokale Unterprogramme

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Objekt muss in Datenliste oder implizit deklariert sein

Ursache: | Objekt ist nicht in Datenliste oder implizit deklariert.
Abhilfe: | Programm entsprechend ändern.


<Objekt> nicht bearbeitbar

Ursache: | Ein bereits belegtes Objekt wurde angesprochen.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Belegung freigeben (/R1/CONFIG.DAT).


Objekt nicht bereit

Ursache: | Programm kann vom Editor nicht bearbeitet werden.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Programm mit "Edit" öffnen.


Objekt nicht korrekt

Ursache: | Das Objekt ist für TTS-Berechnung nicht korrekt.
Auswirkung: | keine
Abhilfe: | Objekt entsprechend korrigieren.


<Objekt> nicht löschbar

Ursache:

Dieses Objekt kann nicht gelöscht werden, da es schreibgeschützt ist.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

  • keine


<Objekt> nicht vorhanden

Ursache:

Ein nicht vorhandenes Objekt wurde angesprochen.

Auswirkung:

Kommando wird nicht bearbeitet.

Abhilfe:

  • Kommando entsprechend korrigieren.

  • Objekt anlegen.


Objekt nicht vorhanden

Ursache: | Objekte, die nicht in der KRC vorliegen, können nicht angesprochen werden.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Richtiges Objekt auswählen.


Objekt nicht vorhanden

Ursache: | Es wurde ein Objekt abgefragt, welches nicht existiert.
Auswirkung: | Objekt kann nicht angezeigt werden.
Abhilfe: | Objektnamen korrigieren oder neu eingeben.


Objektbeschreibung nicht auswertbar

Ursache: | Bei "COPY" von Extern wurde eine nicht auswertbare Modulinformation empfangen.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Schnittstellensoftware überprüfen.


<Objektname> belegt

Ursache:

  • Das Objekt ist bereits belegt und daher nicht bearbeitbar.

  • Modul kann nicht gebunden werden, da mindestens eines der Objekte dieses Moduls belegt hat.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

Keine.


Objektname darf keinen "." enthalten

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<Objektname> ist nicht schreibbar

Ursache: | Objekt ist schreibgeschützt.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Objektzustand prüfen; z. B. Objekt trennen oder abwählen.


Objektname ist zu lang

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<Objektname> nicht korrekt kopiert. Fehler in Zeile <Satznummer>

Ursache: | Bei der Zeilenanalyse wurden Fehler festgestellt.
Auswirkung: | Fehlertoken im Objekt.
Abhilfe: | Objekt entsprechend korrigieren.


<Objektname> nicht korrigierbar

Ursache:

Es wurde eine falsche Extension bei Objekten angegeben.

Bei Objekten ist nur die Extension "DAT" zulässig.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

  • Datenliste wählen.

  • INIT-Schalter auf der I-CPU auf Pos. 3 stellen.


ON oder OFF erwartet

Ursache: | In der Programmzeile fehlt das Schlüsselwort "ON" bzw. "OFF". Beispiel: ANOUT $ANOUT[2]
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT OFF$ANOUT[2]


ON, OFF, ENABLE, DISABLE, DECL erwartet

Ursache: | Es fehlt eines der Schlüsselworte "ON", "OFF", "ENABLE", "DISABLE" oder "DECL", oder es steht an falscher Stelle. Beispiel: INTERRUPT
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INTERRUPT ON


Operand oder Ausdruck erwartet

Ursache: | Entweder wurde kein Operand bzw. Ausdruck angegeben oder ein Zeichen, welches nicht als Operand bzw. Ausdruck ausgewertet werden kann. Beispiel: $OUT[*]=TRUE
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: $OUT[3]=TRUE


Operand ungleich BOOL

Ursache: | Es wird ein Operand vom Datentyp "BOOL" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Operand ungleich INT, CHAR

Ursache: | Es wird ein Operand vom Datentyp "INT" oder "CHAR" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Operand ungleich INT, REAL

Ursache: | Es wird ein Operand vom Datentyp "INT" oder "REAL" erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Beide Operanden ungleich INT, REAL, BOOL, CHAR, ENUM

Ursache: | Der Datentyp der Operanden ist nicht "INT", "REAL", "BOOL", "CHAR" oder "ENUM".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Beide Operanden ungleich POS, FRAME

Ursache: | Der Datentyp der Operanden ist nicht "POS" oder "FRAME".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Operandentypen sind nicht vergleichbar

Ursache: | Die angegebenen Operanden haben unterschiedliche Datentypen und sind nicht vergleichbar.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Operandentypen sind nicht vergleichbar

Ursache: | Die Operanden haben unterschiedliche Datentypen und sind nicht vergleichbar. Beispiel: IF $IN[3]==1THEN ... ENDIF
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: IF $IN[3]==TRUETHEN ... ENDIF


Option doppelt angegeben

Ursache: | Eine Option wurde doppelt angegeben.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Option erwartet nach Minuszeichen

Ursache: | Option nach Minuszeichen fehlt.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Parameter müssen im Baustein deklariert sein

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Parameter nicht ausgewertet

Ursache: | Bei einem bereits angewählten Programm wurde ein Kommando RUN mit Parametern ausgeführt.
Auswirkung: | Die Parameter werden nicht ausgewertet.
Abhilfe: | Programm abbrechen und neu anwählen.


Parameter von EXT[FCT] und DEF[FCT] sind inkompatibel

Ursache: | Die angegebenen Parameter in der EXT-Anweisung entsprechen nicht denen in der Unterprogrammvereinbarung. Beispiel: DEF Test(x:IN) INT x ENDDEF P() EXT Test() END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Test(x:IN) INT x ENDDEF P() EXT Test(INT:IN) END


Parameteränderung nicht erlaubt, Kanal belegt

Ursache:

Es wurde versucht, einen bereits belegten Kanal mit anderen Parametern als den aktuellen zu belegen.

Abhilfe:

  • Die für den Kanal verwendeten Daten entsprechend korrigieren, oder

  • Kanal schließen und mit den entsprechenden Parametern wieder öffnen.


Parameter-Spezifikation in Datenliste nicht zulässig

Abhilfe:

Programm entsprechend ändern.


Parametervariable vom falschen Typ

Ursache: | Die Parametervariable für den Kanal ist vom falschen Typ.
Auswirkung: | keine
Abhilfe: | CHANNEL-Vereinbarung für den Kanal korrigieren.


Path-Ausdruck unzulässig

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Path-Ausdruck verlangt (Feld)

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<Pfad> ist kein Katalog

Ursache: | Kommando enthält ein Subdirectory.
 | Die Angabe eines Subdirectory, z.B. "dir/R1/otto/abc", ist nicht zulässig.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Kommando entsprechend korrigieren.


<Pfad> unzulässige Angabe

Ursache: | Es wurde ein falscher Pfad, Modulname oder Extension angegeben.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Kommando entsprechend korrigieren.


POS, FRAME oder AXIS erwartet

Abhilfe:

Programm entsprechend ändern.


Positive ganze Zahl erwartet

Ursache: | Es ist ausschließlich die Angabe einer ganzen positiven Zahl erlaubt, z.B. bei Angabe der Feldgröße. Beispiel: CHAR Hugo[0]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: CHAR Hugo[7]


Positive ganze Zahl, "]" oder "," erwartet

Ursache: | Es wurde keine ganze positive Zahl angegeben, bzw. der Wertebereich überschritten oder die Zeichen "]" bzw. "," vergessen. Meist bei Indexvereinbarungen. Beispiel: DECL CHAR Otto[-3]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DECL CHAR Otto[3]


PRIO erwartet

Ursache: | Das Schlüsselwort "PRIO" wurde vergessen oder steht an falscher Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Program Cooperation Versionskonflikt (<Message version number>) in Meldung von <Controller name or IP Address>

Ursache: | Eine Programmkooperationsmitteilung, welche von einer anderen Steuerung empfangen wurde, hat ein unterschiedliches Meldungsformat und ist inkompatibel mit dieser Version der Programmkooperationssoftware.
Auswirkung: | Die Steuerungen führen keine Programmkooperationsbefehle aus.
Abhilfe: | Auf allen betroffenen Steuerungen die gleiche Version der Programmkooperationssoftware installieren.


Programmlaufart unzulässig

Ursache: | Die gewählte Programmlaufart ist nicht zulässig.
Auswirkung: | Keine.
Abhilfe: | Programmlaufart ändern.


Programmzeile nicht angelegt

Ursache:

Die angewählte Programmzeile existiert nicht.


Programmzeile wurde korrigiert

Ursache:

Bestätigung, dass die Programmzeile korrigiert wurde.


Protokoll Timeout

Ursache:

Die eingestellte Protokollzeit wurde überschritten.

Abhilfe:

  • Überprüfen, ob die physikalische Verbindung zur Peripherie noch gegeben ist.

  • Wert für Zeitüberwachung entsprechend höher setzen, falls dieser zu niedrig ist.


Protokollfehler aufgetreten

Ursache: | Fehler in der Protokollsoftware des Bediengerätes oder Ausgabegerätes.
Auswirkung: | Kommando wird abgebrochen.
Abhilfe: | Protokollsoftware überprüfen.


Protokollvariable implizit deklariert

Ursache: | Die Protokollvariable wurde implizit deklariert.
Abhilfe: | Programm entsprechend ändern.


Protokollvariable muss Strukturtyp haben

Ursache: | Die Protokollvariable ist nicht vom Strukturtyp.
Abhilfe: | Programm entsprechend ändern.


Prozess belegt

Ursache:

Programm ist bereits angewählt.

Die Abfrage erfolgt während der Kommando- und der Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht ausgeführt.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Bereits angewähltes Programm abwählen.

  • Bei der Programmbearbeitung muss die Meldung quittiert werden.


PTP-Zielpunkt in Singularität <Bezeichnung der Singularität>

Ursache: | Der kartesische Zielpunkt einer PTP-Bewegung liegt in der Singularität. Die zugehörige Achsposition kann deshalb nicht ermittelt werden (wird normalerweise implizit auf 0 Grad gesetzt).
Auswirkung: | Falls der Schalter STOP_AT_PTP_SINGULARITY auf TRUE steht, kann diese Bewegung nicht ausgeführt werden, außer in T1 und MSTEP. In MSTEP wird nur die Hinweismeldung (ohne Reaktion) ausgegeben.
Abhilfe: | Punkt mit MSTEP in T1 anfahren und Zielposition so ändern, dass diese nicht mehr in der Singularität ist.


Quell- und Zielobjekt identisch

Ursache: | Die Quellangabe und die Zielangabe beschreiben das gleiche Objekt.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Zielobjekt ändern.


Realwertige Konstante erwartet

Ursache: | Verwendete Konstante ist nicht vom Typ Real.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Rechte Seite: Feld unzulässig

Ursache: | Im Ausdruck darf rechts kein Feld, unter Umständen aber ein Feldelement angegeben werden. Beispiel: $OUT[3]=$IN[ ]
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: $OUT[3]=$IN[5]


Rechter Operand ungleich BOOL

Ursache: | Rechter Operand hat nicht den Datentyp "BOOL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechter Operand ungleich INT, CHAR

Ursache: | Rechter Operand hat nicht den Datentyp "INT" oder "CHAR".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Rechter Operand ungleich INT, REAL

Ursache: | Rechter Operand hat nicht den Datentyp "INT" oder "REAL".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechter Operand ungleich INT, REAL, BOOL, CHAR, ENUM

Ursache: | Der Datentyp des rechten Operanden ist nicht "INT", "REAL", "BOOL", "CHAR" oder "ENUM".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechter Operand ungleich INT, REAL, CHAR, ENUM

Ursache: | Der Datentyp des rechten Operanden ist nicht "INT", "REAL", "CHAR" oder "ENUM". Beispiel: INT i i=7 IF i<TRUETHEN ... ENDIF
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT i i=7 IF i<10THEN ... ENDIF


Rechter Operand ungleich POS, FRAME

Ursache: | Der Datentyp des rechten Operanden ist nicht "POS" oder "FRAME".
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechter Operand: Feld unzulässig mit Dimension > 1

Ursache: | Die Dimension des rechten Operanden darf nicht größer als 1 sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechter Operand: Feld unzulässig

Ursache: | Rechter Operand darf kein Feld sein. Beispiel: INT x[9] x[2]=13 IF 7 ==x[]THEN ...
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT x[9] x[2]=13 IF 7 == x[2]THEN ...


Rechter Operand: Klammerung verboten, da Path-Ausdruck

Ursache: | Rechter Operand darf nicht eingeklammert werden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Rechts Zeichenkettenkonstante => links Indizierung

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Reelle Konstante, Variable oder Feldelement erwartet

Ursache: | Es wird eine reelle Konstante, Variable oder Feldelement verlangt. Beispiel: ANOUT ON Draht = .5 * Faktor + 1
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT ON Draht = .5 * Faktor + 1.0


Referenzpunktverschiebung ungültig

Ursache:

Justage durch Übernahme der Referenzpunktverschiebung nicht möglich, da diese in "$ROBCOR.DAT" nicht gültig ist.


Referierrichtung wechseln <Achsnummer>

Ursache: | Beim Referieren der Einzelachsen wurde die falsche Richtungstaste betätigt, abhängig vom Maschinen-Datum "$DIR_CAL".
Auswirkung: | Achse kann in diese Richtung nicht referiert werden.
Abhilfe: | In andere Richtung referieren.


Relative P_Pfadangabe passt nicht zur HOME-Einstellung

Abhilfe:

Programm entsprechend ändern.


Relativer Pfad unzulässig

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Satzanwahl nicht möglich: zu viele Interrupts

Ursache:

Satzanwahl in einem Interrupt-Programm.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Reset durchführen.


Returnwert: Feld String-Konstante unzulässig

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ Returnwert nicht mit Typ Funktion verträglich

Ursache: | Der Rückgabewert der Funktion entspricht nicht dem Funktionstyp. Beispiel: DEFFCT BOOLalf() REALHugo Hugo=1 RETURN(Hugo) ENDFCT
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEFFCT REALalf() REAL Hugo Hugo=1 RETURN(Hugo) ENDFCT


RoboCoaster System. Download unzulässig

Ursache:

Im Status ROBOCOASTER wurde versucht, eine Maschinendaten-Datei zu laden, obwohl diese bereits vollständig vorhanden sind.


Roboter justiert

Ursache:

Alle Achsen sind justiert.

Die Abfrage, ob die Achsen justiert sind, erfolgt beim Justiervorgang.

Auswirkung:

  • Roboter synchron setzen

Abfrage : - zyklisch

Abhilfe:

Falls die Achsen neu justiert werden sollen, muss vorher eine Dejustage vorgenommen werden.


RST-Anwahlschalter prüfen

Ursache: | Bei Anwahl bzw. Start von einem anderen Bediengerät aus befindet sich der Anwahlschalter an der RST nicht in Stellung "RUN".
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Anwahlschalter an der RST in Stellung "RUN" bringen.


Rückwärtsfahren nicht möglich: Aufzeichnung bereits abgefahren

Ursache: | Die aufgezeichneten Bewegungen wurden bereits abgefahren.
Auswirkung: | Die Bahn kann nicht zurückgefahren werden.
Abhilfe: | Vorwärtsfahren mit der Starttaste.


Rückwärtsfahren nicht möglich: Fahrbedingung aktiv

Ursache: | Die Bearbeitung der aktuellen Punkt SPS wurde durch eine aktive Fahrbedingung unterbrochen. Da die Punkt SPS noch nicht ausgeführt wurde, konnten die Ausgänge, Merker und Flags nicht aufgezeichnet werden, welche für das erneute Vorwärtsfahren erforderlich sind.
Auswirkung: | Rückwärtsfahren gesperrt.
Abhilfe: | Fahrbedingung simulieren.


Rückwärtsfahren nicht möglich: keine Aufzeichnung vorhanden

Ursache: | In Vorwärtsrichtung wurden keine Punkte abgefahren und aufgezeichnet oder die Aufzeichnung wurde verworfen.
Auswirkung: | Sie können die Bahn nicht zurückfahren.
Abhilfe: | Vorwärtsfahren mit der Starttaste.


Rückwärtsfahren nicht aktiviert

Ursache: | Rückwärtsfahren ist deaktiviert ($VW_BACKWARD = FALSE)
Auswirkung: | Das Kommando Rückwärtsfahren wird abgelehnt, bei Betätigung der Taste "Start Rückwärts".
Abhilfe: | Die Variable "$VW_BACKWARD" auf TRUE setzen.


Rückwärtsfahren nicht möglich: Abgearbeitetes UP

Ursache: | Es wurde versucht, eine Bewegung rückwärts abzufahren, die innerhalb eines bereits abgearbeiteten Unterprogramms (UP) liegt.
 | In diesem UP ist eine Umschaltung nach vorwärts nicht möglich. Deshalb wird auch die Rückwärtsbewegung gesperrt.
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Vorwärtsfahren


Rückwärtsinterpretation für kooperierende Roboter nicht möglich

Ursache: | Die Variable $SpreadAction hat einen Wert >1, und der Trace-Puffer für das Rückwärtsfahren ist leer.
Auswirkung: | Eine Rückwärtsfahrt im Scan-Modus ist in einem konfigurierten Startverbund nicht möglich.
Abhilfe: | Variable $SpeadAction=0 setzen


SAK erreicht

Ursache:

  • Erreichen der programmierten Bahn.

  • Nach Rückpositionieren ($POS_RET, $AXIS_RET, $POS_FOR, $AXIS_FOR, usw.)

Auswirkung:

  • Signalisierung, dass SAK durchgeführt wurde.

  • Danach kann der Programmlauf ab der angefahrenen Position gestartet werden.


SAK-Fahrt auf ZP erforderlich

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

SAK-Fahrt zum Zielpunkt durchführen.


SAK Fahrt mit START-Plus erforderlich

Ursache:

Es wurde versucht, mit der Rückwärts-Starttaste (-) eine SAK Fahrt durchzuführen.

Auswirkung:

Der Roboter startet nicht.

Abhilfe:

  • Verwenden Sie die Starttaste (+).

  • In Datei BACKWARD.INI folgendes eingeben: Implicit_BCO= TRUE


Satz darf nicht geändert werden

Ursache: | Es wurde eine unerlaubte Satzanwahl vorgenommen.
Auswirkung: | Satzanwahl wird nicht durchgeführt.
Abhilfe: | Anderen Satz anwählen.


Satz darf nicht gelöscht werden

Ursache:

Es wurde unzulässigerweise versucht, einen Satz zu löschen.


Satz nicht korrigierbar

Ursache: | TTS- oder BASE-Berechnung kann nicht durchgeführt werden.
 | TTS = werkzeuggekoppeltes bahnbegleitendes Dreibein.
Auswirkung: | keine


Satzanwahl außerhalb des Puffers: Nächster Start löscht Puffer

Ursache:

Die Satzanwahl ist außerhalb der Aufzeichnung.

Auswirkung:

Bei Betätigung der Starttaste wird der Puffer für Rückwärtsfahren gelöscht.

Abhilfe:

  • Vor Betätigung der Starttaste eine erneute Satzanwahl innerhalb des Puffers durchführen.

  • Danach kann weiterhin rückwärtsgefahren werden.


Satzanwahl fehlgeschlagen, Roboter: <RemoteRoboter>

Ursache: | Satzanwahl auf der Remote-Steuerung fehlgeschlagen. Kein oder falsches Programm angewählt, oder die Programme sind nicht identisch.
Auswirkung: | Satzanwahl wird nicht ausgeführt.
Abhilfe: | Richtiges Programm wählen.


Satzanwahl in lokale Funktion nicht erlaubt

Ursache: | Es wurde eine Satzanwahl in eine lokale Funktion versucht.
Auswirkung: | Satzanwahl wird nicht durchgeführt.
Abhilfe: | Aufruf der lokalen Funktion im Hauptprogramm vornehmen.


Satzende oder Kommentar erwartet

Ursache: | Die Syntax wurde nicht korrekt eingehalten oder ein Kommentar ohne vorangehendes ";" eingegeben.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Satzkoinzidenz nicht gegeben, erst Single-Step fahren

Ursache: | Keine SAK-Fahrt bei Betriebsartenwechsel nach AUTO.
Abhilfe: | Zuerst SINGLE-STEP fahren.


Satzwechsel bei STOPP

Ursache:

  • Im Falle eines generatorischen oder bahntreuen Stopp während eines Satzwechsels ist die Berechnung von "$POS_RET" und Systemzeit nicht möglich.

  • "$POS_RET" und Systemzeit sind durch den Beginn des neuen Satzes bestimmt.

Auswirkung:

  • Rampen Stopp.

  • Stopp der Programmbearbeitung.

Abhilfe:

Bedienhandlung so ändern, dass Stopp nicht gleichzeitig mit dem Satzwechsel erfolgt.


Schachtelungstiefe zu groß

Ursache: | Zu viele Kontrollstrukturen (z.B. IF- oder WHILE-Anweisungen) wurden innerhalb der gleichen Kontrollstrukturen verwendet.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Schneller NOT-AUS mit festen Bremsrampen

Ursache:

Bei NOT-AUS mit Dynamikmodell wird eine Strategie mit fest definierten Bremsrampen verwendet, weil dadurch die Bremsung schneller erfolgt.

Auswirkung:

Bei NOT-AUS wird schneller gebremst, als mit der auf dem Dynamikmodell basierenden Strategie.

Abhilfe:

  • Momentengrenzen für NOT-AUS prüfen.

  • Lastdaten prüfen.


Schutzgitter offen

Abhilfe:

Schutzgitter schließen.


SEC, FOR oder CLOCK erwartet

Ursache: | Eines der Schlüsselworte "SEC", "FOR" oder "CLOCK" fehlt oder steht an falscher Position.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


SEN: <Sensor Daten1> <Sensor Daten2> <Sensor Daten3>

Ursache:

Hinweismeldung eines Sensors, die keinen Stopp erfordert.


Servo-Parameter KPS <KPS Nummer> Zeile <Zeilennummer> nicht korrekt.

Ursache: | Angegebener KPS Servo-Parameter für das erwähnte KPS ist nicht korrekt.
Auswirkung: | Angegebener KPS Servo-Parameter für das erwähnte KPS wird ignoriert.
Abhilfe: | Korrigieren Sie das Servofile, welches in R1\MADA\$MACHINE.DAT für das erwähnte KPS angegeben ist oder spezifizieren Sie in R1\MADA\$MACHINE.DAT ein gültiges KPS Servofile.


Servoparameter Achse <Achsnummer> Zeile <Satznummer> nicht korrekt

Ursache: | Ein Parameter im Servofile ist nicht korrekt.
Abhilfe: | Parameter korrigieren.


Signalindex zu groß

Ursache: | Der Signalindex liegt außerhalb der verfügbaren Ein- oder Ausgänge. Beispiel: SIGNAL $DIGIN1 $IN[200] TO $IN[5000]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Signalname darf nicht geändert werden

Ursache: | Der Signalname wurde unzulässigerweise geändert.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


<Signalname> kein analoger Ausgang

Ursache:

Zugriff auf ein nicht vorhandenes analoges Ausgangssignal oder falscher Signalindex.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Signaltyp darf nicht geändert werden

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<SINEC L2, SINEC H1> Baugruppe nicht vorhanded

Ursache: | Es wurde versucht, auf einen SINEC L2- oder SINEC H1-Kanal zuzugreifen, ohne dass die entsprechende Baugruppe gesteckt ist.
Auswirkung: | keine
Abhilfe: | Entsprechende Baugruppe stecken.


Keine Verbindung zur SINEC L2-Baugruppe

Ursache:

Verbindung der IFC zur SINEC L2 - Baugruppe gestört.

Auswirkung:

keine

Abhilfe:

  • Warmstart durchführen.

  • Falls Störung weiter auftritt, Baugruppentausch (IFC mit SINEC L2-Baugruppe) vornehmen.


SINEC L2-Übertragungsfehler <Fehlernr. Sinec L2-M>

Ursache: | Datenübertragung über SINEC L2 aufgrund eines vom SINEC L2-Modul erkannten Fehlers nicht möglich.
Auswirkung: | keine
Abhilfe: | Übertragungsstrecke prüfen und Fehler beseitigen.


SINEC L2-Verbindungskanäle nicht geschlossen

Ursache: | Es wurde versucht, den SINEC L2 - Buskanal zu schließen, ohne vorher alle SINEC L2 - Verbindungskanäle zu schließen.
Auswirkung: | keine
Abhilfe: | Alle SINEC L2 - Verbindungskanäle schließen.


SINEC L2-Buskanal nicht geöffnet

Ursache: | Es wurde versucht, eine SINEC L2 - Verbindung zu öffnen, ohne vorherige Öffnung des SINEC L2 - Buskanals.
Auswirkung: | keine
Abhilfe: | SINEC L2 - Buskanal öffnen.


SINEC AP/TF-FEHLER <SINEC AP/TF-Fhlcode>

Ursache: | siehe "SINEC AP Technologische Funktionen,Teil B" bei Kommandobearbeitung
Abhilfe: | Siehe "SINEC AP Technologische Funktionen, Teil B".


Sprung auf Marke nicht zulässig

Ursache: | Die Marke befindet sich in einer Programmstruktur, z. B. in einer "SWITCH"-Verzweigung, in die nicht gesprungen werden kann.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Sprungziel nicht global deklariert

Abhilfe:

Programm entsprechend ändern.


Sprungziel nicht lokal deklariert

Ursache: | Das Sprungziel wurde nicht lokal deklariert, aber u. U. im nicht lokalen Bereich. Beispiel: DEF Prog() Marke: END DEF Prog2() GOTO Marke END ; im Beispiel stehen beide Programme im gleichen SRC-File
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog2() ... Marke: ... GOTO Marke END


Start blockiert <String>

Ursache: | Während des Einfügens eines Satzes im PROKOR ist der Start blockiert.
Auswirkung: | Start kann nicht durchgeführt werden
Abhilfe: | Einfügevorgang abschließen.


Start blockiert (Steuerung: <Steuerung>, Grund: <Grund>)

Ursache: | Kooperierende Roboter: Der Start ist blockiert, da einer der im Verbund stehenden Roboter eine Vorbedingung nicht erfüllt. (Näheres siehe Parameter Grund)
Auswirkung: | Der Start wird nicht ausgeführt, bis der bemängelte Zustand am entsprechenden Roboter beseitigt ist.
Abhilfe: | An der betreffenden Steuerung den Grund für den blockierten Start beseitigen.


Starttaste erforderlich

Ursache:

  • Ausführung des Kommandos erfordert die Start-Taste.

  • Das Kommando "Start" wurde als Text eingegeben.

Auswirkung:

Roboter steht.

Abhilfe:

  • Start-Taste betätigen.

  • Bei externem Rechner: Auftragskennung überprüfen.


Steuerungskaltstart

Ursache: | Steuerung ist erstmalig hochgelaufen (kein Wiederstart nach Spannungsausfall).
Auswirkung: | Keine


Steuerungsneustart nach Spannungsabfall

Ursache:

  • Steuerung wird wieder eingeschaltet.

  • Versorgungsspannung ist wieder vorhanden.


Steuerungstyp nicht identifizierbar. Default-Datei <Default DSE-Datei> auf DSE<DSE Nummer> geladen

Ursache: | Die autom. Servo-Hardwareerkennung konnte zwar den DSE-Typ erkennen, jedoch nicht den entsprechenden Steuerungstyp identifizieren. Daher wird die KRC2 als Default geladen.
Auswirkung: | Unter Umständen könnte die falsche DSE-Datei geladen sein, wodurch die Steuerung nicht läuft.
Abhilfe: | In der Datei "HW_INF.INI" muss "Automatic" oder manuell die korrekte DSE-Datei eingetragen werden.


String Konstante als OUT Parameter unzulässig

Ursache: | Eine String Konstante wurde als OUT Parameter verwendet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Strukturtypname erwartet

Abhilfe:

Programm entsprechend ändern.


Strukturtyp-Variable nicht erlaubt

Ursache: | An dieser Stelle ist eine Struktur-Variable nicht erlaubt.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Summenbaudrate Überschritten

Ursache: | Die Summenbaudrate beider Kanäle wurde überschritten (Begrenzung auf 19200 Baud).
Abhilfe: | Baudrate korrigieren.


SWITCH enthält kein CASE

Ursache: | "SWITCH"-Konstrukt enthält keinen "CASE"-Zweig.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Symbol ist nicht Anfang eines Ausdrucks/Wertzuweisung

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


SYNACT nicht ausführbar <Satznummer>

Ursache:

Die Programmierung von Synchronaktionen mit den Variablen "$M_TIME" oder "$M_TIME_APO" führt bei Programmfortsetzung nach Rampen Stop, bahntreuer NOT_AUS-Rampe oder generatorischem Stop zu dieser Meldung.


SYNC()-Aufruf nicht programmiert

Ursache: | Der Anwender hat im IRSTOPMESS nicht auf $Power-Fail mit dem Aufruf der SYNC()-Funktion reagiert.
 | Die Abfrage erfolgt bei Spannungsausfall.
Auswirkung: | keine
Abhilfe: | Anwenderprogramm entsprechend korrigieren.


Syntaxfehler im Modul

Ursache: | Im Modul ist ein Syntaxfehler vorhanden.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Überprüfen des Programmcodes im Modul.


Syntaxfehler in Feldspezifikation

Ursache: | Die Feldspezifikation entspricht nicht der Syntax. Beispiel: DEF Hb(a[9]:IN) INT a[]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Hb(a[]:IN) INT a[]


Syntaxfehler in P_Pfadangabe

Ursache: | Die Syntax in der Pfadangabe ist nicht korrekt. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDATDEF P() IMPORT INT Otto_2 IS R1/PROG_1..Otto END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Pfadangabe korrigieren. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 IS /R1/PROG_1..Otto END


Syntaxfehler in WITH Option

Ursache: | In der WITH Option wurde ein Syntaxfehler festgestellt.
Auswirkung: | Programm syntaktisch nicht korrekt.
Abhilfe: | Programm entsprechend ändern.


System aus Hibernate Modus wiederhergestellt

Ursache: | System wurde nach einem Ausfall der Stromversorgung wiederhergestellt.
Auswirkung: | n/a
Abhilfe: | n/a


Systemdateien dürfen nicht gelöscht werden

Ursache:

Es wurde versucht, eine Systemdatei zu löschen.


Tachoabgleich nur für eine Achse möglich

Ursache: | Es wurde versucht, für mehrere Achsen gleichzeitig einen Tachoabgleich der DSE durchzuführen.
 | Die Abfrage erfolgt bei Wertzuweisung an "$PROG_EEPOT".
Auswirkung: | Wertzuweisung wird nicht durchgeführt.
Abhilfe: | Tachoabgleich nur für eine Achse durchführen.


<Dateiformat>: Task für <Recordname> kann nicht gestartet werden

Ursache: | Es sind zu viele EMS-Befehle aktiv, welche in unterschiedlichen Tasks laufen.
Auswirkung: | Das Kommando wird nicht ausgeführt.
Abhilfe: | Warten, bis ein anderes Kommando abgearbeitet ist.


Taste nicht belegt

Ursache: | Betätigung einer nicht belegten Softkey-Taste oder Funktions-Taste innerhalb der geführten Bedienung.
Auswirkung: | keine


Techfunktion $TECH[<Parameter 1-3>].FCT unzulässig

Ursache:

Die in $TECH[i].FKT i=1..3 programmierten Funktionsparameter entsprechen nicht der Funktionsdefinition.

Die Funktionsparameter werden vom Interpreter im Vorlauf überprüft.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Korrektur der Funktionsparameter.


THEN erwartet

Ursache: | "IF"-Anweisung wurde unvollständig angegeben, es fehlt das Schlüsselwort "THEN". Syntax: IF BoolausdruckTHEN Anweisungen ENDIF
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


TO erwartet

Ursache: | Das Schlüsselwort "TO" fehlt.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Tool/Base-Option ist nicht korrekt

Ursache: | TB Option des LIN_REL Befehles wurde nicht korrekt programmiert.
Auswirkung: | Syntaxfehler des Programmes wird gemeldet.
Abhilfe: | Programm entsprechend ändern.


Tool / Base Option der Anweisung nicht korrekt

Ursache: | Tool / Base Option der LIN_REL Anweisung wurde nicht korrekt programmiert; die Syntax ist nicht korrekt.
Auswirkung: | Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


TRACE: Aufzeichnungszeit zu lang

Ursache:

  • Die in "TRACE.DEF" konfigurierte Aufzeichnungszeit ist zu lang.

  • Für die Aufzeichnung steht nicht genügend Speicherplatz zur Verfügung.

Auswirkung:

TRACE wird nicht aufgezeichnet.

Abhilfe:

  • Die TRACE–Aufzeichnungszeit entsprechend verkürzen.

  • Die Anzahl der aufzuzeichnenden Kanäle reduzieren.


TRUE oder FALSE erwartet

Ursache: | Als Zuweisungen sind nur "TRUE" oder "FALSE" zulässig.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


TTS nicht ermittelbar

Ursache: | Abbruch beim Suchen des Bahnrichtungspunktes.
 | TTS = werkzeuggekoppeltes bahnbegleitendes Dreibein
Auswirkung: | keine


Typ aktueller/formaler Parameter nicht verträglich

Ursache: | Die Parameter im Unterprogramm- bzw. Funktionsaufruf passen nicht zu der Unterprogramm/Funktionsvereinbarung. Beispiel: BOOLb b=TRUE up(b) ... DEF up(var:IN) INTvar END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INTb b=4 up(b) ... DEF up(var:IN) INT var END


Typ aktueller/formaler Parameter nicht verträglich

Ursache: | Die Parameter im Unterprogramm- bzw. Funktionsaufruf passen nicht zu der Unterprogramm/Funktionsvereinbarung. Beispiel: BOOLb b=TRUE up(b) ... DEF up(var:IN) INTvar END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INT b b=4 up(b) ... DEF up(var:IN) INT var END


Typ der Laufschleifenvariable ungleich INT

Ursache: | Für die Laufschleifenvariable ist nur der Datentyp INTEGER zulässig. Beispiel: DECLREALi FOR i = 1 TO 5 ... ENDFOR
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DECL INTi FOR i = 1 TO 5 ... ENDFOR


Typ des Ausdrucks ungleich MODUS_T

Ursache: | Der Datentyp des Ausdrucks muss "MODUS_T" sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Typ des Ausdrucks ungleich INT, REAL, CHAR, BOOL, ENUM

Ursache: | Der Datentyp des Ausdrucks muss INT, REAL, CHAR, BOOL oder ENUM sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ des Ausdrucks ungleich STAT_T

Ursache: | Der Datentyp des Ausdrucks muss "STAT_T" sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ des formalen Parameters ungültig

Ursache: | Der Typ des formalen Parameters ist ungültig.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ des lokalen Parameters ist lokal definiert

Abhilfe:

Programm entsprechend ändern.


Typ eines Parameters ist lokal definiert

Abhilfe:

Programm entsprechend ändern.


Typ ENUM-Konstante ungleich Typ ENUM-Variable

Ursache: | Eine Enum-Konstante wurde einer Enum-Variable eines anderen Typs zugewiesen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Typ erwartet

Ursache: | Es wird die Angabe eines Datentyps erwartet. Beispiel: DEFFCT Ida(x1:IN) ... ENDFCT
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEFFCT REALIda(x1:IN) ... ENDFCT


Typ Komponente nicht mit Typ Initialwert verträglich

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ links nicht mit Typ rechts verträglich

Ursache: | Die Datentypen des linken und rechten Operanden sind unverträglich.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ muss POS, FRAME oder AXIS sein

Abhilfe:

Programm entsprechend ändern.


Typ unbekannt

Ursache: | In einer Deklaration wurde ein Datentyp verwendet, der vorher nicht vereinbart worden ist bzw. lokal nicht bekannt ist.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ zu groß

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Typ/Dimension-Konflikt bei Import-Variable

Ursache: | Datentyp und/oder Dimension der Import-Variable und der Datenlistenvariable, auf die Bezug genommen wird, stimmen nicht überein. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Hugo[2,2] Hugo[2,2] = 1 ENDDATDEF P() IMPORT INT Hugo2IS /R1/PROG_1 .. Hugo END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Typ und Dimension der Import-Variablen überprüfen. Beispiel: DEFDAT PROG_1 PUBLIC DECL INT Hugo[2,2] Hugo[2,2] = 1 ENDDATDEF P() IMPORT INT Hugo2[2,2]IS /R1/PROG_1..Hugo END


Typname passt nicht zu Kontext

Abhilfe:

Programm entsprechend ändern.


Typwandlung für Initialwert nicht möglich

Abhilfe:

Programm entsprechend ändern.


Überschleifen $ORI_TYPE=#VAR/#CONSTANT nach $ORI_TYPE=#JOINT nicht möglich

Ursache: | Inkonsistente Achswinkel beim CP-CP-Überschleifen von $ORI_TYPE=#VAR bzw. #CONSTANT nach $ORI_TYPE=#JOINT. Dies passiert, wenn sich während der nicht-OriJoint CP-Bewegung einer der Handachswinkel zu stark dreht. (Siehe auch Meldung Nr. 1491)
Auswirkung: | Genauhalt wird gefahren.
Abhilfe: | Zu starke Drehung der Handachswinkel während nicht-OriJoint Bewegung vermeiden.


Überschleifen nicht möglich

Ursache:

Überschleifen ist rechenzeitbedingt nicht möglich.
(Bei Erreichen des Überschleifkriteriums im IPO)

Auswirkung:

  • keine

Abhilfe:

  • Wert für "$ADVANCE" > 0 programmieren.

  • Achs-Simulation ausschalten.


$CP_STATMON: Überschleifen nicht möglich

Ursache: | Aufgrund der Einstellung CP Konfigurationsüberwachung hat das Programm festgestellt, dass einer oder mehrere der programmierten Achswinkel nicht mit den aktuellen Achswinkeln übereinstimmen.
Auswirkung: | Das Programm kann diesen Punkt nicht überschleifen und fährt auf Genauhaltpunkt.
Abhilfe: | Den Genauhaltpunkt gegebenenfalls nochmals programmieren.


Überschleifen nicht möglich wegen Momentenüberschreitung

Ursache:

Der Überschleifbereich ist nicht ausreichend groß. Die zulässigen Momente würden überschritten.

Zum Abfahren des Überschleifsatzes muss die Geschwindigkeit bereits im vorangehenden Satz reduziert werden.

Auswirkung:

Interpreter

Abhilfe:

  • Länge des Einzelsatzes vergrößern durch Verringerung des Überschleifradius im aktuellen Bewegungssatz-Zielpunkt, oder – falls der Startpunkt überschliffen wird – durch Verringerung dieses Überschleifradius.

  • Geschwindigkeit und Beschleunigung des Vorgängersatzes reduzieren.


Überspannung <Powermodul Nummer>

Ursache:

Zwischenkreisspannung ist zu hoch.
Ursache hierfür kann sein:- Defekter Ballastwiderstand

  • Ballastsicherung

  • G1-Netzteil

  • zu steile Bremsrampe, usw.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Fehler beseitigen.

  • Rücksetzen durch Betätigung des Hardware-Quittungstasters "ACK" an der Bedienfrontplatte.


Überstrom <Achsnummer>

Ursache:

Schutzeinrichtung der Überwachung des Zwischenkreis-Stroms hat infolge Stromüberschreitung ausgelöst.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung der aktiven Kommandos.

Abhilfe:

  • Fehler beseitigen.

  • Rücksetzen des Fehlers durch Betätigung des Hardware-Quittungstasters "ACK" an der DSE I - Baugruppe.


<Dateiformat>: Unbekanntes Kommando

Ursache:

  • Der Befehls-String ist nicht korrekt.

  • Das Kommando ist nicht bekannt.

Auswirkung:

Der Roboter wird gestoppt.

Abhilfe:

Verwenden Sie die korrekte Befehls-Syntax.


Unbestimmter Syntaxfehler

Ursache: | Ein unbekannter Syntaxfehler ist aufgetreten.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


<Dateiformat>: Ungültige Konfiguration für <Recordname>

Ursache:

  • Unzulässiges Format der Konfigurationsdatei.

  • Zu viele Variablen für die Aufnahme konfiguriert.

Auswirkung:

Aufnahme kann nicht gestartet werden.

Abhilfe:

  • Prüfen Sie die Konfiguration.

  • Verringern Sie die Anzahl der Variablen für die Aufnahme.


Ungültige Operation - Wechsel zu 'Master' ist aktiv.

Ursache: | Eine vorherige Anfrage zum Wechseln von 'Slave' zu 'Master' ist aktiv.
Auswirkung: | Die aktuelle Anfrage wird ignoriert.
Abhilfe: | Warten Sie, bis die aktive Anfrage beendet wird, bevor eine neue Anfrage gestartet wird.


Ungültige Satznummer

Ursache: | Die Satznummer ist nicht gültig.
Abhilfe: | Satznummer entsprechend korrigieren.


Ungültiger Vorgang, es exisitiert bereits ein Zeitgeber - 'Master'

Ursache: | Es wurde versucht, diese Steuerung als Zeitgeber 'Master' zu konfigurieren. Der Vorgang schlug fehl, da bereits ein Zeitgeber 'Master' in der Zelle existiert.
Auswirkung: | Die Steuerung bleibt konfiguriert als Zeitgeber 'Slave'
Abhilfe: | Ist es erwünscht, diese Steuerung als Zeitgeber 'Master' zu konfigurieren, muss der existierende 'Master' auf Zeitgeber 'Slave' gesetzt werden.


<Dateiformat>: Ungültiges Dateiformat <Recordname>

Ursache: | Das Dateiformat ist ungültig.
Auswirkung: | Das Kommando wird nicht ausgeführt.
Abhilfe: | Korrigieren Sie das Dateiformat entsprechend.


Unterprogramm extern vereinbart, aber nicht verwendet

Ursache: | Ein Unterprogramm wurde extern vereinbart, wird aber nicht verwendet.
Abhilfe: | Programm entsprechend korrigieren.


Unterprogramm/Funktion falsch abgeschlossen

Ursache: | Falsches Abschluss-Schlüsselwort wurde verwendet, z.B. "END" statt "ENDFCT", oder umgekehrt. Beispiel: DEFFCT REAL Ida(x1:IN) ... END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEFFCT REAL Ida(x1:IN) ... ENDFCT


UNTIL fehlt

Ursache: | "REPEAT"-Schleife wurde nicht mit "UNTIL" abgeschlossen. Beispiel: DEF Prog() INT i i=1 REPEAT END
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Prog() INT i i=1 REPEAT i=i+1 UNTIL i>100 END


Unvollständige Anweisung

Ursache: | Die Schnittstelle zum SBC ist nicht initialisiert.
Auswirkung: | Keine.
Abhilfe: | Schnittstelle zum SBC initialisieren.


Unzulässige Betriebsart

Ursache:

  • Die Taste "Start rückwärts" wurde in der Betriebsart AUT oder EXT betätigt.

  • Der Benutzer aktiviert Handverfahren in AUT oder EXT.

Auswirkung:

Unzulässige Betriebsart
Zulässig ist nur T1 oder T2.

Abhilfe:

In die Betriebsart T1 oder T2 wechseln.


Unzulässige Pfadangabe

Ursache: | "Jokerzeichen" in der Pfadangabe beim Kopieren über SINEC H1.
Abhilfe: | Nur einzelnes Objekt kopieren.


Unzulässiger Fern-Start durch <Machine name / IP address> (kein Master)

Ursache:

Die lokale Steuerung hat eine Start-Aufforderung von einer Steuerung erhalten, ohne dass zu diesem Zeitpunkt eine geometrische Kopplung aktiv war.

Auswirkung:

Keine

Abhilfe:

  • Dieser Zustand besteht aufgrund eines internen Fehlers des Systems.

  • Wenden Sie sich bitte an den KUKA-Kundendienst.


Unzulässiger Name - der Arbeitsbereichsname existiert bereits

Ursache: | Der Arbeitsbereichsname existiert bereits.
Abhilfe: | Der Name kann nicht verwendet werden. Wählen Sie einen anderen eindeutigen Namen.


Unzulässiger oder nicht bekannter Satz

Ursache: | Compiler kann Programmzeile nicht verarbeiten. Beispielsweise die Zuweisung zweier Enumkonstanten: #Otto=#Emil oder Einfügen von Programm-Code ins DAT-File. Die Ursache kann auch ein Schreibfehler sein.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Unzulässiger Parameterwert

Ursache: | Der Maximalwert eines Kanalparameters wurde überschritten.
Abhilfe: | Kanalparameter berichtigen.


Unzulässiges Kommando

Ursache: | Das Kommando ist nicht zulässig.
Abhilfe: | Kommando entsprechend ändern.


USER, ACCESS oder COMMENT erwartet

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


User-, Geräte- oder Knotentypnamen erwartet

Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm ändern.


VAR erwartet

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern


Variable mit Strukturtyp erwartet

Abhilfe:

Programm entsprechend ändern.


Variable nicht in Datenliste deklariert

Abhilfe:

Programm entsprechend ändern.


Variable oder Feldelement erwartet

Ursache: | An einer Stelle, an der entweder eine Variable oder ein Feldelement erwartet werden, steht ein unzulässiger Ausdruck. Beispiel: ANOUT ON Draht = .5 * 1
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: ANOUT ON Draht = .5 * RFaktor ; wobei "RFaktor" eine REAL-Variable aus dem zugehörigen DAT-File darstellt.


Variable zu groß

Ursache: | Die in "SHOW VAR" oder "SET INFO" angegebene Variable ist zu komplex oder zu groß (z.B. Feld ist größer als das Anzeigebild).
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Anforderung in mehrere Abschnitte aufteilen.


Variablenname darf nicht geändert werden

Ursache: | Unzulässige Änderung des Namens der Variablen.
Abhilfe: | Änderung rückgängig machen.


Der Verriegelungsbereich <ws name> ist nicht durch ein anderes Programm blockiert

Ursache: | Ein Programm adressierte einen 'EXITSPACE'-Befehl an einen Arbeitsbereich, welcher nicht zu dieser Steuerung gehörte.
Auswirkung: | Keine
Abhilfe: | Falls der Arbeitsbereich nicht angefordert wurde, den ungültigen 'EXITSPACE'-Befehl aus dem Programm entfernen.


Verwendung von Laufzeitdaten des Hauptprogramms nicht erlaubt

Ursache: | In einem Unterprogramm können nicht die Laufzeitvariablen des Hauptprogramms verwendet werden, auch wenn beide Programme in einem SRC-File vereinbart wurden. Beispiel: DEF P() INT x x=1 END DEF P2() x=2 END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DEF P() INT x x=1 END DEF P2() INT x x=2 END


Verwendung von Laufzeitdaten nicht zulässig

Ursache: | Es dürfen keine Laufzeitdaten verwendet werden. Beispiel: DEF P() DECL INT xxx xxx = 1 INTERRUPT DECL 10 WHEN TRUE DO Up(xxx) ... END
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Statt Laufzeitvariablen permanente Variablen aus einem DAT-File verwenden. Beispiel: DEFDAT P DECL INT xxx = 1 ENDDATDEF P() INTERRUPT DECL 10 WHEN TRUE DO Up(xxx) ... END


Vordefiniertes Signal darf nicht geändert werden

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Vordefinierter Kanalname erwartet

Ursache: | Es sind nur die vordefinierten Schnittstellennamen "SER_1" oder "SER_2" zulässig.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Vordefiniertes Signal erwartet

Ursache: | Es wird ein im System vordefinierter Signalname erwartet, gefunden wurde ein unbekannter Name. Beispiel: SIGNAL $DIGIN1 $xyz[20] TO $IN[29]
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: SIGNAL $DIGIN1 $IN[20] TO $IN[29]


Vorgegebener Typ ist kein Aufzählungsdatentyp

Ursache: | Es wurde versucht, eine Enum-Konstante an eine Variable zuzuweisen, die keine Enum-Variable ist. Beispiel: INT i ENUM Erna e1,e2,e3 i=#e1
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: ENUM Erna e1,e2,e3 DECL Erna RealErna RealErna=#e1


Vorzeichen unzulässig

Ursache: | An dieser Stelle ist kein Vorzeichen zulässig.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Werkzeuggewicht wurde noch nicht gelernt

Ursache: | Bei der EMT-Justage wurde eine Checkfahrt für ein Werkzeug durchgeführt, dessen Gewicht noch nicht "gelernt" wurde.
Abhilfe: | Werkzeuggewicht "lernen".


Wert fehlt

Ursache: | Es wurde kein Wert angegeben.
Abhilfe: | Wert angeben.


Wert für PRIO nicht zulässig

Ursache: | Der angegebene Wert für die Priorität liegt außerhalb des zulässigen Bereichs. Beispiel: INTERRUPT ON 522
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: INTERRUPT ON 22


Wert nicht änderbar bei angewähltem Programm

Ursache: | Der Wert kann bei angewähltem Programm nicht geändert werden.
Abhilfe: | Programm abwählen.


<Wert> unzulässig

Ursache: | Eingabe eines nicht zulässigen Wertes.
Abhilfe: | Zulässigen Wert eingeben.


Wertebereich für <Pfadangabe> <Achsnummer> überschritten

Ursache:

32-Bit-Wort wird überschritten.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm entsprechend ändern.


WHEN erwartet

Ursache: | Bei der Interrupt- oder Triggerdeklaration wurde das Schlüsselwort WHEN vergessen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


WITH Option außerhalb von Spline verboten

Ursache: | Es wurde eine WITH Option außerhalb eines Spline Blockes programmiert.
Auswirkung: | Syntaxfehler im Modul
Abhilfe: | Programm entsprechend ändern.


Workspace Sharing Versionskonflikt (<Message version number>) in Meldung von <Controller name or IP Address>

Ursache: | Die Version der Arbeitsbereichsverwaltungsnachricht, welche von einer anderen Steuerung empfangen wurde, wird nicht von der lokalen Steuerung unterstützt.
Auswirkung: | Diese Nachricht wird nicht verarbeitet.
Abhilfe: | Sicherstellen, dass auf den betroffenen Steuerungen die gleiche Version der KRC-Software installiert ist.


Zahl zu groß

Ursache: | Einer Variable wurde eine Zahl zugewiesen, die den Wertebereich überschreitet.
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Zahl zu klein

Ursache: | Der Zahlenwert ist zu klein.
Abhilfe: | Programm entsprechend ändern.


Zeichen- oder ganzzahlige Konstante erwartet

Ursache: | Es wird ein einzelnes Zeichen (keine Zeichenkette) oder eine ganzzahlige Konstante erwartet.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


".." erwartet

Ursache: | Die angegebene Zeichenfolge ".." wurde vergessen oder steht an falscher Stelle. Beispiel: IMPORT INT Otto_2 IS /R1/PROG_1 Otto
Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: IMPORT INT Otto_2 IS /R1/PROG_1..Otto


Zeichenkette erwartet

Ursache: | In der Programmzeile wird eine Zeichenkette erwartet.
Auswirkung: | Das Programm kann nicht ausgeführt werden.
Abhilfe: | Programm entsprechend ändern.


Zeichenkettenkonstante zu lang

Ursache: | Die zugewiesene Zeichenkettenkonstante ist für die betreffende Variable zu lang. Beispiel: STRUC Otto CHAR a DECL Otto Hugo = {a "abcde"}
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: STRUC Otto CHAR a DECL Otto Hugo = {a "a"}


Zeile <Zeilennummer> in <Modulname> zu lang. Zeile wurde abgeschnitten

Ursache: | Eine zu lange Programmzeile wurde abgeschnitten, um den Verlust des restlichen Programminhalts zu vermeiden.
Auswirkung: | Zeile wird abgeschnitten. Die Programmdatei bleibt erhalten.
Abhilfe: | Fehlerhafte Zeile im Expertenmodus entsprechend korrigieren.


Zeitgebersynchronisation nicht initialisiert

Ursache:

Es wurde versucht, den Zeitgebersynchronisationsstatus zu verändern, bevor dieses Modul initialisiert wurde.

Auswirkung:

Die gewünschte Änderung des Zeitgebersynchronisierungsstatus kann nicht durchgeführt werden.

Abhilfe:

  • Stellen Sie sicher, dass die Zeitgebersynchronisierung als aktive Komponente des Tech-Paketes installiert wurde.

  • Falls nicht, wird die Zeitgebersynchronisierung nicht initialisiert.

  • Falls sie korrekt installiert wurde, starten Sie die Steuerung neu, um ein erneutes Initialisieren zu versuchen.


Zielpunkt nicht erreicht

Ursache: | Bei Satzanwahl auf einen CIRC-Satz mit Kreiswinkel kann die Kontur nicht ermittelt werden. Es wird bei Start ein LIN auf den programmierten Zielpunkt durchgeführt.
Auswirkung: | Die nächste Bewegung ist ebenfalls eine SAK-Fahrt.
Abhilfe: | Keine


Zielvariable ist nicht vom Typ REAL

Ursache: | Falscher Datentyp einer Zielvariablen oder falsches Format in einer CREAD- oder SREAD-Anweisung.
Abhilfe: | CREAD- bzw. SREAD-Anweisung korrigieren: – Formatangabe ändern oder – Variable vom Typ REAL verwenden.


Zu dieser Marke liegt ein falscher Sprung vor

Auswirkung: | Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Zu viele Objekte angewählt

Ursache: | Es wurden zu viele Objekte angewählt.
 | Zulässige Anzahl angewählter Objekte: ca. 150
Auswirkung: | Kommando wird nicht ausgeführt.
Abhilfe: | Anzahl der Objekte auf die maximal zulässige Zahl reduzieren.


Zugehöriger END-Satz fehlt

Ursache: | Ein Programmteil wurde nicht mit dem "END" Schlüsselwort abgeschlossen.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern. Beispiel: DEF Up() ... END


Zusammengesetzte Analogsignale nicht zulässig

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Zusammengesetztes OUT_C-Signal nicht erlaubt

Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Zusammengesetztes Signal breiter als 32 Bit

Ursache: | Es dürfen maximal 32 Ein- oder Ausgänge zu einem Signal zusammengefasst werden. Beispiel: SIGNAL $DIGIN1 $IN[200] TO $IN[232] (entspricht 33 Eingänge)
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: SIGNAL $DIGIN1 $IN[200] TO $IN[231]


Zustimmschalter erforderlich

Ursache: | Der Zustimmungsschalter wurde nicht gedrückt.
 | In der Betriebsart T1 oder T2 muss beim Betätigen der Starttasten (Vorwärts [+] sowie Rückwärts [–]) oder einer Richtungstaste zusätzlich einer der Zustimmungsschalter an der Rückseite des KCP betätigt werden.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Zustimmungsschalter betätigen.


Zuweisung an Konstante unzulässig

Ursache: | Es wurde versucht, einer Konstanten einen Wert zuzuweisen. Beispiel: DAT-File: DECL CONST INT Lasse SRC-File: Lasse = 5
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern. Beispiel: DAT-File: DECL CONST INT Lasse = 5


Zuweisung von Funktionswert an $CYCFLAG nicht erlaubt

Ursache:

Rückgabewert einer BOOL-Funktion wurde direkt einem $CYCFLAG zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Zuweisung von Laufzeitdaten an $CYCFLAG nicht erlaubt

Ursache:

Einem $CYCFLAG wurden lokale Laufzeitdaten zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm ändern (nur globale Variablen verwenden!).

  • Meldung quittieren.


$FILTER Konflikt: Lokal=<Local machine $FILTER>; Verbundenes System=<Remote machine $FILTER>

Ursache: | Geometrische Kopplung ist nur zwischen Steuerungen möglich, die den gleichen $FILTER-Wert realisieren.
Auswirkung: | Programmausführung wird unterbrochen.
Abhilfe: | $FILTER-Wert entsprechend anpassen, so dass er auf allen beteiligten Steuerungen gleich ist.


<$Variable> Wert ungültig

Ursache:

Lesezugriff auf eine Variable, die nicht initialisiert ist oder keinen gültigen Wert hat, z.B. Lesen von "$POS_INT" außerhalb eines Unterbrechungsprogrammes.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


$BWDSTART nicht programmiert: keine Tool und Base Info gefunden

Ursache:

Rückwärtsfahren mit SCAN-Methode: als erste Anweisung in einem Bewegungsfold muss eine $BWDSTART-Zuweisung programmiert sein. Ab dieser Zeile werden alle folgenden Anweisungen bis zur Bewegung ausgeführt, bevor rückwärtsgefahren wird.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm korrigieren.

  • oder in BACKWARD.INI die folgende Zeile einfügen: BACKWARDSTART = FALSE

In diesem Fall werden BASE- und TOOL-Wechsel während des Rückwärtsfahrens nicht berücksichtigt!


$OUT_C[n] ist nicht erlaubt im Submitbaustein

Ursache:

$OUT_C[n] wurde in einem Submitprogramm verwendet.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Submitprogramm entsprechend ändern.


$OUT_C[n] ist nicht erlaubt in Interruptprogrammen

Ursache:

$OUT_C[n] wurde in Interruptprogramm benutzt.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Interruptprogramm entsprechend ändern.

  • Meldung quittieren.


<$ Variable> Variable schreibgeschützt

Ursache:

Schreibender Zugriff auf schreibgeschützte Variable, z.B. "$POS_ACT".

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Abgeschlossenes UP: Bewegungen werden übersprungen

Ursache:

Während des Rückwärtsfahrens stieß der Interpreter auf ein bereits vollständig abgearbeitetes Unterprogramm.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Absolutgenauer Roboter: Punktkonvertierung nur im T1-Betrieb möglich

Ursache:

"$ABS_CONVERT" = TRUE, aber kein T1-Betrieb.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Variable "$ABS_CONVERT" in der Datei "$CUSTOM.DAT" auf FALSE setzen oder T1-Betrieb wählen.

  • Meldung quittieren.


Absolut Modell Parameter Update <Fehlertext>

Ursache:

Fehler bei der Datenübertragung nach $abs_update = true


Achsbeschleunigung nicht programmiert <Achsnummer>

Ursache:

Dem Programmdatum "$ACC_AXIS" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Die angewählte Achse kann nicht justiert werden

Ursache:

Die angewählte zu justierende Achse ist inaktiv.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Nur aktive Achse justieren.


Achsgeschwindigkeit nicht programmiert <Achsnummer>

Ursache:

Dem Programmdatum "$VEL_AXIS" wurde kein Wert zugewiesen. Der Fehler tritt auf, wenn ein Bewegungsbefehl vor dem INI-Folder steht.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Achskopplungsanteil unzulässig <Achsnummer>

Ursache:

Es wurde versucht, eine "erweiterte Störjustage" für eine Achse durchzuführen, wobei sich die koppelnden Achsen nicht in der Stellung zum Zeitpunkt der Datenübernahme befanden.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

  • Die Funktion "erweiterte Störjustage" wird nicht ausgeführt.

Abhilfe:

Koppelnde Achsen in die gleiche Stellung bringen, wie bei der Datenübernahme.


Achtung! Maximale Geschwindigkeit könnte programmiert sein

Ursache: | Wechsel der Betriebsart auf T2 oder AUT
Auswirkung: | Aktuelle Kommandos verriegelt
Abhilfe: | Meldung quittieren


Quitt Akkuspannung für Pufferung zu niedrig <Powermodul Nummer>

Ursache: | Der Akku wurde ausgetauscht.
Abhilfe: | Quittieren der Meldung mittels Softkey »Quitt«.


<Dateiformat>: Aktuelle Position und Startposition <Recordname> nicht identisch

Ursache: | Roboter befindet sich in falscher Position.
Auswirkung: | Der Roboter wird gestoppt.
Abhilfe: | Bewegen Sie den Roboter zur Startposition für die Aufzeichnung.


Anweisung unzulässig

Ursache:

  • Programmanweisung, die nicht als Kommando zulässig ist;

  • Programmanweisung, die nur in einem Interrupt-Programm zulässig ist.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Bei Programmbearbeitung Meldung quittieren.


Der Arbeitsbereich hat sich geändert. (Programm-Update erforderlich)

Ursache:

  • Der "ENTERSPACE"- oder "EXITSPACE"-Befehl bezieht sich auf einen Arbeitsbereich, dessen Definition sich geändert hat.

  • Der Arbeitsbereich wurde möglicherweise entfernt oder umbenannt.

Auswirkung:

Die Arbeitsbereichsanforderung schlägt fehl.

Abhilfe:

Arbeitsbereichsdefinitionen oder Programm korrigieren, um einen definierten Arbeitsbereich anzufordern.


Der Arbeitsbereich <workspace> wird durch <manager name/ip address> gehandhabt

Ursache: | Mehrere Steuerungen sind für diesen Arbeitsbereich als Manager (Verwalter) des Arbeitsbereiches eingetragen.
Auswirkung: | Es ist nur ein Manager für einen Arbeitsbereich zulässig.
Abhilfe: | Es muss ein eindeutiger Manager für den Arbeitsbereich innerhalb der Zelle konfiguriert werden.


Der angefragte Arbeitsbereich wird nicht von der konfig. Steuerung verwaltet

Ursache:

Der konfigurierte Manager für den Arbeitsbereich ist nicht korrekt.

Auswirkung:

  • ENTERSPACE fehlgeschlagen.

  • Das Programm muss abgewählt werden.

Abhilfe:

Der korrekte Manager für den Arbeitsbereich muss eingetragen werden.


Arbeitsbereichanfrage für '<ws_name>' fehlgeschlagen

Ursache:

Die Arbeitsbereichsanfrage durch das KRL-Programm ist fehlgeschlagen.
Hierfür können verschiedene Ursachen vorliegen (Fehlverbindung, nicht vorhandener Arbeitsraum, etc.)

Auswirkung:

Die Programmausführung wird gestoppt.

Abhilfe:

  • Meldung quittieren;

  • Starttaste betätigen, um eine neue Anfrage zu starten.


Arbeitsraumfehler

Ursache:

Die Arbeitsfeldbegrenzung wurde überschritten.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Auslenkung im Startpunkt

Ursache:

Eine PTP-Bewegung soll mit einem Sensor-Korrekturwert abgefahren werden.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Der Sensor-Offset muss vor dem Abfahren eines PTP-Satzes abgebaut werden.


Auslenkung im Zielpunkt

Ursache:

Ein Genauhaltepunkt wurde mit Auslenkung angefahren.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Wert "SCALE_IN" korrigieren.


Azyklische Daten vom TEPRO nicht freigegeben

Ursache:

Eine Samaphore verriegelt den Zugriff auf azyklische Daten.
(TEPRO = Technologieprozess)

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

Fehler im SBC-Programm beseitigen.


Bahnbeschleunigung nicht programmiert

Ursache:

Dem Programmdatum "$ACC.CP" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Bahngeschwindigkeit nicht programmiert

Ursache:

Dem Programmdatum "$VEL.CP" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


<X,Y,Z,A,B,C> BASE nicht programmiert

Ursache:

Dem Programmdatum "$BASE" wurde kein Wert zugewiesen:- in einem Anwender-Programm.

  • nach Urlöschen der Steuerung für ein kartesisches Kommando.

Abfrage erfolgt bei kartesischen Bewegungen.

Auswirkung:

  • Bei Kommandobearbeitung: Kommando wird nicht bearbeitet.

  • Bei Programmbearbeitung: Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Bei Kommandobearbeitung: "$BASE" einen Wert zuweisen.

  • Bei Programmbearbeitung: Programm entsprechend ändern.

  • Meldung quittieren.


BASE-Änderung unzulässig

Ursache:

Während des Conveyorbetriebs wurde versucht, das BASE zu ändern.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm entsprechend korrigieren.


Bewegungskooperationspacket nicht installiert

Ursache: | Eine Bewegungskooperationsfunktion wurde gestartet, das Softwarepaket ist jedoch nicht installiert.
Abhilfe: | Bitte installieren Sie das Bewegungskooperationspacket.


Bewegungssynchronisation kann nicht aufrecht erhalten werden

Ursache:

Während einer zeitsynchronen Bewegung ist die Synchronisation mit der Master-Steuerung infolge von Kommunikationsproblemen verlorengegangen.

Auswirkung:

Programmausführung wird unterbrochen.

Abhilfe:

  • Setzen Sie das Programm zurück oder führen Sie auf allen beteiligten Steuerungen eine Satzanwahl auf den synchronen Satz durch.

  • Falls das Problem wiederholt auftritt, so melden Sie den Sachverhalt bitte an Ihren KUKA-Ansprechpartner.


Bremsen während Justage-Anwahl offen

Ursache:

Von vorhergehender Verfahraktion ist noch eine Bremse offen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Warten, bis alle Bremsen geschlossen sind und die Reglerfreigabe gesperrt ist.


KCP: CAN bus Fehler

Ursache: | Übertragungsfehler im CAN-Bus PHG-Task.
Auswirkung: | Bahntreuer Stop.
Abhilfe: | Meldung quittieren.


CIRC wird als LIN gefahren

Ursache:

Eine CIRC-Bewegung soll als SAK-Fahrt ausgeführt werden.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Nach dem Start wird CIRC als LIN-Bewegung gefahren.


Datenaustausch vom TEPRO fehlt

Ursache:

Der SBC sendet zyklische Daten zu spät. (TEPRO = Technologieprozess)

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

  • SBC-Programm neu initialisieren.

  • Fehler im SBC-Programm beheben.

  • Meldung quittieren.


Datenaustausch zum TEPRO fehlerhaft

Ursache:

Der SBC holt zyklische Daten zu spät ab.
(TEPRO = Technologieprozess)

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

  • SBC Programm neu initialisieren.

  • Meldung quittieren.


Datenaustausch

Ursache:

SBC stoppt Datenaustausch wegen Fehler.

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

Fehler im SBC-Programm beseitigen.


Datenübernahme durchführen <Achsnummer>

Ursache:

Es wurde versucht, eine Störjustage für eine Achse vorzunehmen, für die noch keine Übernahmefahrt durchgeführt wurde.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Übernahmefahrt für die entsprechende Achse durchführen.


Datenübernahme unzulässig <Achsnummer>

Ursache:

Es wurde versucht, eine Übernahmefahrt für eine Achse vorzunehmen, die nicht mit KTL-Geber und DSE ausgestattet ist.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Mit RECALL abbrechen.


deadlock gefunden; das lokale Programm wartet auf '<WorkspaceName>' aus Programm '<RemoteProgram>' (<RemoteKrc>)

Ursache: | Das Programm wartet auf einen Arbeitsbereich, welcher nie freigegeben wird. Es besteht eine Kreisabhängigkeit unter den Arbeitsbereichen.
Auswirkung: | Das Programm kann nicht weiter ausgeführt werden.
Abhilfe: | Kreisabhängigkeit der Arbeitsbereiche beseitigen und das Programm neu starten.


Digitaleingang bereits belegt

Ursache:

Im Programm wird ein Digitaleingang zum zweiten Mal zyklisch eingeschaltet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Den zyklischen Digitaleingang vorher ausschalten.


Division durch 0

Ursache:

Ein Wert soll durch "0" dividiert werden.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm korrigieren.

  • Meldung quittieren.


Doppelte aktive Synchronisierung ID (<Zeichenkette ID der Sync>).

Ursache: | Das KRL-Programm gab einen Programm- oder Bewegungs-Synchronisierungsbefehl mit der gleichen Identifikation einer anderen Programm- oder Bewegungssynchronisierung aus. Dies kann beispielsweise bei den Befehlen "NOWAIT", "SYNCS"... geschehen oder während das Roboterprogramm auf einen Synchronisierungsbefehl wartet und ein weiterer Synchronisierungsbefehl mit gleicher Identifikation auftritt.
Auswirkung: | Befehl wird nicht ausgeführt.
Abhilfe: | Weisen Sie jedem Programm- oder Bewegungs-Synchronisierungsbefehl eine eindeutige Identifikation zu.


Drehzahl-Stopp ausgelöst

Ursache: | Wenn bei einem ausgelösten NOT-AUS ein Fehler auftritt, der nur einen Drehzahl Stopp zulässt, wird diese Meldung zusätzlich ausgegeben.
Auswirkung: | Drehzahl Stopp.
Abhilfe: | Diese Meldung quittieren.


Druckfehler Klebstoff

Ursache:

  • Der Ausgangsdruck des Klebers wird während des Dosierens laufend durch die PLC überwacht. Dabei lag der Druckwert außerhalb des zulässigen Toleranzbereichs.

  • Evtl. befinden sich Luftblasen in der Klebstoffzuführung oder die Auslaufdüse ist verstopft.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Überprüfen der Klebehardware, evtl. Spülen.


Druckluft Gesamtanlage

Ursache:

In der Luftzuführung steht nicht der nötige Druck für die Pneumatikventile zur Verfügung.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Versorgung mit ausreichendem Luftdruck sicher stellen.


Ebenenüberlauf <IP,PCP>

Ursache:

Rechenzeit-Überlastung der CPU.
Zyklisch

Auswirkung:

  • Generatorischer Stop.

  • Ausgang "$ALARM_STOP" hat Signalpegel "0".

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Grundtakt erhöhen.

  • Interpolationstakt oder Lageregeltakt erhöhen (abhängig vom gemeldeten Parameter).


Eine oder mehrere Steuerungen werden im Automatikmodus simuliert

Ursache: | Globale Simulation der SYNCCMD Kommandos wurde für eine oder mehrere Steuerungen aktiviert. Betriebsart wurde von T1/T2 nach AUT/EXT geschaltet.
Auswirkung: | Lokale SYNCCMD Kommandos wirken stets so, als hätte die betroffene Steuerung den Synchronisationspunkt als erste erreicht.
Abhilfe: | Deaktivierung im Dialog "Cell Map Simulation".


Endskip Nummer '<Fehlende Skipnummer am Ende>' fehlt

Ursache: | Eine Sprungadresse endet nicht mit der entsprechenden Endskip Nummer am Programmende.
Auswirkung: | Anzeige des Programmfehlers.
Abhilfe: | Programm entsprechend korrigieren.


Arbeitsbereich Enter/Exit im Trigger nicht erlaubt

Ursache: | Eine Arbeitsbereichsanfrage mit Trigger wurde ausgegeben.
Auswirkung: | Der Befehl wird nicht ausgeführt.
Abhilfe: | Programm entsprechend ändern.


Erstjustage durchführen <Achsnummer>

Ursache:

Es wurde versucht, eine Übernahmefahrt für eine Achse vorzunehmen, für die noch keine Erstjustage durchgeführt worden ist.

Auswirkung:

  • Rampen Stop

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Erstjustage (UHR- oder EMT-Justage) für die entsprechende Achse durchführen.


$CP_STATMON: Falscher Achswinkel

Ursache: | Ein erreichter Achswinkel unterscheidet sich vom programmierten Achswinkel.
Auswirkung: | Nach Satzanwahl innerhalb einer Reihe von CP Punkten kann es vorkommen, dass ein anderer Achswinkel als der programmierte eine komplette Verdrehung der Roboterhand zur Folge hat (Risiko der Beschädigung installierter Versorgungsleitungen). Ebenso kann beim folgenden Satz der Software-Endschalter angefahren werden. Bei einem darauffolgenden PTP-Satz besteht die Gefahr, dass sich die Verfahrbahn komplett gegenüber der ursprünglichen Bahn ändert.
Abhilfe: | Diesen Genauhaltpunkt nochmals teachen. Evtl. SAK-Fahrt mit anderen Achswinkeln wiederholen.


Falsche Anfangsposition

Ursache:

  • EMT-Justage beginnt nicht vor, sondern in der Kerbe.

  • Kabel für EMT-Justage steckt bei "Übernahmefahrt" oder "Störjustage".

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Die zu justierende Achse in die richtige Startposition bringen.

  • Das gegebenenfalls falsch gesteckte Kabel für die EMT-Justage muss gezogen werden.


Falscher Datentyp vom TEPRO

Ursache:

SBC sendet zyklisch falsche Daten.
(TEPRO = Technologieprozess)

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

Fehler im SBC-Programm beseitigen.


Fehler am KTL-Messtaster

Ursache:

Taster bringt Null-Signal.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Schraubverbindung am Taster prüfen.

  • Verbindung des EMT am Roboter prüfen.

  • A3/DSE-Baugruppe kontrollieren.


Fehler Bauteilkontrolle

Ursache:

Bauteil aus der Spannvorrichtung gelöst oder beschädigt.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).
Bei der Applikation Scheibenkleben wird die Klebedüse auf die Scheibe aufgedrückt. Fehlt dieser Druck während des Klebens, hat sich die Scheibe aus der Spannvorrichtung gelöst oder ist evtl. beschädigt.
In diesem Fall muss sofort die Roboterbewegung gestoppt und der Klebstoffauftrag abgebrochen werden!

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Not Stop.

Abhilfe:

Bauteil überprüfen.


<Dateiformat>: Fehler bei Ausführung der Bewegung <Recordname>

Ursache: | Während der Ausführung der Bewegung trat ein treiberspezifischer Fehler auf.
Auswirkung: | Die Aufzeichnung wird gestoppt.
Abhilfe: | Setzen Sie sich mit dem Service der Fa. KUKA in Verbindung.


<Dateiformat>: Fehler beim Restaurieren von Variablen für Aufzeichnung <Recordname>

Ursache: | Fehler im I/O-System.
Auswirkung: | Der Roboter wird gestoppt.
Abhilfe: | Überprüfen Sie das I/O-System.


<Dateiformat>: Fehler beim Start der Bewegung <Recordname>

Ursache:

  • Die Startposition ist nicht korrekt.

  • Die Ausgangsvariable kann nicht geschrieben werden.

Auswirkung:

Die Bewegung wird nicht ausgeführt.

Abhilfe:

  • Prüfen des Record-Files

  • Prüfen des I/O-Systems


Fehler in UPCALL Token

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.


Fehler SBC : <Watchd.,Transf.,Korr>

Ursache:

Fehler bei der Kommunikation zwischen SBC und KRC32.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Hardware und Software der SBC überprüfen.


Fehler XROB Custom Modell ohne Option Absolutgenauigkeit aktiviert

Ursache: | $ABS_ACCUR == false
Auswirkung: | Lader wird abgebrochen.
Abhilfe: | Option "$ABS_ACCUR" auf TRUE setzen.


Funktionswert nicht definiert

Ursache:

Im Funktionsbaustein fehlt RETURN-Anweisung.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

RETURN-Anweisung einfügen.


Geometrische Kopplung am Programmende aufheben

Ursache: | Die geometrische Kopplung muss vor dem regulären Programmende aufgehoben werden.
Auswirkung: | Normaler Roboter-Stopp.
Abhilfe: | Fügen Sie eine Bewegung auf einem lokalen Bezugssystem vor dem Programmende ein. Beispiel: PTP HOME.


Geschwindigkeit beim Momentenbetrieb überschritten <Achsnummer>

Ursache:

Die zulässige Geschwindigkeit wurde beim Momentenbetrieb überschritten.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Geschwindigkeit entsprechend reduzieren.


Haltemoment Bremse <Achsnummer> überschritten

Ursache:

Das Bremsenhaltemoment an der Achse reicht nicht aus, um den Roboterarm an einem beliebigen Punkt im Raum dauerhaft zu halten.

Auswirkung:

Interpreter Stopp

Abhilfe:

  • Lastdaten überprüfen.

  • Last reduzieren.

  • Meldung quittieren.


Haltemoment Motor <Achsnummer> überschritten

Ursache:

Das Motorhaltemoment reicht nicht aus, um den Roboterarm an einem beliebigen Punkt im Raum dauerhaft zu halten.

Auswirkung:

Interpreter Stopp

Abhilfe:

  • Lastdaten überprüfen.

  • Last reduzieren.

  • Meldung quittieren.


Hilfspunkt gleich Zielpunkt

Ursache:

Der Abstand vom Hilfspunkt zum Zielpunkt ist zu gering.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aktiver Kommandos.

Abhilfe:

  • Zielpunkt bzw. Hilfspunkt neu programmieren.

  • Meldung quittieren.


IBGN Anfang '<IBGN Nummer>' fehlt

Ursache: | "IBGN"-Anfang mit der angegebenen Nummer ist nicht vorhanden.
Auswirkung: | Ausführung nicht möglich.
Abhilfe: | Programm entsprechend ändern.


IBGN dürfen nicht verschachtelt werden

Ursache: | "IBGN"-Anweisungen wurden verschachtelt programmiert.
Auswirkung: | Ausführung nicht möglich.
Abhilfe: | Programm entsprechend ändern.


IBGN Ende '<IBGN Nummer>' fehlt

Ursache: | Es wurde ein "IBGN"-Anfang ohne entsprechendes "IBGN"-Ende programmiert.
Auswirkung: | Ausführung nicht möglich.
Abhilfe: | Programm entsprechend ändern.


IBGN '<IBGN Nummer>' wird bereits verwendet

Ursache: | Doppelte Verwendung einer IBGN Nummer
Auswirkung: | Ausführung nicht möglich.
Abhilfe: | Programm entsprechend ändern.


Ignoriertes Stoppkommando

Ursache:

Achse kam nach einer Stopp-Anweisung nicht innerhalb einer bestimmten Zeitspanne zum Stehen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Messung wiederholen.

  • Meldung quittieren.


Inbetriebnahme anwählen

Ursache:

Es wurde ein Kommando eingegeben, das nur im Inbetriebnahme-Modus zulässig ist.

Auswirkung:

Kommando wird nicht ausgeführt.

Abhilfe:

  • Inbetriebnahme-Modus anwählen.

  • Meldung quittieren.


Initialisierung löschen?

Ursache: | Abfrage, ob Initialisierung gelöscht werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


Interner Compilerfehler <Objektname>

Ursache:

Ein Fehler im Compiler ist aufgetreten.

Auswirkung:

Das Programm ist nicht ausführbar.

Abhilfe:

  • Steuerung neu booten.

  • Eventuell Programm ändern.


Interner Fehler in der PTP-Bahnplanung <Nummer>

Ursache: | Fehler in der Planung des PTP-Fahrprofils.
Auswirkung: | Interpreter Stop.
Abhilfe: | Profildaten modifizieren (Rundungsfaktor, Geschwindigkeit, Beschleunigung).


Interner Fehler <Systemfehlernummer> (<Task-Id>, <Status>)

Ursache: | Interner Test der KRC - Software.
Auswirkung: | RC-READY wurde bei Bearbeitung zurückgenommen; Auslösung eines Warmstarts.
Abhilfe: | Meldung quittieren.


Interner Systemfehler mutual exclusion

Ursache: | Ein Softwareproblem in Zusammenhang mit der Arbeitsbereichsverwaltung ist aufgetreten.
Auswirkung: | Das Programm wird nicht korrekt ausgeführt.
Abhilfe: | Teilen Sie dieses Problem dem KUKA-Kundendienst mit.


Interrupt mit Prio <aktuelle Priorität> bereits aktiv und in <SRC-Dateiname> Zeile <Zeilennummer> definiert

Ursache:

  • Eine Interrupt-Deklaration versucht, einen Interrupt zu überschreiben, der gerade aktiv ist. Dies hätte zur Folge, dass der bereits aktive Interrupt gelöscht wird. Der neu zu deklarierende Interrupt würde zwar definiert werden, kann aber aufgrund der gleichen Priorität wie der gerade aktive Interrupt nicht wirksam werden.

  • Beim Verlassen des aktuellen Unterprogrammes wird der neu definierte Interrupt gelöscht.

Auswirkung:

  • Roboterprogramm stoppt.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern, z.B. andere Priorität für den neuen Interrupt wählen.

  • Meldung quittieren.


<Interrupt> nicht definiert.

Ursache:

Ein nicht definierter Interrupt oder Trigger wurde manipuliert.

Die Abfrage erfolgt bei der Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Interrupt deklarieren.

  • Meldung quittieren.


Interruptanweisung abgebrochen

Ursache:

Bewegungsanweisung in einem Interruptprogramm, welches nach einem Fehler-Stopp abgearbeitet wird.

Im Interruptbaustein, der nach Fehler-Stopp aufgerufen wird, dürfen keine Bewegungsanweisungen stehen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Interruptbaustein entsprechend umprogrammieren.

  • Meldung quittieren.


Interruptkomplexität Überschritten

Ursache:

Auf Steuerungsebene und Roboterebene wurden insgesamt mehr als 16 "langsame" Variablen in den logischen Ausdrücken der INTERRUPT DECL-Anweisungen verwendet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Weniger vordefinierte Variablen verwenden. Eventuell logische Ausdrücke mit CYCFLAGS zusammenfassen.


Interrupt-UP: max. 10 Argumente zulässig

Ursache:

Es wurden mehr als 10 Argumente angegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Anzahl der Argumente auf die maximal zulässige Zahl reduzieren.


Justagefahrt unzulässig <Achsnummer>

Ursache:

  • Es wurde versucht, eine "Störjustage" durchzuführen, oder

  • die Achse ist nicht mit KTL-Geber und DSE ausgestattet.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Mit "RECALL" abbrechen, oder

  • Achse mit EMT/UHR justieren.


Kann nicht ohne gemeinsam verwendetes KCP zu <Master name or IP address> verbinden

Ursache: | Verbindungen sind nur zwischen Steuerungen erlaubt, die ein gemeinsames KCP verwenden.
Auswirkung: | Programm wird nicht ausgeführt.
Abhilfe: | Konfigurieren Sie das gemeinsame KCP so, dass die unabhängige sowie die abhängige Maschine das gleiche gemeinsame KCP verwenden.


Kartesische Maximalbeschleunigung überschritten

Ursache:

Die kartesische Maximalbeschleunigung wurde überschritten.
$ACC_CAR_STOP=TRUE und $ACC_CAR_ACT übersteigt $ACC_CAR_LIMIT.

Auswirkung:

  • Bahntreuer Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Entsprechende Änderung des Programms, um innerhalb der zulässigen Beschleunigung zu bleiben.
Alternativ kann der Wert für die Beschleunigung ($ACC_CAR_LIMIT) erhöht oder die Überwachung der Beschleunigung deaktiviert ($ACC_CAR_ACT=FALSE) werden.


Kartesische Zielpunktangabe nicht möglich

Ursache:

Eine PTP-Bewegung wurde mit kartesischer Zielpunktangabe programmiert.

Beim 5-Achs-Roboter ($DEF_A4FIX = TRUE) und deaktivierten Palettiermodus ($PALMODE = FALSE) dürfen nur PTP-Bewegungen mit achsspezifischem Zielpunkt ausgeführt werden.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm korrigieren.

  • Meldung quittieren.


Kein passendes Endspline gefunden

Ursache:

KS unvollständig. Spline ohne Endspline


Kein T1-Betrieb: Justage nicht möglich

Ursache:

Betriebsart der Steuerung ist nicht T1.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Betriebsart auf T1 stellen.

  • Justage erneut durchführen.

  • Meldung quittieren.


Kein Verbindungsaufbau möglich zu <KRC name>. Bitte Verbindung prüfen

Ursache:

Das Programm kann nicht mit der den Arbeitsbereich verwaltenden Steuerung kommunizieren.

Auswirkung:

Arbeitsbereichsanforderung fehlgeschlagen.

Abhilfe:

  • Sicherstellen, dass die entsprechende Steuerung eingeschaltet ist.

  • Mit Hilfe des "Cell Map Setup"-Dialoges die Netzwerkkommunikation zur Arbeitsbereichsverwaltung überprüfen.

  • Prüfen der physikalischen Verbindungen.

  • Überprüfen der IP-Adressen auf den jeweiligen Steuerungen.


Keine OUT-Parameter erlaubt

Ursache:

Bei Trigger mit UP-Aufruf wird Referenzparameter übergeben.

Abhilfe:

  • Programm korrigieren.

  • Meldung quittieren.


Keine Punktkonvertierung ohne absolutgenaues Modell möglich

Ursache: | Konvertierung ohne Modell nicht möglich, wenn $ABS_ACCUR = FALSE und $ABS_CONVERT = TRUE.
Auswirkung: | Die Punktkoordinaten können nicht in das absolutgenaue Robotermodell konvertiert werden.
Abhilfe: | $ABS_ACCUR = TRUE und $ABS_CONVERT = TRUE setzen, um eine Punktkonvertierung durchzuführen. Wichtig: nach einer Punktkonvertierung muss $ABS_CONVERT wieder auf FALSE gesetzt werden!


Kinematikzuweisung unzulässig

Ursache:

An die Systemvariable "$BASE" wurde mit der Funktion EK eine nicht vorhandene Zusatzkinematik zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm korrigieren.


Komplette Prozedur löschen?

Ursache:

  • Zum Zeitpunkt des Kommandos "Übernahmefahrt" war die Achse nicht justiert;

Abfrage, ob Prozedur gelöscht werden soll.

Auswirkung:

Vorgang liegt zur Bearbeitung an.

Abhilfe:

Frage entsprechend beantworten.


Konnte andere Zelle Controller der Datenänderung benachrichtigen nicht (<System variable name>).

Ursache: | Ein internes Problem im Meldungshandling verhindert, dass Änderungsdaten zu den anderen Steuerungen innerhalb der Zelle gesandt werden.
Auswirkung: | Die anderen Steuerungen innerhalb der Zelle können nicht entsprechend reagieren.
Abhilfe: | Reboot der betreffenden Robotersteuerung.


Kontrollstruktur nächster Satz <Satznummer>

Ursache:

Anwahl in eine Kontrollstruktur.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

  • Kontrollstruktur wird bei Ende-Erkennung verlassen.

Abhilfe:

Meldung quittieren.


Kreisparameter unzulässig

Ursache:

Der Abstand zwischen Startpunkt und/oder Hilfspunkt und/oder Zielpunkt ist zu gering bzw. sämtliche Punkte liegen auf einer Geraden. Die Konstruktion eines Kreises ist nicht möglich.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Hilfspunkt bzw. Zielpunkt richtig programmieren.

  • Meldung quittieren.


Laufzeitdaten bei Trigger in UP unzulässig

Ursache:

In einem Unterprogramm wird ein Trigger definiert, der evtl. erst im Hauptprogramm schaltet.

Werden bei der Zuweisung des Triggers Laufzeitdaten verwendet, sind diese zum Schaltzeitpunkt ungültig.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Globale Variablen verwenden.

  • Meldung quittieren.


Lesen nicht erlaubt

Ursache:

Eine "$"-Variable, die bei dem angewählten Interpretertyp unzulässig ist, wurde gelesen.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Bei Programmbearbeitung muss die Meldung quittiert werden.


Lokale Programme besitzen zu viele Arbeitsbereiche. 'Release All'

Ursache: | Zu viele Arbeitsbereiche wurden von dieser Steuerung genommen. Das Maximum ist 32 Arbeitsbereiche.
Auswirkung: | Der Steuerung kann dieser Arbeitsbereich nicht zugeteilt werden.
Abhilfe: | Der Anwender muss nicht benutzte Arbeitsbereiche freigeben.


Max. Anzahl aktive Trigger überschritten

Ursache:

Zu viele Trigger in einem Satz programmiert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Anzahl aktiver Trigger im Programm reduzieren.


Max. Anzahl Trigger (50) definiert

Ursache:

Es wurde die maximale Anzahl Trigger definiert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm entsprechend ändern.


Maximale Anzahl Interrupts definiert

Ursache:

Es wurden mehr als 32 Interrupts definiert.

  • Es dürfen nicht mehr als 32 Interrupts definiert werden.

  • Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Maximale Anzahl Interrupts eingeschaltet

Ursache:

Es wurden mehr als 8 Interrupts eingeschaltet.

  • Es dürfen nicht mehr als 8 Interrupts eingeschaltet werden.

  • Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Max. Anzahl von Arbeitsbereichanfragen zwischen zwei Bewegungsbefehlen

Ursache:

Zwischen zwei Bewegungsbefehlen sind zu viele Arbeitsbereichsanfragen enthalten.

Auswirkung:

Das Programm wird gestoppt.

Abhilfe:

  • Programm entsprechend ändern.

  • Anzahl der Anfragen verringern.


<Dateiformat>: Maximale Aufzeichnungsdauer für <Recordname> überschritten

Ursache: | Fehlendes Stopp-Kommando oder Bewegung dauert zu lange.
Auswirkung: | Unbrauchbare Aufzeichnung.
Abhilfe: | Aufruf des Stopp-Kommandos vor Erreichen der maximal möglichen Aufzeichnungsdauer.


Maximale kinetische Energie <Achsnummer>

Ursache:

Die zulässige kinetische Energie für den Crash-Fall wurde überschritten.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$Alarm_STOP" geht auf Level 0.

Abhilfe:

  • Lastdaten überprüfen.

  • Last gegebenenfalls reduzieren.

  • Programmierte Geschwindigkeit reduzieren.

  • Meldung quittieren.


Maximales Getriebemoment Achse <Achsnummer>

Ursache:

Die möglichen Ursachen für diese Meldung können vielfältig sein, z. B.:

  • Das berechnete Getriebemoment ist größer als das max. zulässige Getriebemoment.

  • Sollstrom des Drehzahlreglers der DSE passt nicht zum Sollstrom des Grundsystems.

  • Die programmierte Roboterposition kann nicht erreicht werden.

  • Positionsgeber oder RDW defekt.

  • Verwendung falscher Lastdaten oder Crash.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Punkte neu teachen, um das Moment zu reduzieren.

  • Positionsgeber/RDW überprüfen und ggf. austauschen.

  • Lastdaten überprüfen und ggf. korrigieren.


MDR: Bewegung im Interrupt nicht zulässig wenn MDR Base aktiv

Ursache: | Eine Bewegung wurde im Interrupt ausgeführt, während MDR Base aktiv war
Auswirkung: | Der Roboter stoppt.
Abhilfe: | Programm entsprechend ändern.


MDR: Filter-Änderung nicht erlaubt

Ursache: | Filteränderung, während MDR Base aktiv ist.
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Keine Änderung des Filters, während MDR Base aktiv ist.


MDR: Motion Driver Base hat sich verändert

Ursache: | Eine Bewegung, relativ zu einer bewegten Base wurde unterbrochen.
Auswirkung: | Roboter Stopp
Abhilfe: | Verwenden einer anderen Base.


MDR: ORI_TYPE Joint nicht erlaubt falls MDR Base aktiv

Ursache: | Ori_Type JOINT ist programmiert und es ist eine MDR Base ($BASE=EB(...)) aktiv. Dies ist nicht zulässig.
Auswirkung: | Roboter wird gestoppt.
Abhilfe: | Andere Ori_Type verwenden.


MDR: PTP nicht erlaubt wenn Motion Driver Base aktiv

Ursache: | Eine PTP-Bewegung wurde programmiert, während Motion Driver Base aktiv war.
Auswirkung: | Roboter und Interpreter Stopp.
Abhilfe: | Entfernung der PTP-Bewegung.


Mehr als 16 Interrupts definiert

Ursache:

Es wurden mehr als 16 Interrupts definiert.

Die Programmanweisung "INTERRUPT ON" kann nicht mehr als 16 definierte Interrupts einschalten.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Anzahl der aktiven Interrupts verringern.


Minimum muss kleiner als Maximum sein

Ursache:

Es wurde ein Minimum deklariert, das über dem Maximalwert liegt.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Wert korrigieren.


<Name des angezeigten Programms> Neuanwahl nicht möglich

Ursache: | Programm, das für Neuanwahl gebunden werden muss, verursacht Bindefehler.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Fehler anhand der in der Fehlerliste aufgeführten Bindefehler beheben.


Neue LK() - Base - Zuweisung in Interupt unzulässig

Ursache:

Es ist nicht erlaubt in einem Interrupt-Programm eine Base-Zuweisung mit "LK()" auszuführen, wenn die zugehörige im IP-Parameter von "LK()" angegebene unabhängige Maschine nicht bereits in der Bewegung, welche durch Interrupt unterbrochen wurde, als Base über "LK()" zugewiesen war.

Auswirkung:

Programm wird gestoppt.

Abhilfe:

  • Interrupt-Programm entsprechend ändern (Base-Zuweisungen entfernen).

  • Es ist kein Anwendungsfall für so eine Programmstruktur bekannt.


NOT-AUS wurde ausgelöst durch <Machine name / IP address>

Ursache: | Die angegebene Steuerung hat während der Bewegungskooperation einen bahntreuen Not-Aus angefordert.
Auswirkung: | Die lokale Programmausführung wird unterbrochen.
Abhilfe: | Auf der im Meldungstext angegebenen Steuerung die Ursache für den Stopp beseitigen.


Nur 8 $OUT_C[n] Zuweisungen erlaubt pro Bewegung

Ursache:

Es wurden mehr als 8 $OUT_C[n] Zuweisungen verwendet.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm entsprechend ändern.


<Programm Name> aktiv: Prozess stoppen (J/N)?

Ursache: | Das Nachladen von Maschinendaten.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Prozess stoppen und Programm nach dem Laden der Maschinendaten neu starten.


<Objektname> analysieren (J/N)?

Ursache: | Abfrage, ob Objekt analysiert werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


<Objektname> binden (J/N)?

Ursache: | Abfrage, ob das Objekt gebunden werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


<Objektname> kopieren (J/N)?

Ursache: | Abfrage, ob kopiert werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


<Objektname> löschen (J/N)?

Ursache: | Abfrage, ob das Objekt gelöscht werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


<Objektname> trennen (J/N)?

Ursache: | Abfrage, ob das Objekt getrennt werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


OBJH-Fehler: <Lokalisierung>

Ursache: | Interner Fehler im OBJH.
Auswirkung: | Keine
Abhilfe: | Bitte setzen Sie sich mit Ihrem KUKA-Kundendienst in Verbindung.


Kann ohne gemeinsam verwendetes KCP Aktionen nicht mit <Controller name or IP address> verknüpfen

Ursache: | Es wurde versucht, Aktionen mit anderen Steuerungen zu verknüpfen, welche nicht durch das gleiche gemeinsam verwendete KCP gesteuert werden.
Auswirkung: | Ausführung nicht möglich.
Abhilfe: | Konfigurieren Sie beide Steuerungen so, dass beide das gleiche gemeinsam verwendete KCP benutzen.


Ölfilter verschmutzt

Ursache:

Hydraulikölfilter ist verschmutzt, so dass der erforderliche Hydraulikdruck nicht erreicht wird.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Ölfilter reinigen oder austauschen.


Öltemperatur zu hoch

Ursache:

Die maximal zulässige Öltemperatur der Hydraulik wurde überschritten.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Warten, bis Hydrauliköl abgekühlt ist.

  • Wenn dieser Zustand häufig auftritt, Hydraulikaggregat überprüfen.


Option <Optionsname> fehlt

Ursache: | Die Option wurde nicht eingetragen.
Auswirkung: | Kommando wird nicht bearbeitet.
Abhilfe: | Option eintragen.


Orientierungsbeschleunigung nicht programmiert

Ursache:

Den Programmdaten "$ACC.ORI1" und "$ACC.ORI2" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Orientierungsgeschwindigkeit nicht programmiert

Ursache:

Den Programmdaten "$VEL.ORI1" und "$VEL.ORI2" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


OriJoint nicht möglich: Konfiguration von Start- und Zielpunkt unterschiedlich

Ursache:

Bei einer OriJoint-Bewegung ist die "Ellbogen-Konfiguration" (Achse 2/3) vom Zielpunkt der Bewegung zu der vom Startpunkt verschieden. Dies würde bedeuten, dass der Zielpunkt nicht mit der programmierten Orientierung angefahren wird.

Auswirkung:

Bewegung kann nicht mit $ORI_TYPE=#JOINT ausgeführt werden.

Abhilfe:

  • $ORI_TYPE=#VAR bzw. #CONSTANT setzen

  • Orientierung des Zielpunkts verändern


ORI_TYPE JOINT wird von der Bewegungskooperation nicht unterstützt

Ursache: | Während zeitsynchroner Bewegungen und bei aktiven LK() Bezugssystemen ist die JOINT Orientierungsführung unzulässig.
Auswirkung: | Programmausführung wird gestoppt.
Abhilfe: | Andere Orientierungsführung verwenden.


Palettiermodus mit diesem Robotertyp nicht möglich

Ursache: | Wenn $ROBROOT A bzw. B < > 0, so ist Palettieren nicht möglich. Palettieren ist nur mit Robotern bei Boden- oder Deckenmontage möglich.
Auswirkung: | Drehzahl Stopp.
Abhilfe: | $ROBROOT richtig eingeben bzw. $PAL_MODE = FALSE setzen.


Passiver STOPP

Ursache:

Stopp von einem passiven Gerät. Diese Meldung wird nur angezeigt, wenn ein aktiver Prozess gestoppt wurde.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.

HINWEIS:
Diese Meldung kann nur vom Auslöser quittiert werden, auch im passiven Zustand.


Path-Trigger bei PTP unzulässig

Ursache:

Path-Trigger bei PTP.

Path-Trigger sind bei PTP unzulässig.

Auswirkung:

Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm korrigieren.

  • Meldung quittieren.

  • Programm neu starten.


Positionierüberwachung <Achsnummer>

Ursache:

Positionierfenster "$IN_POS_MA" wurde nicht innerhalb der eingestellten Positionierzeit "$TIME_POS" erreicht.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Nach Quittieren der Meldung gilt für die Achse: "Position erreicht".

Abhilfe:

  • Wert für Positionierfenster "$IN_POS_MA" vergrößern.

  • Wert für Positionierzeit "$TIME_POS" vergrößern.

  • Driftabgleich durchführen.

  • Regelkreisverstärkung überprüfen.

  • Mechanik überprüfen.

  • Meldung quittieren.


PRIO 40-80 gesperrt

Ursache:

Für einen Trigger Befehl wurde eine gesperrte Priorität zwischen 40 bis 80 verwendet. Dieser Bereich ist für interne Prioritätsvergabe reserviert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Programmkooperation ist nicht installiert. Befehl kann nicht ausgeführt werden.

Ursache: | Ein Befehl zur Programmkooperation kann nicht ausgeführt werden, weil das Programm Cooperating Robots nicht installiert bzw. korrekt konfiguriert ist.
Auswirkung: | Der Befehl wird nicht ausgeführt.
Abhilfe: | Installieren bzw. konfigurieren Sie das Programm Cooperating Robots oder entfernen Sie aus dem KRL-Programm die Befehle zur Programmkooperation.


Programm nicht gebunden

Ursache:

Anwahl eines nicht gebundenen Programms.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm binden.
HINWEIS:
Bei der Programmbearbeitung muss die Meldung quittiert werden.


Programm <Programm Name> überschreiben (J/N)?

Ursache: | Abfrage, ob Objekt überschrieben werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


Programm <Objektname> löschen (J/N)?

Ursache: | Sicherheitsabfrage, ob das angewählte Objekt gelöscht werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


Prozess aktiv

Ursache:

Während eines aktiven Prozesses wurde versucht, ein aktives Kommando zu starten.

Die Abfrage erfolgt während der Kommando- und der Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Warten auf Bearbeitungsende.

  • Stoppen der aktiven Bearbeitung.

  • Bei der Programmbearbeitung muss die Meldung quittiert werden.


PTP Bewegungen zu bewegten Frames sind unzulässig

Ursache: | PTP-Bewegungen in Bezug auf bewegten Frame sind nicht zulässig.
Auswirkung: | Programmausführung wird gestoppt.
Abhilfe: | Teachen des Zielpunktes unter Bezug auf einen festen Frame wie WORLD, oder als kartesische Bewegung ausführen (z.B. LIN).


Quitt Abweichung Absolutposition DSE - RDW Achse <Achsnummer>

Ursache: | Folgemeldung nach Zustandsmeldung "Abweichung Absolutposition DSE - RDW Achse %1"
Abhilfe: | Meldung quittieren


Quitt kritische Abweichung Master-Slave <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Abweichung kritisch Master-Slave <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Abweichungsalarm Master-Slave <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Abweichungsalarm Master-Slave <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Abweichungswarnung Master-Slave <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung: "Abweichungswarnung Master-Slave <...>".
Auswirkung: | Keine.
Abhilfe: | Meldung quittieren.


Quitt Arbeitsraum Nr. <Nummer des Achbereichs> überschritten

Ursache: | Eine oder mehrere Achsen befinden sich außerhalb des zulässigen Achsbereiches.
Auswirkung: | Roboter wird gestoppt.
Abhilfe: | Der Roboter muss mit reduzierter Geschwindigkeit wieder in den Achsbereich gefahren werden.


Quitt <Achsnummer> ohne Leistungsspannung

Ursache: | Folgemeldung der Zustandsmeldung "... OHNE LEISTUNGSSPANNUNG".
Abhilfe: | Meldung quittieren.


Quitt Akku prüfen <KPS Nummer>

Ursache: | Folgemeldung nach Zustandsmeldung "Akku prüfen <...>".
Auswirkung: | Keine.
Abhilfe: | Meldung quittieren.


Quitt Allgemeiner KSD-Fehler <Achsnummer>

Ursache:

  • Folgemeldung der Zustandsmeldung "Antriebsfehler <Achsnummer> Nr. <...>".

  • Das KSD der betroffenen Achse meldet einen allgemeinen Fehlerzustand. Genaue Informationen zu diesem Fehlerzustand des KSDs liefern die ausgegebenen Folgemeldungen.

  • Kommt die Meldung ohne Folgemeldungen, so stand der Fehler im KSD so kurz an, dass die DSE die Fehlernummer im KSD nicht auslesen konnte, bevor der Fehlerzustand wieder verschwunden ist. In diesem Fall muss der Fehlerspeicher im betroffenen KSD ausgelesen werden. Hierfür muss das DSE-RDW-Tool geöffnet werden und die Codestellen des betroffenen KSDs in ein Logfile exportiert werden.

Detaillierte Informationen zu der Fehlerhistorie liefern die Codestellen 162, 163 und 164. Die Codestelle 161 enthält den aktuellen Fehler.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • KUKA Service verständigen.


Quitt Antriebsbus DSE-Nr. <DSE-Nr.> Teilnehmer Nr. <IBS-Teilnehmer> unbekannt

Ursache:

Folgemeldung der Zustandsmeldung "Antriebsbus DSE-Nr.: <DSE-Nr.> Teilnehmer-Nr.: <IBS-Teilnehmer> unbekannt".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Antriebsbusstörung nach DSE <DSE Nummer>, keine Pufferung und auto. Datensicherung möglich

Ursache: | Folgemeldung nach Zustandsmeldung "Antriebsbusstörung nach DSE ..., keine Pufferung und auto. Datensicherung möglich".
Abhilfe: | Meldung quittieren.


Quitt Antriebsbusstörung DSE <DSE Nummer>

Ursache: | Folgemeldung nach Zustandsmeldung "Antriebsbusstörung DSE ...".
Auswirkung: | Antriebsbus läuft wieder.
Abhilfe: | Meldung quittieren.


Quitt Antriebsbusstörung nach <Achsnummer>

Ursache: | Folgemeldung nach Zustandsmeldung "Antriebsbusstörung nach ...".
Abhilfe: | Meldung quittieren.


Quitt Antriebsbusstörung nach <KPS Nummer>

Ursache: | Folgemeldung nach Zustandsmeldung "Antriebsbusstörung nach ...".
Abhilfe: | Meldung quittieren.


Quitt Antriebsfehler <Achsnummer> Nr. <Fehlernummer>

Ursache:

Folgemeldung der Zustandsmeldung "Antriebsfehler <Achsnummer> Nr. <...>".

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.
Nach dem Quittieren kann der Roboter bis zur nächsten Meldung weitergefahren werden.


Quitt Antriebsfreigabe <Powermodul Nummer> fehlt

Ursache: | Antriebsfreigabe an KPSi einer Cobra-Steuerung ist erfolgt.
Auswirkung: | Keine
Abhilfe: | Meldung quittieren


Quitt Ausfall einer Motorphase <Achsnummer>

Ursache:

Die Spannung der Pufferbatterie ist zu niedrig.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Batterie austauschen.

  • Meldung quittieren.


Quitt Ausfall einer Netzphase <Powermodul Nummer>

Ursache:

Eine Phase des Drehstromnetzes ist nicht vorhanden.

Auswirkung:

Das KPS kann die erforderliche Leistung nicht liefern.

Abhilfe:

  • Überprüfung auf Wackelkontakt.

  • Überprüfung auf Kabelbruch.


Quitt Ballastschalter zu lange ein <KPS Nummer> beim Laden

Ursache: | Folgemeldung nach Zustandsmeldung "Ballastschalter zu lange ein ... beim Laden".
Abhilfe: | Meldung quittieren.


Quitt Batteriefehler Geber <Achse>

Ursache: | Es liegt ein Batteriefehler im Geber der angezeigten Achse vor.
Abhilfe: | Batterie austauschen.


Quitt Bremsenkanal nicht geöffnet <Achsnummer>

Ursache: | Die Bremse dieser Achse ist nun offen, oder die Achse nicht mehr in Regelung.
Auswirkung: | Keine
Abhilfe: | Alle Achsen an einem Bremsenkanal zusammen ansteuern, oder Einzelbremsensteuerung verwenden.


Quitt. <KPS-Nummer> Drehstromnetz ausgefallen

Ursache:

  • Folgemeldung der Zustandsmeldung "<KPS-Nummer> Drehstromnetz ausgefallen".

  • Roboterhauptschalter am COBRA-Roboter war ausgeschaltet oder Drehstromnetz war ausgefallen.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Ggf. Drehstromnetz der Anlage prüfen.


Quitt i*i-t Überwachung, Strombelastung der Motorleitung <Achsnummer> nach <Zeit> s 100 %

Ursache: | Folgemeldung der Zustandsmeldung "i*i-t ÜBERWACHUNG, STROMBELASTUNG DER MOTORLEITUNG ...".
Abhilfe: | Meldung quittieren.


Quitt i*i-t Überwachung, Strombelastung der Motorleitung <Achsnummer> nach <Zeit> s 95 %

Ursache: | Folgemeldung der Zustandsmeldung "i*i-t Überwachung, Strombelastung der Motorleitung ... 95 %".
Abhilfe: | Meldung quittieren.


Quitt Kommutierungsfehler <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Kommutierungsfehler <...>".

Auswirkung:

  • Drehzahl Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Lüfter defekt. Modul <Achsnummer> tauschen, um Ausfall zu vermeiden.

Ursache:

Der Lüfter auf dem Umrichter einer Cobra-Steuerung ist defekt.

Auswirkung:

Umrichter wird nicht mehr ausreichend gekühlt

Abhilfe:

  • Überprüfung auf freie Drehbarkeit des Lüfterrades.

  • Tausch des Lüfters.


Quitt Messbereich des Kraftsensors überschritten <Achsnummer>

Ursache:

Dies ist die Folgemeldung zur Meldung: "Messbereich des Kraftsensors überschritten".

  • Die Auflösung des Kraftsensors beträgt -1500 bis +6500 Inkremente. Wird dieser Bereich verlassen, haben wir kein gültiges Signal mehr.

  • Ursache kann ein Reset unter Druck oder ein Wegdriften des Sensors sein.

Auswirkung:

  • Der Wert des Kraftsensors ist falsch.

Abhilfe:

  • Prüfen Sie, ob der Kraftwert in Inkrementen bei geöffneter Zange im Bereich +/- 50 INC ist.

  • Prüfen Sie, ob der Reset richtig funktioniert und nicht unter Druck gesetzt wird.


Quitt Kollisionsüberwachung Achse <Achsnummer>

Ursache:

Das Motormoment befand sich nicht im angegebenen Überwachungsbereich.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Lastdaten überprüfen.

  • Momentenschlauch vergrößern.

  • Meldung quittieren.


Quitt Ungültiges Kommando <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Ungültiges Kommando <...>".

Auswirkung:

  • Drehzahl Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Ballastschalter zu lange eingeschaltet <Achsnummer>

Ursache:

Energie der abgebremsten Achse lag über dem Limit.

Auswirkung:

  • Drehzahl Stop

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Powermodul-Ballastwiderstand überprüfen und ggf. austauschen.

  • Bremsrampe weniger steil einstellen.

  • Meldung quittieren.


Quitt Bedienerschutz / Schutzgitter zu

Ursache:

In der Betriebsart AUTOMATIK oder EXTERN hatte der Anpassteil-Eingang "$USER_SAF" den Signalzustand "0".

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Bremse defekt <Achse>

Ursache:

  • Meldung nach "Bremse defekt <Achse>".

  • Bremsenverschleiß.

  • Bremse defekt

Abhilfe:

  • Meldung quittieren.

  • Entsprechenden Motor austauschen.


Quitt Bremsenabkühlzeit <Achse>

Ursache: | Folgemeldung der Zustandsmeldung: "Bremsenabkühlzeit <Abkühlzeit>".
Abhilfe: | Meldung quittieren.


Quitt Bremsenstörung <KPS Nummer> Kanal <Bremsenkanal>

Ursache:

Folgemeldung nach Zustandsmeldung "Bremsenstörung <...> Kanal <...>".

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Bremsenstörung <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "Bremsenstörung <Achsnummer>".
Abhilfe: | Meldung quittieren.


Quitt Bremsentest erforderlich

Ursache: | Um die Sicherheit des Roboters zu gewährleisten, ist periodisch alle 8 Stunden die Funktionsfähigkeit der mechanischen Haltebremsen zu überprüfen.
Auswirkung: | Wird diese Zeit überschritten, so stoppt der Roboter. Achtung! Der Roboter darf erst weiterbetrieben werden, nachdem der Bremsentest erfolgreich durchgeführt wurde.
Abhilfe: | Bremsentest durchführen.


Quitt Bremsentest fehlgeschlagen <Achse>

Ursache: | Beim Bremsentest, womit die Funktion der mechanischen Haltebremsen geprüft wird, hatte die angegebene Achse ein zu geringes Bremsmoment.
Auswirkung: | Achtung! Der Roboter darf solange nicht weiterbetrieben werden, bis die Fehlerursache beseitigt ist und das Bremsmoment der Haltebremse wieder normalen Wert hat.
Abhilfe: | Bremse und/oder Motor tauschen.


Quitt Datenzuordnung zum SIGNAL falsch

Ursache: | Ausgangszuweisung eines SIGNALs liegt nicht vollständig in einem Datenobjekt (OUTB, OUTW oder OUTDW in der Datei iosys.ini). bei SIGNAL-Zuweisung und Option $DATA_INTEGRITY=TRUE
Auswirkung: | SIGNAL wird nicht geschrieben.
Abhilfe: | SIGNAL muss in einem entsprechend langen Datenobjekt liegen.


Quitt DSE <DSE Nummer> läuft nicht hoch

Ursache:

  • Folgemeldung der Zustandsmeldung "DSE <DSE-Nummer> läuft nicht hoch".

  • Das Grundsystem hat die Rückmeldung DSEREADY nach dem Start des DSE Programms nicht erhalten.

Auswirkung:

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Prüfen, ob die DSE richtig steckt.

  • DSE tauschen.


Quitt E<2- oder 7-Schl.> Schließung geschlossen

Ursache: | Folgemeldung der Zustandsmeldung "E <2- oder 7-Schl.> Schließung geschlossen".
Abhilfe: | Meldung quittieren.


Quitt E<2- oder 7-Schl.> Schließung offen

Ursache: | Folgemeldung der Zustandsmeldung "E <2- oder 7-Schl.> Schließung offen".
Abhilfe: | Meldung quittieren.


Quitt Effektivstrom <Powermodul Nummer> zu groß

Ursache:

Das KPS muss einen zu großen Effektivstrom liefern.

Auswirkung:

KPS schaltet zum Eigenschutz ab.

Abhilfe:

  • Umteachen der Roboterbahn

  • Langsameres Verfahren


Quitt erlaubte Maximalkraft ueberschritten <Achse>

Ursache:

Dies ist die Folgemeldung zur Meldung: "Erlaubte Maximalkraft überschritten".
Das Kraftsensorsignal ist nach dem Einschalten der Kraftregelung ($Force[Achse] > FORCE_LIM) grösser als FORCE_MAX + UPPER_LIMIT_TOL.

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

Abhilfe:

  • Kraftsensorwert $Force_act[Achse] im Varkor prüfen.

  • Kraftsensor und Kabel prüfen.

  • Trace Aufzeichnung der Testgruppe 11-Kraftregelung um zu ermitteln, ob der Regler zu stark überschwingt.


Quitt Fahrfreigabe gesamt

Ursache:

Eingang "$MOVE_ENABLE" hatte 0-Signal.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt unerwarteter Zustand der Ausgänge <Powermodul Nummer>

Ursache:

Folgemeldung nach Zustandsmeldung "Unerwarteter Zustand der Ausgänge <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Falscher Antriebsparametersatz <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "FALSCHER ANTRIEBSPARAMETERSATZ ".
Abhilfe: | Meldung quittieren.


Quitt Fehler bei Kommutierungsjustage: Regler aktiv <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Fehler bei Kommutierungsjustage: Regler aktiv <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Fehler bei Kommutierungsjustage: keine Spannung <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Fehler bei Kommutierungsjustage: Keine Spannung <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Fehler sync. Eingang Antriebsmodul <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "FEHLER SYNC.-EINGANG ANTRIEBSMODUL".
Abhilfe: | Meldung quittieren.


Quitt Fehler Synchronisation mit DSE <Achsnummer>

Ursache:

  • Folgemeldung der Zustandsmeldung "Fehler Synchronisation mit DSE <Achsnummer>".

  • Meldung vom Grundsystem: Das Grundsystem hat den Watchdog-Timer zur Überwachung der Kommunikation mit der DSE nicht gesetzt oder die DSE hat den Watchdog-Timer nicht zurückgesetzt.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

Abhilfe:

  • Meldung quittieren.

  • Steckverbindung zwischen DSE und MFC, sowie zwischen MFC und Motherboard auf einwandfreie Kontaktgabe prüfen (Wackelkontakt).

  • Sollte dies keine Verbesserung, dann bringen DSE oder MFC tauschen.

  • Untersuchen, ob der Antriebsbus oder ISA-Bus auf dem Motherboard gestört werden (EMV).


Quitt Geberleitung defekt <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung "Geberleitung defekt".

Auswirkung:

  • Bahntreuer Stop.

  • Ausgang "$ALARM_STOP" 0-Signal.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Geschwindigkeitsabweichung Master-Slave <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Geschwindigkeitsabweichung Master-Slave <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Interpolationstakt Zeitüberwachung <Achsnummer>

Ursache:

  • Folgemeldung der Zustandsmeldung "Interpolationstakt Zeitüberwachung <Achsnummer>".

  • DSE hat keinen Vorschub vom Grundsystem für diese Achse erhalten.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

Abhilfe:

  • Meldung quittieren.

  • Steckverbindung zwischen DSE und MFC, sowie zwischen MFC und Motherboard prüfen (Wackelkontakt).

  • Sollte dies keine Verbesserung bringen, dann DSE oder MFC tauschen.


Quitt Istgeschwindigkeit <Achsnummer> Überwachung

Ursache: | Folgemeldung der Zustandsmeldung "Istgeschwindigkeit <Achse> Überwachung".
Abhilfe: | Meldung quittieren.


Quitt Ixt Antriebsregler <Achsnummer> überschreitet Wert von <I*I*t Wert> %

Ursache:

Folgemeldung nach Zustandsmeldung "Ixt-Antriebsregler <Achsnummer> überschreitet Wert von <Wertangabe>%".

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Justage durchführen <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung "Justage durchführen".

Auswirkung:

  • Verriegelung aller aktiven Kommandos

Abhilfe:

  • Justage durchführen.

  • Meldung quittieren.


Quitt Justage-Referenzierung erforderlich

Ursache:

Um die korrekte Roboterjustage zu garantieren, muss diese durch Anfahren einer definierten Position referenziert werden. Dies muss periodisch alle 8 Stunden durchgeführt werden.

Auswirkung:

Wird die Referenzfahrt innerhalb dieser Zeit nicht durchgeführt, so darf der Roboter nur in reduzierter Geschwindigkeit verfahren werden.

Abhilfe:

  • Referenzfahrt durchführen.

  • Nach Durchführung der Referenzfahrt kann der Roboter wieder normal verfahren werden.


Quitt Justage-Referenzierung fehlgeschlagen

Ursache:

Um eine korrekte Roboterjustage zu garantieren, muss diese durch Anfahren eines definierten Punktes referenziert werden. Die Referenzierung ist fehlgeschlagen.
Mögliche Ursachen sind:

  • Fehlerhafte Justage

  • Defekter Referenzschalter

  • Falsch positionierter Referenzschalter

Auswirkung:

Der Roboter darf solange nur mit reduzierter Geschwindigkeit verfahren werden, bis die Fehlerursache beseitigt ist und eine erneute Referenzfahrt durchgeführt wurde.

Abhilfe:

  • Justage überprüfen und ggf. korrigieren

  • Funktion und Position des Referenzschalters überprüfen

  • Referenzfahrt erneut durchführen

Nach erneuter erfolgreicher Referenzfahrt kann der Roboter wieder mit normaler Geschwindigkeit betrieben werden.


Quitt K1 Kontakt verschweißt <Powermodul Nummer>

Ursache: | Meldung nach "K1 Kontakt verschweißt <KPS Nummer>".
Abhilfe: | Meldung quittieren.


Quitt KCP Verbindungsfehler

Ursache: | Following Message of KCP-Connection error. This message comes up, when the network connection for KCP is working again. See also message number 328
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Meldung quittieren.


Quitt Kommunikationsfehler mit CAN-RDW <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Quitt Kraftanstieg in Kraftregelung bleibt aus <Achsnummer>

Ursache:

Dies ist die Folgemeldung zur Meldung: "Kraftanstieg in Kraftregelung bleibt aus"
Bei einem angefahrenen kraftgeregelten Punkt steigt der Wert des Kraftsensors nicht an.
Mögliche Ursachen können sein:

  • Kraftsensor, KSK, Kabel, RDW,... defekt oder nicht richtig angeschlossen.

  • Zangenkappen berühren das Bauteil nicht.

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Kraftsensor prüfen.

  • Leitung zum Kraftsensor prüfen.

  • RDW Aufsteckkarte (KSK) prüfen.


Quitt Kühlkörpertemperatur <Achsnummer>

Ursache:

Zu hohe Kühlkörpertemperatur.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Kurzschluss Zwischenkreis <Powermodul Nummer>

Ursache: | Das KPS muss einen zu hohen Strom liefern.
Auswirkung: | KPS wird zum Schutz vor Überlastung abgeschaltet.


Quitt Leistungsüberwachung Zwischenkreisnetzteil <KPS Nummer>

Ursache:

Meldung nach "Leistungsüberwachung Zwischenkreisnetzteil ...".

Auswirkung:

  • Bahntreuer Stopp

  • Verriegelung aktiver Kommandos

Abhilfe:

Meldung quittieren.


Quitt Mainboardtemperatur zu hoch

Ursache:

Folgemeldung der Zustandsmeldung: "Mainboardtemperatur zu hoch <...>"

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Maximale Beschleunigung von <Achsnummer> überschritten

Ursache:

Es wurde eine Achsbeschleunigung detektiert, die größer als die konfigurierte maximal zulässige Beschleunigung war.

Auswirkung:

Der Roboter wird gestoppt.

Abhilfe:

  • Meldung quittieren.

  • Danach ist Weiterfahrt möglich.


Quitt Maximale Geschwindigkeit von <Achsnummer> überschritten

Ursache:

Die Geschwindigkeit einer Achse war größer als die gemäß der Konfiguration maximal zulässige Geschwindigkeit.

Auswirkung:

Roboter wird gestoppt.

Abhilfe:

  • Meldung quittieren.

  • Danach ist normale Weiterfahrt möglich.


Quitt Maximale kartesische Geschwindigkeit überschritten

Ursache:

Die kartesische Geschwindigkeit war größer als die gemäß der Konfiguration maximal zulässigen Geschwindigkeit.

Auswirkung:

Roboter wird gestoppt.

Abhilfe:

  • Meldung quittieren.

  • Danach ist normale Weiterfahrt möglich.


Quitt Motor blockiert <Achsnummer>

Ursache:

" I*t "–Überwachung wurde von einer DSE gemeldet.

Auswirkung:

  • Drehzahl Stop

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Motorleitung <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "MOTORLEITUNG".
Abhilfe: | Meldung quittieren.


Quitt Motortemperatur <Achsnummer>

Ursache:

Die Motortemperatur der in der Meldung angezeigten Achse war zu hoch.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt NOT-AUS

Ursache: | Folgemeldung der Zustandsmeldung "NOT-AUS".
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Meldung quittieren.


Quitt NOTSTOPP wegen Drehjustage

Ursache:

Betätigung der Softkeys für Drehjustage.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" erhält "0"-Signal.

Abhilfe:

Zweimalige Betätigung der Recall-Taste.


Quitt Parameterfehler <Achsnummer> <Parametersatz-Nr.>

Ursache: | Folgemeldung der Zustandsmeldung "PARAMETERFEHLER".
Abhilfe: | Meldung quittieren.


Quitt passiver STOPP <RST oder PHG>

Ursache:

Ausgelöst durch passiven Stopp.

Auswirkung:

  • Rampen Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt PC Lüfter defekt

Ursache: | Folgemeldung nach Zustandsmeldung "PC-Lüfter defekt".
Auswirkung: | Keine.
Abhilfe: | Meldung quittieren.


Quitt Position Tracker Geberleitung defekt auf DSE <Dse Nummer>

Ursache: | Folgemeldung der Zustandsmeldung "Position Tracker Geberleitung defekt".
Auswirkung: | Ausgangssignal $POS_TRACKER_ERROR wird zurückgesetzt.
Abhilfe: | Meldung quittieren.


Quitt Position Tracker Übertragungsfehler <DSE Nummer>. DSE - RDW

Ursache:

  • Folgemeldung der Zustandsmeldung "Position Tracker Übertragungsfehler <DSE-Nummer>. DSE-RDW".

  • Schadhafte Leitung oder Steckverbindung zwischen DSE und RDW, welche nur für Position Tracker benutzt werden.

  • Leitung nicht oder nicht richtig angeschlossen.

  • Störung der Datenübertragung zwischen DSE und RDW.

Auswirkung:

Ausgangssignal $POS_TRACKER_ERROR wird zurückgenommen.

Abhilfe:

  • Meldung quittieren.

  • DSE und RDW Spannungsversorgung prüfen (LEDs).

  • Leitung (Abschirmung!) und Steckverbindungen überprüfen.

  • Serielle Schnittstelle DSE - RDW überprüfen.

  • Ground von Roboter und Schrank prüfen.


Quitt POST Fehler: A/D-Wandler Fehler <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: A/D-Wandler Fehler <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: A/D-Wandler Offset Fehler <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: A/D-Wandler Offset Fehler <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: Antriebsfreigabe während Hochlauf <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: Antriebsfreigabe während Hochlauf <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: Fehler in FPGA Leistungsbaugruppe <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Fehler in FPGA Leistungsbaugruppe <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: FPGA Fehler <Antrieb Nummer>

Ursache:

Folgemeldung nach Zustandsmeldung "Post Fehler: FPGA Fehler <Powermodul>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: FPGA-Geber Loopback-Test Fehler <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: FPGA-Geber Loopback-Test Fehler <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: Prüfsummenfehler bei Parametertabelle <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: Prüfsummenfehler bei Parametertabelle <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: Systemfehler <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: Systemfehler <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt POST Fehler: Ungültiger Parameter <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: Ungültiger Parameter <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Fehler: Zeitüberschreitung A/D-Wandler <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "POST Fehler: Zeitüberschreitung A/D-Wandler <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Powermodul Achse <Achsnummer> nicht oder falsch gesteckt

Ursache: | Folgemeldung der Zustandsmeldung "Powermodul Achse <Achsnummer> nicht oder falsch gesteckt".
Abhilfe: | Meldung quittieren.


Quitt RDW <RDW Nummer> läuft nicht hoch

Ursache: | Folgemeldung der Zustandsmeldung "RDW <Achsnummer> läuft nicht hoch".
Abhilfe: | Meldung quittieren.


Quitt Reglerfreigabe gesamt

Ursache:

Eingang "$SERVO_RDY" hatte 0-Signal.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Safe RDW Systemfehler <Systemfehler-Nr.> (<übergebener Parameter>)

Ursache: | Ein Systemfehler in Safe RDW ist aufgetreten.
Auswirkung: | Antriebsfreigabe gesperrt.
Abhilfe: | DSoftware und Hardware überprüfen. (Ursache kann ein Software- oder Hardwarefehler sein.)


Quitt Schrank-Lüfter defekt

Ursache: | Folgemeldung nach Zustandsmeldung "Schrank-Lüfter defekt".
Auswirkung: |
Abhilfe: | Meldung quittieren.


Quitt Schlupf zu groß <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Schlupf zu groß <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Schranktemperatur zu hoch <Powermodul Nummer>

Ursache: | Folgemeldung der Zustandsmeldung: "Schranktemperatur zu hoch"
Abhilfe: | Meldung quittieren.


Quitt Sensorfehler Innenraumtemperatur <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "SENSORFEHLER INNENRAUMTEMPERATUR".
Abhilfe: | Meldung quittieren.


Quitt Sensorfehler Kühlkörpertemparatur <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "SENSORFEHLER KÜHLKÖRPERTEMPERATUR".
Abhilfe: | Meldung quittieren.


Quitt Sensorfehler Motortemperatur <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "SENSORFEHLER MOTORTEMPERATUR ".
Abhilfe: | Meldung quittieren.


Quitt Sicherer Betriebshalt verletzt

Ursache: | Der Roboter hat sich bewegt, obwohl der sichere Betriebshalt aktiviert ist.
Auswirkung: | Roboter wird angehalten.
Abhilfe: | Der sichere Betriebshalt muss deaktiviert werden oder der Roboter muss zu der Position zurückkehren, an welcher der sichere Betriebshalt aktiviert wurde.


Quitt Sicheren kartesischen Arbeitsraum <Nummer des Arbeitsraums> überschritten

Ursache: | Der Roboter befindet sich außerhalb des definierten kartesischen Arbeitsraumes.
Auswirkung: | Roboter wird gestoppt. Achtung! Der Roboter darf erst weiterfahren, wenn die Fehlerursache beseitigt ist.
Abhilfe: | Roboter in den definierten Arbeitsraum zurückfahren oder den Arbeitsraum, in dem er sich fälschlicherweise befindet, freigeben.


Quitt Sicherheitsparameter nicht korrekt <Parameterindex>

Ursache: | Die Daten im Sicherheits-Parametersatz sind fehlerhaft oder unvollständig.
Auswirkung: | Antriebsfreigabe gesperrt.
Abhilfe: | Die korrekten Sicherheits-Parameter laden.


Quitt Spitzenstrom <Powermodul Nummer> zu groß

Ursache:

Das KPS muss einen zu großen Spitzenstrom liefern.

Auswirkung:

KPS schaltet zum Eigenschutz ab.

Abhilfe:

  • Umteachen der Roboterbahn.

  • Langsameres Verfahren.


Quitt Stellgröße <Achsnummer>

Ursache:

  • Folgemeldung der Zustandsmeldung "Stellgröße <Achsnummer>".

  • Zu großer Schleppfehler. Die Achse folgt nicht dem Sollwert.

  • Kommt die Quittungsmeldung ohne vorherige Zustandsmeldung, so hat sich nur die Schleppfehlerüberwachung im Grundsystem ausgewirkt.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

Abhilfe:

  • Meldung quittieren.

  • Überprüfen der Maschinendaten

- $IN_POS_MA (Positionierfenster Achse),
- $FOL_ERR_MA (Faktor für Schleppfehlerüberwachung) sowie
- $VEL_DSE_MA (Geschwindigkeitsüberwachung).

  • Stromrichter überprüfen.

  • Mechanik und Motor kontrollieren.

  • Überprüfen der Regelparameter und der Getriebeübersetzungen der Achse.


Quitt Steuerschranktür bitte schließen

Ursache: | Folgemeldung nach Zustandsmeldung "Steuerschranktür bitte schließen".
Auswirkung: | Keine.
Abhilfe: | Meldung quittieren.


Quitt Stopp wegen Feldbusfehler

Ursache: | Quittieren eines Stopps durch einen Feldbusfehler
Auswirkung: | Verriegelung der Kommandos und Antriebe AUS wieder aufheben


Quitt Synchronisationsfehler Antriebsmodul <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "SYNCHRONISATIONSFEHLER ANTRIEBSMODUL".
Abhilfe: | Meldung quittieren.


Quitt Temperatur Warnung <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Temperatur Warnung <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Überspannung <KPS Nummer> beim Laden

Ursache:

Folgemeldung nach Zustandsmeldung "Überspannung <...> beim Laden".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aktiver Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Überspannung <Powermodul Nummer>

Ursache: | Folgemeldung der Zustandsmeldung "Überspannung <Powermodul>".
Abhilfe: | Meldung quittieren.


Quitt Überstrom <Achsnummer>

Ursache: | Folgemeldung der Zustandsmeldung "Überstrom <Achsnummer>".
Abhilfe: | Meldung quittieren.


Quitt Übertemperatur Ballastwiderstand <Powermodul Nummer> oder Lüfter

Ursache: | Folgemeldung der Meldung "Übertemperatur Ballastwiderstand ..."
Abhilfe: | Meldung quittieren.


Quitt Übertemperatur Ballastwiderstand <Powermodul Nummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Übertemperatur Ballastwiderstand <...>"

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Übertemperatur Lüfter <Powermodul Nummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Übertemperatur Lüfter <...>"

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Übertragungsfehler <DSE Nummer>. DSE - RDW

Ursache:

  • Folgemeldung der Zustandsmeldung "Übertragungsfehler <DSE-Nummer>. DSE-RDW".

  • Schadhafte Leitung oder Steckverbindung zwischen DSE und RDW.

  • Leitung nicht oder nicht richtig angeschlossen.

  • Störung der Datenübertragung zwischen DSE und RDW.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Meldung quittieren.

  • DSE und RDW Spannungsversorgung prüfen (LEDs).

  • Leitung (Abschirmung!) und Steckverbindungen überprüfen.

  • Serielle Schnittstelle DSE - RDW überprüfen.

  • Masseverbindung von Roboter und Schrank prüfen.


Quitt Falsche Modellnummer <Powermodul Nummer>

Ursache:

Folgemeldung nach Zustandsmeldung "Falsche Modellnummer".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Ungültiger Parameter A <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Ungültiger Parameter <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Unterspannung <KPS Nummer> beim Laden

Ursache:

Folgemeldung nach Zustandsmeldung "Unterspannung <...> beim Laden".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Konfiguration des Antriebsbus DSE <DSE Nummer> zu lang

Ursache:

Folgemeldung der Zustandsmeldung: "Konfiguration des Antriebsbus DSE <...> zu lang".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Unterspannung <Powermodul Nummer>

Ursache: | Folgemeldung der Zustandsmeldung "Unterspannung <Powermodul>".
Abhilfe: | Meldung quittieren.


Quitt Ungültige Motorbelastung <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Unzulässige Motorbelastung <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Verbindung zu lokaler Maschine nicht möglich

Ursache: | Das lokale Programm hat eine Verbindung zu der lokalen Steuerung angefordert.
Auswirkung: | Die Programmausführung wurde gestoppt.
Abhilfe: | Programm entsprechend ändern, dass keine Verbindung zur lokalen Steuerung angefordert wird.


Quitt Verbindungsverlust während einer Bewegungskooperation

Ursache: | Verbindung zu entfernter Steuerung unterbrochen.
Abhilfe: | Meldung quittieren


Quitt Verlust der Zeitgebersynchronisation

Ursache:

  • Verbindung zu anderer Steuerung unterbrochen;

  • Zeitgeber während Bewegungskooperation nicht synchronisiert.

Abhilfe:

Meldung quittieren


Quitt Versionskonflikt Firmware <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Versionskonflikt Firmware <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Warnung: Abstand zur Justageposition zu groß <Achsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Warnung: Abstand zur Justageposition zu groß <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Watchdog Powermodul <Powermodul Nummer>

Ursache:

Watchdog des Powermoduls abgefallen. (Triggerung durch DSE erfolgt im Abstand von 0,125 ms)

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • DSE überprüfen.

  • Powermodul überprüfen.

  • Meldung quittieren.


Quitt Zeitüberschreitung: Kommando an <Antriebsnummer>

Ursache:

Folgemeldung der Zustandsmeldung: "Zeitüberschreitung: Kommando an <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt zweites Motorkabel nicht angeschlossen

Ursache:

Folgemeldung der Zustandsmeldung:
"Zweites Motorkabel nicht angeschlossen"

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren


Quitt Antriebsbus DSE <DSE Nummer> Teilnehmer Nr. <Interbus Teilnehmernr.> nicht vorhanden

Ursache:

Folgemeldung der Zustandsmeldung "Antriebsbus DSE <...> Teilnehmer <...> nicht vorhanden".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Antriebsbus DSE <DSE Nummer> Teilnehmer Nr. <Interbus Teilnehmernr.> nicht konfiguriert

Ursache:

Folgemeldung der Zustandsmeldung: "Antriebsbus DSE <...> Teilnehmer Nr. <...> nicht konfiguriert".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Modul <Achsnummer> KSD-<Maximalstrom des KSDs> erforderlich

Ursache:

Folgemeldung der Zustandsmeldung "Modul <...> KSD- <...> erforderlich".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt zu viele Teilnehmer im Antriebsbus DSE <DSE Nummer>

Ursache:

Folgemeldung der Zustandsmeldung "zu viele Teilnehmer im Antriebsbus DSE <...>".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Quitt Zwischenkreis Ladeschaltung defekt <Powermodul Nummer>

Ursache: | Meldung nach "Zwischenkreis Ladeschaltung defekt <KPS Nummer>".
Abhilfe: | Meldung quittieren.


Rampen-Stopp wurde ausgelöst durch <Machine name / IP address>

Ursache: | Die angegebene Steuerung hat während Bewegungskooperation einen Programm Stopp angefordert.
Auswirkung: | Die lokale Programmausführung wird unterbrochen.
Abhilfe: | Auf der im Meldungstext angegebenen Steuerung die Ursache für den Stopp beseitigen.


Reset erforderlich

Ursache:

RUN auf einen Prozess im Ende-Zustand.

Die Abfrage erfolgt bei der Kommando- und der Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm mit RESET zurücksetzen.

  • Bei der Programmbearbeitung muss die Meldung quittiert werden.


Richtungswechsel nicht möglich

Ursache:

bei Kommandobearbeitung

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Roboter nicht justiert

Ursache:

  • Anwahl eines Programms bei nicht justiertem Roboter.

  • Starten eines Programms bei nicht justiertem Roboter.

Die Abfrage erfolgt bei Kommando- und Programmbearbeitung.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Roboter justieren.

  • Meldung quittieren.


Robotersystem nicht vorhanden

Ursache:

Es ist kein zweites Robotersystem in den Maschinendaten aktiviert (Kommando: $HOME = '/R2')

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei der Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei der Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Maschinen-Daten entsprechend ändern.

  • Meldung quittieren.


<String für Datentyp der Elemente> Rückgabefeld zu klein, Anzahl Elemente = <Anzahl der Elemente>

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Rückpositionieren

Ursache:

Bei Rückkehr aus einem Interrupt-Programm wurde SAK nicht erreicht.

Vor Beendigung des Interrupt-Programms muss wieder auf die Unterbrechungsposition rückpositioniert werden, z.B. mit LIN $POS_RET.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Satzanwahl in Unterprogramm bereits aktiv

Ursache:

Diese Meldung erscheint nur, wenn
LINE_SEL_LOCAL_SUB in progress.ini TRUE ist.


Satzanwahl in Unterprogramm während <#BSTEP / Interrupt> nicht zulässig

Ursache:

Diese Meldung erscheint, wenn LINE_SEL_LOCAL_SUB in der Datei "progress.ini" auf TRUE gesetzt ist.
Der Benutzer versuchte, die Anweisung einer lokalen Subroutine anzuwählen, welche sich nicht im Caller Stack befindet, während das Programm # BSTEP - Modus oder ein Interrupt ausgeführt wurde.
Dies ist nicht zulässig.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Quitt Sicherheitslogik überprüfen. Schützabfallzeit bei NOT-AUS überschritten

Ursache: | Die festgelegte Zeit für den Schützabfall wurde überschritten.
Auswirkung: | Verriegelung aller aktiven Kommandos.
Abhilfe: | Sicherheitslogik überprüfen.


Selektionstiefe zu hoch

Ursache:

Die Schachtelungstiefe der Variablen wurde überschritten.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Variable entsprechend ändern.

  • Meldung quittieren.


SEN: <Sensor Daten1> <Sensor Daten2> <Sensor Daten3>

Ursache:

Sensorfehler, der einen bahntreuen Stopp erfordert.

Auswirkung:

  • Bahntreuer Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Sensorspezifisch.


SEN: <Sensor Daten1> <Sensor Daten2> <Sensor Daten3>

Ursache:

Sensorfehler, der einen Drehzahl Stopp erfordert.

Auswirkung:

  • Drehzahl Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Sensorspezifisch.


SEN: <Sensor Daten1> <Sensor Daten2> <Sensor Daten3>

Ursache:

Sensorfehler, der einen Rampen Stopp erfordert.

Auswirkung:

  • Rampen Stopp.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Sensorspezifisch.


<"normale" bzw. "Konfigurations-"> Servoparameter <Achsnummer> wurden erfolgreich geladen

Ursache: | Lesevorgang der Parameter erfolgreich abgeschlossen.
Auswirkung: | Keine.
Abhilfe: | Meldung quittieren.


Servoparameter nicht übernommen

Ursache:

Servoparameter wurde nicht zur DSE gesendet
(bei Beschreiben der Struktur $SERVOPARA)

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Die Struktur "$SERVOPARA" richtig beschreiben.


Singularitätenfreies Fahren: max. Orientierungsfehler

Ursache:

Max. Orientierungsfehler wurde erreicht.

Auswirkung:

Bahntreuer Stopp

Abhilfe:

  • Bahnverlauf entsprechend ändern.

  • Orientierungsfehlervorgabe ändern in Frame $SINGUL_ERR_JOG (für Handbetrieb) oder $SINGUL_ERR_PRO (für Programmbetrieb).


Skip Nummer '<fehlende Skip Nummer>' fehlt

Ursache: | Der Interpreter läuft zu einem nicht definierten Endskip-Zeichen.
Auswirkung: | Anzeige des Programmfehlers.
Abhilfe: | Programm entsprechend korrigieren.


Sollbeschleunigung <Achsnummer>

Ursache:

Zulässige Beschleunigung wurde überschritten; abhängig von den Maschinen-Daten:
– "$ACC_ACT_MA" (Grenzwert Sollbeschleunigung) und
– "$TL_ACC" (Toleranzzeit Sollbeschleunigung)

Auswirkung:

  • Bahntreuer Stop.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm auf Alpha5-Durchgänge überprüfen.

  • Zeittoleranz Sollbeschleunigung verlängern.

  • Lageregelverstärkung verringern.

  • Endstufe überprüfen.

  • Meldung quittieren.


Sollgeschwindigkeit <Achsnummer>

Ursache:

Zulässige Geschwindigkeit wurde überschritten; abhängig von den Maschinen-Daten:
– "$VEL_ACT_MA" (Grenzwert Sollgeschwindigkeit) und
– "$TL_VEL" (Toleranzzeit Sollgeschwindigkeit)

Auswirkung:

  • Bahntreuer Stop.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Toleranzzeit Sollgeschwindigkeit verlängern.

  • Endstufe überprüfen.

  • Diese Meldung quittieren.


Sollgetriebemoment <Achsnummer>

Ursache:

Das zulässige Getriebemoment wurde überschritten.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$Alarm_STOP" geht auf Level 0.

Abhilfe:

  • Lastdaten überprüfen.

  • Last ggf. reduzieren.

  • Programmierte Beschleunigung reduzieren.

  • Programmierte Geschwindigkeit reduzieren.

  • Meldung quittieren.


Sollmotormoment <Achsnummer>

Ursache:

Das zulässige Motormoment wurde überschritten (abhängig von Dynamikdaten $DYN_DAT(), zyklisch).

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

  • Ausgang "$Alarm_STOP" geht auf Level 0.

Abhilfe:

  • Lastdaten überprüfen.

  • Last ggf. reduzieren.

  • Programmierte Beschleunigung reduzieren.

  • Programmierte Geschwindigkeit reduzieren.

  • Meldung quittieren.


Spannungsausfall

Ursache:

  • Versorgungsspannung für Schaltschrank wurde abgeschaltet.

  • Spannungseinbruch in der Netzversorgung.

Auswirkung:

  • Bahntreuer Stop.

  • Pufferung der Justagedaten.

  • Datensicherung auf HDD.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Falls keine manuelle Abschaltung oder Ausfall der Spannungsversorgung gegeben waren, Netzspannung überprüfen.


Speicherbedarf für Parameterliste zu hoch

Ursache:

Die Übergabeparameter des Programms beanspruchen zu viel Speicherplatz.

Auswirkung:

Drehzahl Stop.

Abhilfe:

  • Meldung quittieren.

  • Parameter entsprechend korrigieren.

  • Programm erneut anwählen.


Startpunkt gleich Hilfspunkt

Ursache:

Der Abstand vom Startpunkt zum Hilfspunkt ist zu gering.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aktiver Kommandos.

Abhilfe:

  • Startpunkt bzw. Hilfspunkt neu programmieren.

  • Meldung quittieren.


Startpunkt gleich Zielpunkt

Ursache:

Der Abstand vom Startpunkt zum Zielpunkt ist zu gering.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aktiver Kommandos.

Abhilfe:

  • Startpunkt bzw. Zielpunkt neu programmieren.

  • Meldung quittieren.


Steuerungskaltstart <Controller Name>

Ursache: | Eine andere Steuerung hat einen Kaltstart durchgeführt, wobei der Arbeitsbereich-Status nicht wieder hergestellt wurde.
Auswirkung: | Der Status der Arbeitsbereiche ist nicht korrekt.
Abhilfe: | Arbeitsbereich-Status bei der neu gestarteten Steuerung entsprechend korrigieren.


Skip Nr '<skipnummer>' wird schon verwendet

Ursache: | Diese Skip Nummer wird bereits verwendet.
Abhilfe: | Verwenden einer anderen Nummer.


Stillstand <Achsnummer>

Ursache:

Achse wurde aus der Stillstand-Position bewegt, abhängig von den Maschinendaten
– "$FOL_ERR_MA"(Schleppfehlergrenzwert) und
– "$TL_FOL_ERR"(Toleranzzeit Schleppfehlergrenzwert).

Auswirkung:

  • Generatorischer Stop.

  • Ausgang "$ALARM_STOP" weist Signalpegel 0 auf.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Schleppfehlergrenzwert erhöhen.

  • Toleranzzeit Schleppfehlergrenzwert verlängern.

  • Endstufe Motorbremse überprüfen.

  • Meldung quittieren.


STOPP wegen Betriebsartwechsel

Ursache:

Betriebsart wurde gewechselt.

Alle aktiven Prozesse werden bei einem Betriebsartenwechsel gestoppt.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


STOPP wegen HOME-Umschaltung

Ursache:

Während der Betätigung einer Richtungstaste oder Ausführen wurde die Home-Einstellung geändert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


STOPP wegen passiv setzen

Ursache:

Während der Betätigung der Start- oder Richtungstaste in der Betriebsart T1, T2 oder bei der SAK-Fahrt wurde das Bediengerät deaktiviert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Bediengerät aktivieren.

  • Meldung quittieren.


STOPP wegen Softwareendschalter <Verfahrrichtung> <Achsnummer>

Ursache:

Ein Sollwert des Software-Endschalters wurde überschritten.

Auswirkung:

Drehzahl Stop.

Abhilfe:

  • Meldung quittieren.

  • Roboter in entgegengesetzter Richtung verfahren.


STOPP wegen Wertebereichsüberlauf <Verfahrrichtung><Achsnummer>

Ursache: | Überlauf des Ist-Wertes einer Endlosachse.
Auswirkung: | Drehzahl Stop.
Abhilfe: | Neujustage der entsprechenden Achse.


Stopp, Überschleifen nicht möglich

Ursache:

Überschleifen aufgrund der Bahnplanung oder aus zeitlichen Gründen nicht möglich.

Auswirkung:

  • Rampen Stopp

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Geschwindigkeit im Satz und/oder ggf. Beschleunigung so weit reduzieren, bis Überschleifen möglich ist.


STOPP wegen Ausfall einer Netzphase DSE <DSE Nummer> KPS <KPS Nummer>

Ursache:

Eine Phase der Spannungsversorgung des KPS fehlt. Das kann auch schon vor dem Schrankanschluss der Fall sein.
Es kann auch die entsprechende Schrankverdrahtung fehlen.

Auswirkung:

Roboter wird angehalten. Der Schrankaußenlüfter wird, falls hardwareseitig möglich, abgeschaltet.

Abhilfe:

  • Stellen Sie die Spannungsversorgung aller drei Phasen sicher.

  • Prüfen Sie die erforderliche Schrankverdrahtung: X110/Pin2 muss auf 24V und X110/Pin3 muss auf GND liegen.


Störjustage ungültig

Ursache:

Es wurde keine Übernahmefahrt für die Achse durchgeführt.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Übernahmefahrt für die Achse durchführen.


Ein Submit Programm darf keine Kommandos bezüglich Workspace Sharing ausführen.

Ursache: | Eine Arbeitsbereichsanweisung wurde im Submit Interpreter ausgeführt, dies ist nicht erlaubt.
Auswirkung: | Das Submit Programm stoppt seine Ausführung
Abhilfe: | Die Arbeitsbereichsanweisung muss aus dem Submit Programm entfernt werden.


Synchronisation von PTP Bewegungen ist nicht verfügbar

Ursache: | Es wurde eine PTP-Bewegung mit Synchronisierung zu einer anderen Steuerung programmiert. Eine Synchronisierung für PTP-Bewegungen ist jedoch nicht verfügbar.
Auswirkung: | Programmausführung wird gestoppt.
Abhilfe: | Kartesische Bewegung (z.B. LIN) programmieren.


TECH_MAX-Wert überschritten

Ursache:

Die Nummer des programmierten Funktionsgenerators ist größer als die in den roboterspezifischen Maschinendaten projektierte maximale Anzahl an Funktionsgeneratoren (TECH_MAX).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm korrigieren.


Techmode unzulässig

Ursache:

Für die Technologieklasse "VEL" wurde der Modus "CYCLE" programmiert.

Die Abfrage erfolgt im Interpreter bei Änderung von "CLASS" oder "MODE".

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Programm korrigieren.


Timeout füllen

Ursache:

Die Maximalzeit für das Füllen des Dosierbehälters mit Klebstoff wurde überschritten.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).
Die Zeit für das Füllen des Dosierbehälters mit Klebstoff wird von der PLC überwacht.
Wenn dabei eine Maximalzeit überschritten wird, liegt ein Fehler in der Kleberhardware vor.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Kleberhardware überprüfen.


TIMER_LIMIT nur in WAIT FOR Anweisung erlaubt

Ursache: | Die Funktion "TIMER_LIMIT" wurde außerhalb einer "WAIT FOR"-Anweisung aufgerufen; dies ist nicht zulässig.
Auswirkung: | Interpreter Stopp


<X,Y,Z,A,B,C> TOOL nicht programmiert

Ursache:

Dem Programmdatum "$TOOL" wurde kein Wert zugewiesen:- in einem Anwender-Programm.

  • nach Urlöschen der Steuerung für ein kartesisches Kommando.

Abfrage erfolgt bei kartesischen Bewegungen.

Auswirkung:

Bei Kommandobearbeitung:- Verriegelung aller aktiven Kommandos.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Bei Kommandobearbeitung: "$TOOL" einen Wert zuweisen.

  • Bei Programmbearbeitung: Programm entsprechend ändern.

  • Meldung quittieren.


Trace Puffer leer, starte Rückwärtsinterpretation

Ursache:

  • Leere Aufzeichnung beim Rückwärtsfahren.

  • Umschaltung auf SCAN-Methode.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


Transformation nicht projektiert

Ursache:

$BASE oder $TOOL wurde zugewiesen, obwohl keine Transformation projektiert ist.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Trigger in Interrupt oder *.SUB nicht erlaubt

Ursache:

Trigger wurde im Interrupt bzw. SUB-Baustein programmiert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm korrigieren.

  • Meldung quittieren.


TTS existiert nicht

Ursache:

Die X-Achse des Werkzeugkoordinatensystems und die Bahntangente verlaufen parallel.

Was ist "TTS"?
TTS = Werkzeuggekoppeltes bahnbegleitendes Dreibein.

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Bewegung neu programmieren.

  • Punktkorrektur durchführen.


Statische Überlastung des Getriebemoments <Achsnummer> um <%-Wert>

Ursache: | Das max. zulässige Getriebemoment der angegebenen Achse wird statisch um den angezeigten %-Wert überschritten.
Auswirkung: | Interpreter Stopp
Abhilfe: | Lastdaten überprüfen: – Masse – Schwerpunkt – Trägheitsmomente


Statische Überlastung des Motormoments <Achsnummer> um <Prozentwert>

Ursache: | Das max. zulässige Motormoment der angegebenen Achse wird statisch um den angezeigten %-Wert überschritten.
Auswirkung: | Interpreter Stopp
Abhilfe: | Lastdaten überprüfen: – Masse – Schwerpunkt – Trägheitsmomente


Überlauf Programmschachtelung

Ursache:

Die Schachtelungstiefe für Unterprogramme und Funktionen wurde überschritten. Tritt auch auf, wenn sich Unterprogramme in einem Endlos-Loop gegenseitig aufrufen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Überlauf

Ursache:

Wert kann vom angegebenen Datentyp nicht aufgenommen werden, z.B. Wertzuweisung einer Zahl >255 an Datentyp "CHAR".

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Bei Programmbearbeitung: Meldung quittieren.


Übernahmefahrt unzulässig <Achsnummer>

Ursache:

  • Zum Zeitpunkt des Kommandos "Übernahmefahrt" war die Achse nicht justiert;

  • Letzte Justageart war Stör-Justage. (Bei Kommando "ADJUST SENSOR")

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Achse mittels EMT oder Uhr justieren.

  • Menü mit Recall verlassen.

  • Meldung quittieren.


Überschleifen CP/PTP nicht durchführbar

Ursache:

  • Im CP-Satz ist die Verfahrdistanz einer Achse größer als 180 Grad.

  • Status-Wechsel im CP-Satz.

  • Software-Endschalter-Verletzung bei Fahrt über "kürzesten Weg".

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Reduzierung des CP-Satzes.

  • Einfügen eines Zwischenpunktes.

  • Meldung quittieren.


Überschleifen nicht programmiert <Überschl.Kriterium>

Ursache:

Den Programmdaten "$APO.VEL", "$APO.ROB", "$APO.DIS" und/oder "$APO.ORI" wurde kein Wert zugewiesen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.

Siehe auch:
Programmierung von Bewegungen PTP, LIN, CIRC


Unbekannter COMP-Fehler: <Fehlerklasse>

Ursache: | Von der Compiler-Software wurde ein Fehler erkannt.
Auswirkung: | Keine
Abhilfe: | Bitte setzen Sie sich mit Ihrem KUKA-Kundendienst in Verbindung.


<Dateiformat>: Unbekannter Fehler

Ursache: | Mit dem EMI-Treiber trat ein unbekannter Fehler auf.
Auswirkung: | Der Roboter wird gestoppt.
Abhilfe: | Setzen Sie sich mit dem Hersteller des Treibers in Verbindung.


Unerreichbarer Punkt Softwareendschalter <Verfahrrichtung><Achsnummer>

Ursache:

Zielpunkt ist wegen Software-Endschalter nicht erreichbar.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässige EXTP/EXTFCTP Vereinbarung

Ursache:

Im Programm wurde eine EXTP- oder EXTFCTP-Anweisung verwendet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

EXTP- oder EXTFCTP-Anweisung im Programm löschen.


Unzulässige Interruptpriorität

Ursache:

Interrupt-Priorität größer als 128 oder kleiner als 1.

Auswirkung:

  • Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.

  • Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Programm entsprechend ändern.


Unzulässige Kerbenform

Ursache:

Justagekerbe bei EMT-Justage ist keine "V"- bzw. "U"-Kerbe.

Auswirkung:

  • Rampen Stop

  • Justagefahrt wird abgebrochen.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • EMT reinigen.

  • EMT-Kerbe auswechseln.


Unzulässige Mailbox-Identifikation

Ursache:

In der C-Funktion "MBX_REC" wurde eine falsche "MBX_ID" angegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässige Roboterstellung

Ursache:

Nach dem Rückpositionieren mit LIN stimmt der Winkel-Status mit dem Status des programmierten Satzes nicht überein.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Rückpositionieren mit PTP durchführen.


Unzulässige Startbewegung

Ursache:

  • Erster Bewegungssatz im Programm ist relativ.

  • Erster Bewegungssatz im Programm ist nicht vollständig programmiert, z.B. PTP [33.33].

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässige Variablenkombination <Satznummer>

Ursache:

In einer Synactanweisung werden Variablen für Einzelsätze und Überschleifsätze miteinander im logischen Vergleich oder in der Wertzuweisung kombiniert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Synactanweisung anders programmieren.

  • Meldung quittieren.


Unzulässige Wertzuweisung

Ursache:

Unzulässige Wertzuweisung bei vordefinierten Variablen, z.B.
$SPEED.ORI1 <= 0.0 oder > $SPEED_MA.ORI1. Oder zugewiesenes $Base oder $Tool für die Kinematik unzulässig.

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

  • Bei Kommandobearbeitung: Kommando wird nicht bearbeitet.

  • Bei Programmbearbeitung: Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässiger DELAY <Satznummer>

Ursache:

Ein negativer "DELAY" in der Synactanweisung wurde nicht in Verbindung mit einer der 4 Positionstriggervariablen verwendet (M_SC_F, M_SC_B, M_SCAPO_F, M_SCAPO_B).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Die logische Bedingung der Synactanweisung ändern.


Unzulässiger DELAY-Wert

Ursache:

Der Wert für "DELAY" ist nicht zulässig.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Zulässigen Wert für "DELAY" eingeben.


Unzulässiger DISTANCE-Wert

Ursache:

Der Wert für "DISTANCE" ist nicht zulässig.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Meldung quittieren.

  • Zulässigen Wert eingeben.


Unzulässiger Feldindex

Ursache:

Zugriff auf ein nicht vorhandenes Feldelement.

Beispiel:
INT Hugo[3,3]
Hugo[7,3]=9

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

  • Bei Kommandobearbeitung: Kommando wird nicht bearbeitet.

  • Bei Programmbearbeitung: Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässiger Feldparameter

Ursache:

Undefinierter Feldparameter oder ganzes Feld "call-by-value" in der Liste der aktuellen Parameter bei Funktionsaufruf.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Keine undefinierten Feldparameter verwenden und ganze Felder als aktuelle Parameter nur "call-by-reference" übergeben.


<Variablenname> unzulässiges Argument

Ursache:

In der Funktion ist mindestens ein Argument nicht zulässig, z.B. SQRT (negativer Wert).

Abfrage erfolgt bei der Interpretation von C-Funktionen.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

  • Meldung quittieren.


Unzulässiges Handle

Ursache:

In CWRITE oder CREAD wurde ein HANDLE programmiert, welcher ungültig ist.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Gültigen HANDLE angeben.


<Dateiformat>: Variable <Variable> und Wert in <Recordname> sind verschieden

Ursache: | Falscher Wert einer Systemvariablen, typischerweise $tool, $base, $ipo_mode ...
Auswirkung: | Der Roboter wird gestoppt.
Abhilfe: | Setzen Sie einen korrekten Wert für die Systemvariable.


<Name> Variable schreibgeschützt in Modul <Dateiname> Satz <Satznummer>

Ursache:

Es wurde in einem Programm-Baustein versucht, eine schreibgeschützte Variable zu beschreiben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.


Verbindung <Bediengerät> - KRC unterbrochen

Ursache: | Die Verbindung des aktiven Bediengerätes zur KRC-Steuerung wurde unterbrochen, während eine Bewegung im Testbetrieb gefahren wurde.
Auswirkung: | Generatorischer Stopp
Abhilfe: | Verbindung wiederherstellen.


Die Verriegelung <ws name> wurden in falscher Reihenfolge genommen. Deadlock möglich

Ursache:

Der gewählte Arbeitsbereich hat eine niedrigere Nummer als der vorher gewählte Arbeitsbereich.

Auswirkung:

Es besteht die Möglichkeit einer Kreisabhängigkeit, wenn Arbeitsbereiche nicht in einer bestimmten Reihenfolge verwendet werden.
Hinweis:
Diese Meldung ist nur eine Warnung vor einer möglichen Kreisabhängigkeit.

Abhilfe:

  • Programm entsprechend korrigieren, so dass nur Arbeitsbereiche mit aufsteigenden Nummern hintereinander verwendet werden.

Hinweis:
Es ist zum Beispiel erlaubt, die Arbeitsbereiche mit der Folge 1, 2, 5 zu verwenden, nicht aber beispielsweise 1, 5, 2.

  • Alternativ das Programm so strukturieren, dass Arbeitsbereiche nicht verschachtelt werden.


Der Verriegelungsbereich <ws name> existiert nicht <KRC name>

Ursache:

Der genannte Arbeitsbereich ist nicht definiert und/oder wird auf der spezifizierten Steuerung verwaltet.

Auswirkung:

Die Arbeitsbereichsanforderung schlägt fehl.

Abhilfe:

  • Prüfen der Arbeitsbereichsaufstellung auf der lokalen und auf den angeschlossenen Steuerungen.

  • Korrigieren etwaig gegebener Inkonsistenzen.

  • Korrigieren möglicher Programmfehler.


Dieser Verriegelungsbereich ist nicht definiert

Ursache:

Der Befehl "ENTERSPACE" referenziert einen undefinierten Arbeitsbereich. Womöglich wurde ein Programm von einer Steuerung auf eine andere Steuerung mit unterschiedlichen Arbeitsbereichen transferiert.

Auswirkung:

Die Arbeitsbereichsanfrage schlägt fehl.

Abhilfe:

  • Arbeitsbereich definieren

  • Ändern des Programms, welches den Arbeitsbereich anfordert.


Verschachtelte Skip Statements sind nicht erlaubt

Ursache: | Verschachtelte Skip Statements im Programm.
Abhilfe: | Programm entsprechend ändern. Siehe hierzu die Dokumentation.


Verschachtelte TIMER_LIMIT() nicht erlaubt

Ursache: | Verschachtelte Funktion TIMER_LIMIT() in KRL-Programm.
Auswirkung: | Interpreter Stopp
Abhilfe: | Meldung quittieren.


Verzögerungzeit (<Größe>) während geometrischer Kopplung geändert (<Wert im Altsatz>ms -> <Wert im Neusatz>ms)

Ursache:

Es wurde versucht, die Verzögerungszeit einer Bewegung zu ändern, während eine geometrische Kopplung aktiv war.
Dies ist nicht zulässig, wenn zeitsynchron verfahren wird.

Auswirkung:

Bahntreuer Stopp

Abhilfe:

  • Geometrische Kopplung reaktivieren;

  • Anpassen von $FILTER bzw. Analogausgabe.


Volumenmenge zu groß

Ursache:

Die Überwachung der aufgetragenen Volumenmenge hat angesprochen. Es wurde zu viel Klebstoff aufgetragen.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Überprüfen der Klebehardware, evtl. Spülen.


Volumenmenge zu klein

Ursache:

Die Überwachung der aufgetragenen Volumenmenge hat angesprochen. Es wurde zu wenig Klebstoff aufgetragen.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Überprüfen der Klebehardware, evtl. Spülen.


Wert für Trigger-PRIO unzulässig

Ursache:

Für Trigger-PRIO wurde ein nicht zulässiger Wert eingegeben.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Wert berichtigen.


Wertebereich Überschritten

Ursache:

Die Wartezeit im WAIT_SEC-Befehl, ausgedrückt in Grundtaktzyklen, ist größer als 2147483647 und übersteigt damit den maximal zulässigen Wert.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Kleinere Wartezeiten eingeben.


Quitt Zange faehrt kraftgeregelt kleiner FORCE_LIM <Achsnummer>

Ursache:

Dies ist die Folgemeldung zur Meldung: "Zange fährt kraftgeregelt kleiner FORCE_LIM"

  • Die Zange öffnet sich weiter als die zu FORCE_LIM korrespondierende Position und wird gestoppt um ein unkontrolliertes Öffnen der Zange zu vermeiden.

  • Diese Überwachungen sind nur während der Kraftregelung aktiv!

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Kraftsensor prüfen.

  • Kraftsensor Kabel prüfen.

  • RDW Aufsteckkarte prüfen.

  • Trace Aufzeichnung der Testgruppe 11-Kraftregelung um zu ermitteln, ob der Regler zu stark schwingt.


Zeichenkette zu lang

Ursache:

Bei einer Wertzuweisung an Felder besteht die Zeichenkette aus mehr Zeichen als das bestehende Feld.
Beispiel:
CHAR c[3]
c[]="abcde"

Die Abfrage erfolgt bei Kommandobearbeitung und Programmbearbeitung.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Programm entsprechend ändern.

Beispiel:
CHAR c[3]
c[]="abc"

  • Meldung quittieren.


Zeitsynchrone Bewegung erfordert gleiche Programmlaufart

Ursache:

Mindestens zwei der beteiligten Steuerungen sind in unterschiedliche Programmlaufarten geschaltet oder die synchrone Bewegung befindet sich auf einigen Steuerungen in einem versteckten Modul.

Auswirkung:

  • Bahntreuer Stopp.

  • Bewegung wird vom Interpreter zurückgewiesen und nach Quittieren der Meldung asynchron gefahren.

Abhilfe:

  • Alle Steuerungen in gleiche Programmlaufart schalten.

  • Betroffene Module entweder auf allen oder auf keiner Steuerung sichtbar machen.


Zentrierung fehlerhaft

Ursache:

Das Werkstück ist nicht richtig positioniert bzw. eingespannt.
Evtl. Fehler in der Zuführeinrichtung oder die Spannvorrichtung für das Werkstück ist defekt.

Die Abfrage erfolgt aus PCL-Anwenderprogramm (Klebetechnologie).

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Spannvorrichtung und Zuführeinrichtung überprüfen.

  • Position des Werkstücks prüfen.


Zu viele ASYPTP-Befehle in Folge

Ursache:

Tritt auf bei der Programmbearbeitung von ASYPTP-Befehlen.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Anzahl der ASYPTP-Befehle in Folge reduzieren.


Zugriff auf Komponente unzulässig

Ursache:

Unzulässiger Zugriff auf eine Komponente des Vorlauf-/Hauptlauf-Traces (z.B. SHOW VAR $PRO_TRACE[5].NAME[2] ).

Auswirkung:

  • Rampen Stop.

  • Kommando wird nicht ausgeführt.


Zyklische Daten vom TEPRO nicht freigegeben

Ursache:

Eine Samaphore verriegelt den Zugriff auf zyklische Daten.
(TEPRO = Technologieprozess)

Auswirkung:

  • Rampen Stop.

  • Unterbrechung der SBC-Schnittstelle.

Abhilfe:

Fehler im SBC-Programm beseitigen.


Alle zyklischen Analogeingänge belegt

Ursache:

Im Programm wurde ein dritter zyklischer Analogeingang eingeschaltet.

Auswirkung:

  • Rampen Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Einen zyklischen Analogeingang abschalten.


<Objektname> angewählt. Löschen (J/N)?

Ursache: | Sicherheitsabfrage, ob das angewählte Objekt gelöscht werden soll.
Auswirkung: | Vorgang liegt zur Bearbeitung an.
Abhilfe: | Frage entsprechend beantworten.


E/A Treiber nicht bereit <Treiber Nummer> <0>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


SoftPLC: <Parameter>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: Antriebsfreigabe während Hochlauf <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: Prüfsummenfehler bei Parametertabelle <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: FPGA-Geber Loopback-Test Fehler <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: Fehler in FPGA Leistungsbaugruppe <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: A/D-Wandler Fehler <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: A/D-Wandler Offset Fehler <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: Ungültiger Parameter <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: Systemfehler <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler: Zeitüberschreitung A/D-Wandler <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Zeitüberschreitung: Kommando an <Antriebsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler bei Kommutierungsjustage: Regler aktiv <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler bei Kommutierungsjustage: keine Spannung <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Warnung: Abstand zur Justageposition zu groß <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kommutierungsfehler <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


POST Fehler: FPGA Fehler <Powermodul Nummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Unerwarteter Zustand der Ausgänge <Powermodul Nummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Falsche Modellnummer <Powermodul Nummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Initialisierung der DSE läuft

Ursache:

  • DSE wird neu mit Parametern initialisiert.

  • Bleibt diese Meldung stehen, so konnte die Initialisierung nicht abgeschlossen werden.

  • Meldung erscheint nicht bei Office = TRUE in "hw_inf.ini".

Auswirkung:

  • Drehzahl Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Auf Fehler in den Maschinendaten achten, insbesondere auf Fehler in der Achs- und Powermodul-Rangierung.

  • Falls die Maschinendaten verändert wurden, mit den Maschinendaten auf der CD vergleichen und ggf. korrigieren.


DN CH <Kanalnummer> Firmware Fehler

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Achsnummer> abgekoppelte Zusatzachse

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Servoparameter <Achsnummer> nicht korrekt

Ursache: | Parameter im Servofile ist falsch.
Auswirkung: | Servoparameter hat keinen Effekt.
Abhilfe: | Berichtigen Sie den Servoparameter in der Datei.


Keine Roboternummer programmiert

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Antriebsfreigabe fehlt (extern)

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Interner Fehler (Datei: <Dateiname>, Zeile: <Zeilennummer>, Wert: <Rückgabewert>)

Ursache: | siehe 1574 (Systemfehler)
Auswirkung: | siehe 1574 (Systemfehler)
Abhilfe: | siehe 1574 (Systemfehler)


Batteriefehler Geber <Achse>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


File <Filename> muss für RoboCoaster System signiert sein

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


RoboCoaster Fehler. Keine Programmanwahl möglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


File <Filename> darf für Nicht-RoboCoaster System nicht signiert sein

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Achsen werden simuliert <Bitmask of simulated axes>

Ursache: | Der Wert der Variable "$Simulated_Axis" ist ungleich Null.
Auswirkung: | Die simulierten Achsen werden während der Programmausführung nicht verfahren.
Abhilfe: | Die Simulation kann durch das Setzen von "$Simulated_Axis = 0" ausgeschaltet werden.


MDR: Zeitüberwachung in <Task>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Einzelbremsenmodul <Achsnummer> nicht vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


DSE-IBS-C<C32 oder C33> erforderlich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Falsche Firmwareversion KSD <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Sichere Einzel-Achsabschaltung <Achsnummer> aktiv

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kommunikationsfehler mit CAN-RDW <Achsnummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Speicherverschiebung aktiv !

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


KCP: Verbindungsfehler <TIMEOUT oder DATA_ERROR>

Abhilfe:

Keine


Keine Szeneriedatei vorhanden. KollisionsVermeidung ist nicht aktiv

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Höchstanzahl Roboter überschritten (<maximale Zahl der Roboter>). Kollisionsvermeidung ausgeschaltet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Roboter <Robotername> unbekannt. Kollisionsvermeidung wird nicht unterstützt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Szeneriefile Ladefehler. Kollisionsvermeidung ausgeschaltet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Roboter <Robotername> Justageverlust. Wird von der Kollisionsvermeidung ausgeschlossen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Status name> <Optionaler parameter> <Optionaler parameter>

Ursache: | Zustandsmeldung
Abhilfe: | Bitte setzen Sie sich mit dem KUKA-Kundendienst in Verbindung.


Master wartet auf Interpolaionsstart der Slaves <Name/IP der Verusrsacher>

Ursache:

Meldung wird nicht mehr verwendet


<Driver name> : Kommunikation abgebrochen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<KPS-Nummer> Drehstromnetz ausgefallen

Ursache:

  • Roboterhauptschalter am COBRA-Roboter ist ausgeschaltet oder Drehstromnetz ist ausgefallen.

Auswirkung:

  • Generatorischer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Ggf. Drehstromnetz der Anlage prüfen.


Bremsentest erforderlich

Ursache: | Um die Sicherheit des Roboters zu gewährleisten, ist periodisch alle 8 Stunden die Funktionsfähigkeit der mechanischen Haltebremsen zu überprüfen.
Auswirkung: | Wird diese Zeit überschritten, stoppt der Roboter.
Abhilfe: | Er darf erst weiterfahren, wenn dieser Test nachgeholt wurde.


Bremsentest fehlgeschlagen <Achse>

Ursache: | Der Bremsentest überprüft die Funktionsfähigkeit der mechanischen Haltebremsen. Die Bremse der angegebenen Achse hat ein zu niedriges Bremsmoment.
Auswirkung: | Der Roboter darf nicht weiter betrieben werden, bis das Bremsmoment der Haltebremse wieder in Ordnung ist.
Abhilfe: | Bremse bzw. Motor tauschen.


Justage-Referenzierung erforderlich

Ursache: | Um die korrekte Roboterjustage zu garantieren, muss die Justage durch Anfahren einer definierten Position referenziert werden. Dies muss periodisch alle 8 Stunden durchgeführt werden.
Auswirkung: | Wird die Referenzfahrt innerhalb dieser Zeit nicht durchgeführt, darf der Roboter nur in reduzierter Geschwindigkeit verfahren.
Abhilfe: | Der Roboter kann wieder normal verfahren, wenn die Referenzfahrt erfolgreich durchgeführt wurde.


Position Tracker Übertragungsfehler <DSE Nummer>. DSE - RDW

Ursache:

  • Schadhafte Leitung oder Steckverbindung zwischen DSE und RDW, welche nur für Position Tracker benutzt werden.

  • Leitung nicht oder nicht richtig angeschlossen.

  • Störung der Datenübertragung zwischen DSE und RDW.

Auswirkung:

Ausgangssignal $POS_TRACKER_ERROR wird gesetzt.

Abhilfe:

  • DSE und RDW Spannungsversorgung prüfen (LEDs).

  • Leitung (Abschirmung!) und Steckverbindungen überprüfen.

  • Serielle Schnittstelle DSE - RDW überprüfen.

  • Ground-Verbindung prüfen.


Assertion failed: <Überwachender Ausdruck><Datei><Zeile>

Ursache: | Die als Erweiterung des ANSI-C Makros assert() gedachte Überwachung hat eine nicht zutreffende Behauptung durchlaufen.
Auswirkung: | Stopp des Roboters.
Abhilfe: | Fehlersuche im Code


Maximale Geschwindigkeit von <Achsnummer> überschritten

Ursache: | Die Sicherheitssteuerung hat eine Achsgeschwindigkeit detektiert, die größer war als in den Sicherheitsparametern konfiguriert.
Auswirkung: | Der Roboter wird angehalten.
Abhilfe: | Die Meldung muss quittiert werden, man kann danach normal weiterfahren.


Maximale kartesische Geschwindigkeit überschritten

Ursache: | Die Sicherheitssteuerung hat eine kartesische Geschwindigkeit detektiert, die größer war als in den Sicherheitsparametern konfiguriert.
Auswirkung: | Der Roboter wird angehalten.
Abhilfe: | Die Meldung muss quittiert werden. Man kann danach normal weiterfahren.


Safe RDW Systemfehler <Systemfehlernummer> (<übergebener Parameter>)

Ursache: | Es gab einen internen Fehler auf der Safe RDW.
Auswirkung: | Die Antriebsfreigabe kann nicht gegeben werden.
Abhilfe: | Das Problem kann sowohl von der Software als auch von der Hardware herrühren.


Maximale Beschleunigung von <Achsnummer> überschritten

Ursache: | Die Sicherheitssteuerung hat eine Achsbeschleunigung detektiert, die größer war als in den Sicherheitsparametern konfiguriert.
Auswirkung: | Der Roboter wird angehalten.
Abhilfe: | Die Meldung muss quittiert werden, man kann danach normal weiterfahren.


Trockenlauf Restaurierung aktiv

Ursache: | Das Grundsystem wartet auf die Beendigung der Trockenlauf Restaurierung durch das Trockenlauf-PlugIn / XEdit (die Meldung kommt nach einem Timeout von 2 Sek.)
Auswirkung: | Die Meldung hat lediglich informativen Charakter.
Abhilfe: | Nach Beendigung des Trockenlaufes (PlugIn + XEdit) geht die Meldung automatisch weg.


NOT-AUS Safety-Controller

Ursache:

  • Not-Aus von Safety-Controller ausgelöst.

Auswirkung:

  • Bahntreuer Stop.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

  • Die Störung beheben und quittieren.


Messbereich des Kraftsensors überschritten <Achsnummer>

Ursache:

  • Die Auflösung des Kraftsensors beträgt -1500 bis +6500 Inkremente. Wird dieser Bereich verlassen, haben wir kein gültiges Signal mehr.

  • Ursache kann ein Reset unter Druck oder ein Wegdriften des Sensors sein.

Auswirkung:

  • Der Wert des Kraftsensors ist falsch.

Abhilfe:

  • Prüfen Sie, ob der Kraftwert in Inkrementen bei geöffneter Zange im Bereich +/- 50 INC ist.

  • Prüfen Sie, ob der Reset richtig funktioniert und nicht unter Druck gesetzt wird.


Wechsel vom Zeitgeber 'Slave' zu 'Master'

Ursache: | Ein Wechsel vom Zeitgeber 'Slave' zu Zeitgeber 'Master' wurde auf der lokalen Steuerung veranlasst.
Auswirkung: | Keine.
Abhilfe: | Diese Meldung dient nur zur Information. Dieser Zustand wird aufgehoben, sobald die Zeitgeber wieder synchronisieren.


workspaces must be confirmed with Monitor->Workspace

Ursache: | The workspace states have been restored by communication.
Auswirkung: | May not continue until workspaces are confirmed in the Monitor->Workspace menu.
Abhilfe: | In the Monitor->Workspace menu, accept or reject every workspace.


Communicating with other controllers to restore shared workspace states

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


Freifahren aktiv

Ursache: | Freifahren wird durch einen sicheren Eingang auf der Safe RDW aktiviert. Der Roboter darf mit sicher reduzierter Geschwindigkeit verfahren werden, ohne dass weitere Überwachungen aktiv sind. Somit kann der Roboter, aus einer Sicherheitsverletzung heraus, manövriert werden oder z.B. Referenzfahrt und Bremsentest durchführen, um den sicheren Zustand wiederherzustellen.
Auswirkung: | Sicher reduzierte Geschwindigkeit wird aktiviert, die restlichen Fahrüberwachungen werden deaktiviert.
Abhilfe: | Verfahren in normaler Geschwindigkeit ist, erst nach der Deaktivierung des Freifahrens möglich.


Sicheres Überwachen des Roboters nicht möglich

Ursache: | Die SafeRDW kann den Roboter nicht sicher überwachen, da ihr dazu die Voraussetzungen fehlen.
Auswirkung: | Die Antriebsfreigabe wird gelöscht.
Abhilfe: | SafeRDW booten, korrekte Sicherheitsparameter laden, Roboter justieren, etc.


Sichere Ein-/Ausgänge fehlerhaft

Ursache: | Die sicheren Ein- und Ausgänge haben einen elektrischen Fehler (Querschluss, Kurzschluss, Zweikanaligkeitsverletzung).
Auswirkung: | Die Antriebsfreigabe wird gelöscht.
Abhilfe: | Verdrahtung überprüfen.


Steuerung wird heruntergefahren

Ursache: | Der Bediener hat das Herunterfahren der Roboter-Steuerung angefordert.
Auswirkung: | Die Roboter-Steuerung wird heruntergefahren.
Abhilfe: | Nach erfolgtem Herunterfahren kann die Roboter-Steuerung durch Einschalten wieder hochgefahren werden.


Absolutgenaues Modell nicht aktiv

Ursache: | Initialisierung des absolutgenauen Modells noch nicht durchgeführt.
Auswirkung: | Roboter lässt sich nicht Verfahren.
Abhilfe: | Wird automatisch gelöscht, wenn PidFile von der RDW geladen wird. Schlägt dies fehl, bleibt die Meldung stehen. Manuell kann das PidFile sowohl über Setzen der Variable $absreload auf TRUE in der Variablenanzeige nochmal geladen werden oder mittels des PidImport Knopf im PlugIn Robotdata auf die RDW geschrieben und ebenfalls nochmal geladen werden. Oder das absolutgenaue Modell ausschalten ($abs_accur = false in Steu\Mada\$option.dat), dann werden aber die Punkte aber nicht mehr genau angefahren!


<RDW Nummer>. RDW defekt. Abspeichern der Justage nicht mehr möglich.

Ursache: | Flash der RDW defekt.
Auswirkung: | Abspeichern der Justage nicht mehr möglich.
Abhilfe: | Roboter auf Home Position fahren, Steuerung runter fahren, RDW tauschen, Steuerung wieder hoch fahren, Experten Modus aktivieren, Softkey Inbetriebn. -> Roboterdaten drücken, anschließend Softkey Festplatte drücken, weil die richtigen Roboterdaten auf der Festplatte gespeichert sind; OK drücken, um die Daten an die neue RDW zu senden und als letztes neu Justieren.


Die maximale Tiefe der KIR-Abhängigkeiten wurde überschritten

Ursache: | Die Bewegungskooperation unterstützt verkettete Abhängigkeiten von bis zu drei Robotern. Es kann also R1 auf R2 geometrisch koppeln, während R2 auf R3 gekoppelt ist. Anbhängigkeiten höherer Ordnung führen zu einem Laufzeitfehler. Werden zeitsynchrone Bewegungen zwischen mehreren Gruppen mit geomtrischer Kooperation programmiert, so kann das die Anhängigkeitstiefe um 1 erhöhen.
Auswirkung: | Aktive Kommandos werden verriegelt.
Abhilfe: | Unnötige Verschachtelung von Abhängigkeiten vermeiden.


Lokaler Sicherheitsstop (QE)

Ursache:

2-Kanaligkeitsverletzung des Signals QE

Auswirkung:

Direktes Abschalten der Antriebe (Stop 0).

Abhilfe:

  • Beide Eingänge QE auf Low schalten, anschließend wieder auf High.

  • Eingänge überprüfen.


Fehler beim Lesen der IDF-Datei

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


SoftPLC: <variabler Textparameter>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Geschwindigeitsabsenkung Punkt <Punktname> <dummy> um <Reduzierung in %>.

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Einzelbremsensteuerung für Zusatzachsen nicht aktiv

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Achsankopplung nicht möglich ( -> DSE/PM-Kanal Zuordnung )

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Ankopplungsprozess aktiv

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler beim Ankoppeln

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler beim Abkoppeln

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Achsnummer> abgekoppelte Zusatzachse, AJOG unzulässig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Achsnummer> abgekoppelte Zusatzachse, MOVE unzulässig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Achsnummer> abgekoppelte Zusatzachse, JUSTAGE unzulässig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


ASYPTP-Befehl enthält abgekoppelte Zusatzachse(n)

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Wert von $ASYNC_AXIS enthält abgekoppelte Zusatzachsen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Trace Puffer leer, starte Rückwärtsinterpretation

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kreiswinkel nicht berücksichtigt

Auswirkung:

Keine.


Fehler Zeilenanalyse bzw. Rückübersetzer

Ursache: | Meldung wird demnächst gelöscht
Auswirkung: | Keine


Falsches Zugriffsrecht

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Segmentwechsel fehlerhaft

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Segmentwechsel erfolgreich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


CONTROL : <DEVCONTROL Nummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler bei allocate device <Mac-ID>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Neuer Satz ist keine Deklaration

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Binäres Ausgabesignal erwartet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Keine korrekte Initialisierung

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehlerhafter Initialisierungswert

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Unterschiedliche Typen bei Initialwertänderung

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


SUB kann nicht an SRC gebunden werden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kein Systemunterprogramm

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Keine Systemfunktion

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Import-Schnittstelle nicht korrekt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Modul ist von einem anderen Prozess belegt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Einfügen vor erstem Satz unzulässig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler im DEFDAT, einfügen nicht erfolgt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Fehler im globalen DEF/DEFFCT

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


DEF/DEFFCT nicht erlaubt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


EXT/EXTFCT/IMPORT hier unzulässig

Ursache: | Eine "EXT", EXTFCT" oder "IMPORT"-Anweisung steht an unzulässiger Stelle.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm entsprechend ändern.


Fehler beim Eintragen der Datenliste

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Informationsverlust bei Typwandlung möglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Compileort nicht mit Aufrufort verträglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kein Objektname

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Satznummer erwartet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Satznummer muss positiv sein

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Attributname muss folgen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Konstante für Schlüssel muss folgen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


INFO erwartet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


MESSAGE erwartet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Speicherbedarf für dynamische Variable zu groß

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Selektion hier nicht erlaubt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Felder als ganzes dürfen nicht selektiert werden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Konstante erwartet

Ursache: | Es wird die Angabe einer Konstanten erwartet.
Auswirkung: | Das Programm ist nicht ausführbar.
Abhilfe: | Programm ändern.


Programm nicht verfügbar

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kein Fehler

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Hierarchienummer befindet sich nicht im Suchpfad

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Analogausgabesignal erwartet

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Teachen für Typ nicht erlaubt

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Satz neu übersetzen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Keine globale Prozedur vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Überschleifparameter sind im Spline verboten

Ursache: | Es wurden Überschleifparameter innerhalb eines Spline Blocks programmiert.
Auswirkung: | Syntaxfehler im Modul
Abhilfe: | Programm entsprechend ändern.


IMPORT auf globale Variablen nicht möglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Distance Trigger in Splinebewegung nicht zulaessig

Ursache:

Distance Trigger in Spline-Bewegung


<Objektname> Satz nicht vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Eingabesatz zu lang

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Eingabesatz zu lang oder falsch abgeschlossen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Feld enthält zu viele Elemente

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> kein dynamischer Speicher frei

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Satz kann nicht formatiert werden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Satz kann nicht rückübersetzt werden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Schachtelungstiefe zu groß

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> vergrößern der Bindeliste nicht möglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Speichermangel: öffnen nicht möglich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> kein physikalischer Speicher frei

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> kein virtueller Speicher frei

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> Fehler in Speicherverwaltung <Fehlernummer>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Interner Fehler (Datei: <Dateiname>, Zeile: <Zeilennummer>, Wert: <Rückgabewert>)

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Der Verriegelungsbereich <ws name> wurde manuell freigegeben

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Dateiformat>: Aufzeichnung <Recordname> wird verworfen

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kein virtueller Speicher mehr vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kein physikalischer Speicher mehr vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> wurde vergrößert. Modul ist bereit

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> hat max. Limit erreicht. Abwahl erforderlich

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Objektname> könnte nicht vergrößert werden. Kein virtueller Speicher mehr vorhanden

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Dateiformat>: Fehler beim Laden von <Recordname>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Dateiformat>: Fehler beim Speichern von <Recordname>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<Dateiformat>: Kommando nicht möglich für <Recordname>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


MDR: SAK-Fahrt nicht zulässig falls MDR-Base ungültig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


MDR: Bewegetes MDR-base nicht zulässig

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Bevorstehende Kollision mit Roboter <Robotername>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kollisionsvermeidung: Unbekanntes Werkzeug: <Werkzeugname>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kollisionsvermeidung: Unbekanntes Ziel <Bestimmungsortname>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Kollisionsvermeidung Versionenkonflikt mit Roboter <Robotername>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Inkonsistente Sync Liste gefunden

Ursache: | Die Liste der Steuerungen, welche an der Synchronisation teilnehmen, ist nicht konsistent unter den Steuerungen.
Auswirkung: | Programmausführung ist gestoppt.
Abhilfe: | Stellen Sie sicher, dass die Liste der an der Synchronisation teilnehmenden Steuerungen auf allen Steuerungen gleich ist.


LK Master (<Master Name oder IP-Adresse>) fehlt in Synchronisationsliste

Ursache: | Es wurde eine zeitsynchrone Bewegung programmiert, an welcher der LK() Master nicht teilnimmt
Auswirkung: | Bahntreuer Stop
Abhilfe: | LK() Master zeitsynchron programmieren


Maximale Anzahl gelichzeitig aktivierte Zykflags. Max 32

Ursache:

Die Anzahl der aktivierten Zykflags 32 wurde überschritten.

Auswirkung:

Bei Kommandobearbeitung:- Kommando wird nicht bearbeitet.
Bei Programmbearbeitung:- Rampen Stop.

  • Verriegelung aller aktiven Kommandos.


Zeitüberschreitung beim Abschalten der Kraftregelung <Achsnummer>

Ursache: | Die Kraftregelung auf der DSE schaltet nicht innerhalb der vorgegebenen Zeit ab. Mögliche Ursache könnte ein fehlendes Sensorsignal sein.
Auswirkung: | Drehzahl Stop
Abhilfe: | Hardware (DSE, RDW und Kraftsensor) prüfen.


Quitt Geberleitung defekt ext. posinput <Achsnummer> <Zusatzinfo bei speziellen Gebern>

Ursache:

  • Folgemeldung der Zustandsmeldung "Geberleitung defekt ext. posinput".

  • Zyklisch.

Auswirkung:

  • Bahntreuer Stop.

  • Ausgang $ALARM_STOP 0-Signal.

  • Verriegelung aller aktiven Kommandos.

Abhilfe:

Meldung quittieren.


MDR: IPO_MODE TCP nicht erlaubt

Ursache: | IPO_MODE TCP wurde bei aktivem "MDR-Base" gesetzt
Auswirkung: | Roboter stoppt.
Abhilfe: | IPO_MODE TCP nicht bei aktivem "MDR-Base" setzen.


Quitt Stellgröße Kraftregler <Achsnummer>

Ursache:

Dies ist die Folgemeldung zur Meldung: "Stellgröße Kraftregler"

  • Kraftsensor Signal passt nicht zur Bewegung.

  • Fehlertyp Nr.1: Istkraft ändert sich und Position bleibt konstant.

  • Fehlertyp Nr.2: Position ändert sich und Istkraft bleibt konstant.

  • Fehlertyp Nr.3: Die Zange öffnet sich weiter als die zu FORCE_LIM korrespondierende Position.

  • Diese Überwachungen sind nur während der Kraftregelung aktiv!

Auswirkung:

  • Generatorischer Stop.

  • Aktive Kommandos verriegelt.

  • Ausgang "ALARM_STOP" weist Signallevel 0 auf.

Abhilfe:

  • Meldung quittieren.

  • Kraftsensor prüfen.

  • Kraftsensor Kabel prüfen.

  • RDW Aufsteckkarte prüfen.

Hinweis:
Überwachungen sind nur während Kraftregelung aktiv!


E-Stop with maximum braking requested by <Machine name or IP Address>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Workspace state data file not available

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


Invalid workspace state data in the file. Checksum Error.

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


File based workspace recovery failed. Switching to communication method.

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


State of workspace <workspace name> is invalid or rejected

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


Ownership of <Workspace name> lost - (cold booted controller)

Zu diesem Thema ist keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


Variable(n) größer als der verfügbare Puffer

Ursache:

Im Falle von Cast_TO, Cast_From oder sprintf, cread, cwrite ... kann es vorkommen, dass die gelesenen Variablen die maximal Größe des Puffers überschreiten.

Auswirkung:

  • Interpreter Stop

  • Die Variable kann nicht in den Puffer geschrieben werden.

Abhilfe:

Puffer vergrößern oder andere Variablen verwenden.


Variablentyp nicht zulässig

Ursache:

Ungültiger Datentyp für die Verwendung im Interpreter für dieses Kommando.

Auswirkung:

  • Interpreter Stop

  • Anweisung wird nicht ausgeführt

Abhilfe:

Anderen Datentyp verwenden.


CWrite: externe Funktion

CWrite: externe Funktion <<Name der ext. Funktion>> nicht verfügbar

Ursache: | Der externe Funktions-Aufruf, welcher sich in einem nachgeladenen Modul befinden sollte, konnte nicht in der Symboltabelle von vxWorks gefunden werden.
Auswirkung: | CWrite-Aufruf kann nicht ausgeführt werden.
Abhilfe: | Hersteller des externen Moduls kontaktieren bzw. Name der externen Funktion ändern.


Quitt Sichere Ein-/Ausgänge fehlerhaft

Ursache: | Die sicheren Ein- und Ausgänge haben einen elektrischen Fehler (Querschluss, Kurzschluss, Zweikanaligkeitsverletzung).
Auswirkung: | Die Antriebsfreigabe wird gelöscht.
Abhilfe: | Verdrahtung überprüfen.


Stop wegen Ueberschreitung von $SPEED_LIMIT_TEACH_MODE

Ursache: | Die Geschwindigkeit des TCP oder des Flansch wurde beim Programmbetrieb in T1 oder beim Handverfahren $SPEED_LIMIT_TEACH_MODE überschritten.
Auswirkung: | Bahntreuer Not-Aus


Maximale Schachtelungstiefe für CWrite erreicht

Ursache:

CWrite auf EXT_FCT Kanal kann maximal drei Schachtelungsebenen haben.

Auswirkung:

Interpreter Stop

Abhilfe:

  • Satzanwahl

  • Programm Reset


TRIGGER im SPLINE muss einem Bewegungs-Segment zugeordnet sein

Ursache: | Es wurde ein TRIGGER im SPLINE programmiert, auf den kein Bewegungs-Segment, sondern das ENDSPLINE-Statement folgt.
Auswirkung: | Programm Stopp
Abhilfe: | Falls der Trigger für den Satz nach dem Spline Block bestimmt ist, dann den Trigger hinter den Spline Block verschieben. Anderenfalls noch eine Bewegung zwischen Trigger und ENDSPLINE einfügen.


Funktion <Funktionsname> im <Trigger oder WITH> darf NICHT sichtbar sein

Ursache:

Wenn sich die Implementierungen von GETPATH(), GETBASE() oder GETVEL() in einem sichtbaren Modul befinden, erscheint diese Fehlermeldung.

Beispiel:
TRIGGER WHEN PATH = GETPATH() DELAY=0 DO $OUT[1]=TRUE
LIN XP1
SPLINE WITH $BASE = GETBASE()
XP2 WITH $VEL=GETVEL()
XP3
ENDSPLINE

Auswirkung:

Laufzeitfehler des Programms

Abhilfe:

  • Meldung quittieren

  • Programm entsprechend korrigieren.


Modul <Modulname> Zeile <Zeilennummer>: Anweisung im <Trigger oder WITH> Kontext nicht erlaubt

Ursache:

Eine Funktion, die im Vorlauf innerhalb einer Triggeranweisung oder in der WITH-Liste eines Splines aufgerufen wird, darf nur ganz bestimmte Anweisungen enthalten.

Auswirkung:

Laufzeitfehler und Programm Stopp

Abhilfe:

  • Meldung quittieren.

  • Anweisung an erlaubte Position verschieben.


Erster Zielpunkt im Spline muss vollständig initialisiert sein

Ursache:

xp1 darf nicht als erster Punkt im Spline programmiert werden. An erster Stelle muss immer ein vollständig initialisiertes Aggregat stehen. Die Lücken der folgenden Punkte werden dann durch die Werte ihrer Vorgänger initialisiert. XP2 ist also zulässig.

Beispiel:
DECL E6POS xp1 {X 1500, Y 0}
DECL E6POS xp2 {X 1200, Z 1800}
spline
spl xp1
spl xp2
endspline

Auswirkung:

Interpreter Stop

Abhilfe:

  • Programm entsprechend korrigieren

  • Meldung quittieren.


Abweichung Resolver Abschaltposition von aktueller Position <Achsnummer>

Ursache:

Abschaltposition des Resolvers stimmt nicht mit der aktuellen Resolverposition überein.

Auswirkung:

Justage dieser Achse wird verworfen.

Abhilfe:

  • Bremsen überprüfen

  • Neu Justieren


<DSE Nummer>. DSE: interner Fehler Nummer <Interner Fehlercode>

Ursache:

Interner Fehlercode:
1: Timeout des RDW Befehls um die RDW Tabelle auszulesen
2: Checksumme der Resolver Ausschaltposition ist nicht gültig

Dieser interne Fehler kann verursacht werden durch:

  • Lose Steckverbindung DSE-RDW Kabel

  • Defekte RDW, DSE, MFC oder defektes DSE-RDW Kabel

  • Software Fehler

Auswirkung:

Eventuell Justageverlust

Abhilfe:

  • Hardware überprüfen: RDW, DSE, MFC und DSE-RDW Kabel.

  • Eventuell die letzte Bedienhandlung wiederholen.

  • Logbuch an Entwicklung Antriebstechnik weiterleiten.


Quitt Lokaler Sicherheitsstop (QE)

Ursache:

2-Kanaligkeitsverletzung des Signals QE

Auswirkung:

Direktes Abschalten der Antriebe (Stop 0).

Abhilfe:

  • Beide Eingänge QE auf Low schalten, anschließend wieder auf High.

  • Eingänge überprüfen.


<Variable/Zuweisung> wird in dieser Version nicht mehr unterstützt

Ursache: | Die angegebene Funktionalität wird in der vorliegenden Software-Version nicht mehr unterstützt. In der Regel wurde diese Funktionalität nicht mehr verwendet oder durch eine bessere Funktion im System ersetzt. Schauen sie in das aktuellste Programmierhandbuch, um einen angemessenen Ersatz zu finden.
Auswirkung: | Das Roboterprogramm wird angehalten. Beim Wiederanstarten wird die Meldung erneut kommen.
Abhilfe: | Die entsprechende Anweisung muß aus dem Programm entfernt werden, da sie keine legele KRL-Anweisung mehr ist.


Datei gelöscht <Filename>

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Datei geändert

Datei geändert <Filename>

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Steuerungskaltstart

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


<ASCII-String><ASCII-String><ASCII-String>

Ursache:

Zu diesem Thema ist keine Online-Hilfe vorhanden.
Informationen finden Sie in den Bedienungshandbüchern.


Interner Fehler (Meldungsdaten undefiniert)

Ursache:

Die Meldungsdaten wurden nicht korrekt gesetzt.


<Kommandoname> <Aktion>

Ursache:

  • OBJH - Kommando Ausführung beendet

  • Kommandobearbeitung

Auswirkung:

  • Keine


Fehler beim Lesen der INI-Datei <Dateiname> <Interner Fehlercode>

Ursache: | Fehlerhafte INI-Datei. Bei Systemstart
Auswirkung: | Verriegelung aller Kommandos
Abhilfe: | INI-Datei korrigieren


KR C1 Online-Hilfe

Sorry...

... zu diesem Thema ist leider keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.