KR C1 Online-Help Technologien

KR C
Online-Help

Rel. 4.0.2

Basisbefehle

KUKA Roboter GmbH
Bluecherstrasse 144
D-86165 Augsburg
Copyright © 1995 -2004


ANOUT-Befehl, statisch

Programmierung statischer ANOUT-Befehl

ANOUT [CHANNEL_1] =

Beschreibung

Nummer des statischen Analogkanals.

Wertebereich

Es können 8 analoge Ausgänge programmgesteuert gesetzt werden.

Hinweis:
Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" besonders gekennzeichnet.

= [0.75]

Beschreibung

Normierte statische Ausgangsgröße am Analogkanal.

Wertebereich

0 ... 1 in Schritten von 0.01

Die Ausgabe ist abhängig vom Bereich des verwendeten Analogmoduls (z. B. liefert ein 10V-Modul bei einem eingestellten Wert von 0.5 eine Ausgangsspannung von 5 V am Analogkanal).


ANOUT-Befehl, zyklisch

Programmierung zyklischer ANOUT-Befehl

ANOUT [ON]

Beschreibung

Ein- bzw. Ausschalten des jeweiligen zyklischen Analogkanals.

Wertebereich

ON / OFF

[CHANNEL 1] =

Beschreibung

Nummer des zyklischen Analogkanals.

Wertebereich

Es können 8 analoge Ausgänge programmgesteuert gesetzt werden.
Davon dürfen bis zu 4 Ausgänge für die zyklischen Analogausgabe verwendet werden.

= [1.15] *

Beschreibung

Multiplikationsfaktor für die Ausgangsgröße des zyklischen Analogkanals, mit dem Geschwindigkeits- bzw. Technologieparameter multipliziert werden.

Wertebereich

0 ... 10 in Schritten von 0.01

* [VEL_ACT]

Beschreibung

Technologische Verknüpfung mit dem zyklischen Analogkanal.

Wertebereich

Die Analogausgabe erfolgt abhängig von der Geschwindigkeit (VEL_ACT) oder gesteuert über Funktionsgenerator (TECH_VAL1 - 8).

Offset = [0.2]

Beschreibung

Auf das Analogmodul normierte räumliche Verschiebung des Geschwindigkeits- bzw. Technologieprofils; vertikal nach oben (+) oder unten (-) - (normierte Verschiebung des Analogkanalpegels).

Wertebereich

-1 ... +1

Delay = [-0.02] [sec]

Beschreibung

Zeitliche Verschiebung des Geschwindigkeits- bzw. Technologieprofils in negativer oder positiver Richtung (zeitliche Verschiebung der zyklischen Analogausgabe).

Wertebereich

- 0.2 .... 0.5 [sec]


An- und Abkoppeln von Interbussegmenten

Programmierung An- und Abkoppeln von Interbus-Segmenten

Befehl zur An- und Abkopplung von Inberbus-Segmenten. Diese Segmente müssen in der Datei "iosys.ini" konfiguriert sein. Die Datei Interbus.ini bietet in der Sektion [NAMES] die Möglichkeit, Namen für die einzelnen Segmente zu vergeben

IBUS [ON]

Beschreibung

Ankoppeln eines Interbus-Segmentes.

Wertebereich

  • [ON] Ankoppeln eines Interbus-Segmentes.

  • [OFF] Abkoppeln eines Interbus-Segmentes .


CIRC-Bewegung

Programmierung CIRC-Bewegung

CIRC-Bewegungen werden für Bearbeitungsvorgänge mit vorgegebener Geschwindigkeit auf einer Kreisbahn verwendet. Dabei bewegt sich der Bezugspunkt des Werkzeuges bzw. Werkstückes auf einem Kreisbogen. Die Bahn wird durch Start-, Hilfs- und Endpunkt beschrieben.

Nur der Bezugspunkt folgt der programmierten Bahn. Das Werkzeug bzw. Werkstück selbst kann seine Orientierung während der Bewegung ändern.
Start- Hilfs- und Endpunkt liegen auf einer Ebene im Raum. Zur möglichst exakten Bestimmung der Ebene sollte der Hilfspunkt nicht zu nahe am Start- bzw. Zielpunkt liegen.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.

Wertebereich

CIRC, PTP, LIN.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1] [P2]

Beschreibung

Name von Hilfspunkt [P1] und Zielpunkt [P2], frei programmierbar, in denen die jeweiligen Koordinaten der Punkte gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Die Koordinaten des Hilfspunktes müssen vor Abschluß des CIRC-Befehls manuell gespeichert werden; es erfolgt keine automatische Übernahme. Falls die Festlegung der Punktkoordinaten erst zu einem späteren Zeitpunkt erfolgen soll, kann "TouchupHP" zunächst an beliebiger Position erfolgen.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P2] (Zielpunkt) bewegt, erscheint im Zustandsfenster eine Parameterliste für Tool, Base und externes Werkzeug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen.

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion".
Die Parameter für das Überschleifen können im Feld [CPDAT1] festgelegt werden. CIRC-Bewegungen werden mit C_DIS überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [0.5] m/s

Beschreibung

Bahngeschwindigkeit in Meter pro Sekunde [m/s].

Wertebereich

0,001 ... 2 m/s (Voreinstellung 2 m/s).

[CPDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [CPDAT1] bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Überschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Überschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Orientierungsführung
Hinweis:
Das Eingabefeld "Orientierungsführung" steht erst ab KR C Software Rel. 5.2 zur Verfügung.

[Standard]
Die Orientierungsführung wird mit der sogenannten 2-Winkel Methode durchgeführt.
Dabei wird die Stoßrichtung des Werkzeugs (X-Achse des Toolsystems) am Startpunkt linear in die des Zielpunktes überführt (durch schwenken).
Zusätzlich wird noch um diese Stoßrichtung gedreht, so dass die programmierte Orientierung am Zielpunkt erreicht wird (durch drehen).

[Hand PTP]
Es werden die Handachswinkel vom Startpunkt linear in die des Zielpunktes überführt (Status der Hand am Zielpunkt wird berücksichtigt).
Die Bahn wird mittels der Grundachsen gehalten. Damit kann die Handsingularität während einer CP-Bewegung vermieden werden.

[Konstante Orientierung]
Die Startorientierung wird relativ zum Bezugssystem konstant gehalten.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


Kommentare

Programmierung von Kommentaren

Textfeld zur Eingabe eines Kommentars.

; [hier steht ein beliebiger Text]

Beschreibung

Es steht ein Textfeld für einen Kommentar zur Verfügung.

Wertebereich

Es kann ein freier Text eingegeben werden.


Kommentare mit Stempel

Programmierung von Kommentaren mit Stempel

; 9.1.01 15:40 NAME: [Peter Muster]

Beschreibung

Datum, Uhrzeit und Name des Bearbeiters, der die Änderung durchgeführt hat.

Wertebereich

Dieser links stehende Teil des Inline-Formulars wird automatisch erstellt. Bei einer Änderung wird die Uhrzeit und das Datum nicht aktualisiert. Es muß dann ein neuer Stempel eingefügt werden.

In das Eingabefeld wird der Name des Bearbeiters eingetragen.

CHANGES: [hier steht ein beliebiger Text]

Beschreibung

Eingabe einer Kurzbeschreibung der durchgeführten Änderungen.

Wertebereich

Es kann ein freier Text eingegeben werden.


LIN-Bewegung

Programmierung LIN-Bewegung

LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet. Dabei werden die Roboterachsen so aufeinander abgestimmt, daß der Werkzeug- bzw. Werkstück-Bezugspunkt entlang einer Geraden zum Zielpunkt bewegt wird.

Nur der Bezugspunkt folgt der programmierten Bahn. Das Werkzeug bzw. Werkstück selbst kann seine Orientierung während der Bewegung ändern.

[LIN]

Beschreibung

Auswahl der Bewegungsart.

Wertebereich

LIN, CIRC, PTP.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1]

Beschreibung

Name des Zielpunktes, frei programmierbar, in dem die Koordinaten des Punktes gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P1] bewegt, erscheint im Zustandsfenster eine Parameterliste für Tool, Base und externes Werkzeug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen.

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion".
Die Parameter für das Überschleifen können im Feld CPDAT1 festgelegt werden. LIN-Bewegungen werden mit "C_DIS" überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [0.5] m/s

Beschreibung

Bahngeschwindigkeit in Meter pro Sekunde [m/s].

Wertebereich

0,001 ... 2 m/s (Voreinstellung 2 m/s).

[CPDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.
Wird der Cursor in das Feld CPDAT1 bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Überschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Überschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Orientierungsführung
Hinweis:
Das Eingabefeld "Orientierungsführung" steht erst ab KR C Software Rel. 5.2 zur Verfügung.

[Standard]
Die Orientierungsführung wird mit der sogenannten 2-Winkel- Methode durchgeführt.
Dabei wird die Stoßrichtung des Werkzeugs (X-Achse des Toolsystems) am Startpunkt linear in die des Zielpunktes überführt (durch schwenken).
Zusätzlich wird noch um diese Stoßrichtung gedreht, so daß die programmierte Orientierung am Zielpunkt erreicht wird (durch drehen).

[Hand PTP]
Es werden die Handachswinkel vom Startpunkt linear in die des Zielpunktes überführt (Status der Hand am Zielpunkt wird berücksichtigt).
Die Bahn wird mittels der Grundachsen gehalten.
Damit kann die Handsingularität während einer CP-Bewegung vermieden werden.

[Konstante Orientierung]
Die Startorientierung wird relativ zum Bezugssystem konstant gehalten.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


PTP-Bewegung

Programmierung PTP-Bewegung

PTP ist eine Punkt-zu-Punkt-Bewegung. Die Positionierung des Robotersystems erfolgt hierbei auf dem schnellsten Weg zwischen zwei Punkten. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

Die PTP-Bewegung verläuft auf einer vom Roboter definierten Bahn und ist nicht exakt vorhersehbar! Um mögliche Kollisionen zu vermeiden, sollte diese Bahn in der Nähe von Hindernissen zunächst mit vermindertem Programm-Override (POV) abgefahren werden!

[PTP]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

PTP, LIN, CIRC.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1]

Beschreibung

Name des Zielpunktes, frei programmierbar, in dem die Koordinaten des Punktes gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P1] bewegt, erscheint im Zustandsfenster eine Parameterliste für Tool, Base und externes Werkzeug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion". PTP-Bewegungen werden mit "C_PTP" überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [100] %

Beschreibung

Geschwindigkeit, mit der die Bewegung durchgeführt wird. Bei PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Wertebereich

1 bis 100% vom Maximalwert (Voreinstellung 100%).

[PDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Überschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Überschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


Momentenüberwachung

Programmierung
Momentenüberwachung

Die Kollisionsüberwachung dient zur Reduzierung von Schäden. Je feinfühliger der Überwachungsschlauch eingestellt ist, desto geringer fallen eventuelle Beschädigung bei Kollisionen aus. Maßgebend sind die gefahrene Geschwindigkeit und die aufgetretenen Momente.

Optimale Kollisionsüberwachung erfordert korrekt ermittelte Lastdaten und einen an die jeweilige Bewegung angepaßten Überwachungsschlauch. Die folgenden Inlineformulare bieten dem Anwender die Möglichkeit seine Programme diesbezüglich zu optimieren.

[SetDefault]

Beschreibung

Die Überwachung wird ausgeschaltet, der Standardwert des Überwachungsschlauchs beträgt im Normalfall 200%.

[SetLimits]

Beschreibung

Weicht in diesem Beispiel das Istmoment um mehr als +/- 50 % des Maximalmoments vom errechneten Sollmoment ab, wird der Roboter mit entsprechender Meldung angehalten. Je kleiner die Werte desto sensibler die Überwachung. Mit Einstellung 200% ist die Überwachung abgeschaltet.

Wertebereich

1 % bis 200 % einzeln einstellbar für Achse A1 bis Achse A6.
Hinweis:
Für Zusatzachsen besteht keine Überwachungsmöglichkeit.

Reset, Satzanwahl und Programmabwahl setzten die eingestellten Grenzen auf Defaultwerte zurück.


OUT AT POINT-Befehl

Programmierung
OUT AT POINT - Schaltfunktion

Dieser Befehl setzt einen Ausgang auf TRUE oder FALSE.

OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.

Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inline-Formulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Die Ausgangsbearbeitung erfolgt im Genauhalt.

  • CONT : Die Ausgangsbearbeitung erfolgt in Überschleifmitte zwischen zwei Bewegungspunkten.


OUT-Befehl

Programmierung
OUT - Schaltfunktion

Dieser Befehl setzt einen Ausgang auf TRUE oder FALSE.

OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inline-Formulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Der Ausgangsbefehl erzwingt einen Vorlaufstopp.

  • CONT : Die Ausgangsbearbeitung erfolgt im Vorlauf.


PULSE-Befehl

Programmierung
PULSE - Funktion

Diese Funktion setzt für eine anzugebende Zeitdauer einen Ausgang auf TRUE oder FALSE.

PULSE [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inline-Formulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Der Ausgangsbefehl erzwingt einen Vorlaufstopp.

  • CONT : Die Ausgangsbearbeitung erfolgt im Vorlauf.

Time= [0.2] sec

Beschreibung

Zeitdauer des Impuls.

Wertebereich

0.1 bis 3 Sekunden. Die Schrittweite beträgt 0.1 Sekunden.


SYNOUT-Befehl

Programmierung SYN OUT - Befehl

"SYN OUT" ist eine bahnabhängige Schaltfunktion.

Beispiel: Bei einer Klebe-Applikation soll an einem bestimmten Punkt der Kleberauftrag beginnen. Bei A (Ausgang1=TRUE) wird die Klebepistole aktiviert. Mit PATH=10mm ist der Punkt definiert, an dem der Kleberauftrag beginnen soll. Die Klebepistole benötigt eine bestimmte Vorlaufzeit bis zum Kleberaustritt, in diesem Beispiel 15 ms. Deshalb wird Delay= -15 ms gesetzt.

SYN OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1 ... 1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ausgang]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inline-Formulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[PATH]

Beschreibung

Position des Schaltvorgangs.

Wertebereich

  • START
    D     ie Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

  • END
    Die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

  • PATH
    Die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder ist bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe ausdehnbar.

Dieses Feld ist nur vorhanden wenn im Feld Position "PATH" selektiert wurde.

= [10] mm

Dieses Feld ist nur vorhanden wenn im Feld Position "PATH" selektiert wurde.

Beschreibung

  • Verschiebung (Weg) der bahnbezogenen Ausgangsbearbeitung.

Wertebereich

Die Verschiebung bei Bahnsätzen (LIN, CIRC) erfolgt in negativer oder positiver Richtung vom Zielpunkt. Die Schrittweite der Verschiebung beträgt 1mm.

Die Startposition bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) kann nicht überschritten werden.

Delay= [-15] ms

Beschreibung

Zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Wertebereich

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung. Die Schrittweite der Verschiebung beträgt 1 ms.

Die Startposition in negativer Richtung bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) in positiver Richtung kann nicht überschritten werden.


SYNPULSE-Befehl

Programmierung SYNPULSE-Befehl

SYN PULSE [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung.
Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.
Anzeige siehe Menü 'Digitale Ausgänge'.
Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Vom System verwendete Ausgänge sind im Menü 'digitale Ausgänge' gekennzeichnet.

[Ventil]

Beschreibung

Hier kann ein symbolischer Name eingetragen werden.

Wertebereich

Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Das Namensfeld ist gegen unbeabsichtigtes Beschreiben geschützt. Erst nachdem in der Softkeyleiste der Softkey 'Langtext' betätigt wurde, ist dieser Schreibschutz aufgehoben.
Nach dem Schließen des Inline-Formulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Über dieses Auswahlmenü wird ein digitaler Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • [TRUE] Ausgang wird auf High-Pegel gesetzt.

  • [FALSE] Ausgang wird auf Low-Pegel gesetzt.

Time= [0.1] sec

Beschreibung

Pulsdauer

Wertebereich

  • 0.1 bis 3 Sekunden

  • Schrittweite 0.1 Sekunden.

at [START]

Beschreibung

Position (wegbezogen) des bahnbezogenen Schaltvorgangs.

Wertebereich

  • [START] Die Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

  • [END] Die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

  • [PATH] Die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe.

Delay= [0] ms

Beschreibung

Zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Wertebereich

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung.
Die Startposition in negativer Richtung bzw. die Genauhaltgrenze nach überschliffenen Sätzen in positiver Richtung kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1 ms.


WAIT-Befehl

Programmierung WAIT-Befehl

Dieser Wartezeit-Befehl löst einen Vorlaufstopp aus.

WAIT Time= [1.25] sec

Beschreibung

Programmierung einer Zeit, die gewartet werden soll.

Wertebereich

0 bis 30 Sekunden.


WAIT FOR-Befehl

Programmierung WAIT FOR - Befehl

Hinweis: Bis KR C Rel. 4.x

[WAIT FOR IN]

Beschreibung

Warte auf Eingang (bzw. Ausgang) mit den nachfolgenden Parametern.

Wertebereich

  • WAIT FOR IN warten auf Eingang

  • WAIT FOR OUT warten auf Ausgang

[10]

Beschreibung

Nummer des Eingangs oder Ausgangs, auf den gewartet wird.

Wertebereich

Eingänge können einem Bereich von 1 bis 1026 gewählt werden, Ausgänge von 1 bis 1024. (Es besteht die Möglichkeit, die Anzahlt der Ein-/Ausgänge auf bis zu 4096 zu erhöhen; dann ist 4096 die Obergrenze).

  • Eingang 1025 ist immer TRUE.

  • Eingang 1026 ist immer FALSE.

[Ventil]

Beschreibung

Langtext-Name, der zu dem ausgewählten Eingang projektiert ist.

Wertebereich

Frei konfigurierbarer Name, der in der Ein-/Ausgangsübersicht vergeben werden kann.

State= [TRUE]

Beschreibung

Warten auf den Zustand TRUE.

Wertebereich

Einstellung, ob auf den Pegel TRUE oder FALSE gewartet werden soll.

[CONT]

Beschreibung

Die Warteanweisung wird im Vorlauf bearbeitet.

Wertebereich

Die Auswahl von CONT bewirkt, dass ein CONTINUE vor die WAIT-Anweisung gestellt wird. Ein Vorlaufstopp wird dann nicht ausgeführt und die Anweisung zur Vorlaufzeit bearbeitet.


WAIT FOR-Befehl

Programmierung WAIT FOR-Befehl

Hinweis: Ab KR C - Software Rel. 5.2

  • Die einzelnen beschreibbaren Felder des erweiterten "WAIT FOR"-Befehls verfügen jeweils über eigene Softkey-Leisten, die dem Anwender die Möglichkeit geben mehrere Operanden miteinander zu verknüpfen.

  • Die entsprechende Softkeyleiste erscheint, wenn der Cursor sich jeweiligen Eingabefeld befindet.

  • Das ILF (Inline-Formular) lässt sich dynamisch erweitern; deshalb unterscheidet sich die Belegung der Softkeyleiste entsprechend den Eingabefeldern.

  • Eingefügt wird nach der Cursorposition. Dynamische Erweiterungen sind löschbar.

  • Zur Vereinfachung der Programmierung sind Klammerebenen vorgegeben und einige Eingaben sind nur über Softkeys programmierbar.

[Softkeyleiste 1.Feld]

Beschreibung

  • Die Softkeyleiste des 1. Feldes erlaubt das Togglen eines "NOT"-Operators um die boolsche Verknüfung zu negieren ("Softkey "Not").

  • Die Eingabe in dieses Feld erfolgt über Softkey "Not".

  • Weiter ist das Einfügen eines weiteren Klammerausdrucks (Term) möglich.

  • Das Einfügen erfolgt nach der aktuellen Cursorposition.

  • Die Verknüpfung erfolgt wahlweise mit "AND"-, "OR"- oder "EXOR"-Operatoren.

[Softkeyleiste 2. Feld]

Beschreibung

  • Die Softkeyleiste des 2. Feldes erlaubt das Toggeln eines "NOT"-Operators um die boolesche Verknüpfung zu negieren ("Softkey "Not").

  • Die Eingabe in dieses Feld erfolgt über Softkey "Not" innerhalb der Klammer.

  • Weiter ist das Einfügen eines weiteren Ausdrucks innerhalb der Klammer möglich.

  • Eingefügt wird nach der aktuellen Cursorposition.

  • Die Verknüpfung erfolgt wahlweise mit "AND"-, "OR"- oder "EXOR"-Operatoren.

[Softkeyleiste 3. Feld]

Beschreibung

Die Softkeyleiste des 3. Feldes ermöglicht das Toggeln zwischen einer

  • Listbox mit vorgegebenen "systemspezifischen" Einträgen (SK) und einer

  • Listbox mit "anwenderspezifischen" Einträgen.

Systemspezifische Einträge:

  • IN : Warte auf Eingang, Bereich von 1 bis 1024, optional bis 4096

  • OUT : Warte auf Ausgang, Bereich von 1 bis 1024, optional bis 4096

  • CYCFLAG : Wartebedingung für zyklische Flags, Bereich 1 bis 32

  • TIMER : Wartebedingung für Timerflags Bereich 1 bis 32

  • FLAG: Wartebedingung für Flags, Bereich 1 bis 1024

Wird ein systemspezifischer Eintrag gewählt, erfolgt die numerische Eingabe des Wertebereiches und die Anzeige des Langtextnamens in den nächsten beiden Eingabefeldern.

Info: Experten haben die Möglichkeiten den Langtextnamen im ILF zu ändern.

Achtung:

Die Eingänge

[1025] = TRUE

und

[1026] = FALSE

können nicht geändert werden!

Anwenderspezifische Einträge:
Die Liste mit den anwenderspezifischen Einträgen ist in der Datei

C:\KRC\ROBOT\INIT\WAIT_UserList.ini

unter der Sektion [USERLIST] zu erstellen.

Item1=Variable_A
Item2=Variable_B
Die Einträge Item1 bis ItemX müssen in aufsteigender Reihenfolge belegt sein.

Die Variablen sind zu deklarieren und zu initialisieren.

Soweit möglich erfolgt eine Syntax-Überprüfung der anwenderspezifischen Eingaben bereits im Inline-Formular (ILF).

Über "MONITOR=TRUE/FALSE" in der Sektion [USERMONITOR] läßt sich diese Syntax-Überprüfung des ILF's ein- bzw. ausschalten.
Wird ein anwenderspezifischer Eintrag gewählt, erfolgt die Eingabe der booleschen Beziehung im darauf folgenden Eingabefeld.

[Softkeyleiste erweitertes ILF]

Beschreibung

Die Softkeyleiste des dynamisch erweitertem ILF ermöglicht das Toggeln der "AND"-, "OR"- "EXOR"-Operatoren .

Weiter ist das Löschen (Operator - ) des nachfolgenden Ausdrucks möglich.

Je nach Ausdruck (Term oder Operand) erfolgt das Löschen erfolgt entweder innerhalb oder außerhalb der Klammer.


KR C1 Online-Hilfe

Sorry...

... zu diesem Thema ist leider keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.