ARC_OFF mit CIRC-Bewegung

Programmierung ARC_OFF mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilfspunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P3 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Synchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endparameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und der Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar. Es wird der letzte Name des ARC_ON Befehls verwendet..


ARC_OFF mit LIN-Bewegung

Programmierung ARC_OFF mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Synchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endparameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und der Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar. Es wird der letzte Name des ARC_ON Befehls verwendet..


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilfspunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P3 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=2

Programmierung der Geschwindig-keit der Zustellbewegung zum ARC_ON Befehl

Eingabe im m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuendparameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird beim Anlegen eines naechsten ARC_ON Befehls automatisch inkrementiert.


ARC_ON mit LIN-Bewegung

Programmierung ARC_ON mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=2

Programmierung der Geschwindigkeit der Zustellbewegung zum ARC_ON Befehl

Eingabe in m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfuegung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuendparameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird beim Anlegen eines naechsten ARC_ON Befehls automatisch inkrementiert.


ARC_ON mit PTP-Bewegung

Programmierung ARC_ON mit PTP-Bewegung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=100%

Programmierung der Geschwindigkeit der Zustellbewegung zum ARC_ON Befehl

Eingabe bei PTP Bewegungen in %

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuendparameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird beim Anlegen eines naechsten ARC_ON Befehls automatisch inkrementiert.


ARC_SWI mit LIN-Bewegung

Programmierung ARC_SWI mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Ueberschleifens

Listbox ergibt die Moeglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.


ARC_SWI mit CIRC-Bewegung

Programmierung ARC_SWI mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Ueberschleifens

Listbox ergibt die Moeglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG -Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.


Keine Hilfe vorhanden

Sorry...

... zu diesem Thema ist leider keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


KR C1 Online-Help Dünnblech-Schweißen

KR C1
Online-Help

Rel. 1.4

Dünnblech-Schweißen

KUKA Roboter GmbH
Bluecherstrasse 144
D-86165 Augsburg
Copyrigt © 1995 -2000