KR C1 Online-Hilfe

KR C
Online-Help

Rel. 4.2.0

KUKA Roboter GmbH
Zugspitzstr. 140
D-86165 Augsburg
Copyright © 1995 - 2004


<Command name> <Action>

Cause:

OBJH – command execution completed.


$MOVE_ENABLE input (1025) not allowed

Cause:

$MOVE_ENABLE may not be configured to $OUT[1025] in Automatic External mode.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Re-assign $MOVE_ENABLE.


Accu defective DSE <DSE number> KPS <KPS number>. Please save mastering before switching off.

Cause: | Accumulator capacity not sufficient for save operation in case of power fail.
Effect: | Loss of mastering or data in case of power fail or switching off.
Remedy: | Install new accumulators. If not every accumulator is monitored by a DC-USV15, KUKA recommends to replace also accumulators, which are not monitored, with new ones. Save mastering before switching off. If robot moves before switching off, mastering needs to be saved again.


Accu missing DSE <DSE number> KPS <KPS number>. Please save mastering before switching off.

Cause:

There are three possible causes:

  • accumulator is not detected, for instance accumulator is not connected properly.

  • optional unit DC-USV15 is not installed for every KPS, and monitoring of the accumulator is activated through $EXT_ACCU_MON=TRUE in $OPTION.DAT.

  • DSE-IBS-C33 is not installed.

Effect:

If accumulator is not connected properly, mastering or data might get lost in an event of power fail or switching off.

Remedy:

  • Save mastering before switching off. If robot moves before switching off, mastering needs to be saved again.

  • If unit DC-USV15 is installed, check the connectors to the accumulator.

  • If multiple KPS are connected to the controller, $EXT_ACCU_MON=TRUE, and not for every single KPS a separate DC-USV15 unit is installed: For every KPS without unit DC-USV15 connect input X114/pin6 with 24V to avoid this message.

  • If unit DC-USV15 is not installed, set $EXT_ACCU_MON=FALSE in $OPTION.DAT.

  • If DSE-IBS-C33 is not installed, install DSE-IBS-C33 or set $EXT_ACCU_MON=FALSE in $OPTION.DAT.


Accu-voltage at <kps number> below <voltage level> during last buffering

Cause:

  • The accu voltage was too low at the last switch off to buffer the shutdown.

  • The accu is not charged correctly anymore.

  • The accu is to old or broken.

Effect:

  • Eventually loss of reference.

  • Cold boot.

  • Active commands inhibited.

Remedy:

  • Exchange accu.


<Command name> active

Cause: | An OBJH command is being executed.
Effect: | None.
Remedy: | Wait until OBJH is free again.


Advanced path profile not possible with linked external axes

Cause: | Coupling of external axes with higher motion profile activated.
Remedy: | Alter configuration accordingly.


Automatic repositioning

Cause: | $MOT_STOP_OPT = TRUE. The robot is not on the programmed path. In EXTERN, $MOT_STOP (flag that the robot is not on path) has been set by the user (via the GUI) to FALSE, so that the robot automatically moves on path at process velocity.
Effect: | None.
Remedy: | The message is deleted as soon as BCO is reached.


Axis-specific work envelope no. <work envelope number> violated

Cause:

The robot is inside (mode = #INSIDE_STOP) or outside (mode = #OUTSIDE_STOP) the defined work envelope.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Select the menu item "Monitoring working envelope - Override" and move the robot free in T1 mode.


Ballast switch energized for too long <power module number>

Cause:

The energy of the braked axis exceeded the limit.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check power module ballast resistor and exchange if necessary.

  • Set braking ramp less steep.


BCO run in step mode required

Remedy:

A BCO run is required in Single Step mode.


Block Select : BCO reaching in T1/T2 required

Cause: | A block selection has been made. A BCO run must be carried out in order to bring the robot onto the programmed path.
Effect: | Files containing errors cannot be executed.
Remedy: | Warning - Danger of crash!The robot is moving on an unprogrammed path. Check the jog override first to ensure that the robot will not start moving at too high a velocity. Select mode T1 or T2 and press the Start key.


Brake cool down time <axis number>;<cooling time> seconds

Cause: | The brake of the axis specified has got too hot.
Effect: | The drives are locked for the duration of the cooling time.
Remedy: | Wait for the duration of the brake cooling time.


Brake defective <axis number>.

Cause:

  • Wear on brakes.

  • Brake defective.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Under certain circumstances, it may not be possible to brake the axis.

Remedy:

Exchange the corresponding motor.


Brake error <KPS number> channel <brake channel>

Cause:

  • Brake error

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Check the hardware for faults.


Brake fault <axis number>

Cause:

Brake cable monitoring device has signaled short-circuit, overloading or break in connection.

Effect:

  • Path-maintaining braking.

  • Program execution is stopped.

Remedy:

  • Rectify fault.

  • Reset the fault by pressing the hardware acknowledgement button "ACK" on the DSE I module.


Buffer battery voltage low <power module number>

Cause: | The voltage of the backup battery is too low.
Effect: | Next time the controller is switched off, it will no longer be possible to write completely to the hard disk the robot data that need to be saved.
Remedy: | Exchange the battery.


Bus voltage charging unit is defective <power module number>

Cause:

The optocoupler on the KPS is not registering current flow.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Intermediate circuit cannot be loaded.

Remedy:

Exchange affected KPS.


Channel <channel name> cannot be assigned

Cause: | The selected channel cannot be assigned.
Effect: | Command is not executed.
Remedy: | Free channel at another point.


Cabinet door open

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Cabinet temperature too high <power module number>

Cause:

The cabinet temperature is too high.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Check the functioning of the fans in the control cabinet.

  • Check whether the ventilation openings on the cabinet are unimpeded and whether enough air is circulating.

  • Reduce the ambient temperature.

  • If necessary, choose a different installation site.


Check accumulator <kps number>

Cause:

  • Message comes directly from the KPS.

  • Accu voltage is under 19V.

  • The accu is not charged correctly anymore.

  • The accu is to old or broken.

Effect:

  • Eventually loss of reference.

  • Cold boot.

  • Active commands inhibited.

Remedy:

  • Exchange accu.


Check machine data

Cause: | It cannot be ascertained whether or not the machine data loaded during a cold start are valid for the robot connected.
Effect: | No RC Ready.
Remedy: | Copy correct machine data to the hard disk.


Clear fast measuring input <number>

Cause: | "Rapid gauging" has been switched on.
Effect: | The measuring tool must be moved free in order to be able to activate "Rapid gauging".
Remedy: | Move measuring tool free.


Collision detection axis <axis number>

Cause:

The motor torque is not located in the specified monitoring range.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Verify load data, increase size of range if required.


Command timeout <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Common drives error <axis number>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Common drives error <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Common drives error <axis number>

Cause:

For the indicated axis number a drive error was announced.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Check the hardware.


Common drives error <axis number>

Cause:

Drive error at the indicated axis number.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check the hardware.


Common drives error <axis number>

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.


Common drives error <DSE number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Commutation fault <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Commutation mastering error : motor not powered <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Complete compilation active

Cause: | The compiler is carrying out a complete compilation.
Effect: | None.
Remedy: | Wait until the complete compilation has been completed.


Commutation mastering error : Servo is on <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Configuration of drive bus DSE 1 too long

Cause:

The configuration gives rise to excessive IBS word length due to too many Interbus devices.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Change the IBS configuration.


Connection lost with machine <IP address>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Path> correction data loader aborted

Cause:

The number of errors detected by the correction data loader exceeds the capacity of the message buffer.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Correct the value assignment of the variables indicated.


<Axis number> decoupled auxiliary axis

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Axis number> detached external axis

Cause:

External axis is operated as asynchronous axis.


Deviation warning master-slave <axis number>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DN CH <...> Bus error <...>

Cause:

Effect:

Remedy:


DN CH <...> Firmware error

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DN CH <...> Hardware error

Cause:

Effect:

Remedy:


DN CH <...> Configuration mode enabled

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DN CH <...> Module error <...>

Cause:

Effect:

Remedy:


DN CH <...> Slave error <...>

Cause:

Effect:

Remedy:


DN CH <...> User error <...>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DN CH <...> Watchdog error

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DN CH <...> Wrong fastwrite MacID in INI-File

Cause:

Effect:

Remedy:


Drive bus DSE <DSE number> participant no. <Interbus participant no.> not configured

Cause:

Interbus configuration and physical structure do not match.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Coordinate Interbus configuration and hardware.


Drive free axis-specific work envelope number <work envelope number>

Cause: | Work envelope monitoring is overridden and the robot is inside (mode = #INSIDE_STOP) or outside (mode = #OUTSIDE_STOP) the defined work envelope.
Effect: | The robot stops.
Remedy: | Free axis work envelope.


Drive free work envelope <work envelope number>

Cause: | TCP is inside a working envelope with – MODE "INSIDE STOP" or outside a working envelope with – MODE "OUTSIDE STOP" and work envelope monitoring is bypassed.
Remedy: | Move robot out of the effected work envelope.


Drive bus DSE <DSE number> participant no. <Interbus participant no.> does not exist

Cause:

Interbus configuration and physical structure do not match.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Coordinate Interbus configuration and hardware.


Drives contactor off

Cause:

  • Power module, intermediate circuit voltage discharged.

  • Emergency Stop is active.

  • Drives circuit is interrupted.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Switch on drives.

  • Check power module, DSE.

  • Check drives circuit.


Drives contactor off, intermediate circuit loaded

Cause:

The drive contactor drops out. The energy in the intermediate circuit is still sufficient to ensure path-maintaining braking.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Check drive circuit for faults.

  • Switch drives back on.


Drives error <axis number> No. <error number>

Cause:

A drive technology error occurs.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Contact the KUKA Servive.


Check safety logic. Drives off timeout during EMERGENCY STOP occurred

Cause: | The defined max. Declivity time for contactor was exceeded with emergency stop.
Remedy: | Check the hardware.


Drives parameter data <axis number> invalid

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


DSE <DSE number> program boot up failure

Cause:

  • The kernal system has not received the signal DSEREADY after the start of the DSE program.

Effect:

  • All active commands inhibited.

Remedy:

  • Check if DSE card is plugged correctly.

  • Exchange DSE card.


DSE <DSE number> not available

Cause:

The bit on the MFC which indicates whether a DSE is present is not set although axes are connected to the DSE.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check DSE.

  • Check MFC.


DSE file <file name> not available

Cause:

  • The DSE program entered in the file HW_INF.INI does not exist.

  • A servo file entered in R1\MADA\$MACHINE.DAT does not exist.

  • The file is empty or could not be opened

Effect:

All active commands inhibited.

Remedy:

  • Check the entry in the file HW_INF.INI or R1\MADA\$MACHINE.DAT and modify as required.

  • Check if the concerned files are on the harddisk (Directories C:\KRC\Roboter\DSE und ..\R1\MADA).


DSE watchdog command <PV no.>

Cause:

The DSE has failed to execute a command.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check DSE and MFC hardware.


Dynamic braking active

Cause: | If "LAGNP" detects a request for dynamic braking (bit "GEN_STOP" set during message processing), "LAGNP" generates this status message.
Effect: | Dynamic braking is continued until the robot has come to a standstill, thereby eliminating the possibility of different statuses in "LAGNP" and "LAGHP".
Remedy: | Once the robot has come to a standstill, this message is reset without a follow-up message being generated.


EMERGENCY STOP

Cause:

  • Emergency Stop button pressed

  • Emergency Stop circuit broken

  • Emergency Stop triggered by program

Effect:

  • Path-maintaining braking

  • All active commands inhibited

Remedy:

  • Release Emergency Stop button (turn the top part in the direction indicated by the arrow)

  • Check Emergency Stop circuit and restore it if necessary

  • Rectify and acknowledge the signalled fault


EMERGENCY STOP due to dial adjustment

Cause:

  • Betätigung des Softkeys für Drehjustage

  • Wertzuweisung $TURN = 1

  • Einstellen eines Gebers, Absolut oder Inkrementell

  • bei der Anweisung $TURN

Effect:

  • Dynamic braking

  • Ausgang "$ALARM_STOP has signal level 0.

  • All active commands inhibited.

Remedy:

  • By twice operate the Recall button the adjustment menu abandoned.


EMERGENCY STOP from KRC (ALARM STOP)

Cause:

The KRC system software has triggered an Emergency Stop due to a serious error.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Rectify the signalled fault.


Encoder cable failure <axis number>

Cause:

  • Encoder cable defective.

  • Loose connection.

  • Supply voltage missing.

  • Encoder defective.

Effect:

  • Dynamic braking.

  • Output "$ALARM_STOP" has signal level 0.

  • All active commands inhibited.

Remedy:

  • Check encoder cable.

  • Check connections.

  • Check supply voltage.

  • Check encoder and exchange if necessary.


Erroneous master-slave assignment <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Error: A/D timeout fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Error digital input reading port ...

Cause: | Error in the I/O hardware.
Effect: | Path-maintaining braking.
Remedy: | Check the corresponding I/O components.


Error digital outputs ...

Cause:

  • Short circuit at outputs 1-8

  • or short circuit at outputs 9-16

Effect:

Maximum braking.

Remedy:

Rectify fault


Error Power Relay K1

Cause:

  • Correct program.

The contact in drive contactor K1 is stuck.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Change power module.


Error on reading, driver: <driver number> <0>

Effect:

Path-maintaining braking.


Error on writing, driver: <driver number> <0>

Effect:

Path-maintaining braking.


Error restart I/O <bus/driver name>

Cause: | Field bus error is still present.
Effect: | Bus inputs and outputs not available.
Remedy: | Eliminate error in field bus hardware.


Error safety loop

Cause:

A channel has failed or more than one enabling switch has been pressed.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Eliminate fault and do not press more than one enabling switch.


Error sync. input drive <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Error write digital outputs port: ...

Cause: | Error in the I/O hardware.
Effect: | Path-maintaining braking.
Remedy: | Check the corresponding I/O hardware.


Error writing to Bosch

Effect: | Path-maintaining braking.
Remedy: | Alter the program.


Error writing to Perceptron

Effect:

Path-maintaining braking.


Errors at complete compilation - ERR-files exist

Cause: | Errors were detected during the complete compilation and error files have been created.
Effect: | Files containing errors cannot be executed.
Remedy: | Alter the programs. Observe the information given in the error files.


Erroneous Correction data

Cause:

The correction data loader has detected a variable with an inadmissible value.-A limit value has been exceeded.

  • The data are not logically coherent.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Correct the value assignment of the variables indicated.


Erroneous DSE axis assignment <axis number>

Cause: | A drive interface has been assigned twice with machine datum $IFACE_DRV[6], or a non-existent interface has been addressed. Further possible causes: KTL encoders have been entered in $IFACE_DRV[6] without connecting APC interfaces, or ADAR axes have been entered in $ADAR_AXIS without connecting ADAR interfaces.
Effect: | No RC Ready.
Remedy: | Correct the corresponding machine datum.


Erroneous <path> machine data

Cause:

The machine data loader has detected a variable with an inadmissible value.-A limit value has been exceeded.

  • The data are not logically coherent.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Correct the value assignment of the variables indicated.


Erroneous Option data

Cause:

The option data loader has detected that a variable has been initialized with an incorrect value:-A limit value has been exceeded.

  • The data are not logically coherent.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Correct the value assignment of the variable indicated.


Erroneous User Data

Cause:

The user data loader has detected that a variable has been initialized with an incorrect value:-A limit value has been exceeded.

  • The data are not logically coherent.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Correct the value assignment of the variable indicated.


External EMERGENCY STOP Pressed

Cause:

  • Emergency Stop button pressed.

  • Emergency Stop triggered by software.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Rectify and acknowledge the signalled fault.

  • Check the Emergency Stop pushbutton.


Safety circuit has detect an error. Use ESC-Diagnose for further information

Cause:

Error in periphery cabling (safety loops)

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Rectify and acknowledge the signalled fault.


Failure of ambient temperature sensor <axis number>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Failure of heat sink temperature sensor <axis number>

Cause:

Sensor defect

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Failure of motor temperature sensor <axis number>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Failure of motor phase <axis number>

Cause:

Power module or intermediate circuit voltage discharged.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Switch on drives.

  • Check power module and DSE.


Feedback switch too long on <KPS number> while charging

Cause:

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Check the hardware.


File <file name> not found.

Cause:

Parameter file for absolutely accurate robot not found.

Effect:

Command is not executed.

Remedy:

  • Load file.

  • Reboot the controller.


<Axis number> Firmware release <KSD Firmware version>

Cause:

Information about the firmware release of the axis in question.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Upgrade drive servo firmware or servo files.


Firmware version mismatch <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Function value not defined

Cause:

RETURN instruction missing in the function module.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Insert a RETURN instruction


General motion enable

Cause:

$MOVE_ENABLE input has 0 signal.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check input.


Hardware limit switch / +24V missing

Cause:

The robot has moved to the hardware limit switch of the axis indicated in the direction indicated.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Move axis off limit switch in the opposite direction.


Heat sink temperature <axis number>

Cause:

Thermostatic switch on the heat sinks of the servo output stage signals that the temperature of the output stage transistors is too high.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Rectify cause of the overheating (e.g. reduce the load).


I/O Driver not ready <driver number> <0>

Effect:

Path-maintaining braking.


I/O-linking: more than <number of links> links not configurable

Effect:

All active commands inhibited.


I/O-linking: multiple assignments of output <number output>

Effect:

All active commands inhibited.


I/O-linking: output <output number> is used by a system variable

Effect:

All active commands inhibited.


I/O Reconfiguration started, please wait

Cause:

I/O Reconfigure triggered by the GUI.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Wait for end of reconfiguration.


i*i-t monitoring, current limit of the motor cable <axis number> after <time> s exceeded 95 %

Cause:

Axis overloaded.
The value for the maximum permissible limit current is specified in the machine data by "$CURR_MON[]".

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

Remedy:

Reduce load.


i*i-t monitoring, current limit of the motor cable <axis number> after <time> s exceeded 100 %

Cause:

Axis overloaded.
The value for the maximum permissible limit current is specified in the machine data by "$CURR_MON[]".

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

Remedy:

Reduce load.


Ixt servo drive <axis number> exceed value <I*I*t value> %

Cause:

If the defined Ixt monitoring warning value of a drive servo is exceeded, the robot must be brought to a standstill; otherwise, the drive servo is deactivated when the maximum value of 100% is exceeded.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


IBS <...> Slave: Bus error in slave circle

Cause:

Effect:

Remedy:


Incorrect power module setting <axis number>

Cause:

$PMCHANNEL assigned twice or incorrect channel.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Machine data loader is aborted.

Remedy:

Correct $PMCHANNEL.


Incorrect servo parameter <axis number>

Cause: | Parameter in servo file is not correct.
Effect: | Servo parameter is not in effect.
Remedy: | Correct servo parameter file.


<$Variable> interface-I/O assignment error <correct index>

Cause: | Interface unit output assigned twice.
Effect: | No RC Ready.
Remedy: | Correct the indicated machine datum.


Internal error

Cause:

Internal test of KRC software.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Invalid $Tool: Working envelope surveillance not possible

Cause: | "$TOOL" is invalid when working envelope monitoring is active.
Remedy: | Assign "$TOOL" or switch off working envelope monitoring.


Invalid command <drive number>

Effect:

Maximum braking.


Invalid motor rating <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Invalid parameter A <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


<$ variable> invalid value

Cause:

The machine data loader has detected that the specified variable was initialized incorrectly:-A limit value has been exceeded.

  • The machine data are not logically coherent.

Effect:

No RC Ready.

Remedy:

Correct the value assignment.


K1 contact fail to open <power module number>

Cause:

K1 contactor is welded.

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

  • The energy supply is not switched off.

Remedy:

Exchange contactor, KPS.


KCP deadman switch

Cause:

The enabling switch was released during an active function (axis motion) in T1 or T2 mode.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Press enabling switch.

  • Check input $SAFETY_SW.


KCP prototype

Cause: | The connected KCP is a prototype device.
Effect: | There is no KCP watchdog function.
Remedy: | Exchange existing KCP for a series production model.


KRC system error <error number> <cause>

Cause:

A KRC system error has occurred.

  • The error has occurred in the kernel system and cannot be acknowledged.

  • "KRC system error 0" indicates that a task has crashed.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Restart the KRC controller.


Loading <"normal" or "configuration"> servo parameters <axis number>

Cause:

Loading drive servo parameters.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Wait until parameters are loaded.


<"/" or "/R1"> machine data loader aborted

Cause:

The number of errors detected by the machine data loader exceeds the capacity of the message buffer.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Process the indicated error messages.


Machine data loader ($CUSTOM.DAT) aborted

Cause:

The number of errors detected by the user data loader exceeds the capacity of the message buffer.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Process the indicated error messages.


Limit <signal name>

Cause: | The value for the corresponding analog output is outside the permissible range.
Effect: | The value of the analog output in question is set to the maximum or minimum limit value.
Remedy: | The message remains active until the value of the corresponding analog output is within the permissible range and limitation is thus no longer required.


Mainboard temperature check not available

Cause:

Motherboard does not support temperature monitoring.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Switch temperature monitoring off.

  • Exchange motherboard.


Mainboard temperature reached warning level

Cause:

  • Control cabinet temperature too high.

  • Ambient temperature too high.

Remedy:

  • Check fan.

  • Exchange fan filter.


Mainboard overtemperature

Cause:

  • Control cabinet fan failure.

  • Ambient temperature too high.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Check fan.

  • Exchange fan filter.

  • Reduce ambient temperature.


Malfunction <teach pendant or RCP>

Cause:

KCP defective.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Exchange KCP.


Memory test error DSE <DSE number>

Cause:

The memory test on the DP-RAM of the DSE was incorrect.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Exchange DSE or MFC.


Message buffer overflow

Cause:

The message buffer containing the messages that are currently active (acknowledgement and status messages) has reached a certain capacity limit.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Rectify and acknowledge the signalled faults.


MFC - Over temperature

Cause:

The temperature sensor on the MFC has been triggered.

Effect:

Path-maintaining braking.

Remedy:

  • Check fan in control cabinet.

  • Exchange MFC if necessary.


Mode inadmissible E<VW security key position>

Cause:

Keyswitch E2 in mode "AUTO".

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.


Module <axis number> KSD-<max current of KSD> required

Cause:

The maximum current of the device does not match the configured maximum current.


Monitoring 600V Power supply <KPS number>

Cause:

KPS intermediate circuit voltage overload.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Reduce load.


Monitoring of the actual velocity <axis number>

Cause:

Fault in control loop:
– Motor cables of two axes interchanged.
– Error in the axis assignment.
– Power module defective.
– Resolver unmastered.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check motor cables.

  • Eliminate fault in the control loop / error in the axis assignment.

  • Check power module and exchange if necessary.

  • In the case of an unmastered resolver, remaster the robot.


More than one calibration file available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Motor blocked <axis number>

Cause:

The command torque value supplied by the speed controller exceeds the max. command torque value by more than 30%.
The motor is shut down by the "i*i-t" monitoring function on reaching an "i*i-t" value of approx. 0.75 [(Command torque value / Max. command torque value)*sec].

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Rectify cause of the torque overload (reduce velocity, acceleration).


Motor cable <axis number>

Cause:

The motor line of the indicated axis number is defective.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Check the hardware.


Motor temperature <axis number>

Cause:

The motor temperature of the axis indicated is greater than 155 °C. (Signaled by PTC element in the motor winding.)

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Reduce mechanical load.

  • Rectify any faults.


Check robot number

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No robot number programmed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Operating mode change

Cause:

The mode selector switch is in an invalid position.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Move the mode selector switch into a valid position.


Operator safety / Gate open

Cause:

The input $USER_SAF has signal state 0. Operating mode is AUTOMATIC or EXTERNAL.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Switch to T1 or T2 mode; robot motion is possible in these modes with a 0 signal.

  • Close safety fence.

  • Check input.


Option data loader aborted

Cause:

The number of errors detected by the option data loader exceeds the capacity of the message buffer.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • No RC Ready.

Remedy:

Process the indicated error messages.


Output state mismatch <power module number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Over current <axis number>

Cause:

Intermediate circuit current monitoring safeguard triggered by overcurrent.

Effect:

  • Maximum braking.

  • Active commands inhibited.

Remedy:

  • Rectify fault.

  • Reset the fault by pressing the hardware acknowledgement button "ACK" on the DSE I module.


Over temperature fan <power module number>

Cause:

One of the fans in the cabinet is defective.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Replace defective fan.


Over temperature feedback resistor <KPS number>

Cause:

The ballast resistor has got too hot, because the robot is accelerated and braked in the motion program without a pause.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Reduce acceleration.

  • Introduce wait times.


Over temperature feedback resistor <power module number> or fan

Cause:

The ballast resistor in question is too hot.
For example: The robot is accelerated and braked in the motion program in too short a space of time.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Enter wait times in the motion program.

  • Reduce acceleration/braking.


Over voltage <power module number>

Cause:

Intermediate circuit voltage is too high.
Possible causes are:-Defective ballast resistor

  • Ballast fuse

  • G1 power supply unit

  • Braking ramp that is too steep, etc.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Rectify fault.

  • Reset by pressing the hardware acknowledgement button "ACK" on the front control panel.


Overvoltage <kps number> while charging

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Check the hardware.


<Variable> overlapping output signals

Cause: | Interface unit outputs assigned twice.
Effect: | No RC Ready.
Remedy: | Correct the value assignment.


<output/input> parameter out of range <max. I/O>

Effect:

All active commands inhibited.


Palletizing mode: Move axis <axis number> <motion direction> into position

Cause: | Axis 4 or 5 is not in the expected position in palletizing mode ($PAL_MODE = TRUE), i.e. axis 4 = 0 degrees and axis 5 = 90 degrees.
Effect: | None.
Remedy: | Move the axis in the direction indicated.


Parity error power module <KPS number>

Cause:

More than five successive parity errors when reading the power module register. Too much interference at power module interface or power module defective.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Check cable.

  • Check shield.

  • Exchange power module.


Passive STOP <RCP or teach pendant>

Cause:

Passive operator control device stop.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


PC fan error

Cause:

The PC fan is defective.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Exchange PC fan.


Perform mastering <axis number>

Cause:

  • Position actual value difference after restart too great and sensor mastering not possible because sensor location run has not been performed.

  • Faulty correction data have been loaded.

Effect:

All active commands inhibited.

Remedy:

Carry out mastering.


Please close cabinet door, otherwise warranty invalid

Cause: | The control cabinet door was open for more than 30 minutes.
Effect: | Risk of fouling.
Remedy: | Close cabinet door.


Please switch off the cabinet

Cause:

The drive servo parameters have been loaded, but will not take effect until the next reboot.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Switch the cabinet off.


POST Error: A/D fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: A/D offset fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Encoder FPGA loopback fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Fatal system error <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: FPGA Fault <power module number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Invalid parameter fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Motor Enable on during power up <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Parameter table checksum fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


POST Error: Power board FPGA fault <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Power fail

Cause:

The power supply to the controller has been interrupted.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Restore power supply.


Power module axis <axis number> not or wrongly plugged

Cause: | The power cable for the axis is not connected to the power module or is connected incorrectly.
Effect: | All active commands inhibited.
Remedy: | Connect power cable correctly.


Task stack for command execution too small

Cause:

  • Task stack for command execution too small.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Alter the program structure and program reset.


Program structure for RESUME inadmissible

Cause:

When the RESUME command was executed, the advance run indicator pointed to the level at which the interrupt was declared.

  • RESUME may only be used with subprograms.

  • The interrupt may only be triggered in the level at which the interrupt was declared.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Program reset.

  • Alter the program accordingly.

  • When RESUME is executed, $ADVANCE=0 is required.


Range overflow <motion direction> <axis number>

Cause: | Overflow of the actual value of an endless axis. Actual value > +/– 90*10E15 increments or –99999000 < $REVO_NUM < 999999000.
Effect: | The motion has already been stopped: – normally in the case of axis-specific manual traversing, – otherwise by maximum braking.
Remedy: | Turn axis back or remaster.


RDW <RDW number> boot up failure

Cause:

  • The resolver/digital converter (RDW) could not be initialized when the controller was booted.

  • Fault in RDW, DSE or connecting cable.

Effect:

  • Does not run up.

Remedy:

  • Check connecting cable and plug-in connections between RDW and DSE.

  • Exchange RDW, DSE or cable between RDW and DSE.


RDW file <program name> not available

Cause: | The RDW program entered in the file RD_HWINF.INI does not exist.
Effect: | All active commands inhibited.
Remedy: | Enter the RDW program correctly in the file RD_HWINF.INI.


Regulator limit exceeded <axis number>

Cause:

  • Following error too big. The axis does not follow the command value.

  • Is there only the acknowledge message and no status message, then the surveillance in the kernal system has triggered.

Effect:

  • Maximum braking.

  • Active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Check maschine data $IN_POS_MA (positioning window axis) and $FOL_ERR_MA (factor for the following error).

  • Check power converter.

  • Check manipulator and motor.

  • Check maschine data of controller parameters and gear ratios.

  • Check maschine data $COM_VAL_MI (limitation of command revolution axis) and $TL_COM_VAL (tolerancetime for limitation of command revolution).


Line selection not possible: too many interrupts

Cause:

Block selection in an interrupt program.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Carry out reset.


RIO configuration change: controller reboot necessary

Cause: | In order for the RIO configuration change to take effect, it is necessary to restart the system.
Effect: |
Remedy: | Restart the controller.


Robot number <robot number (RDC)> does not correspond to calibration file <number of calibration file>

Cause: | The calibration file is not compatible with the robot serial number.
Remedy: | Load the correct calibration file.


Second motorcable not connected

Cause:

The second motor cable is not connected or is connected incorrectly. The additional cable contains two wires which are connected to the robot. The return signal is connected to the KPS X114, pin 7.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check second motor cable and return signal at KPS X114, pin 7.


Selection active

Cause: | Before a new selection can be made, the previous selection must be cancelled or the linking procedure must be terminated.
Effect: | None.
Remedy: | Wait until the linking process has been completed.


SEN: <sensor data1> <sensor data2> <sensor data3>

Cause:

Notification message from a sensor that does not require a stop.


Servo bus disturbance DSE <DSE number>

Cause:

  • Defective bus cable.

  • Defective bus module.

  • Defective bus driver.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Replace defective element.


Servo bus disturbance <Axis number>

Cause:

Defect in

  • Bus connection

  • Bus module

  • Bus driver

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Change the element


Servo bus disturbance <KPS number>

Cause:

A servo bus disturbance occurs.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Correct the defect.


Servo bus disturbance DSE <DSE number>, no buffering and automatic data storage possible

Cause:

The communication with the KPS is faulty, therefore the buffering cannot be activated.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Re-establish communication with the KPS.


Servobus DSE-No. <DSE number> participant No. <IBS participant> unknown

Cause:

An unknown device which cannot be supported has been inserted in Interbus.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Remove unknown device from servo bus.


Servofile configuration <Configuration from the madas> does not fit the <DSE-Software-" or "Firmware-"> release <installed "DSE-SW" bzw. "Firmw.-">

Cause:

The servo file configuration contains parameters for the drive servos which are not supported by the firmware.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Upgrade drive servo firmware or servo files.


Servo independent command execution

Cause: | The variable $SERVO_SIM is set to TRUE.
Effect: | Programs are executed without robot motions.
Remedy: | In order to end robot simulation, set the variable $SERVO_SIM to FALSE.


Servo-Parameters axis <axis number> line <line number> incorrect

Cause: | A parameter in the servo file is incorrect.
Remedy: | Correct the parameter.


Set robot number - program robot name

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Slip exceeded <axis number>

Cause:

The system deviation has exceeded a limit value due to excessive slip.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

check hardware


SoftPLC: <Parameter>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Software limit switch of detached external axis <motion direction> <axis number>

Cause: | Asynchronous axis has tripped the positive or negative software limit switch.
 | The software limit switch is checked cyclically if the axis is operated as an asynchronous axis.
Remedy: | Move affected axis free.


Software limit switch <motion direction> <axis number>

Cause: | The actual value of the axis indicated has reached the software limit switch value.
Effect: | All active commands inhibited.
Remedy: | Move axis off limit switch in the opposite direction.


Software of <DSE number> does not fit to the DSE hardware or defective DSE

Cause:

The wrong software was configured for the DSE.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Ceck if the entry in hw_inf.ini fits to the present DSE hardware.

  • Eventually exchange DSE.


software version of DSE <DSE number> does not fit to kernal system

Cause:

DSE software and kernel system software do not work together.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Save an archiv with all data.

  • Make an new installation of the KRC software.


Start up

Cause: | The Setup menu has been selected.
Effect: | Program execution is not possible.
Remedy: | Exit the Setup menu by pressing the RECALL key.


STOP key <teach pendant or RCP>

Cause:

The Start key or traversing key was pressed while the Stop key was pressed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check Stop key.


Stop while measurement active - movement will be handled as test

Cause: | The Start key or enabling switch was released during load data determination.
Effect: | The measurement run will be regarded as a test run.
Remedy: | The measurement run must be restarted.


String too long

Cause:

In a value assignment to arrays, the string consists of more characters than the existing array.

Example:
CHAR c[3]
c[]="abcde"

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

Example:
CHAR c[3]
c[]="abc"-Acknowledge message.


Sync commands are simulated (<Simulated controls>)

Cause: | Global simulation of sync commands has been activated for the listed controls. The simulated controllers will not participate in program or motion synchronisation at all.
Effect: | Local sync commands act as if the simulated controls have reached the sync point in advance.
Remedy: | Untag the listed robots in the cell map simulation utility.


Synchronisation error drive <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Synchronization error with DSE <axis number>

Cause:

Message from kernal system: The kernel system did not set the watchdog-timer for the surveillance of the communication to the DSE or the DSE did not reset watchdog-timer.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Check pugs of DSE on MFC and MFC on motherboard (loose connection).

  • If this does not work, exchange DSE or MFC.

  • Check if the drive bus or the ISA-bus on the motherboard are malfunctioning (EMC).


Syntax error in file <file name> in row <content of line>

Cause: | Syntax error when interpreting the parameter file (absolutely accurate robot).
Effect: | Command is not executed.
Remedy: | Load file, boot controller.


System time invalid

Cause: | The system time is invalid, according to "TIME_HW_FAILURE", and has been set to the initial value.
Effect: | System time has been initialized with the setting 01.01.93 00:00:00,00.
Remedy: | Update the system time using the "syszeit" form.


Temperature warning <drive number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Too many messages

Cause:

Too many messages have been generated.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

A warm start of the ACR.


Too many participants within drive bus DSE <DSE number>

Cause:

Too many devices in Interbus ring cause an excessively long IBS word length.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Reduce number of devices or word length.


Transmission error <teach pendant or RCP>

Cause:

Connection to KCP is faulty.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check KCP cable.


Transmission error <DSE number>. DSE - RDW

Cause:

  • Damaged cable or connector between DSE and RDW.

  • Cable not connected or connected incorrectly.

  • Data transmission malfunction.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Check power supply of DSE and RDC (LEDs).

  • Check cable (shield!) and connections.

  • Check DSE - RDW serial interface.

  • Check electrical ground connection of robot and cabinet.


Under voltage <axis number>

Cause:

Internal not servo output stage ready.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Rectify fault.

  • Reset by pressing the hardware acknowledgement button "ACK" on the DSE I module.


Undervoltage <kps number> while charging

Cause:

  • Message comes directly from the KPS.

  • Intermediate circuit could not be charged correctly.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check supply voltages of KPS (especially three-phase current) if there are interferences.

  • Exchange KPS.


Warning : axis too far from mastering position <axis number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Warning: PC fan below nominal speed

Cause: | The PC fan has fallen below the nominal speed.
Effect: | Components may overheat.
Remedy: | Check PC fan and exchange if necessary.


Watchdog interpolation cycle <axis number>

Cause:

DSE did not get a new position value from kernel system for this axis.

Effect:

  • Dynamic braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Check pugs of DSE on MFC and MFC on motherboard (loose connection).

  • If this does not work, exchange DSE or MFC.


Watchdog power module <power module number>

Cause:

Power module watchdog has dropped out.
(Triggered by DSE after delay of 0.125 ms)

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check DSE.

  • Check power module.


<Axis number> without power

Effect:

  • Maximum braking.

  • All active commands inhibited.


Work envelope no. <work envelope number> violated.

Cause:

TCP is inside a working envelope with
– MODE "INSIDE STOP"
or outside a working envelope with
– MODE "OUTSIDE STOP".

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Deactivate work envelope.

  • Select the menu item "Skip Work Env Surveillance" and move free in T1 mode.


Wrong/unknown hardware found

Cause:

During setup, the wrong controller type (KR C1, KR C1A, KR C2) was selected or the hardware configuration is invalid.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Carry out setup again or alter hardware configuration.


Wrong amplifier <axis number>

Effect:

  • Maximum braking.

  • Active commands inhibited.


Wrong drives parameter <axis number> <parameter set no.>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Wrong machine data for this robot type

Cause: | The machine data loaded into the controller do not correspond to the robot type.
Effect: | The robot cannot be moved as it would otherwise be damaged.
Remedy: | Load the correct machine data.


Wrong model number <power module number>

Effect:

  • Maximum braking.

  • All active commands inhibited.


Initialization of the DSE running

Cause:

  • DSE is new initialized with parameters.

  • If this message does not dissapear the initialisation has not been finished.

  • The message does not appear when Office = TRUE in hw_inf.ini.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Look for errors in the machine datas, especially for errors in the axis- or powermodule-configuration.

  • Have the maschine data been changed? Eventually compare with maschine data on CD.


".." expected

Cause: | The string ".." is has been forgotten or incorrectly positioned. Example: IMPORT INT Otto_2 IS /R1/PROG_1 Otto
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: IMPORT INT Otto_2 IS /R1/PROG_1..Otto


"," expected

Cause: | The "," symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"," or "}" expected

Cause: | One of the symbols "," or "}" is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


":" expected

Cause: | The ":" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"+" or "-" expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


"*" expected

Cause: | The "*" symbol is missing or incorrectly positioned. Example: ANOUT ON Wire = .5 Value
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT ON Wire = .5 *Value


"=" expected

Cause: | The "=" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"(" expected

Cause: | The "(" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


")" expected

Cause: | The ")" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"[" expected

Cause: | The "[" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"]" expected

Cause: | The "]" symbol is missing or incorrectly positioned. Example: SIGNAL Hugo $OUT[2
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: SIGNAL Hugo $OUT[2]


"]" or "," expected

Cause: | The "]" or "," symbol is missing or incorrectly positioned. Most often in array declarations.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"{" expected

Cause: | The "{" symbol is missing or incorrectly positioned in the program line.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"#" expected

Cause: | The "#" symbol is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


"#" or ENUM type name expected

Cause: | Either the "#" symbol has been forgotten or no declared Enum type name has been used. Example: ENUM Emma e1,e2,e3 STRUC Hugo Emma a DECL Hugo RealHugo = {a e1}
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ENUM Emma e1,e2,e3 STRUC Hugo Emma a DECL Hugo RealHugo = {a #e1}


$OUT_C[n] not allowed here

Cause: | $OUT_C[n] may not be used in trigger or interrupt declarations or on the right-hand side of an assignment.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Aborted

Cause:

"BREAK" repeated.


Absolute path after device/channel name expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Absolute path expected

Cause: | Absolute path expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Access denied

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Access to component inadmissible

Cause:

Illegal access to an advance run/main run trace component (e.g. SHOW VAR $PRO_TRACE[5].NAME[2]).

Effect:

  • Ramp-down braking.

  • Command is not executed.


Access to imported variable is not possible

Cause: | The search path has not been extended to the external data list.
Effect: | Command is not executed.
Remedy: | Extend the search path accordingly.


Active commands inhibited

Cause: | A message is present which inhibits active commands.
Effect: | Command is not executed.
Remedy: | Acknowledge active messages in the message window.


ACTIVE allowed in <mode> only

Cause:

Incorrect operating mode set.

  • "AUT" mode is required for RCP and fixed KCP.

  • "T1" or "T2" mode is required for non-fixed KCP.

  • "EXT" mode is required for host computers.

Effect:

Command is not executed.

Remedy:

Set correct operating mode.


ACTIVE status required

Cause: | The command entered may only be issued by the active operator control device (T1, T2, AUT mode).
Effect: | Command is not executed.
Remedy: | Activate operator control device.


Adhesive level

Cause: | The adhesive drum is empty.
 | Monitoring is carried out from the PLC application program (adhesive bonding technology).
Remedy: | Prepare a new adhesive drum or switch over to a filled drum.


After decimal point only values in interval 0-7 permissible

Cause: | Value range exceeded.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Aggregate component initialized more than once

Cause: | Each component may only be contained once in an aggregate.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Aggregate type (POS) incompatible with context

Effect: | The program cannot be executed.
Remedy: | Alter the program.


All analog functions assigned

Cause:

More than 2 cyclical analog outputs have been activated.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Set ANOUT OFF or cancel the instruction.


All pulse outputs assigned

Cause:

More than 16 pulse outputs have been activated.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Alter the program accordingly.


<Name> already exists

Cause: | A SUB module cannot be created in the editor if an SCR module of the same name already exists and vice versa.
Remedy: | Change the name of the module.


Analog input expected

Cause: | An analog input signal is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Analog output already assigned

Cause:

A cyclical analog output is assigned a second time in the program, for example: – SIGNAL SIG1 $ANOUT[1]
– SIGNAL SIG2 $ANOUT[1]
– ANOUT ON SIG1 = ....
– ANOUT ON SIG2 = ....

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Deactivate cyclical analog output:
ANOUT OFF SIGNALNAME.


Analog output : delay reduction

Cause: | The memory provided internally for the output function with a delay is not adequate for the programmed delay.
Effect: | The programmed "Delay" is automatically reduced accordingly.
Remedy: | Program a smaller value for "Delay".


Analog output expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Application comm. interrupted (File server)

Cause: | The application communication with the file server has been interrupted or disconnected.
Remedy: | Check the transmission link between the ACR and the file server.


Approximation inadmissible for instructions (module <Module name>, line <Motion line number>)

Cause: | "DRIFT", "$TOOL or "$FILTER" has been programmed between two motion blocks that are supposed to be approximated.
Effect: | Motion blocks are not approximated.
Remedy: | Alter the program accordingly.


Approximation not possible

Cause:

Approximate positioning is not possible for computing time reasons.

Remedy:

  • Program value for "$ADVANCE" > 0.

  • Deactivate axis simulation.


Approximation not possible, torque too high

Cause:

The approximate positioning range is not sufficiently large. The permissible torques have been exceeded.

In order to execute the approximation block the velocity must first be reduced in the previous block.

Remedy:

  • Increase the length of the individual block by decreasing the approximate positioning radius at the end point of the current motion block, or – if the start point is approximated – by decreasing this approximate positioning radius.

  • Reduce the velocity and acceleration of the preceding block.


APS system error

Cause: | Internal error in APS detected by APS.
Remedy: | Request confirmation from APS, reboot probably required.


<Variable name> argument inadmissible

Cause:

At least one argument in the function is inadmissible, e.g. SQRT (negative value).

Monitoring is carried out during interpretation of C functions.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Array as operand invalid

Cause: | An array as an operand is not admissible here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array components cannot be indexed

Cause: | An attempt has been made to index an array component.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array contains too many elements

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array dimension greater than 1 inadmissible here

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array element/variable not type REAL

Cause: | An array element or variable of data type REAL is expected in the program line.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array index entered inadmissible here

Cause: | The indicated field index is not permissible here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array index exceeds array limits

Cause: | The specified array index exceeds the declared array limit.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array index inadmissible

Cause:

Attempted access to an array element that does not exist.
Example:
INT Hugo[3,3]
Hugo[7,3]=9

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Array index not compatible with array dimension

Remedy:

Alter the program.


Array invalid

Cause: | No array may be specified here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array limit exceeded

Remedy:

Alter the program.


Array limit missing

Cause: | The array limit has not been specified. Example: REAL vb[]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: REAL vb[4]


Array limits invalid in parameter specification

Cause: | Array limits have been ebtered in a parameter specification. Example: DEF Hb(a[]:IN) INT a[5]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Hb(a[]:IN) INT a[]


Array name entered inadmissible here

Cause: | An array name has been used in an unauthorized position.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Array subscript missing

Remedy:

Alter the program.


Ascending indices expected

Cause: | A higher value was entered for the second index specification in the program line than for the first. Example: SIGNAL $DIGIN1 $IN[20] TO $IN[10]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: SIGNAL $DIGIN1 $IN[10] TO $IN[20]


<Object name> assigned

Cause:

  • The object has already been assigned and can thus not be edited.

  • The module cannot be linked since at least one of the objects in this module is assigned.

Effect:

Command is not executed.

Remedy:

None.


Assignment of function value to $CYCFLAG inadmissible

Cause:

Return value of a BOOL function has been assigned directly to a $CYCFLAG.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


Assignment of runtime value to $CYCFLAG inadmissible

Cause:

A $CYCFLAG has been assigned local runtime data.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program (use global variables only!).

  • Acknowledge message.


Assignment to constant not permissible

Cause: | An attempt has been made to assign a value to a constant. Example: DAT file: DECL CONST INT Leave SRC file: Leave = 5
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DAT file: DECL CONST INT Leave = 5


ASYPTP command includes decoupled auxiliary axis

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Attribute name must follow

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Axis coupling not possible ( -> DSE/PM-Channel assignment)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Axis number> axis inhibited

Cause: | An attempt has been made to move an axis in the inhibited direction (inhibited by software limit switch).
Effect: | Command is not executed.
Remedy: | Move axis off limit switch in the other direction.


<Axis number> axis synchronized

Cause: | In single-axis referencing, an attempt has been made to reference an axis which has already been referenced.
Effect: | The axis is not referenced.
Remedy: | Select the next axis which has not been referenced.


Background occupied

Cause:

A command is already being executed in the background.

Effect:

Command is not executed.

Remedy:

  • Abort command.

  • Wait until command has been executed.


Background process busy with <operator control device>

Cause:

The background process is exclusively occupied with a different operator control device.

Effect:

Background cannot be exclusively assigned.

Remedy:

  • Cancel exclusive assignment of the device indicated.

  • Complete the specifications in the file "$OPTION.DAT".


Backward motions not active

Cause: | Backward motion is deactivated ($VW_BACKWARD = FALSE).
Effect: | The backwards motion command is rejected when the "Start backwards" key is pressed.
Remedy: | Set the variable "$VW_BACKWARD" to TRUE.


Backward motions not possible: finished subroutine

Cause: | An attempt was made to carry out backward a motion located inside a subprogram which has already been executed.
 | It is not possible in this subprogram to switch to forwards motion. Backward motion is thus also disabled.
Effect: | Command is not executed.
Remedy: | Forward motion


<X,Y,Z,A,B,C> BASE not programmed

Cause:

No value has been assigned to the program datum "$BASE":-in an application program.

  • after an overall reset of the controller for a Cartesian command.

Monitoring is carried out in the event of Cartesian motions.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

During command execution:-Assign a value to "$BASE".
During program execution:-Alter the program accordingly.

  • Acknowledge message.


Baud rate summation exceeded

Cause: | The aggregate baud rate of both channels has been exceeded (the limit is 19200 bauds).
Remedy: | Correct the baud rate.


BCO motion: Press START Plus

Cause:

An attempt was made to carry out BCO motion with Start Minus.

Effect:

The robot does not move.

Remedy:

  • Use the Start Plus (+) key.

  • Make the following entry in the file BACKWARD.INI: Implicit_BCO= TRUE


BCO move to aux. point required

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Carry out BCO run to end point.


Binary output signal expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Blank character invalid

Cause: | Inadmissibly one or more blanks were inserted.
Remedy: | Remove blanks.


Blending options are not allowed within a splineblock

Cause: | A forbidden blending option was inserted in a splineblock.
Effect: | Module has syntax error.


Block cannot be corrected

Cause: | TTS or BASE calculation cannot be carried out.
 | TTS = tool-based technological system.


Block cannot be deleted

Remedy:

Alter the program.


Block cannot be modified

Cause: | An unauthorized block selection has been made.
Effect: | Block selection is not carried out.
Remedy: | Select a different block.


Block <object name> cannot be decompiled

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block <object name> cannot be formatted

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block <object name> unavailable

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block change at STOP

Cause:

  • In the event of dynamic braking or path-maintaining braking during a block change, it is not possible to calculate "$POS_RET" and the system time.

  • "$POS_RET" and the system time are detemined by the start of the new block.

Effect:

  • Ramp-down braking.

  • Program execution is stopped.

Remedy:

Modify operation in such a way that the stop does not occur at the same time as the block change.


<Object name> block not available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block number expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block number must be positive

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Block size error

<SER_1> block size error

Cause: | The received data block is too large.
Remedy: | Alter the buffer length in the external data storage device to the control-internal size or smaller.


<Object name> block too long

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Object name> block too long or incorrectly completed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Blocking of outputs in AUT/EXT is enabled

Cause: | Variable "$BLK_IO_AUT" is set to TRUE An attempt was made to set the outputs manually.
Effect: | None.
Remedy: | Set variable "$BLK_IO_AUT" to FALSE.


<SINEC L2, SINEC H1> board not available

Cause: | An attempt has been made to access a SINEC L2 or SINEC H1 channel without the corresponding board being installed.
Effect: | None.
Remedy: | Install the corresponding board.


Both operands not equal to BOOL

Cause: | Neither operand is of data type "BOOL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Both operands not equal to INT, CHAR

Cause: | Neither operand is of data type "INT" or "CHAR".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Both operands not equal to INT, REAL

Cause: | Neither operand is of data type "INT" or "REAL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Both operands not equal to INT, REAL, CHAR, ENUM

Cause: | Neither operand is of data type "INT", "REAL", "CHAR" or "ENUM".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Both sides of the value assignment are not compatible

Cause: | The data types of the elements on either side of the equals sign are incompatible. Example: $OUT[3]=1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: $OUT[3]=TRUE


CA expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


CA parameter out of range

Cause: | Too large a value has been programmed for the parameter CA (complete angle) in the CIRC block.
Remedy: | Correct the value of the CA appropriately.


Call only permissible in robot interpreter program

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


CAN controller <...> failure

Cause:

Effect:

Remedy:


Cartesian target not possible

Cause:

A PTP motion has been programmed with a Cartesian end point specified.

When using a 5-axis robot ($DEF_A4FIX = TRUE) with palletizing mode deactivated ($PALMODE = FALSE), only PTP motions with an axis-specific target may be carried out.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Correct program.

  • Acknowledge message.


CASE/DEFAULT after DEFAULT

Cause: | The "DEFAULT" branch contains a "CASE" or "DEFAULT" keyword.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Change of direction not possible

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Change of segment is erroneous

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<file format>: Change of <variable> not allowed during recording of <record name>

Cause: | Depending on the EMI driver, it may be forbidden to change $tool, $base, $ipo_mode or other system variables during a recording.
Effect: | Recording is stopped.
Remedy: | Do not change the system variables.


Change reference direction <axis number>

Cause: | During single-axis referencing the wrong traversing key was pressed; defined in machine datum "$DIR_CAL".
Effect: | Axis cannot be referenced in this direction.
Remedy: | Carry out referencing in the other direction.


<Object name> cannot be corrected

Cause:

An incorrect object extension has been entered.

Only the extension "DAT" is permissible for objects.

Effect:

Command is not executed.

Remedy:

  • Select data list.

  • Set INIT switch on the I-CPU to position 3.


<Object> Cannot be processed

Cause: | An object was addressed that has already been assigned.
Effect: | Command is not executed.
Remedy: | Enable assignment (/R1/CONFIG.DAT).


Channel already closed

Cause: | An attempt has been made to close a channel that is already closed.
Effect: | None.
Remedy: | Abort command.


Channel already fully assigned

Cause: | The maximum number of jobs have already been assigned to the channel.
Remedy: | Wait until at least one job has been completed.


Channel already open

Cause:

An attempt has been made to open a channel that is already open.


Channel assigned to PLC

Cause:

An attempt has been made to access a channel that has already been parameterized for the PLC link.

Remedy:

  • Reparameterize the channel.

  • Close the channel and open it again.


Channel cannot be opened/closed

Cause: | The operator has attempted to open a SINEC H1 channel by means of the OPEN command or to close it by means of the CLOSE command.
Effect: | None
Remedy: | None; SINEC H1 channels are opened and closed automatically.


Channel handle expected

Cause: | Channel handle expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Channel has to be opened/closed

Cause: | The channel parameters used for assigning the channel do not correspond to the current channel parameters.
Remedy: | Close the channel before assigning it.


Channel inadmissible in command

Cause: | The command does not support channels.
Effect: | The command is not executed.


Channel name expected

Cause: | The Channel name is missing.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Channel name missing

Cause: | No channel name has been specified.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Channel not available

Cause: | Procedure monitoring time has elapsed.
Remedy: | Increase procedure monitoring time.


Channel not compatible with protocol

Cause: | PLC protocol is set and channel declaration is not set to SER1.
Remedy: | Alter the channel declaration protocol.


Channel parameters faulty or incomplete

Cause: | At least one channel parameter in the parameter variable of the channel in "$CUSTOM.DAT" is faulty or not initialized.
Remedy: | Correct or initialize parameter variable.


Channel specification inadmissible

Cause:

  • An attempt has been made to transmit a productive command via the SINEC L2 bus channel.

  • An attempt has been made to output the listing or the message buffer through the SINEC H1 channel to a third station.

Effect:

None.

Remedy:

None.


CHARACTER or INTEGER constant expected

Cause: | An individual character (no string) or integer constant is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Check RCP selector switch

Cause: | The selector switch on the RCP is not set to "RUN" in the case of selection or start from another operator control unit.
Effect: | Command is not executed.
Remedy: | Move the selector switch on the RCP to the "RUN" position.


CIRC angle not accepted

Effect:

None.


Closing channel inadmissible, channel active

Cause: | The channel concerned cannot be closed during transmission.
Remedy: | Wait for the transmission to finish or abort the transmission.


Combined analog signals inadmissible

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Combined OUT_C signal inadmissible

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Combined signal more than 32 bits

Cause: | A maximum of 32 inputs or outputs can be grouped together under one signal. Example: SIGNAL $DIGIN1 $IN[200] TO $IN[232]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: SIGNAL $DIGIN1 $IN[200] TO $IN[231]


Comma or ")" expected

Cause: | A comma or ")" is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Command aborted

Cause:

  • The command has been aborted.

  • During editing, "Abort" has been selected by the editor kernel before the command concerned (ERASE,GET,FIND) is called.


Command execution not possible

Cause:

A preceding command is still being executed.

Effect:

Command is not executed.

Remedy:

  • Abort command.

  • Wait until the end of the preceding command.


Command inadmissible

Cause: | Impermissible or unknown command.
Remedy: | Enter command correctly.


Command not being processed

Cause:

The command to be aborted has already been executed.


Command syntax error

Cause: | The command contains a syntax error.
Effect: | Command is not executed.
Remedy: | Correct command.


<File> : <Number> Compilation error

Cause: | Compilation error due to unrecognized data type can occur in the case of global self-defined data types and ENUMs. This means that the GUI must initiate a second download.
Effect: | When this error is caused by global types, it can be corrected by downloading the files twice.
Remedy: | The GUI filters out the error number and initiates the double download for the file in question.


<Object> : <number of errors> compilation error

Cause: | The indicated number of errors has been detected in the indicated object during total compilation.
Effect: | Command is not executed.
Remedy: | Correct errors.


Compile loc. not compatible with call location

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Component array spec. multidimensional

Remedy:

Alter the program.


Component Declared as array: indexing expected

Cause: | The component is an array; indexing is required for unambiguous assignment.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Component is no array

Remedy:

Alter the program.


Component neither part of FRAME nor POS

Remedy:

Alter the program.


Component name expected

Cause: | A component name has not been specified, e.g. in the aggregate of a structure. Example: STRUC Otto INT a, REAL b DECL Otto Hugo ={ 1, b 2.2}
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2}


Component not declared as array

Cause: | The component was not declared as array.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Component not part of type

Cause: | A component has been used that is not in the data type declaration. Example: STRUC Otto INT a, REAL b DECL Otto Emma Emma.ccc=1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto INT a, REAL b DECL Otto Emma Emma.a=1


Component specified twice

Cause: | A component name has been specified twice, e.g. in the aggregate of a structure. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = {a 1, b 2.2, a 4}
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2}


Component type not defined or correctly defined

Cause: | A component type has been entered which has not been declared or has not been declared correctly. Example: Enum Otto #Ottomotor STRUC Willi Ottoa
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: Enum Otto Ottomotor STRUC Willi Otto a


Component type unknown

Remedy:

Alter the program.


Configuration error I/O driver

Configuration error I/O driver <driver name>

Cause: | Error in the file "IOSYS.INI" (directory "...\KRCROBOTER\INIT")
Effect: | The application belonging to this driver is not functional.
Remedy: | Check file "IOSYS.INI" and modify accordingly.


CONST with several inadmissible variables

Cause: | More than one variable has been entered in the constant declaration.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Constant expected

Cause: | The specification of a constant is missing in the program line, e.g. after the keyword "CASE".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Incorrect range specification

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Constant expected

Cause: | Specification of a constant is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Constant for key must follow

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Constant name not part of variable type

Remedy:

Alter the program.


Constant or variable expected

Cause: | A constant or variable has not been entered. Example: ANOUT ON Wire = .5 * Factor + 1.0 DELAY =
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT ON Wire = .5 * Factor + 1.0 DELAY = 5


Constant type incompatible with expr. type in SWITCH

Effect: | The program cannot be executed.
Remedy: | Alter the program.


CONTROL : <DEVCONTROL number>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Control structure next block <block number>

Cause:

Selection into a control structure.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

  • Control structure is exited when the end is identified.

Remedy:

Acknowledge message.


Controller booted

Cause: | Controller is booted for the first time (not reboot after power failure).
Effect: | None


<Object> copy refused (-S.)

Cause: | System file has been transferred via an interface without the option "-S" being set.
 | "-S" is the code for the download command.
Effect: | The file is not transferred.
Remedy: | Set option "-S".


COR are for data lists only

Cause: | The command "COR" was used, but no data list is selected.
 | "COR" is allowed for data lists only.
Effect: | Command is not executed.
Remedy: | Select corresponding data list.


Correct type entry unavailable

Cause: | In a declaration, a data type is used which has been declared incorrectly. Example: ENUM Otto #Ottomotor DECL Otto Otto1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ENUM Otto Ottomotor DECL Otto Otto1


Corresponding END block missing

Cause: | A program section was not terminated with the keyword "END".
Effect: | The program cannot be executed.
Remedy: | Alter the program.Example: DEF Up() ... END


Corresponding ENDDAT block missing

Cause: | The keyword ENDDAT is missing at the end of a DAT file.
Effect: | The corresponding SRC file cannot be executed.
Remedy: | Alter the program.


Corresponding ENDFOR missing

Cause: | "FOR" loop not terminated with "ENDFOR". Example: DEF Prog() INT i i=1 FOR i=1 TO 6 END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog() INT i i=1 FOR i=1 TO 6 ... ENDFOR END


Corresponding ENDIF missing

Cause: | "IF" loop not terminated with "ENDIF".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Corresponding ENDLOOP missing

Cause: | "LOOP" loop not terminated with "ENDLOOP". Example: DEF Prog() LOOP END
Effect: | The program cannot be executed.
Remedy: | Alter the program.Example: DEF Prog() LOOP ... ENDLOOP END


Corresponding ENDSWITCH missing

Cause: | "SWITCH" loop not terminated with "ENDSWITCH".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Corresponding ENDWHILE missing

Cause: | "WHILE" loop not terminated with "ENDWHILE". Example: DEF Prog() INT i i=1 WHILE i<100 END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog() INT i i=1 WHILE i<100 ... ENDWHILE END


Corresponding UNTIL missing

Cause: | "REPEAT" loop not terminated with "UNTIL". Example: DEF Prog() INT i i=1 REPEAT END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog() INT i i=1 REPEAT i=i+1 UNTIL i>100 END


Count exceeded

Cause: | A variable has been assigned a number which exceeds the range of values.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Couple process active

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


CP-Vel. reduction point <pointname> <dumma> by <reduction in %>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Data inadmissible

Cause:

  • Extension not compatible.

  • The command "COPY *.*" was used.

The command "COPY *.*" is only permitted with a directory.

Effect:

Command is not executed.

Remedy:

Enter extension correctly.


Data list cannot be renamed

Cause: | An attempt has been made to rename a data list.
Effect: | Change is rejected.
Remedy: | Retain old name.


Data list not PUBLIC

Cause: | Global variables from DAT files can only be used in differently named SRC files if the DAT file has been declared as "PUBLIC". Example: DEFDAT P1 DECL GLOBAL INT a = 1 ENDAT DEF P2() a = 2 END
Effect: | The program cannot be executed.
Remedy: | Insert the keyword "PUBLIC" in the header of the DAT file. Under certain circumstances it will be necessary first to make the header visible using the menu command "CONFIGURE -> MISCELLANEOUS -> EDITOR -> DEF-line". Example: DEFDAT P1 PUBLIC DECL GLOBAL INT a = 1 ENDAT DEF P2() a = 2 END


Data storage device not ready: ...

Cause:

Floppy disk missing or disk drive defective.

Effect:

It is not possible to save to floppy disk.

Remedy:

  • Insert floppy disk into the disk drive.

  • Check disk drive.


Data transfer performed <axis number>

Cause:

The sensor location run has been carried out correctly.


Deadman switch required

Cause: | The enabling switch has not been pressed.
 | When pressing the Start keys or a traversing key (forwards [+] or backwards [–]) in T1 or T2 mode, the enabling switch must also be pressed.
Effect: | Command is not executed.
Remedy: | Press enabling switch.


Declaration not in declaration section

Cause: | A declaration is situated outside the declaration section.
Effect: | The program cannot be executed.
Remedy: | Move declaration to the declaration section.


DEV must follow

Effect: | The program cannot be executed.
Remedy: | Alter the program.


DEF/DEFFCT inadmissible

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


DEF or DEFFCT expected

Cause: | The keyword "DEF" or "DEFFCT" has been omitted or written incorrectly.
Effect: | The program cannot be compiled.
Remedy: | Correct program.


Default parameter

Cause:

A default parameter or no parameter has been transferred to a predefined C function.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Call the C function with a parameter.


DEFDAT expected

Cause: | The first line of a DAT files must begin with the keyword "DEFDAT".
Effect: | The corresponding SRC file cannot be executed.
Remedy: | Alter DAT file.


DEFDAT inadmissible

Cause: | "DEFDAT" has been inserted in an unauthorized position.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


DEL must follow

Effect: | The program cannot be executed.
Remedy: | Alter the program.


DELAY expected

Cause: | The keyword "DELAY" has been omitted or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Delete module by means of dedicated function

Remedy:

Alter the program.


Deleting of system files is inadmissible

Cause:

An attempt was made to delete a system file.


Deleting Trace: no backward motions possible

Cause: | Editing was carried out or a block selection was made causing the trace to be deleted.
Effect: | Reverse traversing is not possible.
Remedy: | Forward motion


Device not ready

Cause:

  • Connecting cable defective or not plugged in.

  • Device (e.g. printer) switched off or defective.

Remedy:

Check connection cable and device.


<Axis number> decoupled auxiliary axis, AJOG not allowed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Axis number> decoupled auxiliary axis, MOVE not permitted

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Axis number> decoupled auxiliary axis, MASTERING not allowed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Different types with change of initial value

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Digital input expected

Cause: | A digital input is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Digital input inadmissible here

Cause: | A digital input is not admissible here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Dimension incompatible

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Disk write protected

Cause: | The write protection of the floppy disk is activated.
Effect: | It is not possible to save data on the floppy disk.
Remedy: | Remove the write protection.


DISTANCE: only 1 or 0 allowed

Cause: | Only the values 1 and 0 may be assigned to the switching point "DISTANCE".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


DISTANCE or PATH expected

Cause: | One of the keywords "DISTANCE" or "PATH" is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Division by 0

Cause:

A value is to be divided by "0".

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Correct program.

  • Acknowledge message.


DO expected

Cause: | The keyword "DO" has been omitted in an INTERRUPT or TRIGGER instruction. Syntax: INTERRUPT DECL PriorityWHEN ConditionDO Subprogram name TRIGGER WHEN DISTANCE = Switching pointDELAY = TimeDO InstructionPRIO = Priority
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Drift Compensation aborted

Cause:

The drift compensation was interrupted by a stop (Stop key pressed, message triggering a stop).

Effect:

  • Drift compensation failed.

  • Dynamic braking.

Remedy:

Repeat drift compensation.


DRIFT completed

Cause:

DRIFT is completed.


DSE - Boot finished

Cause: | The DSE was booted. It is used for automated tests that have to to know whether all parts of the system are ready.
Effect: | No effect (just notification)
Remedy: | Not needed


Dual declaration

Cause: | The name used has already been given to a different object.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


EB-Assignment not allowed

Cause: | EB was used not used correctly as the right hand side of a $BASE assignment.
Effect: | Interpreter and robot stop.
Remedy: | Correct Assignment $BASE=EB(...)


Edit commands inadmissible, finish movement first

Cause: | You have attempted to edit a program while in mode "Editing without implicit block selection". The program is still in a motion block.
Effect: | Editing is not possible.
Remedy: | Press the Start key again until the message "Edit commands now allowed" appears. Editing is then possible.


Edit commands now allowed

Cause: | You are in the mode "Editing without implicit block selection", and after completion of the current motion block have received an editor enable.
Effect: | It is possible to edit again.


EMT mastering distance exceeded

Cause:

  • Notch not found.

  • Axis position not before notch prior to start.

Effect:

Ramp-down braking.

Remedy:

  • Move to mastering position (see Operating Handbook).

  • Check EMT.

  • Check reference notch on axis.


END/ENDFCT/ENDDAT inadmissible here

Cause: | The "END", "ENDFCT" or "ENDDAT" keyword has been inserted in an inadmissible position or the syntax has not been observed correctly.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


End of block or comment expected

Cause: | The syntax has not been observed correctly or a comment has been entered without a preceding ";".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


End of control structure inadmissible here

Cause: | The control structure syntax has been violated. Example: FOR i=1 TO 6 ... ELSE ... ENDFOR
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: FOR i=1 TO 6 ... ENDFOR


Entry in symbol table is not label

Effect: | The program cannot be executed.
Remedy: | Alter the program.


ENUM constant type does not match ENUM variable

Cause: | An ENUM constant has been assigned to an ENUM variable of a different type.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


ENUM not declared in $CONFIG

Cause:

  • A SET INFO is being applied to an ENUM variable from a user data list.

  • The search path extension has been altered.

  • No access to ENUM type information.

Remedy:

Enter ENUM declaration and variable declaration in the "$CONFIG.DAT" file.


Error at format selection no. <incorrect format selection number>

Cause: | Parameter inconsistent with format specification, or incorrect format specification in CWRITE instruction.
 | Monitoring is carried out during program execution in S_INT function CWRITE.
Effect: | Program execution is stopped.
Remedy: | Program correct format specification.


Error during allocate device <Mac-ID>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error during reading of INI file ...

Cause: | The INI file read contains errors.
Effect: | All commands inhibited.
Remedy: | Correct INI files accordingly.


<file format>: Error during recording of <record name>

Cause: | Driver specific
Effect: | Recording stops
Remedy: | Contact supplier of driver


Error during scan device ...

Cause:

Effect:

Remedy:


Error during task start

Cause:

Effect:

Remedy:


Error in DEFDAT, insert not successful

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error in global DEF/DEFFCT

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error <error number> in PTP motion planning, perhaps no approximation

Cause:

Internal error when planning the approximation block.

In order to execute the approximation block the velocity must first be reduced in the previous block.

Effect:

  • Depending on the error number, approximation may not be carried out. "Exact positioning" takes place.

  • If, on the other hand, approximation is carried out, no further effects.

Remedy:

  • Modify the profile data (velocity, acceleration, approximate positioning radius) accordingly.

  • If necessary, consult KUKA in order to refine the numeric algorithms.


Error in configuration file

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error in path

Cause: | Error in path (e.g. /R5).
Effect: | Command is not executed.
Remedy: | Check and correct path specification.


Error in trace definition

Cause: | The trace has been incorrectly defined in the "TRACE.DEF" file.
Remedy: | Correct "TRACE.DEF".


Error occurred while reading IDF file

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error on axis coupling

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error on axis decoupling

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error on entering the data list

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error at end of block

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Error reading TRACE.DEF

Cause:

The "TRACE.DEF" file could not be read at the start of trace recording.

Effect:

Trace recording is not carried out.

Remedy:

  • Make "TRACE.DEF" available.

  • Start or check FTP server.


ERROR token in I-code

Remedy:

Alter the program.


<file format>: Error when starting recording <record name>

Cause: | Initialization of driver for recording failed.
Effect: | Recording does not start.
Remedy: | Contact KUKA service.


Error while reading O-File

Cause:

  • Error during loading/reading of "ident_vx.o": memory or file not found.

Monitoring is carried out in the write function "w_ident_state".

Effect:

Jump to the end in load data program.

Remedy:

Copy the file "ident_vx.o" to the directory "/ir_spec/l_ident", or increase memory by changing the value "VxWinRAM" in the registry.


EXIT not in loop body

Cause: | The keyword "EXIT" is outside a loop.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expected constant type unknown

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expected ext. subroutine, found function

Cause: | A subroutine has been declared as external, but a function with the same name has been found.Example: DEFFCT INT Test(x:IN) INT x ... ENDFCTDEF P() EXT Test(INT:IN) END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Test(x:IN) INT x ... END DEF P() EXT Test(INT:IN) END


Expression after return instruction missing

Cause: | In a function, a return value is expected after the RETURN instruction. Example: DEFFCT INT Otto() INT a ... RETURN ENDFCT
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEFFCT INT Otto() INT a ... RETURN (a) ENDFCT


Expression not equal to BOOL

Cause: | An expression of data type "BOOL" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression not equal to CHAR, INT, ENUM

Cause: | An expression of data type "CHAR", "INT" or "ENUM" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression not equal to INT

Cause: | An expression of data type "INT" is expected. Example: INT i FOR i=1.3TO 7 ... ENDFOR
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT i FOR i=1 TO 7 ... ENDFOR


Expression not equal to INT, REAL

Cause: | An expression of data type "INT" or "REAL" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression not equal to POS, FRAME

Cause: | An expression of data type "POS" or "FRAME" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression not equal to POS, FRAME, AXIS

Cause: | An expression of data type "POS", "FRAME" or "AXIS" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression too complex

Cause: | Copying from one channel to another. This is not allowed in SWP1.
Effect: | Command is not executed.


Expression type not equal INT, REAL, CHAR, BOOL, ENUM

Cause: | The data type of the expression must be INT, REAL, CHAR, BOOL or ENUM.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression type not equal to STAT_T

Cause: | The data type of the expression must be STAT_T.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Expression type not MODUS_T

Cause: | The data type of the expression must be "MODUS_T".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


EXT/EXTFCT/IMPORT inadmissible here

Cause: | An "EXT", "EXTFCT" or "IMPORT" instruction has been placed in an inadmissible position.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Extension inadmissible

Cause: | An extension has been specified in a command where it is not allowed (e.g. "analyse otto.src").
Effect: | Command is not executed.
Remedy: | Correct command.


Extension inadmissible

Cause: | The extension is invalid.
Remedy: | Remove the extension.


Extension missing

Cause: | Extension is missing.
Remedy: | Alter the program.


Extension or ".*" invalid

Cause: | Extension or ".*" invalid
Remedy: | Alter the program.


External and SR/FCT declarations do not match

Cause: | External declaration does not correspond to the SR/FCT declaration.
Effect: | The program cannot be executed.
Remedy: | Check external declarations.


External instruction <name of external function> not loaded

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


External function expected, subroutine found

Cause: | A function has been declared as external, but a subroutine with the same name has been found. Example: DEF Test(x:IN) INT x ... ENDDEF P() EXTFCT INT Test(INT:IN) END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEFFCT INT Test(x:IN) INT x ... ENDFCTDEF P() EXTFCT INT Test(INT:IN) END


EXT[FCT] and DEF[FCT] parameters are incompatible

Cause: | The parameters specified in the EXT instruction do not correspond to those in the subprogram declaration. Example: DEF Test(x:IN) INT x ENDDEF P() EXT Test() END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Test(x:IN) INT x ENDDEF P() EXT Test(INT:IN) END


EXTFCTP instruction inadmissible

Cause:

An EXTP or EXTFCTP instruction has been used in the program.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Delete the EXTP or EXTFCTP instruction from the program.


Fast EMERGENCY STOP with fixed ramps

Cause:

In the event of EMERGENCY STOP with dynamic model, the fixed braking ramp strategy is used as this brakes the robot significantly more quickly.

Effect:

In the event of EMERGENCY STOP, the robot is braked more quickly than with the dynamic model strategy alone.

Remedy:

  • Check torque limits for EMERGENCY STOP.

  • Verify load data.


Faulty initialization value

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Faulty file

Cause: | The object is not correct for TTS calculation.
Remedy: | Correct object accordingly.


<file format>: File <file name> cannot be opened

Cause:

  • Read operation: File does not exist.

  • Write operation: File or storage medium write protected or disk full.

Effect:

Motion driver does not execute command.

Remedy:

  • Read operation: Create file

  • Write operation: Remove write protection or create free space on disk by deleting some other files.


File description cannot be processed

Cause: | Module information that cannot be evaluated has been received in a COPY operation from an external source.
Effect: | Command is not executed.
Remedy: | Check interface software.


File name may not contain "."

Effect: | The program cannot be executed.
Remedy: | Alter the program.


File name too long

Effect: | The program cannot be executed.
Remedy: | Alter the program.


First constant incompatible with this constant

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Formal parameter declaration missing

Cause: | A formal parameter has not been declared.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Formal parameter not defined

Cause: | No data type has been assigned to the formal parameters in the subprogram or function. Example: INT i i=1 Hb(i) ... DEF Hb(a:IN) END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT i i=1 Hb(i) ... DEF Hb(a:IN) INT a ... END


Format error

Cause: | Hardware error in the I-CPU interface.
Remedy: | If the error recurs, exchange the module (I-CPU interface).


Global SR/FCT cannot be renamed

Cause: | Unauthorized change of name
Remedy: | Undo change of name.


<Object name> has reached maximum size

Cause: | When a module has reached the maximum size (65536 bytes), a message appears, e.g. "SRC HAS REACHED MAXIMUM SIZE AND CANNOT BE EXPANDED".
Remedy: | Reduce size.


Hierarchy. No. not in search path

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Hydraulic level

Cause: | The oil level in the hydraulic system has fallen below the minimum limit.
 | Monitoring is carried out during PLC program execution.
Remedy: | Top up hydraulic oil and check hydraulic system for leaks.


I/O-linking: output <output number> write-protected

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


I/O-linking: output <output number> write-protected in module <module name> line <line number>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


IBS <...>: Bus is still active. Reset not possible

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Bus error (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Bit <...> is Local Master OK Bit

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Bus error segment <> (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Configuration error (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Configuration error segment <...> (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Error open file <...>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Error switching off segment <...> (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Error switching on segment <...> (<>)

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: Periphery failure segment <...>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...> Master: The watchdog is expired

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <Slave:> Slave: The slave of the IBS-Card couldn't be activaded

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...>: Too many input bytes in IOSYS.INI projected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


IBS <...>: Too many output bytes in IOSYS.INI projected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Identical predefined signal names expected

Cause: | Specification of signals was not restricted to just inputs or just outputs. Example: SIGNAL $DIGIN1 $OUT[20] TO $IN[29]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: SIGNAL $DIGIN1 $IN[20] TO $IN[29]


Identifier not declared

Cause: | No data type has been assigned to the identifier (i.e. the name of the transfer parameter) in the subprogram of function.
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog(a:IN) REAL a ...


IFC syntax error

Cause: | During an attempt to open or close a channel, a syntax error has occurred in the CPU interface with regard to the command generated by the control.
Remedy: | Close the channel and open it again.


Illegal command

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Illegal or unknown block

Cause: | Compiler cannot process the program line. e.g. assignment of two Enum constants: #Otto=#Emil or insertion of program code into the DAT file. The cause can also be a typing error.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Import interface not correct

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Imported variable not declared in data list

Cause:

The IMPORT instruction refers to a variable which does not exist in the specified data list.

Effect:

The program cannot be executed.

Remedy:

  • Check name.

  • Check path.

  • Declare variable.


Imported variable type/dimension conflict

Cause: | Data type and/or dimension of the imported variable and the reference data list variable do not match. Example: DEFDAT PROG_1 PUBLIC DECL INT Hugo[2,2] Hugo[2,2] = 1 ENDDATDEF P() IMPORT INT Hugo2IS /R1/PROG_1 .. Hugo END
Effect: | The program cannot be executed.
Remedy: | Check type and dimension of the imported variable. Example: DEFDAT PROG_1 PUBLIC DECL INT Hugo[2,2] Hugo[2,2] = 1 ENDDATDEF P() IMPORT INT Hugo2[2,2]IS /R1/PROG_1..Hugo END


IN or OUT expected

Cause: | In a subprogram or function declaration, the transferred parameters have not been labeled as "IN" or "OUT" parameters, or a typing error has occurred. IN parameter: "Call by Value"; only a value is transferred; the value of the variable cannot be modified by the subprogram or function. OUT parameter: "Call by Reference"; the address of the memory location of the variable is transferred; the variable can thus be defined by the subprogram or function. Example: DEF Prog(X:IN, Y:xx, Z:OUT) INT X,Y,Z ...
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog(X:IN, Y:OUT, Z:OUT) INT X,Y,Z ...


<Value> inadmissible

Cause: | An inadmissible value has been entered.
Remedy: | Specify valid value.


Inadmissible expression after return instruction

Cause: | The expression after the "RETURN" instruction is inadmissible. Example: DEF Up() ... RETURN (1) END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Up() ... RETURN END


Inadmissible in this edit mode

Cause:

  • A command that would alter the object has been entered in the listing mode of the editor.

  • An attempt has been made in data correction mode to delete or copy a group of blocks or to delete a block consisting of only one line.

Effect:

The attempted action is not executed.

Remedy:

Edit in full editor mode.


Inadmissible mastering sequence

Cause: | The mastering sequence was not adhered to; defined in machine datum "$SEQ_CAL".
Effect: | Axis cannot be mastered.
Remedy: | Observe mastering sequence.


Inadmissible reference system

Cause: | The manual traversing reference system is not permissible for this kinematic system.
 | Monitoring is carried out when the Start and traversing keys are pressed.
Remedy: | Change reference system (TRANSSYS).


Incomplete instruction

Cause: | The SBC interface is not initialized.
Effect: | None.
Remedy: | Initialize SBC interface.


Incomplete reference system definition

Cause: | At least one frame required for calculating the reference matrix has not yet been assigned.
Remedy: | Carry out the corresponding assignment.


Incorrect dimension

Cause: | The specified array dimension does not correspond to the declared dimension. Example: DECL INT f[3] f[4,3]=1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DECL INT f[3] f[2]=1


Incorrect end of control structure

Cause: | A control structure has been terminated with the wrong keyword, e.g. "LOOP" with "ENDWHILE".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Incorrect end of parameter list

Cause: | The parameter list was not completed correctly. Example: DEF Up(x:IN) INT x END DEF Prog() INT Var Var = 1 Up(Var; ) END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Up(x:IN) INT x END DEF Prog() INT Var Var = 1 Up(Var) END


Incorrect initialization

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Index cannot be changed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Indexing or [ ] expected

Cause: | An array variable name has been used without square brackets or index specification.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Indexing or [ ] inadmissible

Cause: | A name, which has not been declared as an array, has been given an index or square brackets. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2} Hugo.a[3]=7
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2} Hugo.a=7


INFO expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Information loss possible on change of type

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Initial value block not in initialization section

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Initial value inadmissible here

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Initial value of index already exists

Cause: | Index value has already been initialized.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Input buffer overflow

Cause:

The input buffer is full.

Effect:

The controller no longer accepts telegrams.

Remedy:

  • Read telegram using CREAD.

  • Increase the number of input buffers in the file SERIAL.INI.


Insert another disk

Cause: | Request for next floppy disk.
Remedy: | Insert floppy disk in the disk drive.


Insert before first block inadmissible

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Instruction inadmissible

Cause:

  • Program instruction that is not admissible as a command;

  • Program instruction that is only admissible in an interrupt program.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • During program execution, acknowledge message.


Instruction not in instruction section

Cause: | An instruction is situated outside the instruction section.
Effect: | The program cannot be executed.
Remedy: | Move instruction to the instruction section.


Integer constant expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


INT. constant not equal 0 expected

Cause: | The specification of an integer constant not equal to 0 is missing. Example: INT i i=1 FOR i=1 TO 7 STEP ... ENDFOR
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT i i=1 FOR i=1 TO 7 STEP 2 ... ENDFOR


INTEGER constant expected

Remedy:

Alter the program.


INTEGER, REAL or CHARACTER constant expected

Cause: | Specification of an INTEGER or REAL value or a CHARACTER constant is missing. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a , b }
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto INT a, REAL b DECL Otto Hugo = { a 1, b 2.2}


InterBus : bus error <segment, position>

Cause:

Error or malfunction in data transmission on the Interbus.

Effect:

  • Data transmission on the Interbus is stopped.

  • Outputs are reset.

Remedy:

Troubleshooting with CMD (Phoenix diagnostic tool).


InterBus: bus error in slave ring

Cause: | Bus error in the ring of the higher-level controller (PLC, etc.).
Effect: | Automatic External interface deactivated.
Remedy: | Rectify bus error in higher-level ring.


InterBus : bus warning <segment, position>

Cause:

Malfunction in the specified bus module.

Effect:

Outputs are reset.

Remedy:

  • Eliminate the error in the specified module.

  • Diagnosis using CMD software (Phoenix).


Interbus: watchdog time expired

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Internal error <error number> (<task Id>,<return value>)

Cause: | Internal software error
Remedy: | Please contact the KUKA customer service department.


Internal error when accessing <object name>

Cause: | An internal error has occurred when accessing an object.
Effect: | The action was not carried out correctly.


Invalid block number

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Initial block number > final block number

Cause: | The initial block number is larger than the ending block number.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


<file format>: Invalid configuration for <record name>

Cause:

  • Invalid format of configuration file.

  • Too many variables configured for recording.

Effect:

Recording cannot be started

Remedy:

  • Ckeck configuration file.

  • Reduce number of variables to be recorded.


<Path> Invalid data module name or extension

Cause: | An incorrect path, module name or extension has been specified.
Effect: | Command is not executed.
Remedy: | Correct command accordingly.


Invalid extension

Cause: | The extension is invalid.
Remedy: | Correct the extension.


<file format>: Invalid file format <record name>

Cause: | Invalid file format
Effect: | Motion driver does not execute command.
Remedy: | Correct file format.


Invalid handle

Cause:

An invalid HANDLE has been programmed in CWRITE or CREAD.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Specify a valid HANDLE.


Invalid input character

Cause: | A character has been entered that is meaningless here. Example: $OUT[2b]=TRUE
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: $OUT[2]=TRUE


Invalid mastering sequence

Cause: | The predefined mastering sequence was not observed (defined in machine datum "$SEQ_CAL").
Remedy: | Carry out mastering procedure observing the defined sequence.


Invalid name - The workspace name already exists

Cause: | The user is attempting to use a workspace name that is already in use on the same controller.
Effect: | The name will not be saved.
Remedy: | Specify a unique name.


Invalid operating mode

Cause: | "Start backwards" was pressed in AUT or EXT mode.
Effect: | Invalid operating mode. Permissible is only T1 or T2.
Remedy: | Switch to T1 or T2 mode.


Invalid parameter value

Cause: | The maximum value of a channel parameter has been exceeded.
Remedy: | Correct the channel parameter.


Invalid pulse duration

Cause:

The value specified for the pulse duration is outside the permissible range.

The permissible range for the pulse duration is 0.05 to 3049.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Program values in the permissible range.


Invalid sign

Cause: | No sign is permissible here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Invalid statement

Cause: | The source and target specifications for the "COPY" command are incompatible.
Effect: | Command is not executed.
Remedy: | Enter source and target specification correctly.


Invalid value for $Simulated_Axis

Cause: | An invalid value for $Simulated_Axis was requested.
Effect: | Invalid value was rejected. Previous value will be used.
Remedy: | $Simulated_Axis is a bitmask, based on the number of axes. The $Simulated_Axis value cannot be negative, and must be equal to or less than 0x0FFF.


<$ variable> invalid value

Cause:

Read access to a variable that has not been initialized or has an invalid value, e.g. "$POS_INT" read outside an interrupt program.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


Interrupt priority inadmissible

Cause:

Interrupt priority greater than 128 or less than 1.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • Alter the program accordingly.


IS expected

Cause: | The keyword "IS" is missing or incorrectly positioned.Example: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 /R1/PROG_1 .. Otto END
Effect: | The program cannot be executed.
Remedy: | Alter the program.Example: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 IS/R1/PROG_1..Otto END


<Operator control device> is active

Cause: | Indicated operator control device is active.
Effect: | Command is not executed.
Remedy: | Deactivate indicated operator control device.


<Path> is not a directory

Cause: | Command contains a subdirectory.
 | Specification of a subdirectory, e.g. "dir /R1/otto/abc", is not permissible.
Effect: | Command is not executed.
Remedy: | Correct command accordingly.


... is not a memory dump

Cause: | When writing a data block (a file received from the controller or a temporary file created by the server), it has been discovered that there is not enough space available on the storage medium (hard disk).
Effect: | The file currently being processed is deleted.
Remedy: | Create space on the storage medium (delete files that are no longer required).


<Module name> is not a module

Cause: | The name specified refers to a directory.
Effect: | Command is not executed.
Remedy: | Use module name.


<Object name> is write protected

Cause: | The object is write-protected.
Effect: | Command is not executed.
Remedy: | Check object status; e.g. unlink or deselect object.


Jump destination not declared globally

Remedy:

Alter the program.


Jump destination not declared locally

Cause: | The jump destination has not been declared locally, but may have been declared elsewhere. Example: DEF Prog() Label: END DEF Prog2() GOTO Label END ; in the example, both programs are located in the same SRC file
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF Prog2() ... Label: ... GOTO Label END


Jump to label inadmissible

Cause: | The label is located in a program structure, e.g. a "SWITCH" branch, to which a jump is not possible.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


KCPDRV: KCP Message Handler failed to start

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


KCPDRV: Safety Flag Violation

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


KCPDRV: Unknown error code <>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


KCPDRV: Watchdog Error

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Key combination <KCP> inadmissible

Cause: | Simultaneous pressing of more than one key on the KCP.
Effect: | KCP operation is briefly interrupted.
Remedy: | Release keys on the KCP.


Key inadmissible

Cause: | Impermissible key (e.g. softkey) pressed in textual operation.
Effect: | The entry is not processed.


Key not assigned

Cause:

An unassigned softkey or function key has been pressed during prompted operation.


Ki expected: 1

Ki expected: 1<=i<=12

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Kinematic instruction inadmissible

Cause:

A non-existent external kinematic system has been assigned to the system variable "$BASE" with the function EK.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct program.


The usage of this KRL statement is not allowed within a spline block.

Cause: | A not allowed statement was used within a spline block.
Effect: | syntax error in module


Label not declared locally

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand: array or path invalid

Cause: | Left operand may not be an array or path. Example: INT x[9] x[2]=13 IF x[]== 7 THEN ...
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT x[9] x[2]=13 IF x[2]== 7 THEN ...


Left operand not equal to BOOL

Cause: | Left operand is not of data type "BOOL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand not equal to INT, CHAR

Cause: | Left operand is not of data type "INT" or "CHAR".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand not equal to INT, REAL

Cause: | Left operand is not of data type "INT" or "REAL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand not equal to INT, REAL, BOOL, CHAR, ENUM

Cause: | The data type of the left operand is not "INT", "REAL", "BOOL", "CHAR" or "ENUM".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand not equal to INT, REAL, CHAR, ENUM

Cause: | Left operand is not of data type INT, REAL, CHAR or ENUM.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left operand not equal to POS, FRAME

Cause: | The data type of the left operand is not "POS" or "FRAME".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Left side: array invalid

Cause: | It is not permissible to specify an array in the left-hand side of the expression, although an array element may be permissible. Example: $OUT[]=TRUE
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: $OUT[3]=TRUE


Line compilation or de-compilation error

Effect:

None


Line <Linenumber> in <Modulename> too long. Line was cut off

Cause: | An excessively long program line was cut off in order to avoid the rest of the program content being lost.
Effect: | The line is cut off. The program file is retained.
Remedy: | Modify the incorrect line accordingly in expert mode.


Line selection to local function not allowed

Cause: | Line selection to a local function. It is only allowed to select local procedures.
Effect: | Line selection will not work.
Remedy: | Select call to local function in your main program.


Line selection beyond buffer: Next start deletes buffer

Cause: | Line selection is outside the trace.
Effect: | When the Start key is pressed, the buffer for backward motion is deleted.
Remedy: | Before pressing the Start key, make another line selection within the buffer. After that the backward motion can be carried out.


Line selection failed, Robot: <remote robot>

Cause: | Line selection on a remote controller failed.
Effect: | Remote line selection was not executed.
Remedy: | No or wrong program selected. Or the programs are not equal.


<Object name> link list cannot be extended

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Module> linking error

Cause: | One or more errors have been detected in the indicated module during linking.
Effect: | Command is not executed.
Remedy: | Using the error list, correct the error(s).


Load dependent acc. adaption not possible for PTP in line <line number>

Cause:

The simulation calculation of the integrated dynamic model exceeds the given limit values of the continuous gear torque.

Monitoring is carried out for each PTP preparation with activated load-dependent acceleration adaptation.

Remedy:

  • If allowed: increase the max. permissible continuous gear torque.

  • Lower the optimization limit "$OPTEXCLUDE".


LOAD not programmed

Cause:

Acceleration adaptation is activated, but the load has not been completely programmed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Program "$LOAD" correctly.


Local EMERGENCY STOP button pressed

Cause:

Emergency stop was released.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Local parameter type defined locally

Remedy:

Alter the program.


Local STRUC/ENUM not declared in global STRUC

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Local subroutine inadmissible in process commands

Remedy:

Alter the program.


LTC: initialization failed (Reason: <Reason>)

Cause:

Initialization of LTC-Task failed

Effect:

The LTC-Task collects no data.

Remedy:

  • copy the file LTC_Para.ini into the init directory

  • Rotot need to be configured at least with 6 axis

  • activat dynamic model


MAC-ID in use

Cause:

Effect:

Remedy:


Machine data error

Cause: | The machine data have not yet been checked.
Effect: | None.
Remedy: | Copy correct machine data or option data file to the controller.


Mailbox identification inadmissible

Cause:

An incorrect "MBX_ID" has been specified in the C function "MBX_REC".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Main process not available

Cause: | Main run display selected, but no main run block interpreted yet.
Effect: | None
Remedy: | Start program.


Mastering performed <axis number>

Cause: | An attempt was made to master an axis that has already been mastered.
Remedy: | Cancel via RECALL.


Max. no. of interrupts defined

Cause:

More than 32 interrupts have been defined.

  • No more than 32 interrupts may be defined.

  • Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Max. no. of interrupts on

Cause:

More than 8 interrupts have been activated.

  • No more than 8 interrupts may be activated.

  • Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Maximum no. of processes assigned to channel

Cause: | Too many processes are running through the serial interface.
Remedy: | Wait until a process is finished.


<file format>: Maximum number of simultaneous recordings

Cause: | Depending on the driver type, the number of simultaneous recordings may be limited - in the extreme only one recording at a time.
Effect: | Recording is not started
Remedy: | Wait for other recordings to finish


MDR: Motion driver returns error <error number>

Cause: | A call of a motion driver callback returned an error
Effect: | Robot and interpreter stop
Remedy: | Driver dependent.


MDR: State switch not allowed

Cause: | The state switch with MD_SETSTATE() was not allowed
Effect: | Robot and interpreter stop
Remedy: | Use allowed state switches: INITIALIZED <-> ACTIVE If state INITIALIZED is not possible there was an error during the initialization.


MDR: Status of device not active

Cause: | A MDR / EB command was called and the status of the device was not ACTIVE.
Effect: | Robot and interpreter stop.
Remedy: | Set the status of the device ACTIVE.


MDR: Device not of type <Desired driver type>

Cause: | Device is not of the correct type.
Effect: | Roboter and interpreter stop.
Remedy: | Use a device of the correct type.


MDR: Devicename unknown

Cause: | A device name not included in the device list was used
Effect: | Interpreter and robot stop
Remedy: | Use a correct devicename


Message cannot be acknowledged

Cause: | Acknowledgement of a status message.
Effect: | Command is not executed.
Remedy: | None. Read the message.


MESSAGE expected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Message not available

Cause: | Attempted textual acknowledgement of a message that is not available.
Effect: | Command cannot be executed.


Module package not available

Cause:

A required module cannot be found, e.g. it has not been declared or has not been declared as global.

Example:
DEFDAT P PUBLIC
DECL CONST INT Hugo = 1
ENDDAT

DEF Up()
IMPORT INT Hugo
END

Effect:

The program cannot be executed.

Remedy:

  • Check path and name of module.

  • Declare module or declare it as global.

Example:
DEFDAT P PUBLIC
DECL GLOBALCONST INT Hugo = 1
ENDDAT

DEF Up()
IMPORT INT Hugo
END


Module used by another process

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


More actual than formal parameters specified

Cause: | More current parameters have been specified in the subprogram or function call than there are formal parameters declared in the subprogram or function declaration. Example: Up(3,5,9) ... DEF Up(a:IN,b:IN) INT a,b ...
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: Up(3,5) ... DEF Up(a:IN,b:IN) INT a,b ...


More than one key <teach pendant>

Cause: | Simultaneous pressing of more than one key on the KCP.
Effect: | KCP operation is briefly interrupted.
Remedy: | Release keys on the KCP.


<Name> ambiguous

Cause: | The specified memory dump name contained wildcards. Expansion of these wildcards results in more than one valid file name. This, however, is not allowed.
Effect: | Data transfer is not carried out.
Remedy: | Enter an unambiguous name.


Name expected

Cause: | The specification of a name is missing in the expression, or the specification does not conform to the rules, e.g. just numbers in a variable name. Example: BOOL
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: BOOL Hugo


Name in first line must be same as module name

Cause: | Name in first line of the program does not match module name.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name invalid for this type of constant

Cause: | A constant name has been specified which does not exist or is not valid for the data type. Example: ENUM Colors blue, yellow, red DECL Colors Individual Color Individual Color=#orange
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ENUM Colors blue, yellow, red, orange DECL Colors Individual Color Individual Color=#orange


Name more than 24 characters

Cause: | The name may not be more than 24 characters long.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name not declared as array

Cause: | Variable has been specified with an index, but is not declared as an array. Example: INT Hugo Hugo[3]=7
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT Hugo Hugo=7


Name not declared as channel

Remedy:

Alter the program.


Name not declared as channel

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name not declared as function

Cause: | An apparent function value is assigned to a variable. The apparent function is usually defined as a subprogram. Example: INT i i=Prog() ... DEF Prog() ... END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT i i=Prog() ... DEFFCT INT Prog() ... ENDFCT


Name not declared as label

Cause: | An attempt has been made to jump to an undefined label using the "GOTO" command.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name not declared as simple variable

Cause: | The name of the variable is correct, but the variable is not a simple variable, or the variable is being used in the wrong context. A subprogam name, for example, has been used instead of the name of a simple variable, or the variable is an array variable which has been used without an index. Example 1: DEF hhh() hhh=1 ENDBeispiel 2: INT Hugo[3] Hugo=1
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name not declared as subroutine

Cause:

  • A subroutine has been called which does not exist, e.g. from an interrupt or trigger declaration.

  • A function is being called as a subroutine.

Effect:

The program cannot be executed.

Remedy:

Alter the program.


Name of a signal expected

Cause: | The name of a signal is missing in the program line. Example: ANOUT OFF
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT OFF $ANOUT[2]


Name of a structure data type expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name of a subroutine expected

Cause: | The name of a subroutine is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name of loop variable expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Name too long

Cause: | The indicated name contains too many indications.
Remedy: | Reduce number of indications.


Nesting depth exceeded

Cause: | Too many control structures (e.g. IF or WHILE instructions) have been used inside identical control structures.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


New block is not a declaration

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No "/" in P_Path

Cause: | The character "/" has been omitted.
Remedy: | Insert "/".


No axis selected

Cause: | An attempt has been made to carry out a tacho balance even though no axis has been selected.
 | Monitoring is carried out in the event of value assignment to "$TACH_CHANGE".
Effect: | Value assignment is not carried out.
Remedy: | First select an axis, then carry out tacho balance.


No block coincidence, step mode first

Cause: | No block coincidence when switching to AUTO mode.
Remedy: | Select SINGLE-STEP mode first.


No CASE after SWITCH

Cause: | "SWITCH" construction does not contain a "CASE" branch.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


No connection to SINEC L2 board

Cause:

The connection of the IFC to the SINEC L2 board is faulty.

Remedy:

  • Carry out a warm restart.

  • If fault recurs, exchange board (IFC with SINEC L2 board).


No data type name: creation inadmissible

Effect: | The program cannot be executed.
Remedy: | Alter the program.


<Object name> no dynamic memory available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No ENUM type specified

Remedy:

Alter the program.


No error

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No file available

Cause: | No file is available that meets the search criteria specified in the DIR command.
Effect: | None.
Remedy: | Check specifications and spelling in the DIR command.


No file name specified

Effect: | The program cannot be executed.
Remedy: | Alter the program.


No file name

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No global procedure available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No interfaces permitted

Remedy:

Alter the program.


no matching endspline found

Cause: | No matching endspline found for open spline block.
Effect: | Syntax of program is not correct.


<file format>: No memory available for <record name>

Cause: | Too many recordings are already in memory.
Effect: | Motion driver does not execute command.
Remedy: | Delete some other record.


No more data/variables available

Cause:

With SREAD/CREAD there is no more text to be read or there are no variables available for storing the values.


No more system memory available

Cause: | There is insufficient system memory to execute the commands "SHOW VAR" or "SET INFO".
Effect: | Command is not executed.
Remedy: | Save programs that are not required to disk in order to free up memory capacity.


No more than three dimensions allowed

Cause: | The maximum 3 dimensions have been exceeded in an array declaration.Example: DECL INT Hugo[3,2,7,6]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DECL INT Hugo[3,2,7]


No more user memory available

Cause: | Insufficient memory capacity for copying objects.
Effect: | Command is not executed.
Remedy: | Delete objects that are not required in order to free up memory capacity.


<Object name> no physical memory available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No runtime data access

Cause: | Access to an invalid or non-existent object value memory or runtime data area via the hierarchy table (search path).
Remedy: | Set the search path to the current interpreter environment.


<Object name> no virtual memory available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No selection of entire arrays

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


No structure data type

Cause: | The variable has no structure data type. Example: INT Hugo Hugo.a=1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT Hugo Hugo=1


No variable exists with this name

Remedy:

Alter the program.


NODE must follow

Effect: | The program cannot be executed.
Remedy: | Alter the program.


NODE, USER or PERI expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Not a DSE axis

Cause: | An attempt has been made to carry out a tacho balance for an axis which is not present on the DSE board.
 | Monitoring is carried out in the event of value assignment to "$TACH_CHANGE".
Effect: | Value assignment is not carried out.
Remedy: | Carry out tacho balance for DSE axes only.


Not a name of a constant of this type

Cause: | The constant name is not compatible with the data type.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Not a name of an ENUM data type

Cause: | An enumeration data type name is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Not a system function

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Not a system subroutine

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Not an AXIS component

Cause: | A component of data type "AXIS" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Not a FRAME component

Cause: | A component of data type "FRAME" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Not a POS component

Cause: | A component of data type "POS" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


<Signal name> not an analog output

Cause:

Non-existent analog output signal or incorrect signal index accessed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


<Object> not available

Cause:

An unavailable object was addressed.

Effect:

Command is not executed.

Remedy:

  • Correct command accordingly.

  • Create object.


<Interrupt or Trigger> not defined.

Cause:

An interrupt or trigger that has not been defined has been manipulated.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Declare interrupt.

  • Acknowledge message.


<Object name> not enough memory: file cannot be opened

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Module> not linked

Cause: | "UNLINK" has been applied to an object that is not a program.
Effect: | Command is not executed.


<Module> not correct

Cause: | An incorrect module has been selected in a linking operation.
Effect: | Command is not executed.
Remedy: | Correct the error in the indicated module.


<Object name> is not correctly copied. Error in line <line number>

Cause: | Errors have been detected in the line analysis.
Effect: | Error token in the object.
Remedy: | Correct object accordingly.


Number too low

Remedy:

Alter the program.


OBJ, NODE, USER or PERI expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Object has invalid type

Remedy:

Alter the program.


Object is not available

Cause: | Objects which are not available in the KRC cannot be addressed.
Effect: | Command is not executed.
Remedy: | Select correct object.


Object must be declared in data list or implicitly

Remedy:

Alter the program.


Object not found

Cause: | An object has been polled that does not exist.
Effect: | Object cannot be displayed.
Remedy: | Correct or re-enter object name.


Object not ready

Cause: | The editor cannot edit the program.
Effect: | Command is not executed.
Remedy: | Open program by selecting "Edit".


ON, OFF, ENABLE, DISABLE, DECL expected

Cause: | One of the keywords "ON", "OFF", "ENABLE", "DISABLE" or "DECL" is missing or incorrectly positioned. Example: INTERRUPT
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INTERRUPT ON


ON or OFF expected

Cause: | The keyword "ON" or "OFF" is missing in the program line. Example: ANOUT $ANOUT[2]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT OFF $ANOUT[2]


One dimensional CHAR field expected

Remedy:

Alter the program.


Only comment may be entered after ENDDAT

Cause: | Illegal program code has been inserted after 'ENDDAT'.
Effect: | The program cannot be executed.
Remedy: | Remove program code after 'ENDDAT' or separate it as a comment.


Only "I", "B", "H", "V" allowed as option only

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operand not equal to BOOL

Cause: | An operand of data type "BOOL" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operand not equal to INT, CHAR

Cause: | An operand of data type "INT" or "CHAR" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operand not equal to INT, REAL

Cause: | An operand of data type "INT" or "REAL" is expected.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operand or expression expected

Cause: | Either no operand or expression has been specified, or a character has been used which cannot be evaluated as an operand or expression. Example: $OUT[*]=TRUE
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: $OUT[3]=TRUE


Operand types not comparable

Cause: | The specified operands are of different data types and cannot be compared.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operand types not comparable

Cause: | The operands are of different data types and cannot be compared. Example: IF $IN[3]==1THEN ... ENDIF
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: IF $IN[3]==TRUE THEN ... ENDIF


Operands not equal to INT, REAL, BOOL, CHAR, ENUM

Cause: | The operands are not of data type "INT", "REAL", "BOOL", "CHAR" or "ENUM".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operands not equal to POS, FRAME

Cause: | The operands are not of data type "POS" or "FRAME".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Operator control unit disabled

Cause:

Command cannot be executed because the KCP settings do not fulfil the conditions.

  • "AUT" mode required for RCP and fixed KCP.

  • "T1" or "T2" mode required for non-fixed KCP.

  • "EXT" required for host computer mode.

Effect:

Command is not executed.

Remedy:

Fulfill the "active" conditions.


Option entered twice

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Option expected after minus sign

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Option <option name> missing

Cause: | The option has not been entered.
Effect: | Command is not executed.
Remedy: | Enter option.


Overflow

Cause:

Value is not compatible with the specified data type, e.g. value assignment of a number >255 to the data type "char".

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • If the message is generated during program execution, acknowledge message.


The owner (<krc name>) of workspace '<workspace name>' could not be reached - network error

Cause: | The workspace manager attempted to grant ownership of a workspace to a remote manager but was unable to reach it. This is normally caused by a lost network connection.
Effect: | The workspace owner will continue to wait because it does know that it owns the workspace. The manager of the workspace will continue to send the grant workspace message until it successfully connects to the owner.
Remedy: | Check network connection.


Parameter change inadmissible, channel assigned

Cause:

An attempt has been made to allocate parameters differing from the current ones to a channel that is already assigned.

Remedy:

  • Correct the data used for the channel as required, or

  • Close the channel and re-open it with the appropriate parameters.


Parameter not processed

Cause: | A RUN command with parameters has been executed for a program that is already selected.
Effect: | The parameters are not processed.
Remedy: | Cancel program and reselect.


Parameter specification inadmissible in data list

Remedy:

Alter the program.


Parameters to be declared in module

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Parentheses inadmissible for path expressions

Cause: | Parentheses inadmissible for path expressions.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Parity error

Cause: | Parity set incorrectly.
Remedy: | Check and correct the parity setting in the controller and operator control device (PC).


Path expression invalid

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Path expression required (array)

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Path inadmissible

Cause: | The path specification for copying via SINEC H1 contains "wildcards".
Remedy: | Copy just one file at a time.


Path incorrect

Cause: | The path specification is incorrect.
Effect: | Action is not executed.
Remedy: | Correct the path.


Path trigger with PTP motion inadmissible

Cause:

Path trigger with PTP motion.

Path triggers are inadmissible with PTP motions.

Effect:

All active commands inhibited.

Remedy:

  • Correct program.

  • Acknowledge message.

  • Restart program.


POS, FRAME, or AXIS expected

Remedy:

Alter the program.


Pos. integer, "]" or "," expected

Cause: | No positive integer has been entered or the range of values was exceeded or the characters "]" or "," have been forgotten. Most often in index declarations. Example: DECL CHAR Otto[-3]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DECL CHAR Otto[3]


Positive integer constant expected

Cause: | A positive integer constant is required.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Positive integer expected

Cause: | Only a positive integer can be specified, e.g. specification of the array size. Example: CHAR Hugo[0]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: CHAR Hugo[7]


Power failure

Cause:

  • Supply voltage for the control cabinet has been disconnected.

  • Voltage dip in the mains supply.

Effect:

  • Path-maintaining braking.

  • Mastering data are backed up.

  • Data backup on hard drive.

  • All active commands inhibited.

Remedy:

If voltage was not disconnected manually: check mains voltage.


Pre process not available

Cause: | Advance run display selected, but no program in STOP or END state.
Effect: | None.
Remedy: | Start program.


Predefined channel name expected

Cause: | Only the predefined interface names "SER_1" and "SER_2" are permissible.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Predefined signal cannot be changed

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Predefined signal expected

Cause: | A signal name that has been predefined in the system is expected; an unknown name has been found. Example: SIGNAL $DIGIN1 $xyz[20] TO $IN[29]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: SIGNAL $DIGIN1 $IN[20] TO $IN[29]


PRIO expected

Cause: | The keyword "PRIO" has been omitted or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Procedure error

Cause:

Transmission error in LSV2 procedure which was not recognized by the parity monitoring.

Remedy:

  • Repeat the transmission.

  • Increase procedure repetition counter.

  • Check cable.


Process active

Cause:

An attempt has been made to start an active command during an active process.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Wait until end of execution.

  • Stop the active execution.

  • If the message is generated during program execution, it must be acknowledged.


Process busy

Cause:

Program is already selected.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Cancel selected program.

  • If the message is generated during program execution, it must be acknowledged.


Process disabled

Cause: | All selected processes have the program run mode "BLOCKED" or a non-disabled process has been terminated.
Effect: | Command is not executed.
Remedy: | Change program execution mode.


PROFIBUS : Error in master-circuit <> <>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Profibus: error in slave line

Remedy: | Eliminate error in the slave line.


Profibus Master is in state AUTOCLEAR. Please execute reset command.

Cause:

  • Bus error in Profibus.

  • Option AUTOCLEAR is set.

Effect:

The bus no longer restarts automatically.

Remedy:

Rectify bus error and carry out RESET via the menu.


Program exec. mode inadmissible

Cause: | The selected program execution mode is not permissible.
Effect: | None.
Remedy: | Change program execution mode.


Program line does not exist

Cause:

The selected program line does not exist.


Program line changed

Cause:

Message that the program line has been corrected.


Program not available

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Program not linked

Cause:

Selection of an unlinked program.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

Link program.NOTE:
If the message is generated during program execution, it must be acknowledged.


Program stack overflow

Cause:

The nesting depth for subprograms and functions has been exceeded. It also occurs if subprograms repeatedly call one another in an endless loop.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Programmed path reached (BCO)

Cause:

  • Programmed path reached.

  • After repositioning ($POS_RET, $AXIS_RET, $POS_FOR, $AXIS_FOR, etc.).

Effect:

  • System signals that BCO run has been carried out.

  • Program execution can then be started from the position to which the robot has been moved.


Protocol error

Cause: | Error in the protocol software of the operator control device or output device.
Effect: | Command is aborted.
Remedy: | Check protocol software.


Protocol timeout

Cause:

The defined protocol time has been exceeded.

Remedy:

  • Check whether the physical connection to the periphery still exists.

  • Increase the timeout setting appropriately if it is too low.


Protocol variable declared implicitly

Remedy:

Alter the program.


Protocol variable must be of structure type

Remedy:

Alter the program.


PTP target position in singularity <Kind of singularity>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Range for <path> <axis number> exceeded

Cause:

32-bit word exceeded.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Alter the program accordingly.


RCP Switch position inadmissible

Cause:

Too many transmission processes have been started.

A maximum of 4 transmission processes can be started.

Remedy:

  • Wait until one process has been completed.

  • Stop a process that is running.


Read protection

Cause:

An "$" variable that is not admissible for the selected interpreter type has been read.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

If the message is generated during program execution, it must be acknowledged.


Read protection due to operator control unit status

Cause: | An attempt has been made to read a "$" variable with the operator control unit status set incorrectly.
Effect: | Command is not executed.
Remedy: | Set the status of the operator control unit to "active".


Read protection due to process status

Cause: | Reading of a "$" variable with an inadmissible process status (active, not active, RC ready).
Effect: | Command is not executed.
Remedy: | Set permissible process status.


Real constant expected

Cause: | Constant used is not of type REAL.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


REAL constant, variable or array element expected

Cause: | A REAL constant, variable or array element is required. Example: ANOUT ON Wire = .5 * Factor + 1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT ON Wire = .5 * Factor + 1.0


Reboot after powerfail

Cause:

  • Controller is switched back on.

  • Supply voltage is present again.


Recompile block

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<file format>: Record <record name> exists

Cause: | The record which should be created has already be loaded or created with the same name.
Effect: | Motion driver does not execute command.
Remedy: | Delete the existing record.


<file format>: Record <record name> not available

Cause: | Record not available in kernel system because it was neither loaded nor created (eg. by recording)
Effect: | Motion driver does not execute command
Remedy: | Create or load record


<file format>: Record <record name> busy

Cause: | Other driver command is in operation on record
Effect: | Motion driver does not execute command
Remedy: | Wait for other command to finish


Reduced velocity during sensor location search

Cause: | The velocity defined by the user for the sensor location run in "$RED_JUS_UEB" is greater than the possible maximum at which the sensor can be detected.
 | The controller automatically reduces the velocity to allow the sensor to be detected.
Remedy: | Reduce the permissible velocity for manual traversing in the machine data.


Reference point offset invalid

Cause:

It is not possible to carry out mastering by transferring the reference point offset as this is not valid in "$ROBCOR.DAT".


Reference system not programmed

Cause:

"$BASE" is programmed incompletely or not at all.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Program "$BASE" correctly.


Referencing axis <axis number> inadmissible

Cause: | Attempt to reference a non-incremental axis.
Effect: | The selected axis is not referenced.
Remedy: | Master the axis.


REFPO determines axis <axis number>

Cause: | This message is generated once the reference points for the individual axes have been calculated.
Effect: | None


Relative path invalid

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Relative P_Path not compatible with node

Remedy:

Alter the program.


Remote start received from non-master: <Machine name / IP address>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Reset required

Cause:

RUN has been applied to a process in the end state.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Reset program by means of RESET.

  • If the message is generated during program execution, it must be acknowledged.


<string for data type of elements> Return array too small, number of elements = <number of elements>

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Return value: string constant array invalid

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Reverse motion execution not possible: No Trace

Cause: | No points were executed and recorded in the forwards direction, or the trace was rejected.
Effect: | It is not possible to move the robot back down the path.
Remedy: | Forward traversing with the Start key


Reverse motion execution not possible: Trace empty

Cause: | The recorded motions have already been processed.
Effect: | It is not possible to move the robot back down the path.
Remedy: | Forward traversing with the Start key


Right operand: array invalid

Cause: | The right operand may not be an array. Example: INT x[9] x[2]=13 IF 7 ==x[]THEN ...
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT x[9] x[2]=13 IF 7 == x[2]THEN ...


Right operand: array with dimension > 1 invalid

Cause: | The dimension of the right-hand operand may not be greater than 1.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand not equal to BOOL

Cause: | Right operand is not of data type "BOOL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand not equal to INT, CHAR

Cause: | Right operand is not of data type "INT" or "CHAR".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand not equal to INT, REAL

Cause: | Right operand is not of data type "INT" or "REAL".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand not equal to INT, REAL, BOOL, CHAR, ENUM

Cause: | The data type of the right operand is not "INT", "REAL", "BOOL", "CHAR" or "ENUM".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand not equal to INT, REAL, CHAR, ENUM

Cause: | The data type of the right operand is not "INT", "REAL", "CHAR" or "ENUM". Example: INT i i=7 IF i<TRUETHEN ... ENDIF
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT i i=7 IF i<10THEN ... ENDIF


Right operand not equal to POS, FRAME

Cause: | The data type of the right operand is not "POS" or "FRAME".
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right operand: parentheses invalid in path expressions

Cause: | Parentheses inadmissible for right operand.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Right side: array invalid

Cause: | It is not permissible to specify an array in the right-hand side of the expression, although an array element may be permissible. Example: $OUT[3]=$IN[]
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: $OUT[3]=$IN[5]


Right string constant => left indexing

Effect: | The program cannot be executed.
Remedy: | Alter the program.


RoboCoaster System. Download rejected

Cause:

A download of a machine data file has been tried in state ROBOCOASTER, although a complete set already has been received successfully.


Robot mastered

Cause: | All axes are mastered.
 | Monitoring is carried out in the event of mastering.
Remedy: | If it is necessary to remaster axes, they must first be unmastered.


Robot system is not available

Cause:

There is no second robot system activated in the machine data (command: $HOME = '/R2').

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Modify the machine data accordingly.

  • Acknowledge message.


Robot not mastered

Cause:

  • Selection of a program without the robot being mastered.

  • Start of a program without the robot being mastered.

Monitoring is carried out during command and program execution.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Master the robot.

  • Acknowledge message.


Runtime data cannot be used

Cause: | Runtime data may not be used. Example: DEF P() DECL INT xxx xxx = 1 INTERRUPT DECL 10 WHEN TRUE DO Up(xxx) ... END
Effect: | The program cannot be executed.
Remedy: | Use permanent variables from the DAT file instead of runtime variables.Example: DEFDAT P DECL INT xxx = 1 ENDDATDEF P() INTERRUPT DECL 10 WHEN TRUE DO Up(xxx) ... END


Runtime data of the main program cannot be used

Cause: | The runtime variables of a main program may not be used in a subprogram, even if both programs have been declared in one SRC file. Example: DEF P() INT x x=1 END DEF P2() x=2 END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEF P() INT x x=1 END DEF P2() INT x x=2 END


Safety fence open

Remedy:

Close safety fence.


SCC overflow

Cause: | Baud rate set too high (SCC = serial communication controller).
Effect: |
Remedy: | Reduce baud rate.


SEC, FOR or CLOCK expected

Cause: | One of the keywords "SEC", "FOR" oder "CLOCK" is missing or incorrectly positioned.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Segment exchange successful

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Module> selected

Cause: | Program cannot be unlinked; module is selected with "RUN".
Effect: | Command is not executed.
Remedy: | Terminate program execution (CANCEL).


Selection inadmissible

Cause: | Block not found in program.
Effect: | Command is not executed.
Remedy: | Select correct block number.


Selection invalid here

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Selection not possible

Cause: | Editor selection not possible.
Remedy: | Check whether the file exists (e.g. if when attempting to open a file in the view mode) or has the attribute "hidden".


Selection required

Cause:

  • Start key pressed although no program is selected.

  • "RUN" with no path specification and no program selected.

Effect:

Command is not executed.

Remedy:

Select program.


Sensor location run for <axis number>

Cause:

During the sensor location run, the sensor switching point was detected.


Separate brake control of auxiliary axis not enabled

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Servo independent command execution only possible at testing mode

Cause: | Robot simulation not possible in operating modes "#AUT" or "#EXT".
Effect: | All active commands inhibited.
Remedy: | Change operating mode.


Signal index too large

Cause: | The signal index is outside the range of available inputs and outputs. Example: SIGNAL $DIGIN1 $IN[200] TO $IN[5000]
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Signal name cannot be changed

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Signal type cannot be changed

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Signal types are different

Effect: | The program cannot be executed.
Remedy: | Alter the program.


SINEC AP/TF error <SINEC AP/TF-Fhlcode>

Remedy:

See "SINEC AP Technological Functions, Part B".


SINEC L2 bus channel not opened

Cause: | An attempt has been made to open a SINEC L2 connection without the SINEC L2 bus channel being open.
Remedy: | Open SINEC L2 bus channel.


SINEC L2 communication channels not closed

Cause: | An attempt has been made to close the SINEC L2 bus channel without all the SINEC L2 communication channels being closed first.
Effect: | None.
Remedy: | Close all SINEC L2 communication channels.


SINEC L2 configuration error

Cause: | The opening or closing of a SINEC L2 channel is refused on account of a configuration error detected by the SINEC L2 module.
Effect: | None.
Remedy: | Check and correct the channel parameters (e.g. baud rate).


SINEC L2 Transmission error <error no. Sinec L2-M>

Cause: | Data transmission via SINEC L2 is not possible on account of an error detected by the SINEC L2 module.
Effect: | None.
Remedy: | Check the transmission link and rectify the error.


Single brake module <axis number> not configured

Cause: | The KSD of the respective motor has a single brake module, but it is not configured in the machine data.
Effect: | The brake is controlled by another channel or not at all.
Remedy: | Stick on a single brake module or change the configuration of the machine data.


SoftPLC: <variable text parameter>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Software limit <motion direction><axis number> out of range

Cause:

End point cannot be reached because of a software limit switch.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


Source and target object are identical

Cause: | The source and target specifications define the same object.
Effect: | Command is not executed.
Remedy: | Change target object.


Specified type is not ENUM type

Cause: | An attempt has been made to assign an Enum constant to a variable which is not an Enum variable. Example: INT i ENUM Erna e1,e2,e3 i=#e1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ENUM Erna e1,e2,e3 DECL Erna RealErna RealErna=#e1


Stacking depth <object name> exceeded

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Start continue not possible

Cause: | BSTEP
Effect: | None


Start key required

Cause:

  • Execution of the command requires the Start key to be pressed.

  • The "Start" command has been entered textually.

Effect:

Robot is stationary.

Remedy:

  • Press the Start key.

  • In the case of an external computer: check job identification.


Start locked <string>

Cause: | Start is inhibited during insertion of a block in PROCOR.
Effect: | Start cannot be executed.
Remedy: | Complete insertion procedure.


statement not allowed within spline block

Cause: | Statement used in spline block that is not allowed within spline blocks.
Effect: | Syntax of program has error.


String constant as OUT parameter not permissible

Cause: | A string constant has been used as an OUT parameter.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


String constant too long

Cause: | The assigned string constant is too long for the variable in question. Example: STRUC Otto CHAR a DECL Otto Hugo = {a "abcde"}
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: STRUC Otto CHAR a DECL Otto Hugo = {a "a"}


String expected

Cause: | A string is expected in the program line.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Structure type name expected

Remedy:

Alter the program.


Structure type variable inadmissible

Cause: | A structure type variable is not admissible here.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


SUB cannot be linked to SRC

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Subroutine/function incorrectly completed

Cause: | Incorrect final keyword used, e.g. "END" instead of "ENDFCT" or vice versa.Example: DEFFCT REAL Ida(x1:IN) ... END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEFFCT REAL Ida(x1:IN) ... ENDFCT


SWITCH contains no CASE

Cause: | "SWITCH" construction does not contain a "CASE" branch.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Symbol is not at beginning of expr./value assignment

Effect: | The program cannot be executed.
Remedy: | Alter the program.


SYNACT not possible <line number>

Cause:

The programming of synchronous actions with the variables "$M_TIME" or "$M_TIME_APO" causes this message to be generated when the program is resumed after ramp-down braking, a path-maintaining EMERGENCY STOP ramp or dynamic braking.


Syntax error in array specification

Cause: | The array specification does not have the correct syntax. Example: DEF Hb(a[9]:IN) INT a[]
Effect: | The program cannot be executed.
Remedy: | Alter the program.Example: DEF Hb(a[]:IN) INT a[]


Syntax error in module

Cause: | The module contains a syntax error.
Effect: | The program cannot be executed.
Remedy: | Check the program code in the module.


Syntax error in P_Path

Cause: | The syntax in the path is incorrect. Example: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDATDEF P() IMPORT INT Otto_2 IS R1/PROG_1..Otto END
Effect: | The program cannot be executed.
Remedy: | Correct the path. Example: DEFDAT PROG_1 PUBLIC DECL INT Otto = 1 ENDDAT DEF P() IMPORT INT Otto_2 IS /R1/PROG_1..Otto END


syntax error in with option

Cause: | A syntax error occured in with option.
Effect: | program has syntax errors.


SYNC()-Call not programmed

Cause: | In IRSTOPMESS, the user has failed to respond to $Power-Fail by calling the SYNC() function.
 | Monitoring is carried out in the event of a power failure.
Remedy: | Correct the application program accordingly.


System recovered from hibernate mode

Cause: | System is recovering from hibernate mode after a powerfail occured.
Effect: | n/a
Remedy: | n/a


Tacho balance only possible for one axis

Cause: | An attempt has been made to carry out a DSE tacho balance for several axes at the same time.
 | Monitoring is carried out in the event of value assignment to "$PROG_EEPOT".
Effect: | Value assignment is not carried out.
Remedy: | Carry out tacho balance for one axis only.


Target point not reached

Cause: | The contour cannot be determined when selecting a CIRC block with a circular angle. A LIN motion to the programmed end point is executed when the robot is started.
Effect: | The next motion is also a BCO run.
Remedy: | None


Target variable must be of type REAL

Cause: | Incorrect data type of a target variable or wrong format in a CREAD or SREAD instruction.
Remedy: | Correct CREAD or SREAD instruction: – Change format specification or – Use variable of type REAL.


<file format>: Task for <record name> cannot be spawned

Cause: | Too many EMI commands running in a separate task are active.
Effect: | Motion driver does not execute command.
Remedy: | Wait for other commands to finish.


Teach-in for type invalid

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Tech. function $TECH[<parameter 1-3>].FCT inadmissible

Cause:

The function parameters programmed in $TECH[i].FKT i=1..3, are incompatible with the function definition.

The function parameters are checked by the interpreter in the advance run.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct the function parameters.


TEPRO inactive

Cause: | SBC no longer sending a signal to KRC. (TEPRO = technological process)
Effect: | SBC interface inoperable.
Remedy: | Re-initialize SBC program.


THEN expected

Cause: | The "IF" instruction has not been entered completely; the keyword "THEN" is missing. Syntax: IF Boolean expressionTHEN Instructions ENDIF
Effect: | The program cannot be executed.
Remedy: | Alter the program.


There exists an invalid jump to this label

Effect: | The program cannot be executed.
Remedy: | Alter the program.


TO expected

Cause: | The keyword "TO" has been omitted.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Too many elements in <object name> array

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<Object name> too many local subroutines

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Too many objects are selected

Cause: | Too many objects have been selected.
 | Permissible number of selected objects: approx. 150
Effect: | Command is not executed.
Remedy: | Reduce the number of objects to the maximum permissible number.


Too many workspaces owned by local programs. 'Release All' will free workspaces.

Cause: | Too many workspaces are owned on the controller. The maximum number of workspaces owned is 32.
Effect: | The program cannot be granted the workspace.
Remedy: | The user should free workspaces not in use by the running program.


Too much memory required for dynamic variable

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Tool/Base Option not correct

Cause: | TB option of lin_rel statement is not correct programmed.
Effect: | syntax error in program.


<X,Y,Z,A,B,C> TOOL not programmed

Cause:

No value has been assigned to the program datum "$TOOL":-in an application program.

  • after an overall reset of the controller for a Cartesian command.

Monitoring is carried out in the event of Cartesian motions.

Effect:

During command execution: -All active commands inhibited.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

During command execution:-Assign a value to "$TOOL".
During program execution:-Alter the program accordingly.

  • Acknowledge message.


Tool weight not yet taught

Cause: | During EMT mastering a check run was carried out for a tool whose weight has not yet been learnt.
Remedy: | "Learn" tool weight.


Trace: recording time is too long

Cause:

  • The recording time configured in "TRACE.DEF" is too long.

  • There is not enough memory available for recording.

Effect:

TRACE is not recorded.

Remedy:

  • Reduce the TRACE recording time accordingly.

  • Reduce the number of channels to be recorded.


Transformation not configured

Cause:

$BASE or $TOOL has been assigned although no transformation is configured.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


TRUE or FALSE expected

Cause: | Only the assignements 'TRUE' and 'FALSE' are admissible.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


TTS cannot be determined

Cause: | Termination of search for the path direction point.
 | TTS = tool-based technological system.


Type actual/formal parameter incompatible

Cause: | The parameters in the subprogram or function call are not compatible with the subprogram or function declaration. Example: BOOLb b=TRUE up(b) ... DEF up(var:IN) INTvar END
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INT b b=4 up(b) ... DEF up(var:IN) INT var END


Type change for initial value not possible

Remedy:

Alter the program.


Type component incompatible with type initial value

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Type expected

Cause: | The specification of a data type is expected. Example: DEFFCT Ida(x1:IN) ... ENDFCT
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEFFCT REAL Ida(x1:IN) ... ENDFCT


Type must be POS, FRAME or AXIS

Remedy:

Alter the program.


Type name incompatible with context

Remedy:

Alter the program.


Type of formal parameter invalid

Cause: | The type of the formal parameter is invalid.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Type of a parameter is defined locally

Remedy:

Alter the program.


Type of left and right hand side incompatible

Cause: | The data types of the left and right operands are incompatible.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Type of loop variable not equal to INT

Cause: | Only the data type INTEGER is allowed for the loop variable. Example: DECL REAL i FOR i = 1 TO 5 ... ENDFOR
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DECL INT i FOR i = 1 TO 5 ... ENDFOR


Type return value incompatible with type function

Cause: | The return value of the function does not correspond to the function type. Example: DEFFCT BOOLalf() REALHugo Hugo=1 RETURN(Hugo) ENDFCT
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: DEFFCT REAL alf() REAL Hugo Hugo=1 RETURN(Hugo) ENDFCT


Type too large

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Type unknown

Cause: | In a declaration, a data type is used which has not been declared or which is unknown locally.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Unable to initiate linked jogging

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Unknown external message

Unknown external message <external message number>

Cause: | It was not possible to convert an external message (e.g. from the interface CPU, PSX) into an RCX message.
Remedy: | Acknowledge message.


<file format>: Unknown command

Cause:

  • Command string incorrect

  • Command unknown

Effect:

Robot stops

Remedy:

Use correct command syntax


Unused externally declared subroutine

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


USER, ACCESS or COMMENT expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


User, device or node type name expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Value assignment inadmissible

Cause:

Inadmissible value assignment to predefined variables,
e.g. $SPEED.ORI1 <= 0.0 or > $SPEED_MA.ORI1. Alternatively, inadmissible $Base or $Tool assigned to the kinematic system.

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Value cannot be changed, program is selected

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Value for PRIO inadmissible

Cause: | The value specified for the priority is outside the permissible range. Example: INTERRUPT ON 522
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: INTERRUPT ON 22


Value missing

Cause: | No value was indicated.
Remedy: | Enter value.


Value of $ASYNC_AXIS contains decoupled auxiliary axes

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


VAR expected

Effect: | The program cannot be executed.
Remedy: | Alter the program.


Variable cannot be renamed

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Variable not declared in data list

Remedy:

Alter the program.


Variable not declared in data list

Cause: | A variable is required which must be declared in the DAT file.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Variable not initialized

Cause: | A variable has not been initialized.
Effect: | The program cannot be executed.
Remedy: | Initialize variable.


Variable or array element expected

Cause: | An inadmissible expression is positioned where either a variable or an array element is expected. Example: ANOUT ON Wire = .5 * 1
Effect: | The program cannot be executed.
Remedy: | Alter the program. Example: ANOUT ON Wire = .5 * RFactor ; "RFactor" represents a REAL variable from the corresponding DAT file.


Variable too large

Cause: | The variable specified in "SHOW VAR" or "SET INFO" is too complex or too large (e.g. box is larger than the display).
Effect: | Command is not executed.
Remedy: | Subdivide the request into several sections.


Variable with structure type expected

Remedy:

Alter the program.


<$ variable> variable write protected

Cause:

Write access to write-protected variable, e.g. "$POS_ACT".

Monitoring is carried out during command and program execution.

Effect:

During command execution:-Command is not executed.
During program execution:-Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


<Name> variable write protected in module <file name> line <line number>

Cause:

In a program module an attempt was made to change a write-protected variable.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


Version (<Message version number>) mismatch for message from <IP address>

Cause: | All participants of a Motion Cooperation must use the same software versions.
Effect: | Motion Cooperation is not permitted.
Remedy: | Upgrade all controllers to the most recent version available.


WHEN expected

Cause: | The keyword WHEN has been omitted in an interrupt or trigger declaration.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Wildcard inadmissible

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


WITH option outside spline block is not allowed

Cause: | a with option was used outside a spline block. This is not allowed
Effect: | module has syntax error


Working envelope surveillance can only be overridden in T1 mode

Cause: | An attempt was made, in T2, AUT or EXT mode, to change the value of the variable "$WBOXDISABLE".
Remedy: | Switch to T1 mode.


The workspace '<WorkspaceName>' was manually freed at a remote controller (<KrcName>)

Cause: | The workspace was freed by a user at a remote controller.
Effect: | The workspace owner was freed and the next queued program was given ownership.


The workspace is in use - it's definition cannot be changed

Cause: | The user is attempting to change a workspace definition that is currently in use.
Effect: | The workspace definition will not be saved.
Remedy: | Clear the workspace of requests before making a definition change.


Write protection due to operator control unit status

Cause: | An attempt has been made to write a "$" variable with the operator control unit status set incorrectly.
Effect: | Command is not executed.
Remedy: | Set the status of the operator control unit to "active".


Write protection due to process status

Cause: | Write access to a "$" variable with an inadmissible process status (active, not active, RC ready).
Effect: | Command is not executed.
Remedy: | Set permissible process status.


Wrong type of parameter variable

Cause: | The parameter variable for the channel is of the wrong type.
Remedy: | Correct CHANNEL declaration for the channel.


$BWDSTART not in FOLD. No Tool and Base information found

Cause:

Backward motion with SCAN method: a $BWDSTART assignment must be programmed as the first instruction in a motion fold. From this line onwards, all following instructions up to the motion are executed before backward motion is carried out.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Correct program.

  • or insert the following line in BACKWARD.INI: BACKWARDSTART = FALSE

In this case, BASE and TOOL changes during reverse traversing are ignored!): BACKWARDSTART = FALSE


$FILTER mismatch: local=<Local machine $FILTER>; remote-synched=<Remote machine $FILTER>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


$OUT_C[n] is not allowed in interrupt programs

Cause:

$OUT_C(N) used in interrupt program.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Alter the interrupt program accordingly.

  • Acknowledge message.


$OUT_C[n] is not allowed in a Submit Program

Cause:

$OUT_C(N) has been used in a submit program.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Alter the submit program.


Absolute accuracy robot: Point conversion only possible in T1 mode

Cause:

$ABS_CONVERT = TRUE, but no T1 mode.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Set variable "$ABS_CONVERT" in the "$CUSTOM.DAT" file to FALSE or select T1 mode.

  • Acknowledge message.


Ackn. Ambient temperature sensor failure <axis number>

Cause: | Follow-up message to status message "FAILURE OF AMBIENT TEMPERATURE SENSOR".
Remedy: | Acknowledge message.


Ackn. ballast switch energized for too long <axis number>

Cause:

Energy of the braked axis was above the limit.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check power module ballast resistor and exchange if necessary.

  • Set braking ramp less steep.

  • Acknowledge message.


Ackn. over temperature feedback resistor <Axis>

Cause: | Follow-up message to status message: "Brake cool down time <cooling time>"
Remedy: | Acknowledge message.


Ackn. Brake defective <axis>

Cause:

  • Follow up message to "Brake defective <axis>".

  • Wear on brakes.

  • Brake defective.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Under certain circumstances, it may not be possible to brake the axis.

Remedy:

  • Acknowledge message.

  • Exchange the corresponding motor.


Ackn. brake error <axis number>

Cause: | Follow-up message to status message "Brake fault <axis number>".
Remedy: | Acknowledge message.


Ackn. brake error <KPS Nummer> channel <brakechannel>

Cause:

Follow-up message to status message "Brake error <...> channel <...>".

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. cabinet over temperature <power module number>

Cause: | Follow-up message to status message: "Cabinet temperature too high"
Remedy: | Acknowledge message.


Ackn. cabinet fan failure

Cause: | Defect fan in KR C3 cabinet
Effect: | Overheating of cabinet hardware
Remedy: | Check cabinet fan and change if needed.


Ackn. check accumulator <kps number>

Cause: | Follow-up message to status message "Check accumulator <...>".
Effect: | None.
Remedy: | Acknowledge message.


Ackn. collision detection axis <axis number>

Cause:

The motor torque was not located in the specified monitoring tunnel.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Verify load data.

  • Increase torque monitoring tunnel.

  • Acknowledge message.


Ackn. Command timeout <drive number>

Cause:

Follow-up message to status message: "Command timeout <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Communication error with CAN-RDC <axis number>

Cause: | The CAN-communication between the CAN-RDC and the KSD is interrupted.
Effect: | No commutating and positioning of the motor is possible.
Remedy: | In most of the cases a reboot of the CAN-RDW may be sufficient.


Ackn. Commutation fault <axis number>

Cause:

Follow-up message to status message: "Commutation fault<...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Commutation mastering error: motor not powered <axis number>

Cause:

Follow-up message to status message: "Commutation mastering error : motor not powered <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Commutation mastering error: Servo is on <axis number>

Cause:

Follow-up message to status message: "Commutation mastering error : Servo is on <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. configuration of drive bus DSE <DSE number> too long

Cause:

Follow-up message to status message: "Configuration of driverbus DSE <...> too long".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. DN CH <...> Too many module errors <...>

Cause:

Effect:

Remedy:


Ackn. deviation alarm master-slave <axis number>

Cause:

Follow-up message to status message: "Deviation alarm master-slave <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. deviation critical master-slave <axis number>

Cause:

Follow-up message to status message: "Deviation critical master-slave <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. deviation warning master-slave <axis number>

Cause: | Follow-up message to status message: "Deviation warning master-slave <...>".
Effect: | None.
Remedy: | Acknowledge message.


Ackn. drives error <axis number> No. <error number>

Cause:

Follow-up message to status message "DRIVES ERROR <axis number> No. <...>".

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. drives parameter data <axis number> invalid

Cause: | Follow-up message to status message "DRIVES PARAMETER DATA INVALID".
Remedy: | Acknowledge message.


Ackn. drive bus DSE <DSE number> participant no. <Interbus participant no.> does not exist

Cause:

Follow-up message to status message: "Drivebus DSE <...> participant No. <...> does not exist".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. drive bus DSE <DSE number> participant no. <Interbus participant no.> not configured

Cause:

Follow-up message to status message: "Driverbus DSE <...> participant no. <...> not configured".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. DSE <DSE number> boot up failure

Cause:

  • Follw-up message to the status message "DSE boot up failure".

Effect:

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • Check if DSE card is plugged correctly.

  • Exchange DSE card.


Ackn. E<2 or 7> switch closed

Cause: | Follow-up message to status message "E <2 or 7> switch closed".
Remedy: | Acknowledge message.


Ackn. E<2 or 7> switch open

Cause: | Follow-up message to status message "E <2 or 7> switch open".
Remedy: | Acknowledge message.


Ackn. EMERGENCY STOP

Cause: | Follow-up message to status message "EMERGENCY STOP".
Effect: | All active commands inhibited.
Remedy: | Acknowledge message.


Ackn. EMERGENCY STOP due to dial mastering

Cause:

Softkeys for dial mastering pressed.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" receives 0 signal.

Remedy:

Press the Recall key twice.


Ackn. Encoder battery fault <Axis>

Cause: | Encoder backup battery failed or encoder cable has failed.
Effect: | Mastering lost on every power up.
Remedy: | Replace encoder battery.


Ackn. encoder cable failure <axis number>

Cause:

Follow-up message to status message: "Encoder cable failure".

Effect:

  • Path-maintaining braking.

  • Output "$ALARM_STOP" 0 signal

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Error: A/D timeout fault <drive number>

Cause:

Follow-up message to status message: "Error : A/D timeout fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Error sync. input drive <axis number>

Cause: | Follow-up message to status message "ERROR SYNC. INPUT DRIVE".
Remedy: | Acknowledge message.


Ackn. Failure of heat sink temperature sensor <axis number>

Cause: | Follow-up message to status message "FAILURE OF HEAT SINK TEMPERATURE SENSOR".
Remedy: | Acknowledge message.


Ackn. Failure of motor temperature sensor <axis number>

Cause: | Follow-up message to status message "FAILURE OF MOTOR TEMPERATURE SENSOR".
Remedy: | Acknowledge message.


Acknowledge error 6SC620 <axis number>

Cause:

Malfunction/error in drive module or in Simodrive 6SC620 processor module acknowledged.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. failure of motor phase <Axis number>

Cause:

Backup battery voltage too low.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Exchange battery.

  • Acknowledge message.


Ackn. feedback switch too long on <kps number> while charging

Cause: | Follow-up message to status message "Feedback switch too long on ... while charging".
Remedy: | Acknowledge message.


Ackn. Firmware version mismatch <drive number>

Cause:

Follow-up message to status message: "Firmware version mismatch <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. general motion enable

Cause:

$MOVE_ENABLE input has 0 signal.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. general servo enable

Cause:

Input "$SERVO_RDY" had 0 signal.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. heatsink temperature <axis number>

Cause:

Heat sink temperature too high.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Invalid command <drive number>

Cause:

Follow-up message to status message: "Invalid command<...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Invalid motor rating <drive number>

Cause:

Follow-up message to status message: "Invalid motor rating <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Invalid parameter A <axis number>

Cause:

Follow-up message to status message: "Invalid parameter <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Ixt servo drive <axis number> exceed value of <I*I*t value> %

Cause:

Follow-up message to status message "Ixt servo drive <axis number> exceed value of <value>%".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. K1 contact fail to open <power module number>

Cause: | Follow-up message to "K1 contact fail to open <KPS number>".
Remedy: | Acknowledge message.


Ackn. mainboard overtemperature

Cause:

Follow-up message to status message: "Mainboard overtemperature <...>"

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. module <axis number> KSD-<max. current of KSD> required

Cause:

Follow-up message to the status message: "Module <...> KSD <...> required".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Monitoring 600V power supply <KPS number>

Cause:

Follow-up message to "Monitoring 600V Power supply: ...".

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Mastering performed <axis number>

Cause:

Follow-up message to status message: "Perform mastering"

Remedy:

  • Carry out mastering.

  • Acknowledge message.


Ackn. motor cable <axis number>

Cause: | Follow-up message to status message "MOTOR CABLE".
Remedy: | Acknowledge message.


Ackn. motor blocked <axis number>

Cause:

"I*I-t" monitoring has been signalled by a DSE.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. motor temperature <axis number>

Cause:

The motor temperature of the axis indicated in the message was too high.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. operator safety

Cause:

The interface unit input "$USER_SAF" has the signal state "0" in AUTOMATIC or EXTERNAL mode.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Wrong model number <power module number>

Cause:

Follow-up message to status message "Wrong model number".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. over current <axis number>

Cause: | Follow-up message to status message "Over current <axis number>".
Remedy: | Acknowledge message.


Ackn. over temperature, ballast resistor <power module number> or fan

Cause: | Follow-up message to status message "Over temperature feedback resistor...".
Remedy: | Acknowledge message.


Ackn. over temperature fan <power module number>

Cause:

Follow-up message to status message: "Over temperature fan <...>"

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. over temperature feedback resistor <power module number>

Cause:

Follow-up message to status message: "Over temperature feedback resistor <...>"

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. overvoltage <kps number> while charging

Cause:

Follow-up message to status message "Overvoltage <...> while charging".

Effect:

  • Maximum braking.

  • Active commands inhibited.

Remedy:

Acknowledge message.


Ackn. over voltage <power module number>

Cause: | Follow-up message to status message "Over voltage <power module>"
Remedy: | Acknowledge message.


Ackn. passive STOP <RCP or teach pendant>

Cause:

Triggered by passive stop.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. PC fan error

Cause: | Follow-up message to status message "PC fan error".
Effect: | None.
Remedy: | Acknowledge message.


Ackn. Please close cabinet door

Cause: | Follow-up message to status message "Please close cabinet door".
Effect: | None.
Remedy: | Acknowledge message.


Ackn. POST Error: A/D fault <drive number>

Cause:

Follow-up message to status message: "POST Error : A/D fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: A/D offset fault <drive number>

Cause:

Follow-up message to status message: "POST Error : A/D offset fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Encoder FPGA loopback fault <drive number>

Cause:

Follow-up message to status message: "POST Error : Encoder FPGA loopback fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Fatal system error <drive number>

Cause:

Follow-up message to status message: "POST Error : Fatal system error <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: FPGA Fault <Drive Number>

Cause:

Follow-up message to status message "Ackn.: POST Error: FPGA Fault <power module>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Invalid parameter fault <drive number>

Cause:

Follow-up message to status message: "POST Error :Invalid parameter fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Motor Enable on during power up <drive number>

Cause:

Follow-up message to status message: "POST Error : Motor Enable on during power up <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Parameter table checksum fault <drive number>

Cause:

Follow-up message to status message: "POST Error : Parameter table checksum fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. POST Error: Power board FPGA fault <drive number>

Cause:

Follow-up message to status message: "Power board FPGA fault <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. power module axis <axis number> not /or incorrectly connected

Cause: | Follow-up message to status message "Power module axis <axis number> not or wrongly plugged".
Remedy: | Acknowledge message.


Ackn. RDW <RDW number> boot up failure

Cause: | Follow-up message to status message "RDW <axis number> boot up failure".
Remedy: | Acknowledge message.


Ackn. regulator limit exceeded <axis number>

Cause:

  • Follw-up message to the status message "Regulator limit exceeded <axis number>".

  • Following error too big. The axis does not follow the command value.

  • Is there only the acknowledge message and no status message, then the surveillance in the kernal system has triggered.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Acknowledge message.

  • Check maschine data $IN_POS_MA (positioning window axis), $FOL_ERR_MA (factor for the following error) and $VEL_DSE_MA (factor for velocity monitoring).

  • Check power converter.

  • Check manipulator and motor.

  • Check maschine data of controller parameters and gear ratios.


Ackn. SBX-HPU connected

Cause:

While evaluating the signal "Teach pendant plugged in", the software has detected that the two channels (MPC interface and safety box) have different statuses.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. SBX-HPU connected input

Cause:

Safety box signals a fault in signal input "teach pendant plugged in".

Effect:

  • Ramp-down braking

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. SBX-HPU deposited input

Cause:

Safety box signals a fault in the input unit of the permanently installed input.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. second motorcable not connected

Cause:

Follow-up message to status message: "Second motorcable not connected <...>"

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. servo bus disturbance <KPS number>

Cause: | Follow-up message to status message "Servo bus disturbance ...".
Remedy: | Acknowledge message.


Ackn. Servobus DSE-No. <DSE-No.> participant No. <IBS participant> unknown

Cause:

Follow-up message to status message: "Servobus DSE-No.: <DSE-No.> participant No.: <IBS participant> unknown".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. slip exceeded <axis number>

Cause:

Follow-up message to status message: "Slip exceeded <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. speed deviation master-slave <axis number>

Cause:

Follow-up message to status message: "Speed deviation master-slave <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Stop for error fieldbus

Cause:

Acknowledge stop for error fieldbus.


Ackn. Synchronisation error drive <axis number>

Cause: | Follow-up message to status message "SYNCHRONISATION ERROR DRIVE".
Remedy: | Acknowledge message.


Ackn. synchronization error with DSE <axis number>

Cause:

  • Follow-up message to status message "Synchronization error with DSE <axis number>".

Message from kernal system: The kernel system did not set the watchdog-timer for the surveillance of the communication to the DSE or the DSE did not reset watchdog-timer.

Effect:

  • Ramp stop.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Acknowledge message.

  • Check pugs of DSE on MFC and MFC on motherboard (loose connection).

  • If this does not work, exchange DSE or MFC.

  • Check if the drive bus or the ISA-bus on the motherboard are malfunctioning (EMC).


Ackn. Temperature warning <drive number>

Cause:

Follow-up message to status message: "Temperature warning <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. too many participants within drive bus DSE <DSE number>

Cause:

Follow-up message to status message: "Too many participants within driverbus DSE <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. transmission error <DSE number>. DSE - RDW

Cause:

  • Follw-up message to the status message "Transmission error <DSE number>. DSE - RDW".

  • Damaged cable or connector between DSE and RDW.

  • Cable not connected or connected incorrectly.

  • Data transmission malfunction.

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Acknowledge message.

  • Check power supply of DSE and RDC (LEDs).

  • Check cable (shield!) and connections.

  • Check DSE - RDW serial interface.

  • Check electrical ground connection of robot and cabinet.


Ackn. under voltage <power module number>

Cause: | Follow-up message to status message "Under voltage <power module>"
Remedy: | Acknowledge message.


Ackn. undervoltage <kps number> while charging

Cause:

Follow-up message to status message "Undervoltage <...> while charging".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. Warning: axis too far from mastering position <axis number>

Cause:

Follow-up message to status message: "Warning : axis too far from mastering position <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Ackn. watchdog interpolation cycle <axis number>

Cause:

  • Follow-up message to status message "Watchdog interpolation cycle <axis number>".

  • DSE did not get a new position value from kernel system for this axis.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • Output "$ALARM_STOP" has signal level 0.

Remedy:

  • Acknowledge message.

  • Check pugs of DSE on MFC and MFC on motherboard (loose connection).

  • If this does not work, exchange DSE or MFC.


Ackn. watchdog power module <power module number>

Cause:

Power module watchdog has dropped out. (Triggered by DSE after delay of 0.125 ms)

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Check DSE.

  • Check power module.

  • Acknowledge message.


Ackn. <axis number> without power

Cause: | Follow-up message to status message "... WITHOUT POWER".
Remedy: | Acknowledge message.


Ackn. Wrong drives parameter <axis number> <parameter set no.>

Cause: | Follow-up message to status message "WRONG DRIVES PARAMETER".
Remedy: | Acknowledge message.


Ackn. output state mismatch <power module number>

Cause:

Follow-up message to status message "Output state mismatch <...>".

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Acyclic data not released by TEPRO

Cause:

Semaphore is inhibiting access to acyclic data.

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

Eliminate the error in the SBC program.


Adjustment possible only in mode T1

Cause:

Controller is not switched to T1 mode.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Set operating mode to T1.

  • Carry out mastering again.

  • Acknowledge message.


Adjustment procedure not possible <axis number>

Cause:

  • An attempt was made to carry out a "sensor location run", or

  • the axis is not equipped with a KTL encoder and DSE.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Cancel via "RECALL", or

  • Master axis with EMT or dial gauge.


Angle status inadmissible

Cause:

Following repositioning with a LIN motion, the angle status does not agree with the status of the programmed block.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • Perform repositioning with a PTP motion.


Approximation not programmed <approximation criterion>

Cause:

No value has been assigned to the program data "$APO.VEL", "$APO.ROB", "$APO.DIS" and/or "$APO.ORI".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Array parameter inadmissible

Cause:

Undefined array parameter or complete "call-by-value" array in the list of current parameters when function is called.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Do not use undefined array parameters and transfer complete arrays as current parameters only on a "call-by-reference" basis.


Axis <axis number> acceleration not programmed

Cause:

No value has been assigned to the program datum "$ACC_AXIS".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Axis <axis number> velocity not programmed

Cause:

No value has been assigned to the program datum "$VEL_AXIS". This error occurs when a motion command is positioned before the INI folder.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


BASE change inadmissible

Cause:

During conveyor operation an attempt has been made to change the BASE.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Correct program accordingly.


Brake holding torque <axis number> exceeded

Cause:

The brake holding torque of the axis is not sufficient to keep the robot arm permanently stopped at any given point in space.

Effect:

Interpreter stop.

Remedy:

  • Verify load data.

  • Reduce load.

  • Acknowledge message.


Brakes open during mastering selection

Cause:

A brake is still open from the preceding motion.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Wait until all brakes are closed and the servos are disabled.


Ackn. Buffer battery voltage low <power module number>

Cause: | The battery has been exchanged.
Remedy: | Acknowledge message by means of the softkey "Ackn.".


<Object> cannot be deleted

Cause: | This object cannot be deleted as it is write-protected.
Effect: | Command is not executed.


Centering error

Cause:

The workpiece is not correctly positioned or clamped.
There is possibly a fault in the feed equipment, or the fixture is defective.

Monitoring is carried out from the PLC application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Check clamping fixture and feed equipment.

  • Check position of the workpiece.


Ackn. Check safety logic. Drives off timeout during EMERGENCY STOP

Effect: | All active commands inhibited.
Remedy: | Check safety logic.


CIRC is executed as LIN

Cause:

An attempt has been made to execute a CIRC motion as a BCO run.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • After the start the CIRC block is executed as a LIN motion.


CIRC parameter inadmissible

Cause:

Distance between start point and/or midpoint and/or end point is too small, or all points lie on a straight line. Formation of a circle is not possible.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Program midpoint and/or end point correctly.

  • Acknowledge message.


Combination of variables inadmissible <block number>

Cause:

In a Synact instruction, variables for individual blocks and approximate positioning blocks are combined in the logic comparison or value assignment.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Program Synact instruction differently.

  • Acknowledge message.


Command acceleration exceeded <axis number>

Cause:

Permissible acceleration exceeded; dependent on machine data:
– "$ACC_ACT_MA" (command acceleration limit value) and
– "$TL_ACC" (command acceleration tolerance time)

Effect:

  • Path-maintaining braking.

  • Output "$ALARM_STOP" has signal level 0.

  • All active commands inhibited.

Remedy:

  • Check program for alpha5 transitions.

  • Increase command acceleration time tolerance.

  • Reduce position control gain.

  • Check output stage.

  • Acknowledge message.


Command velocity exceeded <axis number>

Cause:

Permissible velocity exceeded; dependent on machine data:
– "$VEL_ACT_MA" (command velocity limit value) and
– "$TL_VEL" (command velocity tolerance time)

Effect:

  • Path-maintaining braking.

  • Output "$ALARM_STOP" has signal level 0.

  • All active commands inhibited.

Remedy:

  • Increase command velocity tolerance time.

  • Check output stage.

  • Acknowledge this message.


Commanded motor torque <axis number>

Cause:

The permissible motor torque has been exceeded (dependent on dynymic datas $DYN_DAT(), cyclically).

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • Output "$Alarm_STOP" is set to signal level 0.

Remedy:

  • Verify load data.

  • Reduce load if necessary.

  • Reduce programmed acceleration.

  • Reduce programmed velocity.

  • Acknowledge message.


Commanded gear torque <axis number>

Cause:

The permissible gear torque has been exceeded.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • Output "$Alarm_STOP" is set to signal level 0.

Remedy:

  • Verify load data.

  • Reduce load if necessary.

  • Reduce programmed acceleration.

  • Reduce programmed velocity.

  • Acknowledge message.


Communication <operator control device> - KRC interrupted

Cause: | The communication between the active operator control device and the KRC controller was interrupted during a motion in test mode.
Effect: | Dynamic braking.
Remedy: | Restore communication.


Communication with TEPRO faulty

Cause:

SBC receives cyclical data too late.

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

  • Re-initialize SBC program.

  • Acknowledge message.


Component check error

Cause:

Component damaged or no longer clamped to the fixture.

Monitoring is carried out from the PLC application program (adhesive bonding technology).
In the application of adhesive to glass, the adhesive nozzle is pressed onto the glass. If this pressure is missing during adhesive application, the glass might be damaged or might no longer be clamped to the fixture.
In this case, the robot motion and adhesive application must be stopped immediately!

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Emergency Stop.

Remedy:

Check component.


COR.dat check sum error

Cause:

The correction data have been changed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Perform sensor location search/mastering.

  • Save correction data.


CP/PTP approximation not feasible

Cause:

  • In the CP block the traversing distance of an axis is greater than 180 degrees.

  • Status change in the CP block.

  • Software limit switch violated in travel along "shortest path".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Reduce the angle in the CP block.

  • Insert an intermediate point.

  • Acknowledge message.


<file format>: Current position and start position <record name> not identical

Cause: | Robot is at wrong position.
Effect: | Robot stops
Remedy: | Move robot to start position of record.


Cyclic data not released by TEPRO

Cause:

Semaphore is inhibiting access to cyclic data. (TEPRO = technological process)

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

Eliminate the error in the SBC program.


Data exchange

Cause:

The SBC stops data exchange because of an error.

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

Eliminate the error in the SBC program.


Data exchange with TEPRO missing

Cause:

SBC sends cyclical data too late. (TEPRO = technological process)

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

  • Re-initialize SBC program.

  • Eliminate the error in the SBC program.

  • Acknowledge this message.


Data transfer invalid <axis number>

Cause:

An attempt was made to carry out a sensor location run for an axis which is not equipped with a KTL encoder and DSE.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Cancel via RECALL.


Delay <block number> inadmissible

Cause: | A negative delay in the synact instruction has not been used in combination with one of the 4 position trigger variables (M_SC_F, M_SC_B, M_SCAPO_F, M_SCAPO_B).
Effect: | Ramp-down braking. All active commands inhibited.
Remedy: | Change the logic condition of the synact instruction.


Deviation at target point

Cause:

A deviation has arisen when addressing an exact positioning point.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct "SCALE_IN" value.


Deviation in the start point

Cause:

Execution of a PTP motion with a sensor correction value.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

The sensor offset must be eliminated before executing a PTP block.


Digital input already assigned

Cause:

A digital input has been cyclically activated in the program for a second time.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Deactivate the cyclical digital input.


Dynamic braking cancelled

Cause: | If during an activated Emergency Stop a fault occurs that permits only maximum braking, this message is additionally displayed.
Effect: | Maximum braking.
Remedy: | Acknowledge this message.


Dynamic braking error <axis number>

Cause:

Actual value does not decrease although braking ramp is predefined.

Effect:

  • Maximum braking.

  • Output "$ALARM_STOP" has signal level 0.

  • All active commands inhibited.

Remedy:

  • Check measuring circuit module.

  • Check manipulated variable encoder.


E-Stop requested by <Machine name / IP address>

Cause: | The specified controller has requested an emergency stop during Motion Cooperation.
Effect: | Local program execution is halted.
Remedy: | Handle the exception on the controller with is specified in the message text.


EMT sensor faulty

Cause:

Sensor supplies a zero signal.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Check screwed connection on sensor.

  • Check EMT connection on robot.

  • Check A3/DSE module.


Endskip number '<Number of active skip at end>' is missing

Cause: | A skip number statement was not ended by a matching endskip number at the programs end.
Effect: | User must have an acknowlegdement message.


Enter/exit requests cannot be issued with triggers.

Cause: | The enter/exit request was issued using a trigger.
Effect: | The command will not be executed.
Remedy: | Do not issue enter/exit requests using triggers.


<Object name> error in memory manager <error number>

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Error in UPCALL token

Effect:

  • Ramp-down braking.

  • All active commands inhibited.


<file format>: Error restoring variables for record <record name>

Cause: | Error in I/O system
Effect: | Robot stops
Remedy: | Check the I/O system.


<file format>: Error while executing motion <record name>

Cause: | Driver specific
Effect: | Robot stops
Remedy: | Contact the supplier of the driver.


Excessive volume

Cause:

The dispensed volume monitoring has responded. Too much adhesive has been dispensed.

Monitoring is carried out from the PCL application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check the adhesive application hardware and purge it if necessary.


Failed to notify other cell controllers of data change (<System variable name>).

Cause: | An internal message queue problem is not allowing this controller to send notification to other controllers in the cell of the data change.
Effect: | The other controllers in the cell will be unaware of the data change and will not respond appropriately.
Remedy: | Reboot the controller that is reporting the error.


Finished subroutine: Skip motions

Cause:

During backward motion, the interpreter encountered a subprogram which had already been completely executed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


Gear torque exceeded axis <axis number>

Cause:

The calculated gear torque is greater than the maximum permissible gear torque.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reteach points in order to reduce torque.


General error: <error number> <function> <additional information>

Cause: | Unknown feedback from a function in the object.
Remedy: | Please inform the KUKA customer service department.


General system air pressure

Cause:

There is insufficient pressure in the air inlet for the pneumatic valves.

Monitoring is carried out from the PLC application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Ensure that the air pressure is sufficient.


Internal compiler error <object name>

Cause:

An error has occurred in the compiler.

Effect:

The program cannot be executed.

Remedy:

  • Reboot the controller.

  • Alter the program if necessary.


Internal error <system error number> (<task Id>, <status>)

Cause: | Internal test of KRC software.
Effect: | RC-READY canceled during processing and warm restart triggered.
Remedy: | Acknowledge message.


Internal error (Default message)

Cause: | Internal; the message data have not been set correctly.
Effect: |
Remedy: |


Internal error in PTP motion planning <number>

Cause: | Error in the planning of the PTP motion profile.
Effect: | Interpreter stop.
Remedy: | Modify the profile data (rounding factor, velocity, acceleration).


Interrupt expression complexity exceeded

Cause:

In total more than 16 "slow" variables have been used in the logical expressions of the INTERRUPT DECL instructions on the control and robot levels.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Use fewer predefined variables. If necessary, group logic expressions together using cyclical flags.


Interrupt instruction aborted

Cause:

Motion instruction in an interrupt program which is executed after an error-induced stop.

The interrupt module called after an error-induced stop may not contain motion instructions.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Reprogram the interrupt module accordingly.

  • Acknowledge message.


Interrupt-UP: max. 10 arguments admissible.

Cause:

More than 10 arguments have been specified.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reduce the number of arguments to the maximum permissible number.


Invalid axis coupling ratio <axis number>

Cause:

An attempt was made to carry out "Extended sensor mastering" for an axis, but the coupling axes were not in the same position as was reported in the data transfer.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

  • The function "Extended sensor mastering" is not carried out.

Remedy:

Move coupling axes to the same position as in the data transfer.


Invalid data type from TEPRO

Cause:

SBC cyclically sends invalid data. (TEPRO = technological process)

Effect:

  • Ramp-down braking.

  • SBC interface interrupted.

Remedy:

Eliminate the error in the SBC program.


Invalid DELAY value

Cause:

The value for "DELAY" is not permissible.

  • Ramp-down braking.

  • All active commands inhibited.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • Specify valid value.


Invalid DISTANCE value

Cause:

The value for "DISTANCE" is not permissible.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message.

  • Specify valid value.


Invalid SYNACT variable

Invalid SYNACT variable <variable name> <block number>

Cause:

In logical comparison of value assignments during cyclic Synact monitoring, an error occurred when accessing a variable,
e.g. variable write-protected.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Data or program correction.

  • Acknowledge message.


Invalid trigger-PRIO

Cause:

An inadmissible value was entered for Trigger-PRIO.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct the value.


Hardware limit-switch / +24V missing

Cause:

The interface module monitoring function has detected that a common input for hardware limit switches has been set.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Move robot off limit switch.

  • Acknowledge message.

CAUTION!
Particular care is required when moving the robot off the limit switch. No axis-specific interlocks are set.


KCP: CAN bus error

Cause: | Transmission error in CAN bus.
Effect: | Path-maintaining braking.
Remedy: | Acknowledge message.


Level overflow <IP,PCP>

Cause:

Computing time overload of CPU.

Effect:

  • Dynamic braking.

  • Output "$ALARM_STOP" has signal level "0".

  • All active commands inhibited.

Remedy:

  • Increase basic cycle.

  • Increase interpolation cycle or position control cycle (depending on the indicated parameter).


Line selection to subroutine already active

Cause:

This message can only come up if the feature LINE_SEL_LOCAL_SUB in progress.ini is TRUE.

The user did a line selection to a subroutine that is not on the caller stack and started executing this subroutine. When he tries to do another line selection to another subroutine that is also not on the caller stack of the interpreter this message comes up.

The user has to acknowledge the message and do either a line selection to a location on the caller stack or to finish to selected subroutine.


Line selection to subroutine while <#BSTEP / Interrupt> not allowed

Cause: | This message can only come up if the feature LINE_SEL_LOCAL_SUB in progress.ini is TRUE. The user tried to select a line of a local subroutine that is not on the caller stack while the program was in #BSTEP mode or in interrupt execution. This is not allowed.
Remedy: | Acknowledge the message and either change the direction to forward or finish the interrupt subroutine.


Maximal cartesian acceleration exceeded

Cause: | The cartesian acceleration monitoring is active ($ACC_CAR_STOP=TRUE) and $ACC_CAR_ACT exceeded $ACC_CAR_LIMIT in at least one component.
Effect: | Normal stop on path; block active commands
Remedy: | Quit message and change the program to avoid exceeding the allowed acceleration limits. Alternatively increase the acceleration limits ($ACC_CAR_LIMIT) or disable the acceleration monitoring by setting $ACC_CAR_ACT=FALSE.


Maximum kinetic energy <axis number>

Cause:

Permissible kinetic energy for crash exceeded.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

  • Output "$Alarm_STOP" is set to signal level 0.

Remedy:

  • Verify load data.

  • Reduce load if necessary.

  • Reduce programmed velocity.

  • Acknowledge message.


Max. active triggers reached

Cause:

Too many Trigger commands programmed in a block.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reduce number of active Trigger commands in the program.


Max. no. of enter/exit requests between motion statements reached

Cause: | Too many enter/exit requests were made between two motions.
Effect: | The program is forced to stop and should be cancelled.
Remedy: | The programmer should edit the proigram and reduce the number of requests between motions.


<file format>: Maximum recording time exceeded for <record name>

Cause: | Missing STOP command, or motion too long
Effect: | Invalid recording
Remedy: | Call STOP command before maximum recording time is reached


Max. oil temperature exceeded

Cause:

The maximum permissible hydraulic oil temperature has been exceeded.

Monitoring is carried out from the PLC application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Wait until the hydraulic oil has cooled down.

  • If this situation occurs frequently, check the hydraulic unit.


Max. triggers (50) defined

Cause:

The maximum number of Trigger commands has been defined.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Alter the program.


MDR: Change of filter not allowed

Cause: | Change of filter while mdr base is active.
Effect: | Robot and interpreter stop.
Remedy: | Do not change the filter while mdr base active.


MDR: Motion driver base has moved

Cause: | A motion relative to a motion driver base has been interrupted and the base has been moved when the motion should be continued.
Effect: | Robot stops.
Remedy: | Use another base


MDR: Motion in interrupt not possible when MDR base active

Cause: | Motion in interrupt while MDR base active
Effect: | Robot stops
Remedy: | No motions in interrupt while MDR base active


MDR: ORI_TYPE joint not allowed when MDR base active

Cause: | Ori_Type JOINT is programmed and a MDR Base is active ( $BASE=EB(...) ).
Effect: | Robot stops
Remedy: | Use another Ori_Type


MDR: PTP not allowed while motion driver base active

Cause: | A PTP movement was programmed when a motion driver base was active.
Effect: | Robot and interpreter stop.
Remedy: | Remove PTP.


Memory request for parameter list too large

Cause:

The transfer parameters of the program require too much memory.

Effect:

Maximum braking.

Remedy:

  • Acknowledge message.

  • Correct the parameters accordingly.

  • Reselect program.


Mid point equal to end point

Cause:

Distance between midpoint and end point is too small.

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

Remedy:

  • Reprogram end point and/or midpoint.

  • Acknowledge message.


Minimum must be less than maximum

Cause:

A minimum value has been declared which is greater than the maximum value.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Correct the value.


More than 16 interrupts are defined

Cause:

More than 16 interrupts have been defined.

The program instruction "INTERRUPT ON" cannot activate more than 16 defined interrupts.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reduce number of active interrupts.


Motion synchronization is not supported for PTP motions

Cause: | A PTP motion has been programmed with motion synchronization of another controller.
Remedy: | Do not use motion synchronization for PTP motions. Use only Cartesian motion types, such as LIN.


Motor holding torque <axis number> exceeded

Cause:

The motor holding torque is not sufficient to keep the robot arm permanently stopped at any given point in space.

Effect:

Interpreter stop.

Remedy:

  • Verify load data.

  • Reduce load.

  • Acknowledge message.


No more dynamic analog inputs available

Cause:

A third cyclical analog input has been activated in the program.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Deactivate a cyclical analog input.


No trigger allowed in ISR or *.SUB

Cause:

Trigger was programmed in interrupt or SUB module.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Correct program.

  • Acknowledge message.


Normal stop requested by <Machine name / IP address>

Cause: | The specified controller has requested a program stop during Motion Cooperation.
Effect: | Local program execution is halted.
Remedy: | Handle the exception on the controller with is specified in the message text.


OBJH - error: <localization>

Cause: | Internal error in OBJH.
Remedy: | Please contact the KUKA customer service department.


Oil filter dirty

Cause:

The hydraulic pressure is no longer sufficient because the hydraulic oil filter is dirty.

Monitoring is carried out from the PCL application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Clean or exchange oil filter.


Only 8 $OUT_C[n] Assignments are allowed per Motion

Cause:

More than 8 $OUT_C(N) assignments have been used.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Alter the program.


Orientation acceleration not programmed

Cause:

No value has been assigned to the program data "$ACC.ORI1" and "$ACC.ORI2".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Orientation velocity not programmed

Cause:

No value has been assigned to the program data "$VEL.ORI1" and "$VEL.ORI2".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


OriJoint not possible: Configuration of start- and targetposition differs

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Overload of gear torque <axis number> by <% value>

Cause: | The max. permissible gear torque of the specified axis is statically exceeded by the percentage indicated.
Effect: | Interpreter stop.
Remedy: | Verify load data: – Mass – Center of gravity – Moments of inertia


OUT parameters inadmissible

Cause:

Trigger with subprogram call where reference parameters are transferred.

Remedy:

  • Correct program.

  • Acknowledge message.


Palletize mode not possible with this robot type

Cause: | If $ROBROOT A or B < > 0, palletizing is not possible. NOTE: Palletizing is only possible with floor and ceiling-mounted robots.
Effect: | Maximum braking.
Remedy: | Enter $ROBROOT correctly or set $PAL_MODE = FALSE.


Passive STOP

Cause:

Passive device stop. This message is only displayed if an active process has been stopped.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.
NOTE:
This message can only be acknowledged on the device which generated it, even in passive status.


Path acceleration not programmed

Cause:

No value has been assigned to the program datum "$ACC.CP".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Path velocity not programmed

Cause:

No value has been assigned to the program datum "$VEL.CP".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


Perform data transfer <axis number>

Cause:

An attempt has been made to carry out sensor mastering for an axis for which a sensor location run has not yet been performed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Perform sensor location run for the corresponding axis.


Perform initial mastering <axis number>

Cause:

An attempt was made to carry out a sensor location run for an axis for which initial mastering has not yet been performed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Perform initial mastering (dial gauge or EMT mastering) for the corresponding axis.


Perform sensor location search <axis number>!

Cause:

  • Sensor location run has not been carried out.

  • File "$ROBCOR.DAT" not present.

Effect:

All active commands inhibited.

Remedy:

Please contact the KUKA customer service department.


Point conversion impossible without absolute accuracy model

Cause: | Conversion impossible without model if $ABS_ACCUR = FALSE and $ABS_CONVERT = TRUE.
Effect: | The point coordinates cannot be converted in the absolutely accurate robot model.
Remedy: | Set $ABS_ACCUR = TRUE and $ABS_CONVERT = TRUE in order to carry out a point conversion. Important: following point conversion, $ABS_CONVERT must be set to FALSE again.


Positioning monitor <axis number>

Cause:

The positioning window "$IN_POS_MA" was not reached within the set positioning time "$TIME_POS".

Effect:

  • Maximum braking.

  • All active commands inhibited.

  • Once the message has been acknowledged, the axis state is: "Position reached".

Remedy:

  • Increase value for positioning window "$IN_POS_MA".

  • Increase value for positioning time "$TIME_POS".

  • Carry out drift compensation.

  • Check control loop gain.

  • Check manipulator.

  • Acknowledge message.


Pressure sensor cable failure

Cause:

The current flow of the analog input channel for pressure sensing has fallen below the minimum limit (4 - 20 mA interface).

Possible reasons for the current flow falling below the minimum limit:
– loose cable connection (connector).
– conductor in cable snapped.
– defective power source.
– defective sensor.

Effect:

Ramp-down braking.

Remedy:

  • Check the cables and connectors.

  • Check the power source.

  • Check the sensor.


PRIO 40-80 closed

Cause:

A disabled priority between 40 and 80 has been used for a trigger command. This range is reserved for internal priority allocation.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


PTP motions are prohibited on moving frames

Cause: | PTP motions are not allowed with respect to a moving frame of reference.
Remedy: | Teach the destination with respect to a fixed frame, such as world, or use a Cartesian motion type, such as LIN.


Ackn. Bus voltage charging unit is defective <power module number>

Cause: | Follow-up message to "Bus voltage charging unit is defective <KPS number>".
Remedy: | Acknowledge message.


Ackn. i*i-t mon., current limit of the motor cable <axis number> after <time> s exceeded 100 %

Cause: | Follow-up message to status message "i*i-t monitoring, current limit of the motor cable ...".
Remedy: | Acknowledge message.


Ackn. i*i-t mon., current limit of the motor cable <axis number> after <time> s exceeded 95 %

Cause: | Follow-up message to status message "i*i-t monitoring, current limit of the motor cable ... 95 %".
Remedy: | Acknowledge message.


Ackn. monitoring of the actual velocity <axis number>

Cause: | Follow-up message to status message "Monitoring of the actual velocity <axis>".
Remedy: | Acknowledge message.


Quit servo bus disturbance <Axis number>

Cause: | Follow-up message to status message "Servo bus disturbance ...".
Remedy: | Acknowledge message.


Quit Servo bus disturbance DSE <DSE number>

Cause: | Follow-up message to status message "Servo bus disturbance DSE ...".
Remedy: | Acknowledge message.


Ackn. Servo bus disturbance DSE <DSE number>, no buffering and automatic data storage possible

Cause: | Follow-up message to status message "Servo bus disturbance DSE ..., no buffering and automatic data storage possible".
Remedy: | Acknowledge message.


Reposition

Cause:

BCO not achieved when returning from the interrupt program.

The robot must be repositioned to the interrupt point before the end of the interrupt program, e.g. with LIN $POS_RET.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Acknowledge message.


The requested workspace is not managed by the selected remote manager

Cause: | The remote manager selected by the user in the workspace configuration was not correct.
Effect: | The ENTERSPACE command failed. The program must be canceled.
Remedy: | Respecify the remote manager to the actual manager.


<Name of displayed program> reselection not possible

Cause: | Program that must be linked for reselection causes linking error.
Effect: | All active commands inhibited.
Remedy: | Eliminate the error using the error list containing the linking errors.


Runtime values for Trigger in subroutines inadmissible

Cause:

In a subroutine a trigger is defined which is possibly not activated until the main program.

If runtime values are used in trigger assignment, they are not valid at the time of activation.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program accordingly.

  • Use global variables.

  • Acknowledge message.


SBC error : <Watchd.,Transf.,Korr>

Cause:

Communication error between SBC and KRC32.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Check SBC hardware and software.


Select startup

Cause:

A command has been entered that is only allowed in startup mode.

Effect:

Command is not executed.

Remedy:

  • Select startup mode.

  • Acknowledge message.


Selected axis is not adjustable

Cause:

The axis selected for mastering is inactive.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Only master an active axis.


SEN: <sensor data1> <sensor data2> <sensor data3>

Cause:

Sensor error that requires ramp-down braking.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Sensor-specific.


SEN: <sensor data1> <sensor data2> <sensor data3>

Cause:

Sensor error that requires maximum braking.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Sensor-specific.


SEN: <sensor data1> <sensor data2> <sensor data3>

Cause:

Sensor error that requires path-maintaining braking.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Sensor-specific.


Sensor adjustment invalid <axis number>

Cause:

The axis selected for sensor mastering has an incremental or absolute encoder.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Master axis with EMT or dial gauge.


Sensor location search invalid <axis number>

Cause:

  • The axis was not mastered at the time of the command "Sensor location search".

  • Last type of mastering was sensor mastering.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Master axis with EMT or dial gauge.

  • Exit menu via Recall.

  • Acknowledge this message.


Sensor mastering inadmissible

Cause:

No sensor location run has been performed for the axis.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Perform sensor location run for the axis.


Servo parameters not transferred

Cause:

Servo parameters were not sent to DSE.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Define the structure "$SERVOPARA" correctly.


Singularity-less motion: max. orientation error

Cause:

Max. orientation error has been reached.

Effect:

Path-maintaining braking.

Remedy:

  • Change path.

  • Modify orientation error default in frame $SINGUL_ERR_JOG (for jog mode) or $SINGUL_ERR_PRO (for program mode).


Skip Nr '<skipnumber>' already in use

Cause: | This skip number is already in use.
Remedy: | Use another number.


Skip number '<missing skip number>' is missing

Cause: | The interpreter run to an endskip token without the matching skip.
Effect: | User must see an acknowledge message to recognize his programming error.
Remedy: | Alter program.


Skip statements musn't be nested

Cause: | Nested skip endskip statements in the program.
Remedy: | Alter program. See also documentation.


Start movement inadmissible

Cause:

  • The first motion block in the program is relative.

  • The first motion block in the program is not programmed completely, e.g. PTP [33.33].

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the program.

  • Acknowledge message.


Start point equal to end point

Cause:

Distance between start point and end point is too small.

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

Remedy:

  • Reprogram start point and/or end point.

  • Acknowledge message.


Start point equal to mid point

Cause:

Distance between start point and midpoint is too small.

Effect:

  • Ramp-down braking.

  • Active commands inhibited.

Remedy:

  • Reprogram midpoint and/or start point.

  • Acknowledge message.


Static motor torque overload <axis number> by <% value>

Cause: | The max. permissible motor torque of the specified axis is statically exceeded by the percentage indicated.
Effect: | Interpreter stop.
Remedy: | Verify load data: – Mass – Center of gravity – Moments of inertia


Stop, approximation not possible

Cause:

Approximation not possible for reasons of path planning or time.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reduce the velocity and/or acceleration in the instruction until approximation is possible.


Stop command ignored

Cause:

Axis was not brought to a standstill within a defined time following a Stop instruction.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Repeat the measurement.

  • Acknowledge message.


Stop due to loading new custom data

Cause:

Loader for the file "$CUSTOM.DAT" has been called during an active process.

No process may be active when editing "$CUSTOM.DAT" as the system is fully occupied with the loader.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

  • Acknowledge message;

  • Do not edit "$CUSTOM.DAT" during an "active process".


STOP due to node switchover

Cause:

The "Home" setting was changed while a traversing key was being pressed or the program was being executed.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


STOP due to operating mode change

Cause:

Operating mode has been changed.

All active processes are stopped if the operating mode is changed.

Effect:

  • Path-maintaining braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


STOP due to software limit switch <motion direction> <axis number>

Cause:

A sofware limit switch command value has been exceeded.

Effect:

Maximum braking.

Remedy:

  • Acknowledge message.

  • Move the robot in the opposite direction.


STOP due to unit passive

Cause:

The operator control unit has been deactivated during actuation of the Start key or a traversing key in mode T1 or T2, or during the BCO run.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Activate operator control device.

  • Acknowledge message.


STOP due to value out of range overflow <motion direction><axis number>

Cause: | Overflow of the actual value of an endless axis.
Effect: | Maximum braking.
Remedy: | Remastering of the corresponding axis.


Stopped <axis number>

Cause:

Axis has been moved out of the standstill position according to the machine data
– "$FOL_ERR_MA"(following error limit value) and
– "$TL_FOL_ERR"(tolerance time following error limit value).

Effect:

  • Dynamic braking.

  • Output "$ALARM_STOP" has signal level 0.

  • All active commands inhibited.

Remedy:

  • Increase following error limit value.

  • Increase tolerance time following error limit value.

  • Check motor brake output stage.

  • Acknowledge message.


A submit program is not able to execute Workspace Sharing commands.

Cause: | The submit program attempted to execute a mutual exclusion command. This is not allowed.
Effect: | The submit program stops execution.
Remedy: | The user must cancel the submit program and remove the mutual exclusion commands from it.


Success loading <""normal" or "configuration-"> servo parameters <axis number>

Cause: | Reading of the parameters completed successfully.
Effect: | None.
Remedy: | Acknowledge message.


TECH_MAX value exceeded

Cause:

The number of the programmed function generator is greater than the maximum number of function generators configured in the robot-specific machine data (TECH_MAX).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct program.


Tech mode inadmissible

Cause:

The "CYCLE" mode has been programmed for the technology category "VEL".

Monitoring is carried out in the interpreter when changing "CLASS" or "MODE".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Correct program.


Timeout during filling

Cause:

The maximum time for filling the dispenser with adhesive has been exceeded.

Monitoring is carried out from the PLC application program (adhesive bonding technology).
The time taken for filling the dispenser with adhesive is monitored by the PLC.
If the maximum time is exceeded, there is a fault in the adhesive application hardware.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check the adhesive application hardware.


Too many ASYPTP commands

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Reduce number of ASYPTP commands.


Torque mode velocity limit exceeded <axis number>

Cause:

The permissible velocity was exceeded in torque mode.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Reduce velocity accordingly.


Trace buffer empty, start with backward scan

Cause:

  • Empty trace for backward motion,

  • switching to SCAN method.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


TTS not existing

Cause:

The X-axis of the tool coordinate system and the path tangent are parallel.

What is "TTS"?
TTS = tool-based technological system.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

  • Reprogram motion.

  • Carry out point correction.


Unable to maintain motion synchronization

Cause: | The controller was unable to maintain the requested synchronization due to a communication error.
Effect: | Program execution is halted.
Remedy: | Reset the programs and repeat the application, or perform a line select to the synchronized motion on all participating controllers. If the problem persists, please contact your local KUKA representative.


Undefined syntax error

Cause: | An unknown syntax error has occurred.
Effect: | The program cannot be executed.
Remedy: | Alter the program.


Unknown compiler error: <error class>

Cause: | The compiler software has detected an error.
Remedy: | Please contact the KUKA customer service department.


<file format>: Unknown Error

Cause: | EMI driver encountered an error whose type is unknown to the system.
Effect: | Robot stops.
Remedy: | Contact supplier of driver.


User-memory deleted ...

Cause:

Effect:

Remedy:


Vacuum error

Cause:

Vacuum missing or insufficient

Monitoring is carried out from the PLC application program (adhesive bonding technology).
In the application of adhesive to glass, the glass is held in position by a vacuum. If this vacuum is not available, the glass cannot be held in position after it has been centered.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check vacuum pump.


Value range exceeded

Cause:

The wait time in the WAIT_SEC command, expressed in basic clock rate cycles, exceeds the long range, i.e. is greater than 2147483647.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Enter shorter wait times.


<file format>: Variable <variable> and value in <record name> differ

Cause: | Wrong value of a system variable, typically $tool, $base, $ipo_mode ...
Effect: | Robot stops.
Remedy: | Set correct value of the system variable.


Variable stack depth exceeded

Cause:

The nesting depth of the variable has been exceeded.

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Alter the variable accordingly.

  • Acknowledge message.


V-Groove has wrong profile

Cause:

The mastering notch for EMT mastering does not have a V or U profile.

Effect:

  • Ramp-down braking.

  • Mastering procedure is aborted.

  • All active commands inhibited.

Remedy:

  • Clean EMT.

  • Replace EMT notch.


Volume actual value cable failure

Cause:

The current flow of the analog input channel for volume sensing has fallen below the minimum limit (4 - 20 mA interface).

Possible reasons for the current flow falling below the minimum limit:
– loose cable connection (connector).
– conductor in cable snapped.
– defective power source.
– defective sensor.

Effect:

Ramp-down braking.

Remedy:

  • Check the cables and connectors.

  • Check the power source.

  • Check the sensor.


Volume too small

Cause:

The dispensed volume monitoring has responded. Insufficient adhesive has been dispensed.

Monitoring is carried out from the PCL application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check the adhesive application hardware and purge it if necessary.


Work envelope exceeded

Cause:

The working zone limit has been exceeded.

Effect:

  • Maximum braking.

  • All active commands inhibited.

Remedy:

Acknowledge message.


The workspace <workspace> is managed by <manager name/ip address>

Cause: | Multiple controllers in the cell have been defined to be the manager of the workspace.
Effect: | The workspace cannot be used until there is only one manager in the cell.
Remedy: | Select a single controller in the cell to be the manager. All other controllers referencing the workspace must specify the workspace as being managed remotely.


Workspace request for '<workspace name>' failed

Cause: | The request made by the KRL program failed. This can be caused by a variety of reasons (bad connection, no such workspace etc.). The purpose of this error is to communicate which workspace request failed.
Effect: | The program stops execution.
Remedy: | Acknowledge the error and press start to re-request the workspace.


Wrong adhesive pressure

Cause:

  • The output pressure of the adhesive is continuously monitored by the PLC during dispensing. A pressure value outside the permissible tolerance range has been detected.

  • It may be that there are bubbles in the adhesive supply line or that the outlet nozzle is clogged.

Monitoring is carried out from the PLC application program (adhesive bonding technology).

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

Check the adhesive application hardware and purge it if necessary.


Wrong start position

Cause:

  • EMT mastering begins in the notch instead of before it.

  • Cable for EMT mastering connected during "sensor location run" or "sensor mastering".

Effect:

  • Ramp-down braking.

  • All active commands inhibited.

Remedy:

  • Move the axis to be mastered into the correct start position.

  • If the cable for EMT mastering has been connected incorrectly, it must be removed.


<Program name> active: stop process (Y/N)?

Cause: | Reloading of machine data.
Effect: | The process awaits processing.
Remedy: | Stop process and restart the program once the machine data have been loaded.


<Object name> compile (Y/N)?

Cause: | Query asking whether or not the object should be compiled.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> copy (Y/N)?

Cause: | Query asking whether or not the object should be copied.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> delete (Y/N)?

Cause: | Query asking whether or not the object should be deleted.
Effect: | The process awaits processing.
Remedy: | Answer query.


Delete complete initialization?

Cause: | Query asking whether or not the initialization should be deleted.
Effect: | The process awaits processing.
Remedy: | Answer query.


Delete complete procedure?

Cause: | Query asking whether or not the procedure should be deleted.
Effect: | The process awaits processing.
Remedy: | Answer query.


Directory <object name> not found. Create (Y/N)?

Cause: | Request for confirmation asking whether or not the target directory should be created.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> link (Y/N)?

Cause: | Query asking whether or not the object should be linked.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> overwrite (Y/N)?

Cause: | Query asking whether or not the object should be overwritten.
Effect: | The process awaits processing.
Remedy: | Answer query.


Program <program name>, overwrite (Y/N)?

Cause: | Query asking whether or not the object should be overwritten.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> program, delete (Y/N)?

Cause: | Request for confirmation asking whether or not the selected object should be deleted.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> unlink (Y/N)?

Cause: | Query asking whether or not the object should be unlinked.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> selected. Delete (Y/N)?

Cause: | Request for confirmation asking whether or not the object should be deleted.
Effect: | The process awaits processing.
Remedy: | Answer query.


<Object name> selected, overwrite (Y/N)?

Cause: | Request for confirmation asking whether or not the object should be overwritten.
Effect: | The process awaits processing.
Remedy: | Answer query.


IBS <...> Master: Bus error. Error detection in process

Cause: | The ballast resistor has got too hot, because the robot is accelerated and braked without pause.
Effect: | Ramp-down braking.
Remedy: | Reduce acceleration in the program and introduce wait times.


Internal Error (file: <file name>, line: <line number>, value: <return value>)

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace <workspace name> was manually freed

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


deadlock exists; local program is waiting for '<WorkspaceName>' owned by program '<RemoteProgram>' (<RemoteKrc>)

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace <ws name> was taken out of sequence. This state can lead to deadlock

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace <ws name> does not exist on <KRC name>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace referenced has not been defined

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Unable to connect to <KRC name>. Check connection

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


exitspace '<workspace name>' failed - unable to connect to <krc name>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace <workspace name> is currently not owned by any program

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace <workspace name> is currently owned by another program

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


The workspace definition has changed. The program must be updated

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Mutual Exclusion Internal System Error

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


$ORI_TYPE implicitly set to #VAR

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Blending $ORI_TYPE=#VAR/#CONSTANT to $ORI_TYPE=#JOINT not possible

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


<file format>: Record <record name> will be removed from memory

Cause: | an error occured during recording
Effect: | record will be removed from memory
Remedy: | remove error situation during recording


Start blocked (Controller: <Controller>, Reason: <Reason>)

Cause: | Start will be blocked, because one of the other controllers are not ready to execute the start command.
Effect: | Start will be blocked


No more virtual memory available

Cause: | Sent when the linear memory allocation does not work successfully.
Effect: | No effect.


No more physical memory available

Cause: | Sent when the physical memory allocation does not work successfully.
Effect: | No effect.


<object name> has been expanded. Module is ready

Cause: | Sent after area move process if the module is canceled.
Effect: | no effect


<object name> has reached max limit size. Cancel required

Cause: | Sended in selected mode, when area move necessary
Effect: | No effect


<object name> could not be expanded. No more virtual memory available

Cause: | send when area move process does not work properly after cancel
Effect: | no effect


endspline is missing

Cause:

No matching endspline for spline


<file format>: Error loading <record name>

Cause: | file format not be correct. I/O errors
Effect: | file is not loaded to kernel system
Remedy: | check file format. check storage device.


<file format>: Error saving <record name>

Cause: | An I/O error occured when writing to disk.
Effect: | The file will be erased from disk. Unless you get a further message saying otherwise the record will remain in memory.
Remedy: | Check storage device.


<file format>: Error starting motion <record name>

Cause: | The start position is not correct. The output variables could not be written
Effect: | The motion is not executed.
Remedy: | Check motion record file. Check I/O-system.


<file format>: Command not possible for <record name>

Cause: | An internal state transition of the driver could not be executed.
Effect: | driver specific
Remedy: | contact driver supplier


MDR: BCO motion not allowed if MDR-base invalid

Cause: | Executing BCO motion and actual MDR base is invalid (i.e. workpiece not found)
Effect: | Stop programm
Remedy: | Wait for a valid base (i.e. workpiece found)


MDR: Moving MDR-base not allowed

Cause: | In this situation (e.g. BCO motion) a moving MDR base is not allowed
Effect: | Stop robot program
Remedy: | Stop the MDR base


Imminent collision with robot <Robot Name>

Cause: | A collision was predicted between two robots
Effect: | The two robots come to a stop on their paths
Remedy: | Acknowledge the error and move the robots back. Analyse the program to check why collision would have happened


Collision Avoidance: Unknown Load: <Load name>

Cause: | Two scene files have the same robot. However, one defines a load that the other doesn't. When the robot grasps that load, a message is sent to the other robot with the load name, which does not exist!
Effect: | The message is posted. The robots are stopped.
Remedy: | The user should make sure that the load is present in both scene files.


Collision Avoidance: Unknown destination <Destination name>

Cause: | Two scene files have the same robot. However, one defines a load that the other doesn't. When the robot is moving to that load, a message is sent to the other robot with the load name as a terget, which does not exist!
Effect: | The message is posted. The robots are stopped
Remedy: | The user should make sure that the load is present in both scene files.


Collision Avoidance Version mismatch with robot <Robot name>

Cause: | Two or more controllers have different and incompatible versions of Collision Avoidance messages (communication messages)
Effect: | The message is posted. The user has to acknowledge it. Collision avoidance is turned off between the two machines
Remedy: | Make sure all Collision Avoidance versions are compatible.


Program Cooperation version (<Message version number>) mismatch for message from <Controller name or IP Address>

Cause: | A program cooperation message received from another controller has a newer or older message format and is incompatible with this version of program cooperation software.
Effect: | The controllers will not perform program cooperation features.
Remedy: | Install the same version of the program cooperation option on both controllers.


Can't activate new LK() - link in interrupt program

Cause: | It is not possible to establish a new LK()-link in a interrupt program. New means that it is not possible wich a independent machine indicated with the IP-Parameter in LK() which was not a active link of the interrupted program. It is allowed to reactivate a link which was turned of during the interrupt program.
Effect: | Program execution is stopped.
Remedy: | Change your interrupt program, i.e. remove Base assignments. There is no known use case for such program structures.


Backward scan for cooperating robots not possible

Cause: | $SpreadAction has a value >1, and the backward trace buffer is empty.
Effect: | Scan mode is not possible for cooperating robots
Remedy: | set $SpreadAction = 0


Local clock not synchronized during motion cooperation

Cause: | The local and remote clocks must be synchronized during Motion Cooperation operation.
Effect: | Program execution is stopped.
Remedy: | Verify that clock synchronization is installed and working properly.


Clock on <Name or IP of remote machine> not synchronized

Cause: | The local and remote clocks must be synchronized during Motion Cooperation operation.
Effect: | Program execution is stopped.
Remedy: | Verify that clock synchronization is installed and working properly.


Statement not allowed within spline block

Cause: | usage of statement that is forbidden within a spline..endspline block
Effect: | syntax of program not correct


Tool / Base option of statement not correct

Cause: | tool / base option of statement was programmed in an incorrect way
Effect: | syntax of programm not correct


Ackn. short circuit DC link <power module number>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Ackn. peak current too high <power module number>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Ackn. RMS current too high <power module number>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Ackn. phase loss <power module number>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Ackn. Fan error. Change module <Axis number> as soon as possible for avoiding breakdown

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Cannot link to local machine

Cause: | The local program has requested a link to the local controller.
Effect: | Program execution is stopped.
Remedy: | Modify the program so that the link does not reference the local controller.


The Program Cooperation option is not installed. Command cannot be executed.

Cause: | An attempt was made to execute a program cooperation commmand such as a program sync, program control or workspace sharing request. However the program cooperation option is not installed.
Effect: | The command cannot be executed.
Remedy: | Install the program cooperation option or eliminate the program cooperation commands from the KRL program.


One or more controllers are sync simulated in Auto mode

Cause: | One or more controllers are tagged as simulated for program and motion synchronization. Operating mode was changed from T1/T2 to AUT/EXT.
Effect: | Local sync commands act as if the simulated controls have reached the sync point in advance.
Remedy: | Untag all controllers using the cell map simulation utility.


Ackn. deviation in absolute position value DSE - RDC axis <Axis number>

Cause: | Follow-up message to status message ""eviation in absolute position value DSE - RDC axis %1"
Remedy: | Acknowledge message


Cannot link to <Master name or IP address> without common shared pendant

Cause: | Linking is only permitted between controllers that share a pendant (KCP).
Effect: | Program execution is stopped.
Remedy: | Configure the shared pendant so that the independent and dependent machines share a common pendant.


Cannot spread actions with <Controller name or IP address> without common shared KCP

Cause: | An attempt was made to spread actions to another controller that is not controlled by the same shared KCP as this controller.
Effect: | Action cannot be spread.
Remedy: | Configure both this controller and the remote controller to use the same shared KCP.


$CP_STATMON: wrong axis value

Cause: | Axis value differs from the programmed one.
Effect: | After movement selection in between a series of cp movements, it is possible that different axis values can cause a complete twist of the robot wrist, reachnig software end switch or the following ptp movement differs from the origin ptp movement.
Remedy: | Teach this position a second time. Repeat BCO with other axis values.


$CP_STATMON: approximation not possible

Cause: | As variable $CP_STATMON is enabled, the program monitors the cp configration. In this case the programm has detected a different axis value compared to the programmed one.
Effect: | The program can not blend this position and moves forward to the programmed position.
Remedy: | Program the position a second time.


Inconsistent sync list detected

Cause: | The list of controllers participating in the synchronization is not consistent between all controllers.
Effect: | Program execution is stopped.
Remedy: | Ensure that the list of controllers participating in the syncrhonization is the same in all programs.


LK master (<Master name or IP address>) missing in time sync list

Cause: | A time synchronous motion was programmed but LK() master does not participate
Effect: | Normal stop
Remedy: | Program time synchronous moves on LK() master


Active cyclic flag limit is exceeded. Max 32

Cause:

If the number of active cycflags 32 and a new cyclic flag is activated, this message is sent.

Effect:

During command execution:

  • Command is not executed.

During program execution:

  • Ramp-down braking.

  • All active commands inhibited.


Timeout switching off force control <axis number>

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


Ackn. encoder cable failure ext. posinput <axis number>

Cause:

Follow-up message to status message: "Encoder cable failure ext. posinput".

Effect:

  • Path-maintaining braking.

  • Output $ALARM_STOP 0 signal

  • All active commands inhibited.

Remedy:

Acknowledge message.


MDR: IPO_MODE TCP not allowed

Cause: | IPO_MODE TCP was set when a MDR-base was active
Effect: | Robot stops
Remedy: | Don't use IPO_MODE TCP when a MDR-base is active


Ackn. force controller error <axis number> no. <error type>

Cause:

This is the following message of the message: "Force controller error"

  • Force sensor signal does not fit to movement.

  • Error type no.1: The actual force changes and the position does not change.

  • Error type no.2: The position changes and the actual force does not change.

  • Error type no.3: The gun opens wider than the corresponding position to FORCE_LIM.

  • This surveillance is only active while the force controller is active!

Effect:

  • Maximum braking.

  • Active commands inhibited.

  • Output $ALARM_STOP has signal level 0.

Remedy:

  • Acknowledge message.

  • Check force sensor.

  • Check force sensor cable.

  • Check RDC plug in board.


Time synched motion requires equal program run mode on all controls

Cause: | At least two time synched controls are in different program run modes or the synched motion is located in a hidden module on some controllers.
Effect: | Normal stop on path. Motion is rejected by the interpreter and is planned asynchronous after acknowledging this message.
Remedy: | Switch all controls to the same program run mode. Mark all involved modules either as visible or hidden.


Duplicate active sync ID (<String ID of the sync>).

Cause: | The KRL program issued a Program or Motion Sync command with the same ID of an outstanding program or motion sync. This can happen with NOWAIT program syncs, or can happen when a KRL interrupt occurs while the robot program was actively waiting at the sync command and within the interrupt, there is another sync command with the same ID.
Effect: | Sync commands with the same ID are indistinguishable, so 2 active at the same time are not allowed.
Remedy: | Assign a unique ID to each program or motion sync command.


Ackn. drives disabled <power module number>

Cause:

Drives are enabled on KPSi again


Ackn. connection lost during motion cooperation

Cause: | Follow-up message to status message: “Connection lost with remote machine”
Remedy: | Acknowledge message


Ackn. loss of clock synchronization

Cause: | Follow-up message to status message: “Clock not synchronized during motion cooperation”
Remedy: | Acknowledge message


Invalid operation, clock master already exists

Cause: | The user attempted to set the controller to be a clock master. This operation failed because a clock master already exists in the cell.
Effect: | The controller remains a clock slave.
Remedy: | If it is desired that the controller become a master the user should first set the existing master to be a slave.


Clock Sync not initialized

Cause: | An attempt was made to change the controllers clock sync state while the clock sync module has not been initialized.
Effect: | The desired change in clock sync state will not be applied.
Remedy: | Make sure that clock sync is an active component of the tech package installed. If it is not, clock sync will not be initialized. If it is, reboot the controller to attempt to reinitialize clock sync.


Breakchannel not opened <axis number>

Cause: | Brakes have not been opened, because not all axes of this brake channel are active.
Effect: | Errors: e.g. Following error, oder Motor blocking.
Remedy: | Move all axes at one breakchannel together or use seperate brake control.


Error_01

Sorry... as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.


KR C1 Online-Hilfe

Sorry...

as yet, no online help is currently available for this subject.

Information can be found in the operating handbooks.