ARC_OFF mit LIN-Bewegung

Programmierung ARC_OFF mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach KAltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=1.75

Programmierung der Geschwindig-keit der Zustellbewegung zum ARC_ON Befehl

Eingabe im m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuend-parameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_ON mit LIN-Bewegung

Programmierung ARC_ON mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=1.75

Programmierung der Geschwindig-keit der Zustellbewegung zum ARC_ON Befehl

Eingabe im m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfuegung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuend-parameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=100%

Programmierung der Geschwindig-keit der Zustellbewegung zum ARC_ON Befehl

Eingabe bei PTP Bewegungen in %

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Gasvorstroemzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorstroemen.

Die Zuendzeit gilt ab Erkennen des "Strom fliesst" - Signales. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die hoehere Zuendspannung wird im Vorlauf ausgegeben und gilt nur fuer die Dauer der Zuendzeit. Eine Zuendzeit = 0 gibt keine Zuend-parameter aus und schaltet dann sofort auf die Schweissparameter um.

Fuer die Dauer der Zuendzeit ist dieser Wert des Drahtvorschubes gueltig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_SWI mit CIRC-Bewegung

Programmierung ARC_SWI mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Ueberschleifens

Listbox ergibt die Moeglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG -Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.


ARC_SWI mit LIN-Bewegung

Programmierung ARC_SWI mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Ueberschleifens

Listbox ergibt die Moeglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbos koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.


TRACK_OFF mit CIRC-Bewegung

Programmierung TRACK_OFF mit CIRC-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P0

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln und Sensorbetrieb ist nicht moeglich!

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeintraechtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Seite bietet die kV Einstellungen des Sensors fuer Seite und Hoehe. Zunaechst sollte immer die Default-Einstellung verwebdet werden.

Die Sensoroffseteinstellungen koennen ueber diese Listbox so manipuliert werden, so dass der Sensoroffset anstehen bleiben, oder auf dem Wege zur naechsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets duerfen nur CP Bewegungen ausgefuehrt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


TRACK_OFF mit CIRC-Bewegung

Programmierung TRACK_OFF mit CIRC-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das FeldP1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln kann nicht im Zusammenhang mit dem Pendelsensor verwendet werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeintraechtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Seite bietet die kV Einstellungen des Sensors fuer Seite und Hoehe. Zunaechst sollte immer die Default-Einstellung verwebdet werden.

Die Sensoroffseteinstellungen koennen ueber diese Listbox so manipuliert werden, so dass der Sensoroffset anstehen bleiben, oder auf dem Wege zur naechsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets duerfen nur CP Bewegungen ausgefuehrt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


TRACK_SWI mit CIRC-Bewegung

Programmierung TRACK_SWI mit CIRC-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P0

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aus-/Einschalten des Ueberschleifens

Das Ueberschleifen kann hiermit aktiviert werden. Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Defaulteinstellung=5 mm)

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln und Sensorbetrieb ist nicht moeglich!

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeintraechtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Seite bietet die kV Einstellungen des Sensors fuer Seite und Hoehe. Zunaechst sollte immer die Default-Einstellung verwebdet werden.

Die Sensoroffseteinstellungen koennen ueber diese Listbox so manipuliert werden, so dass der Sensoroffset anstehen bleiben, oder auf dem Wege zur naechsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets duerfen nur CP Bewegungen ausgefuehrt werden.


TRACK_SWI mit LIN-Bewegung

Programmierung TRACK_SWI mit LIN-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das FeldP1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aus-/Einschalten des Ueberschleifens

Das Ueberschleifen kann hiermit aktiviert werden. Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Defaulteinstellung=5 mm)

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln kann nicht im Zusammenhang mit dem Pendelsensor verwendet werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeintraechtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Seite bietet die kV Einstellungen des Sensors fuer Seite und Hoehe. Zunaechst sollte immer die Default-Einstellung verwebdet werden.

Die Sensoroffseteinstellungen koennen ueber diese Listbox so manipuliert werden, so dass der Sensoroffset anstehen bleiben, oder auf dem Wege zur naechsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets duerfen nur CP Bewegungen ausgefuehrt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_OFF mit CIRC-Bewegung

Programmierung ARC_OFF mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweissmodi

Mit dieser Auswahl der Listbox koennen verschiedene Kennlinien selektiert werden. Die Umschaltung fuer den Schweissgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Die Schweissgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen fuer die Analogkanaele werden gebildet in Abh. des selektierten Schweissmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rueckbrennzeit gilt jeweils fuer den Nahtabschnitt, und spielt eigentlich nur im Rueckbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz

Das Freischalten weiterer Analogkanaele in den Parameterlisten fuer zuenden, schweissen und Krater fuellen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Moeglichkeit ist mit einem Offlinetool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhaengig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfuegung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronitaet zum mechanischen Pendeln zu Erreichen, muss die Pendellaenge der des mechanischen Pendelns entsprechen. Um die Waerme-Einbringung auf der linken, bzw. rechten Seite zu steuern, muessen und unter Umstaenden die Werte der Schweiss-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweissdatensatz getauscht werden.

(Skalierungen identisch mit Schweissparameter)

Diese Seite der Parameterliste steht nur dann zur Verfuegung, wennn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfuellt ist. Funktion ist ein Rampen der Analogkanaele 1 und 2 von einem Datensatz zum naechsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Endarameterliste geoeffnet:

Die Endkraterzeit in sec laesst den IR an stehender Position noch Draht foerdern um mit reduzierter Leistung, den Endkrater zu fuellen.

Endkraterspannung und deer Drahtvorschub sind nur gueltig fuer die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweisspannung anstehen

Die Rueckbrennzeit kann speziell fuer den Rueckbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweissdatensatz.

Die Gasnachstroemzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung fuer 3 Analogkanaele.

Eine separate Beschriftung ist ueber Offlinetool moeglich. Die Eingabegrenzen werden ebenfalls wie in der Schweissparameterliste ueber den hoechsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach KAltstart und aktivierter RE_initialisierung erneut beruecksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_OFF mit CIRC-Bewegung

Programmierung ARC_OFF mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

E1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Schweissgeschwindigkeit entspricht wird in m/min angegeben

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relative zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Seam1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_OFF mit LIN-Bewegung

Programmierung ARC_OFF mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

E1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Schweissgeschwindigkeit entspricht wird in m/min angegeben

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relative zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.

Seam1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=2m/sec

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz ist auf 5 mm in der $CONFIG Variable A_AP_DIS_TCH fixiert.(Default-Einstellung)

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Startverzoegerung bedeutet, dass der IR fuer diese Dauer in Sekunden nach Erkennen des Stromflusses stehen bleibt.

Seam1

Kommentarfeld

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_ON mit LIN-Bewegung

Programmierung ARC_ON mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=2 m/sec

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz ist auf 5 mm in der $CONFIG Variable A_AP_DIS_TCH fixiert.(Default-Einstellung)

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT.

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Startverzoegerung bedeutet, dass der IR fuer diese Dauer in Sekunden nach Erkennen des Stromflusses stehen bleibt.

Seam1

Kommentarfeld

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls


ARC_ON mit PTP-Bewegung

Programmierung ARC_ON mit PTP-Bewegung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz ist auf 5 mm in der $CONFIG Variable A_AP_DIS_TCH fixiert.(Default-Einstellung)

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

S1

Zuenddatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Startverzoegerung bedeutet, dass der IR fuer diese Dauer in Sekunden nach Erkennen des Stromflusses stehen bleibt.

Seam1

Kommentarfeld

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird autoinkrementiert beim Anlegen eines naechsten ARC_ON Befehls.


ARC_SWI mit CIRC-Bewegung

Programmierung ARC_SWI mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivieren des Ueberschleifens

Auswahl: Mit oder Ohne Ueberschleifen

Die Ueberschleifdistanz wird fuer alle Schweissbefehle in der $CONFIG-Variable A_AP_DIS_TCH festgelegt.(Default=5mm)

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Schweissgeschwindigkeit entspricht wird in m/min angegeben

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relative zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.


ARC_SWI mit LIN-Bewegung

Programmierung ARC_SWI mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivieren des Ueberschleifens

Auswahl: Mit oder Ohne Ueberschleifen

Die Ueberschleifdistanz wird fuer alle Schweissbefehle in der $CONFIG-Variable A_AP_DIS_TCH festgelegt. (Default: 5 mm)

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PGNO= 1

Programmnummer

Eingabe der Programmnummer fuer die Schweisstromquelle

Eingabegrenze ist der Wert der Variable PRGNO_MAX im File A20.DAT

W1

Schweissdatensatz

Es stehen maximal 23 Zeichen fuer den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor ueber dieses Feld bewegt, so wird die Parameterliste geoeffnet:

Der Parameter Schweissgeschwindigkeit entspricht wird in m/min angegeben

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewaehlt.

Es stehen folgende Wahlmoeglichkeiten zur Verfuegung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapezp/Unsymetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellaenge doppelt so lang sein wie die Amplitudenhoehe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellaenge entspricht der Laenge in mm, die eine Pendelfigur benoetigt, um einmal auf der Bahn ausgefuehrt werden kann.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Nullinie bis Maximum)

Mit der Variation der Pendelbene kann relative zur Anstellung des Brenners zusaetzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so faengt die Pendelfigur auf der anderen Seite der Auslenkung an.


CHK_GRP-Anweisung

Programmierung CHK_GRP-Anweisung

Feld | Beschreibung | Wertebereich
GRP 1 | Der gewünschte Greifer kann ausgewählt werden. | Es werden alle projektierten Greifer zur Auswahl angeboten.
OPN | Definition des Zustandes, auf den der ausgewählte Greifer überwacht werden soll. | OPN - Der Greifer muß geöffnet sein. CLS - Der Greifer muß geschlossen sein .
START | Definiert den Zeitpunkt der Überwachung. | START - Kontrolle am Beginn der nachfolgend programmierten Bewegung . END - Kontrolle am Ende der nachfolgend programmierten Bewegung.
Delay=0 | Der Zeitpunkt der Überwachung kann zusätzlich verschoben werden. | Die zeitliche Verschiebung kann im Bereich von -200ms bis 200ms erfolgen.


GRP-Anweisung

Programmierung GRP-Anweisung

Feld | Beschreibung | Wertebereich
GRP 1 | Der gewünschte Greifer kann ausgewählt werden. | Es werden alle projektierten Greifer zur Auswahl angeboten.
OPN | Definition des Zustandes, den der ausgewählte Greifer einnehmen soll. | OPN - Der Greifer wird geöffnet . CLO - Der Greifer wird geschlossen.
CONT | Legt fest, ob die Schaltaktion bereits im Vorlauf ausgeführt wird. | CONT - Die Schaltaktion wird im Vorlauf ausgeführt . Wird CONT nicht programmiert, erfolgt die Schaltaktion im Hauptlauf (Vorlaufstopp).
START | Definiert den Zeitpunkt der Schaltaktion. | START - Die Schaltaktion erfolgt am Beginn der nachfolgend programmierten Bewegung . END - Die Schaltaktion erfolgt am Ende der nachfolgend programmierten Bewegung.
Delay=0 | Der Zeitpunkt der Schaltaktion kann zusätzlich verschoben werden. | Die zeitliche Verschiebung kann im Bereich von -200ms bis 200ms erfolgen.


Kommentare

Programmierung von Kommentaren

Feld | Beschreibung | Wertebereich
; hier steht ein beliebiger Text | Es steht ein Textfeld für einen Kommentar zur Verfügung | Es kann ein freier Text eingegeben werden.


Kommentare mit Stempel

Programmierung von Kommentaren mit Stempel

Feld | Beschreibung | Wertebereich
; 9.1.01 15:40 NAME | Datum, Uhrzeit und Name dessen, der die Änderung durchgeführt hat. | Dieser Teil des Inline-Formulars wird automatisch erstellt. Bei einer Änderung wird die Uhrzeit und das Datum nicht wieder aktualisiert. Es muß dann ein neuer Stempel eingefügt werden.
Peter Muster | Name des Bearbeiters. | Es kann ein freier Text eingegeben werden.
CHANGES | Feld, hinter dem die Änderungen eingegeben werden. | Fester Name des Feldes.
Hier steht ein beliebigerText | Eingabe der durchgeführten Änderungen. | Es kann ein freier Text eingegeben werden.


An- und Abkoppeln von Interbussegmenten

Programmierung An- und Abkoppeln von Interbussegmenten

Feld | Beschreibung | Wertebereich
IBUS | Schaltbares Inberbussegment | Befehl zur An- und Abkopplung von Inberbussegmenten. Diese Segmente müssen in der Datei iosys.ini konfiguriert sein. Die Datei Interbus.ini bietet in der Sektion [NAMES] die Möglichkeit, Namen für die einzelnen Segmente zu vergeben
ON | Ankoppeln eines Segmentes | ON Ankoppeln eines Interbussegmentes. OFF Abkoppeln eines Interbussegmentes .


CIRC-Bewegung

Programmierung CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

P1, P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Parameter, der Überschleifen aktiviert.

CONT steht für "continues motion". Es wird der programmierte Punkt nicht genau angefahren, sondern vorzeitig die Bewegung zum nächsten Punkt begonnen. Die Parameter für den Überschleif können im Feld C PDAT1 festgelegt werden. PTP-Bewegungen werden mit C_PTP und LIN- bzw. CIRC-Bewegungen mit C_DIS überschliffen.

VEL=0.5m/s

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Bei LIN-/CIRC-Bewegungen ist die Einheit m/s. Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld C PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.


LIN-Bewegung

Programmierung LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Parameter, der Überschleifen aktiviert.

CONT steht für "continues motion". Es wird der programmierte Punkt nicht genau angefahren, sondern vorzeitig die Bewegung zum nächsten Punkt begonnen. Die Parameter für den Überschleif können im Feld C PDAT1 festgelegt werden. PTP-Bewegungen werden mit C_PTP und LIN- bzw. CIRC-Bewegungen mit C_DIS überschliffen.

VEL=0.5m/s

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Bei LIN-/CIRC-Bewegungen ist die Einheit m/s. Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld C PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.


PTP-Bewegung

Programmierung PTP-Bewegung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes spreichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Parameter, der Überschleifen aktiviert.

CONT steht für "continues motion". Es wird der programmierte Punkt nicht genau angefahren, sondern vorzeitig die Bewegung zum nächsten Punkt begonnen. Die Parameter für den Überschleif können im Feld PDAT1 festgelegt werden. PTP-Bewegungen werden mit C_PTP und LIN- bzw. CIRC-Bewegungen mit C_DIS überschliffen.

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.


OUT AT POINT-Befehl

Programmierung OUT AT POINT-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

CONT

Parameter, der das Überschleifen des Ausgangs aktiviert.

CONT : die Ausgangsbearbeitung erfolgt in Überschleifmitte zwischen 2 Bewegungspunkten.

keine Angabe: der Ausgangsbearbeitung erfolgt im Genauhalt zwischen 2 Bearbeitungspunkten.


OUT-Befehl

Programmierung OUT-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

Setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

CONT

Parameter, der das Überschleifen des Ausgangs aktiviert.

CONT : die Ausgangsbearbeitung erfolgt im Vorlauf.

keine Angabe: der Ausgangsbefehl erzwingt Vorlaufstop.


PULSE-Befehl

Programmierung PULSE-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden sind im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

CONT

Parameter, der das Überschleifen des Ausgangs aktiviert.

CONT : die Ausgangsbearbeitung erfolgt im Vorlauf.

keine Angabe: der Ausgangsbefehl erzwingt Vorlaufstop.

Zeitfenster

Pulsedauer

Die Pulsdauer kann von 0.1 bis 3 Sekunden festgelegt werden. Die Schrittweite beträgt 0.1 Sekunden.


SYNOUT-Befehl

Programmierung SYNOUT-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

Position

Position des Schaltvorgangs.

START : die Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

END : die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

PATH : die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder ist bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe ausdehnbar.

Weg

wegmäßige Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Dieses Feld ist nur vorhanden wenn im Positionsfeld PATH selektiert wurde. Die wegmäßige Verschiebung bei Bahnsätzen (LIN, CIRC) erfolgt in negativer oder positiver Richtung vom Zielpunkt.

Beachte: Die Startposition bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1mm.

Delay

zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung.

Beachte: Die Startposition in negativer Richtung bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) in positiver Richtung kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1 ms.


SYNPULSE-Befehl

Programmierung SYNPULSE-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

Setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

Zeitfenster

Pulsedauer

Die Pulsdauer kann von 0.1 bis 3 Sekunden festgelegt werden. Die Schrittweite beträgt 0.1 Sekunden.

Position

Position des bahnbezogenen Schaltvorgangs.

START : die Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

END : die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

PATH : die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder ist bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe ausdehnbar.

Weg

wegmäßige Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Dieses Feld ist nur vorhanden wenn im Positionsfeld PATH selektiert wurde. Die wegmäßige Verschiebung bei Bahnsätzen (LIN, CIRC) erfolgt in negativer oder positiver Richtung vom Zielpunkt.

Beachte: Die Startposition bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1mm.

Delay

zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung.

Beachte: Die Startposition in negativer Richtung bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) in positiver Richtung kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1 ms.


WAIT FOR-Befehl

Programmierung WAIT FOR-Befehl

Feld | Beschreibung | Wertebereich
WAIT FOR IN | Warte auf Eingang mit den nachfolgenden Parametern. | WAIT FOR IN warten auf Eingang WAIT FOR OUT warten auf Ausgang
10 | Eingangsnummer, auf den gewartet wird. | Ausgänge sind in einem Bereich von 1 bis 1024 möglich. Eingänge können von 1 bis 1026 gewählt werden (Es besteht die Möglichkeit, die Anzahlt der Ein-/Ausgänge auf bis zu 4096 zu erhöhen, dann ist 4096 die entsprechende Obergrenze). Vorsicht: Eingang 1025 ist immer TRUE. Eingang 1026 ist immer FALSE.
Ventil | Langtextname, der zu dem ausgewählten Eingang projektiert ist. | Frei konfigurierbarer Name, der in der Ein-/Ausgangsübersicht vergeben werden kann.
State=TRUE | Warten auf den Zustand TRUE. | Es kann auf den Pegel TRUE oder FALSE gewartet werden.
CONT | Die Warteanweisung wird im Vorlauf bearbeitet. | Die Auswahl von CONT führt dazu, dass ein CONTINUE vor die WAIT-Anweisung gestellt wird. Ein Vorlaufstop wird dann nicht ausgeführt und die Anweisung zur Vorlaufzeit bearbeitet.


WAIT-Befehl

Programmierung WAIT-Befehl

Feld | Beschreibung | Wertebereich
WAIT Time | Programmierung einer Wartezeit. | Dieser Befehl löst einen Vorlaufstop aus.
1.25 | Zeit, die gewartet werden soll. | Zulässige sind Wartezeiten von 0 bis 30 Sekunden.


RETRACT-CIRC

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert .

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll .

CLS - Der Vorhub wird geschlossen.

OPN - Der Vorhub wird geöffnet. .

GUN=1

Definiert die aktive Schweißzange .

Auswahl zwischen bis zu 5 Schweißzangen.


RETRACT-LIN

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll .

CLS - Der Vorhub wird geschlossen.

OPN - Der Vorhub wird geöffnet.

GUN=1

Definiert die aktive Schweißzange .

Auswahl zwischen bis zu 5 Schweißzangen .


RETRACT-PTP

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll.

CLS - Der Vorhub wird geschlossen .

OPN - Der Vorhub wird geöffnet .

GUN=1

Definiert die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.


SPOT-CIRC

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld C PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT) .

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden.


SPOT-LIN

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert .

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen .

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT) .

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden .


SPOT-PTP

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert .

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT).

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden .


Eindimensionale Korrekturanweisung KUKA TP

Eindimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 1D | Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die Suchbewegung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Zweidimensionale Korrekturanweisung KUKA TP

Zweidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 2D CD0 | 1. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Dreidimensionale Korrekturanweisung KUKA TP

Dreidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 3D CD0 | 1. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CD2 | 3. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die dritte Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT"sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Ausschalten der Korrekturanweisung KUKA TP

Ausschalten der Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR OFF | Der Befehl bewirkt, dass das BASE_CORR_ON-Flag und das BASE_CORR-Frame zurück gesetzt werden. | Der Parameter CONT gibt an, ob der Befehl überschliffen werden soll.


Frei programmierbare Korrekturanweisung KUKA TP

Frei programmierbare Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CD {1,2,3} | Bestimmung einer Fläche | Wert 1: Bestimmt die Fläche Wert 2: erste Rotationsdimension der Fläche Wert 3: zweite Rotationsdimension der Fläche
CD {4,5} | Bestimmung einer Linie | Wert 1: Bestimmt die Linie Wert 2: erste Rotationsdimension der Linie
CD {6} | Legt die Verschiebung fest |
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlang- samt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.

Hinweis:

  • Der Wert -1 steht für einen Null -Offset und es wird ein vordefinierter Default-Datensatz verwendet.

  • Beim CORR CD-Befehl können nur Korrekturdaten mit CD & Nummer verwendet werden. Also keine selbst kreierten Namen von Datensätzen.


Programmierung der Touchsense Suche mit LIN-Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

LIN

Bewegungstyp LIN

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Bei LIN-Bewegungen ist die Einheit m/s.

PDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


Suche mit PTP-Bewegung

Programmierung der Touchsense Suche mit PTP-Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

PTP

Bewegungstyp PTP

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Bei LIN-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


Eindimensionale Korrekturanweisung KUKA TPS

Eindimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 1D | Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die Suchbewegung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Zweidimensionale Korrekturanweisung KUKA TPS

Zweidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 2D CD0 | 1. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Dreidimensionale Korrekturanweisung KUKA TPS

Dreidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 3D CD0 | 1. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CD2 | 3. Bewegungssatz fuer die Suchbewegung | In diesem Datensatz werden die Parameter für die dritte Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT"sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Ausschalten der Korrekturanweisung KUKA TPS

Ausschalten der Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR OFF | Der Befehl bewirkt, dass das BASE_CORR_ON-Flag und das BASE_CORR-Frame zurück gesetzt werden. | Der Parameter CONT gibt an, ob der Befehl überschliffen werden soll.


Frei programmierbare Korrekturanweisung KUKA TPS

Frei programmierbare Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CD {1,2,3} | Bestimmung einer Fläche | Wert 1: Bestimmt die Fläche Wert 2: erste Rotationsdimension der Fläche Wert 3: zweite Rotationsdimension der Fläche
CD {4,5} | Bestimmung einer Linie | Wert 1: Bestimmt die Linie Wert 2: erste Rotationsdimension der Linie
CD {6} | Legt die Verschiebung fest |
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlang- samt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.

Hinweis:

  • Der Wert -1 steht für einen Null -Offset und es wird ein vordefinierter Default-Datensatz verwendet.

  • Beim CORR CD-Befehl können nur Korrekturdaten mit CD & Nummer verwendet werden. Also keine selbst kreierten Namen von Datensätzen.


Programmierung der Touchsense Suche mit Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

PTP/LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


Seite nicht vorhanden

Sorry...

... zu diesem Thema ist leider keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


KR C1 Online-Help Technologien

KR C1
Online-Help

Rel. 1.4

Technologien

KUKA Roboter GmbH
Bluecherstrasse 144
D-86165 Augsburg
Copyrigt © 1995 -2000