ARC_OFF mit LIN-Bewegung

Programmierung ARC_OFF mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfügung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronität zum mechanischen Pendeln zu Erreichen, muss die Pendellänge der des mechanischen Pendelns entsprechen. Um die Wärme-Einbringung auf der linken, bzw. rechten Seite zu steuern, müssen und unter Umständen die Werte der Schweiß-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweißdatensatz getauscht werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE-Iinitialisierung erneut berücksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=1.75

Programmierung der Geschwindigkeit der Zustellbewegung zum ARC_ON Befehl

Eingabe im m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zünddatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Gasvorströmzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorströmen.

Die Zündzeit gilt ab Erkennen des "Strom fließt" - Signals. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die höhere Zündspannung wird im Vorlauf ausgegeben und gilt nur für die Dauer der Zündzeit. Eine Zündzeit = 0 gibt keine Zünd-parameter aus und schaltet dann sofort auf die Schweißparameter um.

Für die Dauer der Zündzeit ist dieser Wert des Drahtvorschubes gültig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


ARC_ON mit LIN-Bewegung

Programmierung ARC_ON mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=1.75

Programmierung der Geschwindigkeit der Zustellbewegung zum ARC_ON Befehl

Eingabe im m/sec bei Bahnbewegungen

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zünddatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Gasvorströmzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorströmen.

Die Zündzeit gilt ab Erkennen des "Strom fließt" - Signals. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die höhere Zündspannung wird im Vorlauf ausgegeben und gilt nur für die Dauer der Zündzeit. Eine Zündzeit = 0 gibt keine Zünd-parameter aus und schaltet dann sofort auf die Schweißparameter um.

Für die Dauer der Zündzeit ist dieser Wert des Drahtvorschubes gültig.

Die Eingabegrenzen werden gebildet in Abhängigkeit. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Experten-Programmierung "$CONFIG.DAT": ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung Möglichkeit ist mit einem Offline-Tool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird die Nummer beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert


ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

Vel=100%

Programmierung der Geschwindigkeit der Zustellbewegung zum ARC_ON Befehl

Eingabe bei PTP Bewegungen in %

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

S1

Zünddatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Gasvorströmzeit kann vor Erreichen der Position fliegend oder an der Position erfolgen. Die Eingabe geschieht in Sekunden und ist limitiert auf 1.5 sec. Die $CONFIG Variable A_PR_GAS_OPT= TRUE bedingt ein fliegendes Gasvorströmen.

Die Zündzeit gilt ab Erkennen des "Strom fließt" - Signals. Die Eingabe ist in Sekunden und limitiert auf 1.5 sec.

Die höhere Zündspannung wird im Vorlauf ausgegeben und gilt nur für die Dauer der Zündzeit. Eine Zündzeit = 0 gibt keine Zünd-parameter aus und schaltet dann sofort auf die Schweißparameter um.

Für die Dauer der Zündzeit ist dieser Wert des Drahtvorschubes gültig.

Die Eingabegrenzen werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


ARC_SWI mit CIRC-Bewegung

Programmierung ARC_SWI mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P3

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Überschleifens

Listbox ergibt die Möglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG -Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfügung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronität zum mechanischen Pendeln zu Erreichen, muss die Pendellänge der des mechanischen Pendelns entsprechen. Um die Wärme-Einbringung auf der linken, bzw. rechten Seite zu steuern, müssen und unter Umständen die Werte der Schweiß-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweißdatensatz getauscht werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.


ARC_SWI mit LIN-Bewegung

Programmierung ARC_SWI mit LIN-Bewegung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aktivierung des Überschleifens

Listbox ergibt die Möglichkeit die Funktion ein- oder auszuschalten. Die Ueberschleifdistanz bei ARC Befehlen wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt, und beinhaltet als Default 5mm

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

PS/MM

Schweißmodus

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfügung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronität zum mechanischen Pendeln zu Erreichen, muss die Pendellänge der des mechanischen Pendelns entsprechen. Um die Wärme-Einbringung auf der linken, bzw. rechten Seite zu steuern, müssen und unter Umständen die Werte der Schweiß-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweißdatensatz getauscht werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.


TRACK_OFF mit CIRC-Bewegung

Programmierung TRACK_OFF mit CIRC-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P0

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln und Sensorbetrieb ist nicht möglich!

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeinträchtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut berücksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Seite bietet die kV Einstellungen des Sensors für Seite und Höhe. Zunächst sollte immer die Default-Einstellung verwendet werden.

Die Sensor-Offset-Einstellungen können über diese Listbox so manipuliert werden, so dass der Sensor-Offset anstehen bleiben, oder auf dem Wege zur nächsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets dürfen nur CP Bewegungen ausgeführt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


TRACK_OFF mit LIN-Bewegung

Programmierung TRACK_OFF mit LIN-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das FeldP1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln kann nicht im Zusammenhang mit dem Pendelsensor verwendet werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeinträchtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut berücksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Seite bietet die kV Einstellungen des Sensors für Seite und Höhe. Zunächst sollte immer die Default-Einstellung verwendet werden.

Die Sensor-Offset-Einstellungen können über diese Listbox so manipuliert werden, so dass der Sensor-Offset anstehen bleiben, oder auf dem Wege zur nächsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets dürfen nur CP Bewegungen ausgeführt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


TRACK_SWI mit CIRC-Bewegung

Programmierung TRACK_SWI mit CIRC-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Hilf-Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug. Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

P0

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aus-/Einschalten des Überschleifens

Das Überschleifen kann hiermit aktiviert werden. Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Defaulteinstellung=5 mm)

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln und Sensorbetrieb ist nicht möglich!

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeinträchtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut berücksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Seite bietet die kV Einstellungen des Sensors für Seite und Höhe. Zunächst sollte immer die Default-Einstellung verwendet werden.

Die Sensor-Offset-Einstellungen können über diese Listbox so manipuliert werden, so dass der Sensor-Offset anstehen bleiben, oder auf dem Wege zur nächsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets dürfen nur CP Bewegungen ausgeführt werden.


TRACK_SWI mit LIN-Bewegung

Programmierung TRACK_SWI mit LIN-Bewegung

TRACK Befehle erscheinen nur bei aktivierter $CONFIG Variable A50_OPTION=#ACTIVE.

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Zielpunktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das FeldP1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CONT

Aus-/Einschalten des Überschleifens

Das Überschleifen kann hiermit aktiviert werden. Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Defaulteinstellung=5 mm)

CPDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Die Ueberschleifdistanz wird in der $CONFIG Variable A_AP_DIS_TCH festgelegt (Default 5 mm)

PS/MM

Schweißmodi

Mit dieser Auswahl der Listbox können verschiedene Kennlinien selektiert werden. Die Umschaltung für den Schweißgleichrichter geschieht mit einem digitalen Ausgang.

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Thermisches Pendeln kann nicht im Zusammenhang mit dem Pendelsensor verwendet werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

Die Rampenfunktion darf nicht bei Sensorbetrieb verwendet werden, da eine Referenzierung sonst beeinträchtigt wird.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut berücksichtigt.

TRACK

Aktivieren des Pendelsensors

Listbox zum nahtspezifischen EIN- / und Ausschalten des TAST Sensors

T

Sensordatensatzname

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Seite bietet die kV Einstellungen des Sensors für Seite und Höhe. Zunächst sollte immer die Default-Einstellung verwendet werden.

Die Sensor-Offset-Einstellungen können über diese Listbox so manipuliert werden, so dass der Sensor-Offset anstehen bleiben, oder auf dem Wege zur nächsten Bahnbewegung linear abgebaut werden. Im Falle des beibehaltenen Offsets dürfen nur CP Bewegungen ausgeführt werden.

Naht1

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


ARC_OFF mit CIRC-Bewegung

Programmierung ARC_OFF mit CIRC-Bewegung

”ARC OFF” beendet den Schweißprozeß mit der Endkraterfüllung und dem Rückbrennen von überschüssigem Schweißdraht, so daß beim Zündprozeß am Beginn der nächsten Schweißnaht die richtige freie Drahtlänge und --form gegeben ist.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

CIRC, LIN.

[PS]

Beschreibung

Schweißmodus.
Mit dieser Auswahl der Listbox können unterschiedliche Kennlinien ausgewählt werden. Die Umschaltung für den Schweißgleichrichter geschieht mittels digitalem Ausgang.

Wertebereich

PS, MM

[W1]

Beschreibung

Schweißdatensatz
Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in dieses Feld gesetzt, wird folgende Parameterliste geöffnet:

Schweißparameter, Liste 1

Schweißgeschwindigkeit
Wertebereich: 0 ... 2 m/min
Falls mit Versatzoverride ungleich 100% gearbeitet wird, erfolgt entsprechende Anpassung der Konstantgeschwindigkeit.

Schweißspannung
Wertebereich: 13 ... 39 Volt

Drahtvorschub
Wertebereich: 0 ... 20 m/min

Nahtspezifische Rückbrennzeit
Wertebereich: 1 ... 1,5 Sekunden

Schweißparameter, Liste 2

Pulskorrektur
Wertebereich: 0 ... 20

Schweißparameter, Liste 3
Mechanisches Pendeln

Pendelfigur
Zur Auswahl stehen folgende Figuren:
Ohne Pendeln
Dreieck, Doppeldreieck,
Trapez, Doppeltrapez,
Spirale, Doppelacht

Hinweis: Bei der Spirale muß die Pendellänge doppelt zu lang sein, wie die Amplitudenhöhe, weil sonst keine kreisende Bewegung möglich ist.

Pendellänge
Wertebereich: 1,5 ... 12 mm

Pendelamplitude
Wertebereich: 0 ... 15 mm

Pendelebene
Wertebereich: -180 ... 180 Grad

Schweißparameter, Liste 4
Thermisches Pendeln

Pendelfigur
Zur Auswahl stehen folgende Figuren:
Ohne Pendeln
Dreieck, Trapez.

Schweißspannung
Dies ist die minimale Spannung; die maximale Spannung ist in Liste 1 (Schweißspannung) definiert.
Wertebereich: 13 ... 39 Volt

Drahtvorschub
Wertebereich: 0 ... 20 mm

Thermische Pendellänge
Wertebereich: 1,5 ... 12 mm

Schweißparameter, Liste 5

Rampenfunktion
Wertebereich: 0 ... 25 mm

[E]

Beschreibung

Endparameter
Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in dieses Feld gesetzt, wird folgende Parameterliste geöffnet:

Endkraterparameter, Liste 1

Endkraterzeit
Wertebereich: 0 ... 1,5 Sekunden

Endkraterspannung
Wertebereich: 13 ... 39 Volt

Drahtvorschub
zum Füllen des Endkraters ;
projektierungsabhängig.
Wertebereich: 0 ... 20 m/min

Rückbrennzeit
Wertebereich: 1 ... 1,5 Sekunden

Endkraterparameter, Liste 2

Endkraterzeit
Wertebereich: 0 ... 1,5 Sekunden

Endkraterspannung
Wertebereich: 13 ... 39 Volt

Drahtvorschub
zum Füllen des Endkraters ;
projektierungsabhängig.
Wertebereich: 0 ... 20 m/min

Rückbrennzeit
Wertebereich: 1 ... 1,5 Sekunden

Programmierung ARC_OFF mit CIRC-Bewegung

Feld

Beschreibung

Wertebereich

W1

Schweißdatensatz

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Parameterliste geöffnet:

Die Schweißgeschwindigkeit wird in m/min eingegeben. Falls mit einem Versatzoverride <> 100 % verwendet wird, so wird die Konstantgeschwindigkeit entsprechend angepasst.

Die Eingabegrenzen für die Analogkanäle werden gebildet in Abh. des selektierten Schweißmodi, und der konfigurierten Kennlinien --> siehe unter Expertenprogrammierung $CONFIG.DAT: ANA_DEF[2,8,5] Struktur. Diese wird beim Hochlaufen der Steuerung automatisch ausgewertet, sofern die Konfiguration im A10.DAT-File RE_INITIALIZE=TRUE gesetzt wurde, und es sich um einen Kaltstart handelt.

Die Rückbrennzeit gilt jeweils für den Nahtabschnitt, und spielt eigentlich nur im Rückbrennmode #SSDV8_MODE eine Rolle.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz

Das Freischalten weiterer Analogkanäle in den Parameterlisten für zünden, schweißen und Krater füllen geschieht mit der $CONFIG Variable A_ACT_AN_MAX= (2...8) Default=2.

Beispielhafter Analogkanal 3 mit individueller Beschriftung. Möglichkeit ist mit einem Offline-Tool gegeben.

Mit dem Parameter Pendelfigur wird die Pendelfigur ausgewählt.

Es stehen folgende Wahlmöglichkeiten zur Verfügung:

Ohne Pendeln /Dreieck/Doppeldreieck/Trapez/Doppeltrapez/Unsymmetr. Trapez/Spirale/Doppelacht.

Bei der Auswahl der Spirale muss die Pendellänge doppelt so lang sein wie die Amplitudenhöhe, da sonst keine kreisende Bewegung entstehen kann.

Die Pendellänge entspricht der Länge in mm, die eine Pendelfigur benötigt, um einmal auf der Bahn ausgeführt werden kann. Die Pendelfrequenz ist von der Geschwindigkeit abhängig.

Die Pendelamplitude entspricht der Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum)

Mit der Variation der Pendelbene kann relativ zur Anstellung des Brenners zusätzlich die Pendelebene gedreht werden. Wird die Pendelebene um 180 Grad gedreht, so fängt die Pendelfigur auf der anderen Seite der Auslenkung an.

Diese Seite des thermischen Pendelns steht nur zur Verfügung, wenn die globale Option A_TH_WEAVE_OPT=TRUE vor dem Hochlaufen gesetzt wurde. Um Sycnchronität zum mechanischen Pendeln zu Erreichen, muss die Pendellänge der des mechanischen Pendelns entsprechen. Um die Wärme-Einbringung auf der linken, bzw. rechten Seite zu steuern, müssen und unter Umständen die Werte der Schweiß-Spannung und des Drahtvorschubes hier mit den Werten der Daten im Schweißdatensatz getauscht werden.

(Skalierungen identisch mit Schweißparameter)

Diese Seite der Parameterliste steht nur dann zur Verfügung, wenn vor Hochlauf die $CONFIG Variable A_RAMP_OPTION=TRUE erfüllt ist. Funktion ist ein Rampen der Analogkanäle 1 und 2 von einem Datensatz zum nächsten.

E

Enddatensatznummer

Es stehen maximal 23 Zeichen für den Namen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor über dieses Feld bewegt, so wird die Endarameterliste geöffnet:

Die Endkraterzeit in sec lässt den IR an stehender Position noch Draht fördern um mit reduzierter Leistung, den Endkrater zu füllen.

Endkraterspannung und der Drahtvorschub sind nur gültig für die Endkraterzeit. Wird die Zeit auf 0 sec gesetzt, so bleibt die Schweißspannung anstehen

Die Rückbrennzeit kann speziell für den Rückbrennmode #SSDV8_MODE separat eingestellt werden.

Mit der Variable HIDE_BB_TIME=TRUE im A10.DAT File kann dieses Parameterlistenelement ausgeblendet werden sowohl im Endkrater- und Schweißdatensatz.

Die Gasnachströmzeit in Sekunden geschieht an stehender IR-Position.

Das weitere Parameterlistenelement erscheint aufgrund der erweiterten Projektierung für 3 Analogkanäle.

Eine separate Beschriftung ist über Offline-Tool möglich. Die Eingabegrenzen werden ebenfalls wie in der Schweißparameterliste über den höchsten projektierten Wert in der ANA_DEF[2,8,5] Struktur in der $CONFIG.DAT bestimmt. Diese wird nach Kaltstart und aktivierter RE_initialisierung erneut berücksichtigt.

Naht0

Nahtkommentar

Kommentarfeld frei beschreibbar . Wird als letztes Zeichen eine Nummer verwendet, so wird automatisch inkrementiert beim Anlegen eines nächsten ARC_ON Befehls.


A20 ARC_OFF mit CIRC-Bewegung

Programmierung ARC_OFF mit CIRC-Bewegung

”ARC OFF”umfaßt die Bewegungsparameter, die Programmnummer für die Stromquelle, die Schweißparameter und ggf. die mechanische Pendelfigur sowie die Parameter für die Endkrater-Füllung für

  • die Schweißnaht nach erfolgtem Schweißstart (ARC ON) bis zum Ende der Naht, vorausgesetzt gleiche Bewegungs- und Schweißparameter für die gesamte Schweißnaht

  • den letzten Nahtabschnitt von einem ”ARC SWITCH”-Befehl bis zum Ende der Naht, bei Aufteilung der Schweißnaht in mehrere Abschnitte.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.

Siehe auch:

Wertebereich

CIRC, LIN.

ARC_OFF Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[E1]

Beschreibung

Schweißdatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [E1], erscheint im Zustandsfenster eine Parameterliste für die Schweiß parameter und das mechanische Pendeln.

Schweißparameter

Schweißgeschwindigkeit
Einstellung der Schweißgeschwindigkeit.
Wertebereich: 0,01 ... 5 m/min

Endkraterzeit
Einstellung der Zeit für die Endkraterbildung.
Wertebereich: 0 ... 2 s

Pendelfigur
Auswahl einer Figur für das mechanische Pendeln.
Verfügbar sind: Ohne Pendeln / Dreieck / Doppeldreieck / Trapez / Doppeltrapez / Unsymmetr. Trapez / Spirale / Doppelacht.
Hinweis: Bei der Spirale muß die Pendellänge doppelt zu lang sein, wie die Amplitudenhöhe, weil sonst keine kreisende Bewegung möglich ist.

Mechanisches Pendeln

Pendellänge
Länge in mm, die eine Pendelfigur für eine Ausführung auf der Bahn benötigt.
Wertebereich: 0 ... 25 mm

Pendelamplitude
Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum).
Wertebereich: 0 ... 25 mm

Pendelebene
Drehung der Pendelebene relativ zur Stellung des Brenners. Bei Drehung um 180 Grad beginnt die Pendelfigur auf der gegenüberliegenden Seite der Auslenkung.
Wertebereich: -180 ... 180 Grad

[Seam1]

Beschreibung

Kommentar, frei beschreibbar.

Wertebereich

Vorein stellung: "Seam...". Kommentare, welche mit einer Ziffer enden, werden beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert.


A20 ARC_OFF mit LIN-Bewegung

Programmierung ARC_OFF mit LIN-Bewegung

”ARC OFF”umfaßt die Bewegungsparameter, die Programmnummer für die Stromquelle, die Schweißparameter und ggf. die mechanische Pendelfigur sowie die Parameter für die Endkrater-Füllung für

  • die Schweißnaht nach erfolgtem Schweißstart (ARC ON) bis zum Ende der Naht, vorausgesetzt gleiche Bewegungs- und Schweißparameter für die gesamte Schweißnaht

  • den letzten Nahtabschnitt von einem ”ARC SWITCH”-Befehl bis zum Ende der Naht, bei Aufteilung der Schweißnaht in mehrere Abschnitte.

[LIN]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

LIN, CIRC.

ARC_OFF Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[E1]

Beschreibung

Schweißdatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [E1], erscheint im Zustandsfenster eine Parameterliste für die Schweiß parameter und das mechanische Pendeln.

Schweißparameter

Schweißgeschwindigkeit
Einstellung der Schweißgeschwindigkeit.
Wertebereich: 0,01 ... 5 m/min

Endkraterzeit
Einstellung der Zeit für die Endkraterbildung.
Wertebereich: 0 ... 2 s

Pendelfigur
Auswahl einer Figur für das mechanische Pendeln.
Verfügbar sind: Ohne Pendeln / Dreieck / Doppeldreieck / Trapez / Doppeltrapez / Unsymmetr. Trapez / Spirale / Doppelacht.
Hinweis: Bei der Spirale muß die Pendellänge doppelt zu lang sein, wie die Amplitudenhöhe, weil sonst keine kreisende Bewegung möglich ist.

Mechanisches Pendeln

Pendellänge
Länge in mm, die eine Pendelfigur für eine Ausführung auf der Bahn benötigt.
Wertebereich: 0 ... 25 mm

Pendelamplitude
Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum).
Wertebereich: 0 ... 25 mm

Pendelebene
Drehung der Pendelebene relativ zur Stellung des Brenners. Bei Drehung um 180 Grad beginnt die Pendelfigur auf der gegenüberliegenden Seite der Auslenkung.
Wertebereich: -180 ... 180 Grad

[Seam1]

Beschreibung

Kommentar, frei beschreibbar.

Wertebereich

Vorein stellung: "Seam...". Kommentare, welche mit einer Ziffer enden, werden beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert.


A20 ARC_ON mit CIRC-Bewegung

Programmierung ARC_ON mit CIRC-Bewegung

”ARC ON”umfaßt die Bewegungsparameter (Bewegungsart, Geschwindigkeit) vom Ausgangspunkt zum Anfangspunkt der Schweißnaht, die Startparameter sowie die Programmnummer für die Stromquelle.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

CIRC, PTP, LIN

ARC_O N Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[S1]

Beschreibung

Zünddatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [S1], erscheint im Zustandsfenster eine Parameterliste für die Zünd parameter.

Startverzögerung
Zeitdauer in Sekunden, in welcher der Roboter nach Erkennen des Stromflusses stehen bleibt.
Wertebereich: 0 ... 2 sec

[Seam1]

Beschreibung

Kommentar, frei beschreibbar.

Wertebereich

Vorein stellung: "Seam...". Kommentare, welche mit einer Ziffer enden, werden beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert.


A20 ARC_ON mit LIN-Bewegung

Programmierung ARC_ON mit LIN-Bewegung

”ARC ON”umfaßt die Bewegungsparameter (Bewegungsart, Geschwindigkeit) vom Ausgangspunkt zum Anfangspunkt der Schweißnaht, die Startparameter sowie die Programmnummer für die Stromquelle.

[LIN]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

LIN, CIRC, PTP.

ARC_O N Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[S1]

Beschreibung

Zünddatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [S1], erscheint im Zustandsfenster eine Parameterliste für die Zünd parameter.

Startverzögerung
Zeitdauer in Sekunden, in der der Roboter nach Erkennen des Stromflusses stehen bleibt.
Wertebereich: 0 ... 2 sec

[Seam1]

Beschreibung

Kommentar, frei beschreibbar.

Wertebereich

Vorein stellung: "Seam...". Kommentare, welche mit einer Ziffer enden, werden beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert.


A20 ARC_ON mit PTP-Bewegung

Programmierung ARC_ON mit PTP-Bewegung

”ARC ON”umfaßt die Bewegungsparameter (Bewegungsart, Geschwindigkeit) vom Ausgangspunkt zum Anfangspunkt der Schweißnaht, die Startparameter sowie die Programmnummer für die Stromquelle.

Ein Überschleifen ist bei ARC ON nicht möglich, die Bewegung erfolgt bis zum Genau-Halt.

Die PTP-Bewegung verläuft auf einer vom Roboter definierten B a hn und ist nicht e xakt vorhersehbar! Um mögliche Kollisionen zu vermeiden, sollte diese Bahn in der Nähe von Hindernissen zunächst mit vermindertem Programmoverride (POV) abgefahren werden!

[PTP]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

LIN, CIRC, PTP.

ARC_O N Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[S1]

Beschreibung

Zünddatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [S1], erscheint im Zustandsfenster eine Parameterliste für die Zünd parameter.

Startverzögerung
Zeitdauer in Sekunden, in der der Roboter nach Erkennen des Stromflusses stehen bleibt.
Wertebereich: 0 ... 2 sec

[Seam1]

Beschreibung

Kommentar, frei beschreibbar.

Wertebereich

Vorein stellung: "Seam...". Kommentare, welche mit einer Ziffer enden, werden beim Anlegen des nächsten ARC_ON Befehls automatisch inkrementiert.


A20 ARC_SWI mit CIRC-Bewegung

Programmierung ARC_SWI mit CIRC-Bewegung

”ARC SWITCH” findet zwischen den Befehlen ”ARC_ON” und ”ARC_OFF” Anwendung, sofern die Schweißnaht in mehrere Abschnitte mit unterschiedlichen Bewegungs- und/oder Schweißparametern aufgeteilt wird. Er enthält die Bewegungsparameter für den aktuellen Nahtabschnitt, die Programmnummer sowie die Schweißparameter und die Parameter für mechanisches Pendeln.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

CIRC, LIN

ARC_OFF Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[W1]

Beschreibung

Schweißdatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [E1], erscheint im Zustandsfenster eine Parameterliste für die Schweiß parameter und das mechanische Pendeln.

Schweißparameter

Schweißgeschwindigkeit
Einstellung der Schweißgeschwindigkeit.
Wertebereich: 0,01 ... 5 m/min

Pendelfigur
Auswahl einer Figur für das mechanische Pendeln.
Verfügbar sind: Ohne Pendeln / Dreieck / Doppeldreieck / Trapez / Doppeltrapez / Unsymmetr. Trapez / Spirale / Doppelacht.
Hinweis: Bei der Spirale muß die Pendellänge doppelt zu lang sein, wie die Amplitudenhöhe, weil sonst keine kreisende Bewegung möglich ist.

Mechanisches Pendeln

Pendellänge
Länge in mm, die eine Pendelfigur für eine Ausführung auf der Bahn benötigt.
Wertebereich: 0 ... 25 mm

Pendelamplitude
Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum).
Wertebereich: 0 ... 25 mm

Pendelebene
Drehung der Pendelebene relativ zur Stellung des Brenners. Bei Drehung um 180 Grad beginnt die Pendelfigur auf der gegenüberliegenden Seite der Auslenkung.
Wertebereich: -180 ... 180 Grad


A20 ARC_SWI mit LIN-Bewegung

Programmierung ARC_SWI mit LIN-Bewegung

”ARC SWITCH” findet zwischen den Befehlen ”ARC_ON” und ”ARC_OFF” Anwendung, sofern die Schweißnaht in mehrere Abschnitte mit unterschiedlichen Bewegungs- und/oder Schweißparametern aufgeteilt wird. Er enthält die Bewegungsparameter für den aktuellen Nahtabschnitt, die Programmnummer sowie die Schweißparameter und die Parameter für mechanisches Pendeln.

[LIN]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

LIN, CIRC

ARC_OFF Pgno= [1]

Beschreibung

Programmnummer für die Schweißstromquelle.

Wertebereich

Eingabegrenze ist der Wert der Variablen "PRGNO_MAX" in der Datei "A20.DAT".

[W1]

Beschreibung

Schweißdatensatz

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Steht der Cursor in Feld [E1], erscheint im Zustandsfenster eine Parameterliste für die Schweiß parameter und das mechanische Pendeln.

Schweißparameter

Schweißgeschwindigkeit
Einstellung der Schweißgeschwindigkeit.
Wertebereich: 0,01 ... 5 m/min

Pendelfigur
Auswahl einer Figur für das mechanische Pendeln.
Verfügbar sind: Ohne Pendeln / Dreieck / Doppeldreieck / Trapez / Doppeltrapez / Unsymmetr. Trapez / Spirale / Doppelacht.
Hinweis: Bei der Spirale muß die Pendellänge doppelt zu lang sein, wie die Amplitudenhöhe, weil sonst keine kreisende Bewegung möglich ist.

Mechanisches Pendeln

Pendellänge
Länge in mm, die eine Pendelfigur für eine Ausführung auf der Bahn benötigt.
Wertebereich: 0 ... 25 mm

Pendelamplitude
Auslenkung der Pendelfigur in mm ( Null-Linie bis Maximum).
Wertebereich: 0 ... 25 mm

Pendelebene
Drehung der Pendelebene relativ zur Stellung des Brenners. Bei Drehung um 180 Grad beginnt die Pendelfigur auf der gegenüberliegenden Seite der Auslenkung.
Wertebereich: -180 ... 180 Grad


CHK_GRP-Anweisung

Programmierung CHK_GRP-Anweisung

Feld | Beschreibung | Wertebereich
GRP 1 | Der gewünschte Greifer kann ausgewählt werden. | Es werden alle projektierten Greifer zur Auswahl angeboten.
OPN | Definition des Zustandes, auf den der ausgewählte Greifer überwacht werden soll. | OPN - Der Greifer muß geöffnet sein. CLS - Der Greifer muß geschlossen sein .
START | Definiert den Zeitpunkt der Überwachung. | START - Kontrolle am Beginn der nachfolgend programmierten Bewegung . END - Kontrolle am Ende der nachfolgend programmierten Bewegung.
Delay=0 | Der Zeitpunkt der Überwachung kann zusätzlich verschoben werden. | Die zeitliche Verschiebung kann im Bereich von -200ms bis 200ms erfolgen.


GRP-Anweisung

Programmierung GRP-Anweisung

Feld | Beschreibung | Wertebereich
GRP 1 | Der gewünschte Greifer kann ausgewählt werden. | Es werden alle projektierten Greifer zur Auswahl angeboten.
OPN | Definition des Zustandes, den der ausgewählte Greifer einnehmen soll. | OPN - Der Greifer wird geöffnet . CLO - Der Greifer wird geschlossen.
CONT | Legt fest, ob die Schaltaktion bereits im Vorlauf ausgeführt wird. | CONT - Die Schaltaktion wird im Vorlauf ausgeführt . Wird CONT nicht programmiert, erfolgt die Schaltaktion im Hauptlauf (Vorlaufstopp).
START | Definiert den Zeitpunkt der Schaltaktion. | START - Die Schaltaktion erfolgt am Beginn der nachfolgend programmierten Bewegung . END - Die Schaltaktion erfolgt am Ende der nachfolgend programmierten Bewegung.
Delay=0 | Der Zeitpunkt der Schaltaktion kann zusätzlich verschoben werden. | Die zeitliche Verschiebung kann im Bereich von -200ms bis 200ms erfolgen.


Kommentare

Programmierung von Kommentaren

Feld | Beschreibung | Wertebereich
; hier steht ein beliebiger Text | Es steht ein Textfeld für einen Kommentar zur Verfügung | Es kann ein freier Text eingegeben werden.


Kommentare mit Stempel

Programmierung von Kommentaren mit Stempel

Feld | Beschreibung | Wertebereich
; 9.1.01 15:40 NAME | Datum, Uhrzeit und Name dessen, der die Änderung durchgeführt hat. | Dieser Teil des Inline-Formulars wird automatisch erstellt. Bei einer Änderung wird die Uhrzeit und das Datum nicht wieder aktualisiert. Es muß dann ein neuer Stempel eingefügt werden.
Peter Muster | Name des Bearbeiters. | Es kann ein freier Text eingegeben werden.
CHANGES | Feld, hinter dem die Änderungen eingegeben werden. | Fester Name des Feldes.
Hier steht ein beliebiger Text | Eingabe der durchgeführten Änderungen. | Es kann ein freier Text eingegeben werden.


An- und Abkoppeln von Interbussegmenten

Programmierung An- und Abkoppeln von Interbus-Segmenten

Feld | Beschreibung | Wertebereich
IBUS | Schaltbares Inberbussegment | Befehl zur An- und Abkopplung von Inberbus-Segmenten. Diese Segmente müssen in der Datei " iosys.ini" konfiguriert sein. Die Datei Interbus.ini bietet in der Sektion [NAMES] die Möglichkeit, Namen für die einzelnen Segmente zu vergeben
ON | Ankoppeln eines Segmentes | ON Ankoppeln eines Interbussegmentes. OFF Abkoppeln eines Interbussegmentes .


CIRC-Bewegung

Programmierung
CIRC-Bewegung

CIRC-Bewegungen werden für Bearbeitungsvorgänge mit vorgegebener Geschwindigkeit auf einer Kreisbahn verwendet. Dabei bewegt sich der Bezugspunkt des Werkzeuges bzw. Werkstückes auf einem Kreisbogen. Die Bahn wird durch Start-, Hilfs- und Endpunkt beschrieben.

Nur der Bezugspunkt folgt der programmierten Bahn. Das Werkzeug bzw. Werkstück selbst kann seine Orientierung während der Bewegung ändern.
Start- Hilfs- und Endpunkt liegen auf einer Ebene im Raum. Zur möglichst exakten Bestimmung der Ebene sollte der Hilfspunkt nicht zu nahe am Start- bzw. Zielpunkt liegen.

[CIRC]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

CIRC, PTP, LIN.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1] [P2]

Beschreibung

Name von Hilfspunkt [P1] und Zielpunkt [P2], frei programmierbar, in denen die jeweiligen Koordinaten der Punkte gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Die Koordinaten des Hilfspunktes müssen vor Abschluß des CIRC-Befehls manuell gespeichert werden; es erfolgt keine automatische Übernahme. Falls die Festlegung der Punktkoordinaten erst zu einem späteren Zeitpunkt erfolgen soll, kann "TouchupHP" zunächst an beliebiger Position erfolgen.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P2] (Zielpunkt) bewegt, erscheint im Zustandsfenster eine Parameterliste für Tool, Base und externes Werkzeug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen.

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion".
Die Parameter für das Überschleifen können im Feld [CPDAT1] festgelegt werden. CIRC-Bewegungen werden mit C_DIS überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [0.5] m/s

Beschreibung

Bahngeschwindigkeit in Meter pro Sekunde [m/s].

Wertebereich

0,001 ... 2 m/s (Voreinstellung 2 m/s).

[CPDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [CPDAT1] bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Ueberschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Ueberschleifdistanz" steht nur zur Verfügung, wenn [CONT] eingeschaltet ist.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


LIN-Bewegung

Programmierung
LIN-Bewegung

LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet. Dabei werden die Roboterachsen so aufeinander abgestimmt, daß der Werkzeug- bzw. Werkstück-Bezugspunkt entlang einer Geraden zum Zielpunkt bewegt wird.

Nur der Bezugspunkt folgt der programmierten Bahn. Das Werkzeug bzw. Werkstück selbst kann seine Orientierung während der Bewegung ändern.

[LIN]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

LIN, CIRC, PTP.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1]

Beschreibung

Name des Zielpunktes, frei programmierbar, in dem die Koordinaten des Punktes gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P1] bewegt, erscheint im Zustands fenster eine Parameterliste für Tool, Base und externes Werkze ug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen.

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion".
Die Parameter für das Überschleifen können im Feld CPDAT1 festgelegt werden. LIN-Bewegungen werden mit "C_DIS" überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [0.5] m/s

Beschreibung

Bahngeschwindigkeit in Meter pro Sekunde [m/s].

Wertebereich

0,001 ... 2 m/s (Voreinstellung 2 m/s).

[CPDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CPDAT1 bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Ueberschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Ueberschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


PTP-Bewegung

Programmierung PTP-Bewegung

PTP ist eine Punkt-zu-Punkt-Bewegung. Die Positionierung des Robotersystems erfolgt hierbei auf dem schnellsten Weg zwischen zwei Punkten. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

Die PTP-Bewegung verläuft auf einer vom Roboter definierten Bahn und ist nicht exakt vorhersehbar! Um mögliche Kollisionen zu vermeiden, sollte diese Bahn in der Nähe von Hindernissen zunächst mit vermindertem Programmoverride (POV) abgefahren werden!

[PTP]

Beschreibung

Auswahl der Bewegungsart.
Siehe auch:

Wertebereich

PTP, LIN, CIRC.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

[P1]

Beschreibung

Name des Zielpunktes, frei programmierbar, in dem die Koordinaten des Punktes gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld [P1] bewegt, erscheint im Zustandsfenster eine Parameterliste für Tool, Base und externes Werkzeug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

[CONT]

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. [CONT] bedeutet "CONTinues motion". PTP-Bewegungen werden mit "C_PTP" überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= [100] %

Beschreibung

Geschwindigkeit, mit der die Bewegung durchgeführt wird. Bei PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Wertebereich

1 bis 100% vom Maximalwert (Voreinstellung 100%).

[PDAT1]

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Ueberschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Ueberschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


OUT AT POINT-Befehl

Programmierung
OUT AT POINT - Schaltfunktion

Dieser Befehl setzt einen Ausgang auf TRUE oder FALSE.

OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.

Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Die Ausgangsbearbeitung erfolgt im Genauhalt.

  • CONT : Die Ausgangsbearbeitung erfolgt in Überschleifmitte zwischen zwei Bewegungspunkten.


OUT-Befehl

Programmierung
OUT - Schaltfunktion

Dieser Befehl setzt einen Ausgang auf TRUE oder FALSE.

OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Der Ausgangsbefehl erzwingt einen Vorlaufstopp.

  • CONT : Die Ausgangsbearbeitung erfolgt im Vorlauf.


PULSE-Befehl

Programmierung
PULSE - Funktion

Diese Funktion setzt für eine anzugebende Zeitdauer einen Ausgang auf TRUE oder FALSE.

PULSE [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ventil]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[CONT]

Beschreibung

Parameter, der das Überschleifen der Bearbeitung des Ausgangs aktiviert.

Wertebereich

  • Leeres Feld: Der Ausgangsbefehl erzwingt einen Vorlaufstopp.

  • CONT : Die Ausgangsbearbeitung erfolgt im Vorlauf.

Time= [0.2] sec

Beschreibung

Zeitdauer des Impuls.

Wertebereich

0.1 bis 3 Sekunden. Die Schrittweite beträgt 0.1 Sekunden.


SYNOUT-Befehl

Programmierung SYN OUT - Befehl

"SYN OUT" ist eine bahnabhängige Schaltfunktion.

Beispiel: Bei einer Klebe-Applikation soll an einem bestimmten Punkt der Kleberauftrag beginnen. Bei A (Ausgang1=TRUE) wird die Klebepistole aktiviert. Mit PATH=10mm ist der Punkt definiert, an dem der Kleberauftrag beginnen soll. Die Klebepistole benötigt eine bestimmte Vorlaufzeit bis zum Kleberaustritt, in diesem Beispiel 15 ms. Deshalb wird Delay= -15 ms gesetzt.

SYN OUT [1]

Beschreibung

Nummer des zu setzenden Ausgangs.

Wertebereich

Es stehen 1...1024 Ausgangsnummern zur Verfügung. Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert werden.
Anzeige siehe Menü "Digitale Ausgänge".

Hinweis: Vom System verwendete Ausgänge sind im Menü "digitale Ausgänge" gekennzeichnet.

[Ausgang]

Beschreibung

Symbolischer Name; kann frei vergeben werden.

Wertebereich

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Dieses Feld ist gegen unbeabsichtigtes Beschreiben geschützt. Der Schreibschutz wird mit Betätigung der Taste "Langtext" aufgehoben. Nach Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

State= [TRUE]

Beschreibung

Mit "State=" wird der digitale Ausgang gesetzt oder zurück gesetzt.

Wertebereich

  • TRUE Ausgang wird auf High-Pegel gesetzt.

  • FALSE Ausgang wird auf Low-Pegel gesetzt.

[PATH]

Beschreibung

Position des Schaltvorgangs.

Wertebereich

  • START : D ie Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

  • END : die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

  • PATH : die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder ist bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe ausdehnbar.

Dieses Feld ist nur vorhanden wenn im Feld Position "PATH" selektiert wurde.

= [10] mm

Dieses Feld ist nur vorhanden wenn im Feld Position "PATH" selektiert wurde.

Beschreibung

  • Verschiebung (Weg) der bahnbezogenen Ausgangsbearbeitung.

Wertebereich

Die Verschiebung bei Bahnsätzen (LIN, CIRC) erfolgt in negativer oder positiver Richtung vom Zielpunkt. Die Schrittweite der Verschiebung beträgt 1mm.

Die Startposition bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) kann nicht überschritten werden.

Delay= [-15] ms

Beschreibung

Zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Wertebereich

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung. Die Schrittweite der Verschiebung beträgt 1 ms.

Die Startposition in negativer Richtung bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) in positiver Richtung kann nicht überschritten werden.


SYNPULSE-Befehl

Programmierung SYNPULSE-Befehl

Feld

Beschreibung

Wertebereich

Nummer

Nummer des Ausgangs der gesetzt werden soll.

Es stehen 1...1024 Ausgangsnummern zur Verfügung.

Optional kann die Anzahl der zur Verfügung stehenden Nummern bis 4096 erweitert sein.

Anzeige siehe Menü 'Digitale Ausgänge'.

Beachte: Ausgänge die vom System benutzt werden, sind speziell im Menü 'digitale Ausgänge' gekennzeichnet.

Name

Ein symbolischer Name kann frei vergeben werden.

Für den symbolischen Namen steht eine ausreichend große Anzahl an Zeichen zur Verfügung. Es wird empfohlen einen eindeutigen etwa bis zu 20 Zeichen langen Namen zu vergeben. Sonderzeichen im Rahmen des KRL-Sprachumfangs sind zulässig.

Beachte: Das Feld 'symbolischer Name' ist vor unbeabsichtigtem Beschreiben geschützt. Erst wenn in der Softkeyleiste die Taste 'Langtext' betätigt wird, ist der Schreibschutz aufgehoben. Nach dem Schließen des Inlineformulars wird der Schreibschutz wieder gesetzt.

Status

Setzt oder rücksetzt einen digitalen Ausgang.

TRUE Ausgang wird auf High-Pegel gesetzt.

FALSE Ausgang wird auf Low-Pegel gesetzt.

Zeitfenster

Pulsdauer

Die Pulsdauer kann von 0.1 bis 3 Sekunden festgelegt werden. Die Schrittweite beträgt 0.1 Sekunden.

Position

Position des bahnbezogenen Schaltvorgangs.

START : die Ausgangsbearbeitung erfolgt im Startpunkt des nächsten Bewegungsatzes.

END : die Ausgangsbearbeitung erfolgt im Zielpunkt des nächsten Bewegungsatzes.

PATH : die Ausgangsbearbeitung erfolgt zwischen Start- und Zielpunkt des nächsten Bahnsatzes (LIN, CIRC) durch negative Wegangabe oder ist bei überschliffenen Bewegungen bis zum nächsten Genauhalt mit positiver Wegangabe ausdehnbar.

Weg

wegmäßige Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Dieses Feld ist nur vorhanden wenn im Positionsfeld PATH selektiert wurde. Die wegmäßige Verschiebung bei Bahnsätzen (LIN, CIRC) erfolgt in negativer oder positiver Richtung vom Zielpunkt.

Beachte: Die Startposition bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1mm.

Delay

zeitliche Verschiebung der bahnbezogenen Ausgangsbearbeitung.

Die zeitliche Verschiebung erfolgt in negativer oder positiver Richtung.

Beachte: Die Startposition in negativer Richtung bzw. die Genauhaltgrenze (nach überschliffenen Sätzen) in positiver Richtung kann nicht überschritten werden. Die Schrittweite der Verschiebung beträgt 1 ms.


WAIT FOR-Befehl

Programmierung WAIT FOR-Befehl

Feld | Beschreibung | Wertebereich
WAIT FOR IN | Warte auf Eingang mit den nachfolgenden Parametern. | WAIT FOR IN warten auf Eingang WAIT FOR OUT warten auf Ausgang
10 | Eingangsnummer, auf den gewartet wird. | Ausgänge sind in einem Bereich von 1 bis 1024 möglich. Eingänge können von 1 bis 1026 gewählt werden (Es besteht die Möglichkeit, die Anzahlt der Ein-/Ausgänge auf bis zu 4096 zu erhöhen, dann ist 4096 die entsprechende Obergrenze). Vorsicht: Eingang 1025 ist immer TRUE. Eingang 1026 ist immer FALSE.
Ventil | Langtextname, der zu dem ausgewählten Eingang projektiert ist. | Frei konfigurierbarer Name, der in der Ein-/Ausgangsübersicht vergeben werden kann.
State=TRUE | Warten auf den Zustand TRUE. | Es kann auf den Pegel TRUE oder FALSE gewartet werden.
CONT | Die Warteanweisung wird im Vorlauf bearbeitet. | Die Auswahl von CONT führt dazu, dass ein CONTINUE vor die WAIT-Anweisung gestellt wird. Ein Vorlaufstopp wird dann nicht ausgeführt und die Anweisung zur Vorlaufzeit bearbeitet.


WAIT-Befehl

Programmierung WAIT-Befehl

Feld | Beschreibung | Wertebereich
WAIT Time | Programmierung einer Wartezeit. | Dieser Befehl löst einen Vorlaufstopp aus.
1.25 | Zeit, die gewartet werden soll. | Zulässige sind Wartezeiten von 0 bis 30 Sekunden.


RETRACT-CIRC

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert .

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll .

CLS - Der Vorhub wird geschlossen.

OPN - Der Vorhub wird geöffnet. .

GUN=1

Definiert die aktive Schweißzange .

Auswahl zwischen bis zu 5 Schweißzangen.


RETRACT-LIN

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll .

CLS - Der Vorhub wird geschlossen.

OPN - Der Vorhub wird geöffnet.

GUN=1

Definiert die aktive Schweißzange .

Auswahl zwischen bis zu 5 Schweißzangen .


RETRACT-PTP

Programmierung RETRACT-Anweisung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

CLS

Definiert den Zustand, den der Vorhub einnehmen soll.

CLS - Der Vorhub wird geschlossen .

OPN - Der Vorhub wird geöffnet .

GUN=1

Definiert die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.


SPOT-CIRC

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

CIRC

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

P2

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P2 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld C PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT) .

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden.


SPOT-LIN

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert .

CPDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen .

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT) .

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden .


SPOT-PTP

Programmierung SPOT-Anweisung

Feld

Beschreibung

Wertebereich

PTP

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Es wird die Orientierung am Startpunkt in die des Endpunktes übergeführt, ohne die Orientierung des Hilfspunktes zu beachten.

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug .

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert .

VEL=100%

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-/CIRC-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Geschwindigkeit und Beschleunigung .

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

GUN=1

Bestimmt die aktive Schweißzange.

Auswahl zwischen bis zu 5 Schweißzangen.

RETR CLS

Vorhub nach dem Schweißprozeß (RETRACT).

CLS = Vorhub geschlossen

OPN = Vorhub geöffnet

SDAT1

Datensatz, in dem die Schweißparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld SDAT1 bewegt, dann erscheint ein Auswahlfenster für die Zangenschließzeit und Parameter für ein Elektrodenpaar.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Schweißparameter zu verwenden .


Eindimensionale Korrekturanweisung KUKA TP

Eindimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 1D | Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die Suchbewegung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Zweidimensionale Korrekturanweisung KUKA TP

Zweidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 2D CD0 | 1. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Dreidimensionale Korrekturanweisung KUKA TP

Dreidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 3D CD0 | 1. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CD2 | 3. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die dritte Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT"sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Ausschalten der Korrekturanweisung KUKA TP

Ausschalten der Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR OFF | Der Befehl bewirkt, dass das BASE_CORR_ON-Flag und das BASE_CORR-Frame zurück gesetzt werden. | Der Parameter CONT gibt an, ob der Befehl überschliffen werden soll.


Frei programmierbare Korrekturanweisung KUKA TP

Frei programmierbare Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CD {1,2,3} | Bestimmung einer Fläche | Wert 1: Bestimmt die Fläche Wert 2: erste Rotationsdimension der Fläche Wert 3: zweite Rotationsdimension der Fläche
CD {4,5} | Bestimmung einer Linie | Wert 1: Bestimmt die Linie Wert 2: erste Rotationsdimension der Linie
CD {6} | Legt die Verschiebung fest |
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlang- samt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.

Hinweis:

  • Der Wert -1 steht für einen Null -Offset und es wird ein vordefinierter Default-Datensatz verwendet.

  • Beim CORR CD-Befehl können nur Korrekturdaten mit CD & Nummer verwendet werden. Also keine selbst kreierten Namen von Datensätzen.


Programmierung der Touchsense Suche mit LIN-Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

LIN

Bewegungstyp LIN

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Bei LIN-Bewegungen ist die Einheit m/s.

PDAT2

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT2 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


Suche mit PTP-Bewegung

Programmierung der Touchsense Suche mit PTP-Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

PTP

Bewegungstyp PTP

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Bei LIN-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


Eindimensionale Korrekturanweisung KUKA TPS

Eindimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 1D | Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die Suchbewegung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Zweidimensionale Korrekturanweisung KUKA TPS

Zweidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 2D CD0 | 1. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Dreidimensionale Korrekturanweisung KUKA TPS

Dreidimensionale Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR 3D CD0 | 1. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die erste Suchrichtung abgelegt
CD1 | 2. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die zweite Suchrichtung abgelegt
CD2 | 3. Bewegungssatz für die Suchbewegung | In diesem Datensatz werden die Parameter für die dritte Suchrichtung abgelegt
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT"sollten Sie nicht verändern, denn ein Genauhalt verlangsamt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.


Ausschalten der Korrekturanweisung KUKA TPS

Ausschalten der Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CORR OFF | Der Befehl bewirkt, dass das BASE_CORR_ON-Flag und das BASE_CORR-Frame zurück gesetzt werden. | Der Parameter CONT gibt an, ob der Befehl überschliffen werden soll.


Frei programmierbare Korrekturanweisung KUKA TPS

Frei programmierbare Korrekturanweisung

ILF für Tochsense

Feld | Beschreibung | Wertebereich
CD {1,2,3} | Bestimmung einer Fläche | Wert 1: Bestimmt die Fläche Wert 2: erste Rotationsdimension der Fläche Wert 3: zweite Rotationsdimension der Fläche
CD {4,5} | Bestimmung einer Linie | Wert 1: Bestimmt die Linie Wert 2: erste Rotationsdimension der Linie
CD {6} | Legt die Verschiebung fest |
CONT | Legt fest ob überschliffen werden soll | Die Voreinstellung "CONT" sollten Sie nicht verändern, denn ein Genauhalt verlang- samt den Suchvorgang unnötig. Falls ohne "CONT" programmiert wird, löst das einen Vorlaufstop aus. Der nachfolgende Zielpunkt kann nicht überschliffen werden.

Hinweis:

  • Der Wert -1 steht für einen Null -Offset und es wird ein vordefinierter Default-Datensatz verwendet.

  • Beim CORR CD-Befehl können nur Korrekturdaten mit CD & Nummer verwendet werden. Also keine selbst kreierten Namen von Datensätzen.


Programmierung der Touchsense Suche mit Bewegung

ILF für Tochsense

Feld

Beschreibung

Wertebereich

PTP/LIN

Der Bewegungstyp kann ausgewählt werden.

PTP entspricht einer Punkt-zu-Punkt-Bewegung. Sie ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

LIN verbindet den Start- und Zielpunkt auf dem kürzesten Weg (lineare Bewegung).

P1

Ein frei programmierbarer Punktname kann vergeben werden, der die Koordinaten des Punktes speichert.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, dann erscheint ein Auswahlfenster für Tool, Base und externes Werkzeug.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert.

VEL=

Geschwindigkeit, mit der die Bewegung durchgeführt wird.

Für PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben. Bei LIN-Bewegungen ist die Einheit m/s.

PDAT1

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, dann erscheint ein Auswahlfenster für Beschleunigung und Überschleifparameter.

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Search Via P2

Hilfspunkt der die Suchrichtung festlegt

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig.

CD1

Datensatz der sich auf den Referenzlauf am Master-Bauteil beziehen.

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Kalibriermodus, den Offset des Suchkommandos sowie für Angaben über die Suchrichtung.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Befehlen einheitliche Parameter zu verwenden.

PA0

Datensatz für Daten die die Suchbewegung beschreiben

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld CD 1 bewegt, dann erscheinen Auswahlfenster für den Touchmodus, den Suchweg der Referenzfahrt, die Suchgeschwindigkeit sowie für Angaben Werte der Rückbeschleunigung und die Rückgeschwindigkeit.

Seite 1:

Seite 2:

Datensatzbezeichnungen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Datensatzes nicht automatisch inkrementiert.


NOT-AUS

Ursache:

  • Not-Aus-Taster gedrückt

  • Not-Aus-Kreis unterbrochen

  • Not-Stop vom Programm ausgelöst

Auswirkung:

  • Bahntreuer Stop

  • Verriegelung aller aktiven Kommandos

Abhilfe:

  • Not-Aus-Taster entriegeln (drehen Sie hierzu das Oberteil in Pfeilrichtung)

  • Not-Aus-Kreis kontrollieren und ggf. wieder herstellen

  • Die gemeldete Störung beheben und quittieren


Default

Programmierung
PTP-Bewegung

PTP ist eine Punkt-zu-Punkt-Bewegung. Die Positionierung des Robotersystems erfolgt hierbei auf dem schnellsten Weg zwischen zwei Punkten. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

Die PTP-Bewegung verläuft auf einer vom Roboter definierten B a hn und ist nicht e xakt vorhersehbar! Um mögliche Kollisionen zu vermeiden, sollte diese Bahn in der Nähe von Hindernissen zunächst mit vermindertem Programmoverride (POV) abgefahren werden!

PTP

Beschreibung

Auswahl der Bewegungsart.

Wertebereich

PTP, LIN, CIRC.

  • PTP ist eine Punkt-zu-Punkt-Bewegung. Dies ist die schnellste Verbindung zweier Punkte. Alle Achsen beginnen und beenden die Bewegung gleichzeitig (synchron).

  • LIN ist eine lineare Bewegung, welche Start- und Zielpunkt entlang einer Geraden verbindet.

  • CIRC erzeugt mit Hilfe eines Hilfspunktes eine Kreisbahn vom Startpunkt über den Hilfspunkt zum Zielpunkt. Dabei wird die am Startpunkt gegebene Orientierung kontinuierlich in die des Endpunktes übergeführt. Die Orientierung des Hilfspunktes ist damit vorgegeben und nicht veränderbar.

P1

Beschreibung

Name des Zielpunktes, frei programmierbar, in dem die Koordinaten des Punktes gespeichert werden.

Punktnamen, die mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Punktnamen dürfen nicht mit "POINT" beginnen, weil dies ein Schlüsselwort ist!

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld P1 bewegt, erscheint im Zustands fenster eine Parameterliste für Tool, Base und externes Werkze ug.

Tool
Auswahl zwischen bis zu 16 Werkzeugen

Base
Auswahl zwischen bis zu 16 gespeicherten Werkstück-Koordinatensystemen (BASE).

Externer TCP
False: Roboter führt Werkzeug.
True: Roboter führt Werkstück.

CONT

Beschreibung

Auswahl, ob der Zielpunkt mit Genauhalt angefahren oder überschliffen werden soll. "CONT" bedeutet "CONT inues motion". PTP-Bewegungen werden mit "C_PTP" überschliffen.

Wertebereich

  • Leeres Feld: Genau-Halt. Der Zielpunkt wird exakt angefahren.

  • CONT: Überschleifen. Die Steuerung überwacht einen sogenannten Überschleifbereich um den Zielpunkt. Beim Eintritt des Werkzeug-Bezugspunktes in diesen Bereich wird die Roboterbewegung auf den Zielpunkt des nächsten Bewegungsbefehls überführt.

VEL= 100 %

Beschreibung

Geschwindigkeit, mit der die Bewegung durchgeführt wird. Bei PTP-Bewegungen wird die Geschwindigkeit als Prozentwert der maximalen Geschwindigkeit angegeben.

Wertebereich

1 bis 100% vom Maximalwert (Voreinstellung 100%).

P DAT1

Beschreibung

Datensatz, in dem die Bewegungsparameter gespeichert werden.

Datensatzbezeichnungen, welche mit einer Ziffer enden, werden beim Anlegen eines weiteren Punktes automatisch inkrementiert. Es kann der gleiche Parametersatz verwendet werden, um bei mehreren Punkten einheitliche Bewegungsparameter zu verwenden.

Wertebereich

Es stehen maximal 23 Zeichen zur Verfügung. Sonderzeichen sind nicht zulässig. Wird der Cursor in das Feld PDAT1 bewegt, erscheint im Zustandsfenster eine Parameterliste für die Beschleunigungs- und Überschleifparameter.

Beschleunigung
Einstellung der Beschleunigung. 100% entspricht maximaler Beschleunigung.

Ueberschleifdistanz
Änderung des Überschleifbereichs.

Hinweis:
Der Parameter "Ueberschleifdistanz" steht nur zur Verfügung, wenn "CONT" eingeschaltet ist.

Je nach Länge des Verfahrweges, Höhe der Beschleunigung und Größe der Überschleifdistanz kann der Fall eintreten, daß die programmierte Bahngeschwindigkeit (Vel) nicht erreicht werden kann; beispielsweise wenn sich Handachsen bei der Durchfahrt einer gestreckten Lage mit mehr als der zulässigen Höchstgeschwindigkeit bewegen müßten. Achten Sie daher auf praktisch erreichbare Werte.


KR C1 Online-Hilfe

Sorry...

... zu diesem Thema ist leider keine Online-Hilfe vorhanden.

Informationen finden Sie in den Bedienungshandbüchern.


KR C1 Online-Help Technologien

KR C ...
Online-Help

Rel. 2.0

Technologien

KUKA Roboter GmbH
Bluecherstrasse 144
D-86165 Augsburg
Copyright © 1995 -2002